Willkommen im Hilfesystem für TwinLightControl

Willkommen im Hilfesystem für TwinLightControl. Das Hilfesystem soll eine Vorstellung davon vermitteln, was mit TwinLightControl möglich ist.

Das Hilfesystem besteht aus drei Teilen.

Der erste Teil erklärt kurz, was TwinLightControl will und kann. Dieser Teil erklärt Gemeinsamkeiten mit und Unterschiede zu anderen am Markt befindlichen Programmen.

Der zweite Teil ist ein "Wie wird ..."-Teil. Es enthält eine Schritt-für-Schritt-Anleitung, mit deren Hilfe man schnell eigene Dia-Shows erstellen und präsentieren kann. In diesem Teil werden sowohl Dinge im Detail erklärt, die mit TwinLightControl möglich sind, als auch grundsätzliche Schritte, die schnell zu einem vorzeigbaren Ergebnis führen.

Der dritte Teil ist ein Referenz-Teil und liefert Hintergrundinformationen zu einigen Teilen von TwinLightControl.

Alle Hilfe-Teile sind von den Hilfe-Buttons der einzelnen Fenster und Dialoge aus erreichbar.

Für eine schnelle Hilfe stellt TwinLightControl Kurzhinweise zur Verfügung: lässt man den Mauszeiger kurz auf einem Button, Eingabefeld, Optionsfeld usw. ruhen, wird ein Kurzhinweis zur Funktion des betreffenden Steuerelementes angezeigt. Außerdem erscheint ein Kurzhinweis in der Statuszeile am unteren Fensterrrand.

Um den gesamten Inhalt dieser CHM-Hilfe-Datei auszudrucken, wählen Sie "Drucken" und dann "Ausgewähltes Thema und alle Unterthemen drucken".
Den vollständigen Inhalt dieser Hilfe-Datei finden Sie auch als PDF-Version im Verzeichnis "Help" Ihrer TwinLightControl-Installation.

Was will und kann TwinLightControl?

  • Was ist TwinLightControl?
  • Das Konzept von TwinLightControl
  • Was ist neu?
  • Systemvoraussetzungen, Installation und Deinstallation
  • Bekannte Probleme
  • Fehler in TwinLightControl
  • Beispiele für Dia-Shows
Wie wird ...?
  • Wie wird TwinLightControl gestartet?
  • Fahrplan zur fertigen Dia-Show
  • Wie wird eine neue Dia-Show erzeugt?
  • Wie wird eine Beschreibung der Dia-Show erstellt?
  • Wie werden die Voreinstellungen geändert?
  • Wie wird der serielle Port konfiguriert?
  • Wie werden Magazine zur Dia-Show hinzugefügt?
  • Wie werden Einträge im Magazin-Editor geändert?
  • Wie werden Magazine aus der Dia-Show entfernt?
  • Wie werden Dias zur Dia-Show hinzugefügt oder aus ihr entfernt?
  • Wie werden Einträge im Dia-Editor geändert?
  • Wie werden Bild-Dateien zur Dia-Show hinzugefügt, aus ihr entfernt bzw. angezeigt?
  • Wie werden Dias im Magazin nach vorn verschoben?
  • Wie werden Dias im Magazin nach hinten verschoben?
  • Wie wird ein Verschiebe-Protokoll verwendet?
  • Wie werden nicht benutzte Dias demarkiert und Lücken in Dia-Magazinen geschlossen?
  • Wie werden Programmschritte zur Timeline hinzugefügt?
  • Wie wird das virtuelle Leuchtpult verwendet?
  • Wie werden Einträge im Timeline-Editor geändert?
  • Wie werden Programmschritte aus der Timeline entfernt?
  • Wie werden Audio-Dateien zur Dia-Show hinzugefügt, aus ihr entfernt bzw. abgespielt?
  • Wie werden Play-Listen für den Audio-Player verwendet?
  • Wie wird der Audio-Recorder verwendet?
  • Wie wird die Reihenfolge von Programmschritten in der Timeline geändert?
  • Wie wird ein Timeline-Check durchgeführt?
  • Wie wird die Timeline grafisch dargestellt?
  • Wie werden Audio-Synchronisations-Punkte gesetzt?
  • Wie wird zu einem bestimmten Datensatz gesprungen?
  • Wie wird nach bestimmten Datensätzen gesucht?
  • Wie wird eine Dia-Show skaliert?
  • Wie wird ein Bericht zur Dia-Show erzeugt?
  • Wie wird die Dia-Reihenfolge grafisch dargestellt?
  • Wie wird der Projektor aktiviert?
  • Wie wird die Firmware-Version abgefragt?
  • Wie wird die virtuelle Fernbedienung benutzt und eine Dia-Show übertragen und gestartet?
  • Wie wird eine Leinwand-Simulation durchgeführt?
  • Wie wird eine DiaEdit-Datei importiert?
  • Wie wird in eine DiaEdit-Datei exportiert?
  • Wie wird der Dia-Show-Wizard benutzt?
  • Was ist der Live-Modus und wie wird er verwendet?
  • Wie wird das Erscheinungsbild einer Tabelle den persönlichen Bedürfnissen angepasst?
TwinLightControl-Referenz
  • Tips und Tricks
  • Der wahlfreie Zugriff auf Dias und die Realisierung in TwinLightControl
  • Begriffserklärungen
  • Die Verzeichnisstruktur von TwinLightControl
  • Das Datei-Handling von TwinLightControl
  • Die Undo- und Redo-Funktionen von TwinLightControl
  • Allgemeine Bemerkungen zum Editieren von Zellen im Magazin-, Dia- und Timeline-Editor
  • Tastenkürzel und Maus-Klicks für die Dia-Show
  • Tastenkürzel und Maus-Klicks im Magazin-Editor
  • Tastenkürzel und Maus-Klicks im Dia-Editor
  • Tastenkürzel und Maus-Klicks im Timeline-Editor
  • Tastenkürzel und Maus-Klicks in der virtuellen Fernbedienung
  • Tastenkürzel und Maus-Klicks im Audio-Player
  • Tastenkürzel und Maus-Klicks in der grafischen Darstellung der Timeline
  • Verwendung des "eDio Wireless USB Remote Controller IR501"
  • Verwendung von Notebook-Presentern zur Fernsteuerung
  • Farbige Markierungen in den Editoren
  • Magazin-Typen
  • Überblend-Effekte
  • Bemerkungen zu MP3-Dateien
  • Leinwand-Rechner
  • Wichtige Bedienhinweise für den Projektor (MSCxxxP)
  • Wesentliche Unterschiede zwischen "Rolleivision Twin MSCxxxP" und "Rolleivision 35 twin digital P"
  • Befehlssatz zur Steuerung des Twin MSC 300 (Information von Rollei)
  • Steuerung des Rolleivision 35 twin digital P (Auszug aus dem Programmierhandbuch)
  • Firmware-Update V8.5 (Information von Rollei)
  • Firmware-Probleme bei älteren Projektoren
  • Literatur


Lizenzvertrag / Copyright

Lizenzvertrag

Bevor Sie diese Software benutzen, lesen Sie sich bitte die folgenden Zeilen sorgfältig durch. Wenn Sie mit einem der folgenden Punkte nicht einverstanden sein, dann benutzen Sie dieses Programm nicht und entfernen alle Installationen von Ihren Datenträgern.

Testversion

Sie haben hiermit das Recht, dieses Programm und die damit verbundenen Dateien einen Monat lang eingehend zu testen. Für diese Testversion erhalten Sie eine Serien-Nummer, die bei der Installation des Programms angegeben werden muss. Sie dürfen das Programm mit den damit verbundenen Dateien nicht weitergeben.

Die Testversion unterscheidet sich von der Vollversion lediglich darin, dass maximal 20 Programmzeilen zum Projektor übertragen werden können.

Eine Benutzung des Programms über die Testphase hinaus verstößt gegen internationale Copyright-Bestimmungen!

Registrierung

Dieses Programm ist Shareware, also weder Freeware noch Public Domain. Eine Benutzung über die Testphase von 30 Tagen hinaus erfordert eine Registrierung. Sie erhalten eine Lizenz-Datei für die Vollversion auf Anfrage und nach Entrichtung der Gebühr.

Vollversion

Es gibt zwei verschiedene Vollversionen von TwinLightControl: die "Uneigeschränkte Vollversion" und die "Eingeschränkte Vollversion". Letztere kann maximal 150 Programmschritte zum Projektor übertragen, ansonsten ist sie voll funktionsfähig. Die Vollversion dieses Programms darf auf beliebig vielen Computern installiert werden, sofern jede Installation nur von einer Person gleichzeitig benutzt wird. Für jeden Computer ist eine separate Lizenz-Datei erforderlich. Die Nutzung durch mehrere Personen gleichzeitig erfordert zusätzliche Lizenzen. Eine Einzellizenz für die "Uneigeschränkte Vollversion" kostet € 100,-, für die "Eingeschränkte Vollversion" € 60,-, für ein Upgrade € 40,- (ggf. inkl. Versand per E-Mail bzw. auf CD-ROM).

Die Vollversion beinhaltet die kostenlose Beseitigung von Fehlern und den Anspruch auf Updates, sofern diese den Rahmen normaler Software-Pflege nicht übersteigen. Enthält ein Update grundsätzlich neue Features, wird eine dem Umfang der neuen Leistungsmerkmale angemessene Update-Gebühr fällig. Sie werden aber darüber vorher per E-Mail oder auf der QuiverTree-Homepage informiert.

Haftung

Wir haben diese Software nach bestem Wissen und Gewissen erstellt und alle bekannten Fehler eliminiert. Keine Software ist allerdings völlig frei von Fehlern. Deshalb können wir keine Gewähr dafür übernehmen, dass diese Software in jeder Umgebung, auf jedem Rechner, und mit jeglichen anderen Anwendungen zusammen fehlerfrei läuft. Jegliche Haftung für direkte wie indirekte Schäden wird hiermit ausgeschlossen, soweit dies gesetzlich zulässig ist. In jedem Fall jedoch ist die Haftung beschränkt auf die Lizenzgebühr.

Es wird empfohlen, dieses Programm mit Kopien von Originaldaten zu testen, um Datenverluste zu vermeiden. Für Schäden an Daten oder Hardware, weder Computer noch Projektor, wird keinerlei Haftung übernommen. Sollten Sie bis zur Lizensierung Fehler entdecken, so akzeptieren Sie diese, sofern Sie sich registrieren lassen. Fehlermeldungen mit möglichst genauer Beschreibung werden gern entgegengenommen. Es kann jedoch keine Garantie gegeben werden, dass alle Fehler behoben werden können.

Über die serielle Schnittstelle (RS232) können Dia-Projektoren vom Typ Rolleivision Twin MSC3xxP (Rolleivision 35 twin digital P) angesteuert werden. Die Nutzung dieser Möglichkeit erfolgt auf eigene Gefahr. Bei unsachgemäßer Verwendung kann der Dia-Projektor beschädigt werden. Der Autor übernimmt übernimmt keinerlei Gewährleistung für die korrekte Funktion der Projektor-Steuerung über
die serielle Schnittstelle.

Entstehung

TwinLightControl wurde mit Hilfe von Borland C++ Builder 4 (© 1996-99 by Borland International) geschrieben.

Das Datenübertragungsprotokoll zwischen Computer und Rolleivision Twin Projektoren wurde uns von Rollei mitgeteilt.

Des weiteren wurde Software folgender Firmen oder Personen verwendet:
SQLMemTable (AidAim Software),
DbAltGridSuite, Transfer@Once (Quasidata),
BASS Audio Library (Un4Seen Development),
XPMenu (Khaled Shagrouni),
Windows XP Theme Manager (© 1999-2005 Mike Lischke, Soft Gems Software Solutions),
ZipBuilder (Roger Aelbrecht),
Helpmatic Pro HTML (HSG Software Solutions),
EC Software Help Suite,
ISTool (Bjoemar Henden),
InnoSetup (Jordan Russell).

Copyrights

Alle erwähnten Warenzeichen und Copyrights gehören ihren jeweiligen Besitzern.

Design und Programmierung

H.Schlichter

Design und grafische Gestaltung

P.Schlichter

Kontakt

Homepage: http://www.quivertree.de

E-Mail: twinlightcontrol@quivertree.de

QuiverTree

Februar 2022


Registrierung von TwinLightControl

Für die Testversion von TwinLightControl ist eine Serien-Nummer erforderlich. Auf der Website von "QuiverTree" unter "Software" findet man ein Formular, welches ausgefüllt abgesendet werden muss. Daraufhin erhält man eine E-Mail mit der gewünschten Serien-Nummer.

Für die Vollversion von TwinLightControl ist die Registrierung erforderlich. Dabei sind folgende Schritte zu absolvieren:

  • Man wählt den Menüpunkt "Hilfe/Vollversion freischalten". Dabei wird automatisch ein sog. Software-Schlüssel erzeugt, der mit dem Button "Software-Schlüssel senden" sofort an QuiverTree gesendet werden kann. Nicht vergessen, die gewünschte Lizensierungsart auszuwählen. Die gesendete E-Mail gilt gleichzeitig als Bestätigung der Bestellung. Hat man auf dem Computer, für den der Software-Schlüssel erzeugt wurde, keine Möglichkeit, E-Mails zu versenden, kann man die Datei "SoftKey.dat", die den Software-Schlüssel enthält, auch manuell auf einem anderen Computer versenden. Die Datei befindet sich im Verzeichnis "Licensel". Wo sich dieses Verzeichnis befindet, hängt von der Windows-Version ab und kann ermittelt werden, indem man den Menüpunkt "Hilfe/Datei-Pfade anzeigen..." aufruft.
  • Nach Eingang der Lizenz-Gebühr von € 100,- (Uneingeschränkte Vollversion) bzw. € 60,- (Eingeschränkte Vollversion) bzw. € 40,- (Upgrade) erhält man per E-Mail die Datei "License.dat", die den Lizenz-Schlüssel enthält. Sie muss in das gleiche Verzeichnis kopiert werden, in dem sich auch "SoftKey.dat" befindet. Beim dem nächsten Start von TwinLightControl ist die Vollversion automatisch freigeschaltet. Es gibt einen Menüpunkt "Lizenz-Datei laden...", mit dessen Hilfe eine auf der Festplatte gespeicherte Lizenz-Datei automatisch in das richtige Verzeichnis kopiert und die Vollversion freigeschaltet wird.
  • Die beiden Dateien "SoftKey.dat" und "License.dat" sind hardware-gebunden, d.h. nur für den Computer gültig, für den sie erzeugt wurden. Sollte eine Lizenz für einen weiteren Computer benötigt werden, muss die Prozedur für diesen wiederholt werden. Dies ist dann der Fall, wenn man z.B. Dia-Shows auf einem stationären PC erstellt und auf einem Laptop präsentiert. Für registrierte User ist dies kostenlos, d.h. eine Lizenz berechtigt zur Nutzung von TwinLightControl auf verschiedenen Computern. Es sei darauf hingewiesen, dass die gleichzeitige Nutzung einer TwinLightControl-Lizenz durch unterschiedliche Personen gegen die Lizenz-Bestimmungen verstößt.
  • Die Lizenz-Datei ist hardware-gebunden. Wenn also an einem Computer, für den eine Lizenz-Datei erzeugt wurde, z.B. die Festplatte ausgetauscht wird, muss eine neue Lizenz-Datei erzeugt werden. Dieses Procedere ist für registrierte User selbstverständlich kostenlos.


Was ist TwinLightControl?

TwinLightControl ist ein Programm zur Steuerung von Rolleivision Twin Projektoren. Diese Projektoren ermöglichen Dia-Shows in Überblendtechnik mit Hilfe nur eines Projektors aus nur einem Magazin.

Mit Hilfe von TwinLightControl kann man folgendes tun:

  • Dia-Shows bequem am PC erstellen, verändern, speichern, laden, ...
  • ein Dia-Archiv verwalten
  • eingescannte Dias importieren und eine Leinwand-Simulation erstellen
  • Audio-Dateien importieren und sekundengenau mit der Bildfolge synchronisieren
  • bereits vorhandene Dia-Shows, die mit "DiaEdit", der Rollei-eigenen Software, erstellt wurden, einlesen und konvertieren
  • den Projektor direkt über den PC steuern und so die erstellte Dia-Show präsentieren
  • fertige Dia-Shows in den Speicher-Modul des Projektors übertragen, so dass diese unabhängig von einem PC präsentiert werden können
  • Dia-Shows aus dem Speicher-Modul des Projektors lesen und nachbearbeiten
  • Fertige Dia-Shows ausdrucken


Das Konzept von TwinLightControl

"TwinLightControl" ist von Konzept, Leistungsfähigkeit und Preis her zwischen "DiaEdit", dem Rollei-eigenen Programm zur Erstellung und Präsentation von Dia-Shows, und professionellen Programmen wie "m.objects" oder "Wings" einzuordnen.

Während "DiaEdit" von der Bedienung und Leistungsfähigkeit her eher spartanisch ist, glänzen die anderen oben erwähnten Programme durch ihre grafische Benutzeroberfläche und ihre Fähigkeit, Sound und Videoclips einbinden zu können.

Diese Programme wurden für die verschiedensten Projektor-Typen entwickelt und setzen in der Regel voraus, dass die Dias in der Reihenfolge, in der sie präsentiert werden sollen, in die einzelnen Magazine einsortiert werden. Ein Vorteil der Rolleivision Twin Projektoren ist es aber gerade, dass man auf die in einem Magazin befindlichen Dias einen wahlfreien Zugriff hat, d.h. im Prinzip können die Dias in beliebiger Reihenfolge projiziert werden. So hat man die Möglichkeit, ohne Umsortieren aus dem gleichen Magazin je nach Bedarf unterschiedliche Dia-Shows zu präsentieren.

TwinLightControl setzt genau an diesem Punkt an: die Dias werden nicht aus der Timeline in die Magazine sortiert, sondern umgekehrt, aus den Magazinen in die Timeline. So kann man aus einem Archiv von Magazinen die unterschiedlichsten Dia-Shows erstellen, ohne dass umsortiert werden muss. (Dieses Vorgehen hat natürlich wie alles seine Grenzen.)

Da TwinLightControl Magazine, Dias und die Timeline separat erfasst, kann TwinLightControl auch als einfaches Verwaltungsprogramm für das eigene Dia-Archiv verwendet werden.

Bei der Entwicklung von TwinLightControl wurde besonderes Augenmerk auf eine ergonomische Bedienoberfläche gelegt. Das bedeutet im einzelnen:

  • alle Funktionen sollen möglichst intuitiv bedienbar sein
  • alle Eingabewerte werden auf ihre Gültigkeit hin überprüft, fehlerhafte Werte werden abgewiesen
  • für alle vom Anwender einzugebenden Werte werden sinnvolle Voreinstellungen angeboten
  • alle Bedienerfehler sollen abgefangen und möglichst verständlich kommentiert werden
  • der ständige Wechsel zwischen Maus und Tastatur soll vermieden werden; (fast) alle Funktionen sind über Maus und Tastatur erreichbar, je nach Vorliebe des Anwenders
  • TwinLightControl versucht "mitzudenken", was der Anwender als nächstes sinnvollerweise tun wird

Inwieweit es gelungen ist, dem Anspruch auf eine ergonomische Bedienoberfläche gerecht zu werden, mag der Anwender entscheiden. Für Hinweise, Kritik und Lob sind wir jederzeit dankbar.


Was ist neu?

Wichtiger Hinweis!

Um den gesamten Inhalt dieser CHM-Hilfe-Datei auszudrucken, wählen Sie "Drucken" und dann "Ausgewähltes Thema und alle Unterthemen drucken".
Den vollständigen Inhalt dieser Hilfe-Datei finden Sie auch als PDF-Version im Verzeichnis "Help" Ihrer TwinLightControl-Installation.

Wichtiger Hinweis!

Bitte sichern Sie in regelmäßigen Abständen Ihre wertvollen Daten, vor allem vor der Installation und ersten Benutzung einer neuen TwinLightControl-Version. Näheres zur Datensicherung findet man hier .

Dies gilt insbesondere vor der Installation und Verwendung von Beta-Versionen. Fertigen Sie unbedingt ein Backup Ihrer *.twc-Dateien an. Wenn in der Beta-Version Probleme auftreten sollten, installieren Sie die letzte freigegebene TLC-Version. Danach können Sie das Backup Ihrer *.twc-Dateien wieder einspielen.

Unter dem Menüpunkt Hilfe / Info... kann man feststellen, welche Version von TwinLightControl man hat. Die Versions-Information hat das Format X.X.X.XXX. Entscheidend sind die Ziffern bis zum dritten Punkt, die letzten drei Ziffern sind nur intern von Bedeutung. Ein Blick auf die QiverTree-Website zeigt, ob die installierte Version von TwinLightControl aktuell ist.

Wichtiger Hinweis!

Ab Version 4.1.5 kann für die Erzeugung der Überblendungen bei der Leinwand-Simulation sog. Alpha-Blending verwendet werden. Alpha-Blending ist eine Technik, die mit Windows 2000 eingeführt wurde. Sie kann deshalb i.d.R. erst ab dieser Windows-Version verwendet werden und führt selbst dann gelegentlich zu Problemen. Wenn Sie bei der Leinwand-Simulation ein unerklärliches Verhalten feststellen (z.B. können bei einer Überblendung massenhaft Meldungen der Art "Systemressourcen erschöpft" erzeugt werden), dann schalten Sie in den Voreinstellungen unter "Leinwand-Simulation" das "Alpha-Blending" aus. Näheres zu Alpha-Blending findet man hier .

Ab Version 4.2.1 ist Alpha-Blending mit OpenGL möglich.

Version 5.1.7 (Februar 2022)

  • Anpasssung an Windows 11
  • Verschiedene Bugfixes

Version 5.1.6 (Januar 2019)

  • Anpassung an Windows 10.
  • Verschiedene Bugfixes.

Version 5.1.5 Beta (Dezember 2015)

  • Anpassung an Windows 10.
  • Verschiedene Bugfixes.

Version 5.1.4 Beta (November 2014)

  • Verschiedene Bugfixes.

Version 5.1.3 Beta (März 2014)

  • Anpassung an Windows 8, Windows 8.1.

Version 5.1.2 Beta (Dezember 2013)
  • Verschiedene Bugfixes.

Version 5.1.1 Beta (Oktober 2012)

  • Verschiedene Bugfixes; u.a. wurde ein Fehler beim Zusammenfügen zweier Dia-Shows beseitigt.

Version 5.1.0 (Mai 2012)

  • Voreinstellungen können exportiert und importiert und so leicht von einem Computer auf einen anderen übertragen werden. Näheres findet man hier und hier .
  • Hinweise über beendende Audio-Funktionen in der Timeline können auf Wunsch abgeschaltet werden. Näheres findet man hier .
  • Die Positionen der Dialoge bei einer Leinwand-Simulation bzw. einer realen Dia-Show können wahlweise erinnert werden. Näheres findet man hier .
  • Auf Wunsch kann vor dem Verschieben von Dias im Magazin ein Verschiebe-Protokoll aktiviert werden. Es protokolliert die in TwinLightControl vorgenommenen Verschiebe-Aktionen und hilft, diese Aktionen später an den realen Magazinen mit geringstmöglichem Aufwand nachzuvollziehen. Näheres erfährt man hier .
  • Aktualisierung der Hilfe.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes; u.a. wurde ein Fehler beseitigt, dass unter bestimmten Umständen Audio-Dateien ein oder zwei Zehntelsekunden vor ihrem eigentlichen Ende gestoppt werden.

Version 5.0.7 Beta (Januar 2011)

  • Es gibt eine Schnittstelle zu den weit verbreiteten Notebook-Presentern. So kann TwinLightControl mit jedem Notebook-Presenter, der den Multimedia-Modus beherrscht, während einer Präsentation ferngesteuert werden. Näheres findet man hier .
  • Direkt im Leuchtpult kann jedes beliebige Magazin ausgewählt werden. Näheres findet man hier .
  • Die Hilfe-Datei wurde von einigen "Altlasten" befreit.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 5.0.6 (Januar 2011)

  • Mit dem Menüpunkt "Hilfe/Datei-Pfade anzeigen..." kann man mit einem Mausklick die einzelnen Verzeichnisse im Explorer öffnen.
  • Mit dem Menüpunkt "Hilfe/Lizenz-Datei laden..." kann eine vorhandene Lizenz-Datei geladen und die Vollversion freigeschaltet werden.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 5.0.5 (Oktober 2010)

  • Im Menü "Hilfe" gibt es einen Eintrag "Datei-Pfade anzeigen...", der vor allem unter Windows Vista und Windows 7 hilfreich sein kann.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes; behebt u.a. den Fehler, dass die Lizenz-Datei nicht erkannt wird, wenn TLC von einem Nicht-Admin mit eingeschränkten Rechten ausgeführt wird.

Version 5.0.4 Beta (Juli 2010)

  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes; behebt u.a. den Fehler, dass die Lizenz-Datei nicht erkannt wird, wenn TLC von einem Nicht-Admin mit eingeschränkten Rechten ausgeführt wird.

Version 5.0.3 (Juli 2010)

  • Bei angeschlossenem und aktivem Sekundär-Monitor kann die Leinwand-Simulation im Vollbild-Modus auf diesen Monitor ausgegeben werden.
  • Die Synchronisation zwischen Leuchtpult und Timeline beim Scrollen ist wahlweise zu- oder abschaltbar.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 5.0.2 Beta (Juni 2010)

  • Bei angeschlossenem und aktivem Sekundär-Monitor kann die Leinwand-Simulation im Vollbild-Modus auf diesen Monitor ausgegeben werden.
  • Die Synchronisation zwischen Leuchtpult und Timeline beim Scrollen ist wahlweise zu- oder abschaltbar.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 5.0.1 Beta (Mai 2010)

  • Verschiedene Änderungen zur Anpassung an Windows 7. Diese erfordern ggf. die (kostenlose) Erneuerung des Lizenz-Schlüssels für TwinLightControl.
  • Wichtige Hinweise für Benutzer von Windows Vista und Windows 7!
    Unter Windows Vista und Windows 7 gibt es neue Richtlinien für das Dateisystem. Abhängig davon,ob man als Administrator oder als normaler Benutzer angemeldet ist, hat man unterschiedliche Dateizugriffsrechte. Ein normaler Benutzer darf z.B.in das Programmverzeichnis (normalerweise "C:\Programme") keine Daten schreiben. Versucht er dies dennoch, kommt die sog. Dateivirtualisierung ins Spiel. Die Daten werden dann z.B. nicht ins Verzeichnis C:\Programme\QuiverTree\TwinLightControl\" geschrieben, sondern in ein Verzeichnis "...\User\AppData\Local\VirtualStore\Program Files (x86)\QuiverTree\TwinLightControl\". Dort kann TwinLightControl die Daten natürlich nicht finden, und es kommt zu unerklärlichen Reaktionen des Programms.

    Deshalb werden ab Windows Vista die für das Funktionieren von TwinLightControl erforderlichen Dateien in unterschiedlichen Verzeichnissen abgelegt. Bis einschl. Windows XP waren alle Dateien im Programmverzeichnis (normalerweise C:\Programme\QuiverTree\TwinLightControl") zu finden. Ab Windows Vista werden die Verzeichnisse folgendermaßen abgelegt:
    Archiv | {userdocs}\Archiv
    AudioRecorder | {userdocs}\AudioRecorder
    Bitmaps | {userappdata}\Bitmaps
    DiaShows | {userdocs}\DiaShows
    Download | {userappdata}\Download
    Help | {app}\Help
    Journal | {userappdata}\Journal
    License | {userappdata}\License
    PlaceHolder | {userdocs}\PlaceHolder
    PlayLists | {userdocs}\PlayLists

    Hinter den symbolischen Verzeichnisnamen verbirgt sich folgendes (kann je nach System variieren):
    {app} Installationsverzeichnis, z.B. C:\Programme (x86)\QuiverTree\TwinLightControl
    {userdocs} Eigene Dateien des aktiven Benutzers, z.B. C:\...\User-xxx\Eigene Dateien\QuiverTree\TwinLightControl
    oder C:\...\User-xxx\Dokumente\QuiverTree\TwinLightControl
    {userappdata} Anwendungsdaten des aktiven Benutzers, z.B. C:\...\User-xxx\Anwendungsdaten\QuiverTree\TwinLightControl
    oder C:\...\User-xxx\AppData\Roaming\QuiverTree\TwinLightControl

    Alle anderen Dateien befinden sich wie bisher im Programmverzeichnis (Installationsverzeichnis).

    Für den normalen TwinLightControl-Benutzer sind nur die Verzeichnisse Archiv, AudioRecorder, DiaShows, PlaceHolder und PlayLists interessant. Dort befinden sich die eigentlichen DiaShow-Dateien, archivierte DiaShow-Dateien, mit dem AudioRecorder aufgenommene Tracks, Platzhalter für Bilder und Play-Listen für den AudioPlayer.

    Die Anpassung an Window Vista / Windows 7 wird mit Version 5.0.1 vorgenommen. Um sie so einfach wie möglich zu gestalten, werden bei der Installation von Version 5.0.1 auf dem Computer bereits vorhandene Daten in die richtigen Verzeichnisse verschoben. Aus Sicherheitsgründen wird dringend empfohlen, vor der Installation ein Backup der Verzeichnisse DiaShows, Journal und License vorzunehmen, um Datenverluste zu vermeiden. Außerdem sollte nach der Installation der gesamte Computer noch einmal nach TwinLightControl-Daten durchsucht und überprüft werden, ob sie sich am richtigen Platz befinden (s.o.). Man beachte dabei, dass das Verzeichnis {userappdata} normalerweise nicht sichtbar ist, man muss es also ggf. im Explorer erst sichtbar machen.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 5.0.0 Beta (März 2010)

  • Verschiedene Änderungen zur Anpassung an Windows 7. Diese erfordern ggf. die (kostenlose) Erneuerung des Lizenz-Schlüssels für TwinLightControl.
  • TwinLightControl hat nun ein virtuelles Lichtpult für die Übertragung der Dias eines Magazins in die Timeline Was es damit auf sich hat und wie man es benutzt, findet man hier .
  • Detailverbesserungen bei der Einstellung der Bildschirmhelligkeit für Live-Dia-Shows.
  • Redesign einiger Datenbankfunktionen. Vor allem das Laden von *.twc-Dateien geht jetzt schneller.
  • Update auf die aktuelle Version der BASS Audio Library.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 4.3.5 (Mai 2009)

  • Die Lizenzgebühr für TwinLightControl wird gesenkt. Ab sofort gelten folgende Preise:
    "Uneingeschränkte Vollversion": Euro 100,-
    "Eingeschränkte Vollversion" (maximal 150 Programmschritte): Euro 60,-
    Upgrade von "Eingeschränkter" auf "Uneingeschränkte Vollversion": Euro 40,-
  • Wenn man im Dia-Editor das Feld "Benutzt" markiert, wird das Dia nicht wie bisher in die Timeline einsortiert, sondern hinten angehängt.
  • Im Magazin-, Dia- und Timeline-Editor kann nun auch mit dem Mausrad gescrollt werden.
  • Korrektur eines Fehlers beim Entfernen von Programm-Schritten aus der Timeline.
  • Korrektur eines Fehlers beim Handling von Magazinen für 36, 40, 60 oder 80 Dias.
  • Korrektur eines Fehlers beim Import aus einer DiaEdit-Datei mit Magazinen für 36, 40, 60 oder 80 Dias.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 4.3.4 (Juli 2008)

  • Die Schriftgröße in allen Dialogen und Tabellen kann den eigenen Bedürfnissen angepasst werden (bisher war dies nur in der grafischen Darstellung der Timeline möglich). Dadurch wird die Lesbarkeit bei geringeren Grafikauflösungen verbessert. Näheres findet man hier .
  • Ein kompletter Audio-Thread in der Timeline (von der startenden bis zur beendenden Audio-Funktion) kann in die andere Audio-Spur verschoben werden. Näheres findet man hier .
  • Beim Start von TwinLightControl wird, wenn eine Internetverbindung besteht, automatisch überprüft, ob neue Updates verfügbar sind.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 4.3.3 (Juli 2008)

  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 4.3.3 Beta (Mai 2008)

  • Der Fehler, dass in den Reports die jeweils letzte Zeile einer Seite von der Fußzeile verdeckt wird, ist beseitigt.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 4.3.2 (März 2008)

  • Ein Fehler in der Projektorsteuerung, der die Projektortypen bis einschl. MSC 330P bzw. Firmwareversionen bis einschl. V 6.1 betraf, wurde beseitigt. Für die geduldige Hilfe bei der Fehlersuche sei Herrn B.Dam aus Dänemark ausdrücklich gedankt.
    Unter Windows Vista gibt es nach wie vor sporadische Probleme mit der Projektorsteuerung und ein prinzipielles Problem mit dem Audio-Recorder. Die Freigabe des Service Pack 2 durch Microsoft wird in diesen Punkten hoffentlich Besserung bringen.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 4.3.1 (März 2008)

  • Im Dia-Editor kann ein zu einem Dia eingefügtes Bild nachträglich um 90° im oder gegen den Uhrzeigersinn gedreht werden. Das ist z.B. dann nützlich, wenn die Bilder mit einer Digitalkamera von der Leinwand abfotografiert wurden und somit alle im Querformat vorliegen.
  • Der Audio-Recorder funktioniert nun auch im Programm-Modus, d.h. es sind automatische, durch das in der Timeline befindliche Programm gesteuerte Aufnahmen möglich. Für die Darstellung der Bitmaps wird ein modernes Filterverfahren verwendet, damit bei allen Bildschirmauflösungen eine gute Qualität gewährleistet ist.
  • Beginnend mit dieser Version wird die Optik von TwinLightControl schrittweise modernisiert. Es wird eine XP-/Vista-konforme Bedienoberfläche realisiert. Das beinhaltet u.a. auch XP-/Vista-konforme, skalierte (d.h. an die jeweilige Bildschirmauflösung angepasste) Icons. Für die Skalierung der Icons kommende moderne Filterverfahren zum Einsatz, die bei allen Bildschirmauflösungen eine gute Qualität gewährleisten.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 4.3.0 (Januar 2008)

  • Es gibt nun einen Audio-Recorder, mit dem man eigene Audio-Dateien erzeugen kann. Er ist in erster Linie für die Unterlegung einer Dia-Show mit Kommentaren gedacht. Näheres findet man hier .
  • Die Demo-Dia-Shows wurden korrigiert und aktualisiert.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 4.2.6 Beta (Januar 2008)

  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes. Unter Windows Vista wurde ein besonders hartnäckiger Bug beseitigt, für die geduldige Mitarbeit bei der Fehlersuche sei Herrn Alexander Selzer ausdrücklich gedankt.

Version 4.2.5 (Dezember 2007)

  • Es gibt eine neue Lizensierungsart für TwinLightControl: neben der bisherigen "Uneingeschränkten Vollversion" (Lizenzgebühr Euro 140,-) gibt es nun auch eine "Eingeschränkte Vollversion" (Lizenzgebühr Euro 80,-). Diese Lizenzform ist für jene User gedacht, die nur gelegentlich kleinere Dia-Shows erstellen und präsentieren, aber trotzdem alle Vorteile von TwinLightControl nutzen wollen. Einzige Einschränkung ist, dass maximal 150 Programmschritte zum Projektor übertragen werden können. Ein Upgrade auf die "Uneingeschränkte Vollversion" ist jederzeit möglich Upgradegebühr Euro 60,-).
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 4.2.4 Beta (November 2007)

  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 4.2.3 (Oktober 2007)

  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 4.2.2 (September 2007)

  • Das Hilfe-System für TwinLightControl wurde vollständig auf das CHM-Format umgestellt und ist damit auch Windows-Vista-Usern zugänglich.
  • Die kontext-sensitive Hilfe ist nun in allen Fenstern bei Drücken des Hilfe-Buttons oder der Taste F1 verfügbar.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.

Version 4.2.1 (August 2007)

  • Eine nette Animation mit Hilfe von OpenGL im Info-Fenster. Die Animation kann mit den vier Pfeiltasten und der Leertaste gesteuert werden.
  • Überblendungen können nun auch mit Hilfe von OpenGL durchgeführt werden, was je nach Grafikkarte mehr oder weniger deutliche Geschwindigkeitsvorteile bringt. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 4.2.0 (Juni 2007)
  • Wenn beim ersten Programmschritt einer Dia-Show eine Audio-Datei eingetragen ist, wird diese erst dann gestartet, wenn der Projektor die beiden ersten Dias eingezogen hat und das erste Dia aufblendet. Damit ist eine bessere Synchronisation von Bild und Ton am Anfang einer Dia-Show möglich. Bisher war es so, dass der Audio-Track sofort gestartet wurde, während der Projektor noch mit dem Einziehen der beiden ersten Dias beschäftigt war. Optional kann eine der beiden Möglichkeiten gewählt werden.
  • Im Magazin-Editor gibt es einen neuen Magazin-Typ "100-er CS-Koppelmagazin". Damit wird dem Umstand Rechnung getragen, dass einige User koppelbare CS-100-Magazine der Marke Eigenbau verwenden. Näheres findet man hier .
  • Im Menü "Hilfe" gibt es nun eine Update-Funktion, die nach verfügbaren Updates (Reguläre Version und Beta-Version) sucht und diese ggf. herunterlädt und installiert. Näheres findet man hier .
  • Eines der Gültigkeitskriterien für Audio-Synchronisationspunkte wurde geändert: die Wartezeit auf einen Audio-Sync-Punkt muss nun größer sein als die Zeit, die der Projektor für einen Dia-Wechsel benötigt (bisher musste diese Zeit lediglich größer als 0 sein). Auf bereits bestehende Dia-Shows hat dies i.d.R. keine Auswirkung, da fehlerhafte Audio-Sync-Punkte sowieso nicht funktioniert hätten.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 4.1.5 (April 2007)
  • Es gibt jetzt die Möglichkeit, in der Standalone-Version der grafischen Darstellung der Timeline bei der Leinwand-Simulation größere Bilder zu verwenden. Die Größe der Bilder richtet sich nach der eingestellten Bildschirm-Auflösung. Näheres findet man hier .
  • Im Magazin-Editor gibt es ein neues Feld "Quadratformat-Anzahl", welches die Zahl der quadratischen Diaformate im Magazin angibt. Dieses Feld dient nur der Information und kann nicht editiert werden.
  • Im Timeline-Editor gibt es für beide Audio-Spuren je ein neues Feld "Audio-Looping". Damit kann für jede Audio-Datei separat festgelegt werden, ob Looping verwendet werden soll oder nicht. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 4.1.4 (März 2007)
  • In der Timeline wird die Spalte "Programm-Nummer" mehrfach angezeigt, was beim Editieren und Navigieren helfen soll. Näheres findet man hier .
  • In der virtuellen Fernbedienung wird die bei einer simulierten oder realen Dia-Show bisher verstrichene Zeit angezeigt. Näheres findet man hier .
  • In den Voreinstellungen gibt es ein neues Datum "Globale Helligkeit". Mit diesem Wert werden alle Helligkeitswerte in der Timeline multipliziert, bevor sie zum Projektor geschickt werden. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 4.1.3 (Februar 2007)
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes; u.a.:
  • Beim Start von TLC wurde gemeldet, dass keine Soundkarte installiert sei. Dieser Fehler war ein Folgefehler und trat nur bei Bildschirmauflösungen ungleich 1280x1024 Pixel auf.
Version 4.1.2 (Februar 2007)
  • Im Feld "Dia-Format" gibt es eine weitere Wahlmöglichkeit: "Quadratisches Format". Dieses Sonderformat kann gewählt werden, wenn Dias im Format 24 x 24 oder 40 x 40 vorhanden sind. Näheres findet man hier .
  • Import von DiaEdit-Dateien: es können nun auch DiaEdit-Dateien importiert werden, die mit der DOS-Version von 'DiaEdit' erstellt wurden.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes; u.a.:
  • Beim Zusammenfügen zweier Dia-Shows wurden im Dia-Editor falsche Magazin-Nummern eingetragen.
  • Beim Abspielen von Play-Listen im Audio-Player hängte TLC sich gelegentlich auf.
Version 4.1.1 (Januar 2007)
  • Es können zwei Dia-Shows zu einer einzigen zusammengefügt werden. Näheres findet man hier .
  • Es können Play-Listen für den Audio-Player erstellt, gespeichert, geladen und abgespielt werden. Dieses Feature ist vorteilhaft die Darbietung von Hintergrundmusik während einer Dia-Show-Pause. Näheres findet man hier .
  • Erweiterte Audio-Informationen (ID3-Tags).
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 4.1.0 (Januar 2007)
  • Zweite Audio-Spur, mit deren Hilfe beliebige Ein- und Überblendungen möglich sind. Näheres findet man hier und hier .
  • Der Audio-Player, der Leinwand-Rechner und das Tool zum Restaurieren der Bildschirm-Helligkeit befinden sich jetzt im Menü "Tools".
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 4.0.0 (Dezember 2006)
  • Komplettes Redesign des Audio-Players mit stark erweiterter Funktionalität. Näheres findet man hier und hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.2.6 (November 2006)
  • Das Einfügen, Löschen und Verschieben von Magazinen, Dias, Programmschritten, Bild-Dateien und Audio-Dateien wurde überarbeitet und optimiert, was sich in einer erhöhten Geschwindigkeit dieser Operationen niederschlägt.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.2.5 (November 2006)
  • Der Audio-Player hat nun einen Looping-Modus. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.2.4 (Oktober 2006)
  • Im Dialog für die Audio-Eigenschaften eines Programmschritts (grafische Darstellung der Timeline) kann eine Audio-Funktion zu einem anderen Programmschritt verschoben werden. Näheres findet man hier .
  • Beim Timeline-Check kann der fehlende Abschluss einer Audio-Datei automatisch hinzugefügt werden. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.2.3 (Oktober 2006)
  • Der Timeline-Check wurde komplett überarbeitet. Es wird nun zwischen Fehlern und Warnungen unterschieden. Fehler müssen beseitigt werden, bevor der Timeline-Check absolviert werden kann. Warnungen lassen die Absolvierung des Timeline-Checks zu, sollten aber ebenso beseitigt werden. Vom Dialog, der die Fehlermeldung anzeigt, kann man sofort zur fehlerhaften Stelle springen. Näheres findet man hier .
  • Die Ballon-Tips können wahlweise ein- oder ausgeschaltet werden. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes; u.a.:
  • Die grafische Darstellung der Timeline war fehlerhaft, wenn ein Audio-Synchronisations-Punkt auf eine eingebettete Licht-Sonderfunktion (z.B. eine Einblendung) gelegt wurde.
  • Wichtiger Hinweis! Bedauerlicherweise enthielten die beiden letzten Versionen (3.2.1 und 3.2.2) einen Fehler, der mit diesen Versionen erstellte oder bearbeitete *.twc-Dateien betrifft und sich folgendermaßen äußert: Wenn man in den Voreinstellungen "Pause" gewählt hat, wurde beim Hinzufügen von Dias zur Timeline in den Zeilen mit einer Pause die Standzeit nicht, wie erforderlich, auf "0,0", sondern je nach Projektor-Typ auf "4,0" bzw. "5,5" gesetzt. Man erkennt dies, indem man in der Timeline das Feld "Standzeit" selektiert, welches bei "Pausen" zwar grau hinterlegt ist, aber bei Selektion die eingetragene Zeit zeigt. Wenn dort ein Wert größer als "0,0" steht, ist dies ein Fehler. Die Leinwand-Simulation ist davon zwar nicht betroffen, da sie nur das Datum "Pause" abfragt, aber der Projektor selbst macht nur dann wirklich eine Pause, wenn in der Standzeit eine "0,0" steht. Die fehlerhaften Dateien können leicht folgendermaßen korrigiert werden: man selektiert (mit Strg+LinksClick) alle Zeilen in der Timeline, die eine "Pause" enthalten und wählt dann im Kontext-Menü "Überblend-Eigenschaften editieren". Im erscheinenden Dialog wählt man dann zunächst "Keine Pause", drückt das Button "Übernehmen", wählt danach erneut "Pause" und drückt am Ende "OK". Dann ist bei den "Pausen" überall "0,0" als Standzeit eingetragen.
Version 3.2.2 (September 2006)
  • Im Live-Modus können nun für ein Dia auch das Dia-Format und ein Dia-Kommentar eingegeben werden. Näheres findet man hier .
  • An geeigneter Stelle werden Ballon-Tips eingesetzt.
  • Verbesserung des Audio-Players; u.a. gibt es nun eine Option "QuickStart", mit der man den Audio-Player an der momentanen Stellung des Positions-Reglers starten kann. Näheres findet man hier .
  • Verbesserung des Timeline-Checks in bezug auf die Behandlung von Audio-Funktionen. Näheres findet man hier .
  • Die Darstellung der Audio-Tracks in der grafischen Darstellung der Timeline wurde verbessert; Audio-Tracks und Audio-Synchronisations-Pausen werden in ihrer wahren Länge dargestellt. Näheres findet man hier .
  • In der grafischen Darstellung der Timeline werden für jede Audio-Datei deren Länge sowie die Start- und Stop-Position angezeigt. Näheres findet man hier .
  • In der grafischen Darstellung der Timeline kann die Schriftgröße frei gewählt werden. Näheres findet man hier .
  • In der grafischen Darstellung der Timeline kann, sofern vorhanden, mit dem Mausrad gescrollt werden. Näheres findet man hier .
  • Die Tastenkürzel und Maus-Clicks für Positions-Marker wurden verändert. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.2.1 (September 2006)
  • In der Timeline können nun Positions-Marker gesetzt werden, die ein bequemes Navigieren zwischen einzelnen Programmschritten ermöglichen. Näheres findet man hier .
  • Die Farben in der grafischen Darstellung der Timeline können frei gewählt und somit den persönlichen Vorlieben angepasst werden. Näheres findet man hier .
  • Im Live-Modus kann nun auch das Dia-Format (Quer-/Hochformat) gesetzt werden. Näheres findet man hier .
  • Das Scrollen in den einzelnen Tabellen wurde optimiert.
  • Die Demo-Dateien wurden aktualisiert.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes; u.a. Korrektur eines Fehlers, der gelegentlich beim Öffnen von *.twc-Dateien auftrat, die mit einer älteren TwinLightControl-Version erstellt wurden.
Version 3.2.0 (August 2006)
  • Einstellungen einer Null-Zeile (Cut, Überblendzeit) gehen beim Entfernen der Null-Zeilen nicht mehr verloren. Man kann also einen Timeline-Check mehrmals ausführen und zurücknehmen, ohne dass man die in den Null-Zeilen vorgenommenen Änderungen wiederholen muss. Näheres findet man hier .
  • In der Dia-Tabelle gibt es ein neues Feld "Benutzt", welches anzeigt, ob sich ein Dia bereits in der Timeline befindet. Mit dem manuellen Setzen oder Löschen dieses Feldes kann ein Dia in die Timeline übernommen oder aus der Timeline entfernt werden. Näheres findet man hier .
  • Befindet sich ein Dia bereits in der Timeline, wird im Dia-Editor das Feld "Benutzt" hellgrün hinterlegt. Näheres findet man hier .
  • In der Timeline-Tabelle können die Magazin- und die Dia-Fach-Nummer händisch geändert werden, was für nachträgliche Korrekturen hilfreich ist. Näheres findet man hier .
  • Wenn im Dia-Editor ein Dia als "Nicht belegt" markiert werden soll, und das betreffende Dia befindet sich bereits in der Timeline, wird nachgefragt, ob die Aktion ausgeführt werden soll.
  • Beim Timeline-Check wird überprüft, ob sich einunddasselbe Dia mehrmals direkt hintereinander in der Timeline befindet.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.1.8 (August 2006)
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.1.7 (Juli 2006)
  • Im Live-Modus kann ein Dia auch dauerhaft aus dem Dia-Editor entfernt werden. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.1.6 (Juni 2006)
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.1.5 (Mai 2006)
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.1.4 (April 2006)
  • Bei einem Wechsel des Dia-Formats in der Timeline kann nun neben einer kurzen Überblendzeit auch die Licht-Sonderfunktion "Ab-/Aufblenden" automatisch verwendet werden. Näheres findet man hier .
  • Die Überblend-Eigenschaften mehrerer selektierter Programmschritte können in einem Schritt editiert werden. Näheres findet man hier .
  • Im Live-Modus kann das aktuell projizierte Dia wahlweise vor dem aktuellen Programmschritt in die Timeline eingefügt oder an das Ende der Timeline angefügt werden. Die Shortcuts für diese Operationen wurden gegenüber Version 3.1.3 geändert. Näheres findet man hier .
  • Im Live-Modus: für das aktuell projizierte Dia wird, sofern es sich in der Timeline befindet, der zugehörige Programmschritt zur besseren Sichtbarkeit rot markiert. Näheres findet man hier .
  • Im Audio-Player gibt es ein neues Button zum schnellen Halbieren bzw. Verdoppeln der Lautstärke, was bei Live-Vorträgen für einen temporären Speaker-Support von Nutzen sein kann. Näheres findet man hier .
  • Bei Bewegung der Maus in den Magazin-, Dia- und Timeline-Editor wird dieser automatisch fokussiert. Diese Option ist an-/abschaltbar. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.1.3 (April 2006)
  • Im Projektor-Betrieb gibt es jetzt den sog. Live-Modus. Er bietet eine einfache Möglichkeit, beim manuellen Durchlauf von Magazinen gewünschte Dias sofort in die Timeline zu übernehmen. Dieses neue Feature geht auf eine Idee von E.Wendorff zurück. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes, u.a. die Audio-Funktionen "... am Ende" in der Leinwand-Simulation betreffend.
Version 3.1.2 (März 2006)
  • Der Import von Bildern wurde optimiert und geht jetzt deutlich schneller vonstatten. JPEG- bzw. BMP-Dateien für Dias sind jetzt direkt in den Dia-Editor integriert. Dafür gibt es im Dia-Editor ein neues Feld "Bild". Näheres findet man hier .
  • Das Aussehen des Magazin-, Dia- und Timeline-Editors kann jetzt noch besser den persönlichen Anforderungen angepasst werden. Neben der Breite der Zellen ist nun auch deren Höhe veränderbar. Die Funktion zur automatischen Anpassung der Spaltenbreite an den Inhalt der Spalte wurde verbessert. Näheres findet man hier .
  • Eine gute Nachricht für alle Besitzer des älteren Projektortyps "Rolleivision 35 twin digital P": Die Schnittstellensteuerung ist in einer ersten Version verfügbar (die Übertragung des Projektorspeichers in die Timeline funktioniert allerdings noch nicht). Damit können alle Vorteile, die TwinLightControl bietet, auch für den "twin digital P" genutzt werden. Es ist allerdings zu beachten, dass der "twin digital P" nicht alle Features unterstützt, die die neueren Projektortypen "Twin MSCxxxP" bieten. Mehr zu den Unterschieden . Alle Interessenten sind eingeladen, die Projektorsteuerung zu testen.
  • Die Standard-Timeout-Werte für den "Rolleivision Twin MSCxxxP" wurden geändert. Das hat u.U. eine Verbesserung der Kommunikation zwischen PC und Projektor zur Folge. Näheres findet man hier .
  • Falls es Probleme bei der Ansteuerung des Projektors gibt, hat man jetzt die Möglichkeit, den Datenverkehr über die serielle Schnittstelle zu überwachen. Dies geschieht mit Hilfe eines kleinen Monitor-Fensters. Näheres findet man hier .
  • Neue Shortcuts für den Audio-Player mit entsprechender Tastenbelegung für den "eDio IR Remote Controller".
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.1.1 (Januar 2006)
  • Wichtige Neuerung: Für die Vollversion von TwinLightControl ist eine Registrierung erforderlich. Näheres findet man hier .
  • Vorschlag für eine separate Infrarot-Fernbedienung, die die Fernsteuerung von TwinLightControl möglich macht. Unbedingt lesen! Näheres findet man hier .
  • Im Audio-Player gibt es Shortcuts für Ton ein/aus, Lautstärke erhöhen/erniedrigen und Audio-Track vorspulen/zurückspulen. Näheres findet man hier .
  • Es gibt einen neuen Menü-Punkt zum Setzen bzw. Restaurieren der Bildschirm-Helligkeit. Näheres findet man hier .
  • In den Feldern Dia-Format, Licht-Sonderfunktion und Audio-Funktion werden kleine Piktogramme angezeigt. Dieses Feature ist an-/abschaltbar. Näheres findet man hier .
  • Beim Timeline-Check wird eine Warnung ausgegeben, wenn ein Audio-Track nicht beendet wurde, bevor der nächste gestartet wird bzw. das Ende der Timeline erreicht ist. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.1.0 (Dezember 2005)
  • In der grafischen Darstellung der Timeline gibt es nun Audio-Kurven (in Analogie zu den Licht-Kurven), die die Übersichtlichkeit der Synchronisation von Bild und Ton verbessern. Näheres findet man hier und hier .
  • Im Magazin-, Dia- und Timeline-Editor kann jede Spalte einzeln angezeigt oder versteckt werden. Diese Einstellungen sowie die Breiten aller Spalten werden in der Registry abgelegt und bleiben somit über die Beendigung von TwinLightControl hinaus erhalten. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes; u.a.:
  • Wenn beim Start einer Live-Dia-Show auf dem Computer kein Bildschirmschoner aktiviert war, aber die Option "Bildschirmhelligkeit dimmen" gewählt wurde, wurde die Bildschirmhelligkeit nach dem Ende der Dia-Show nicht wieder auf "Normal" zurückgestellt.
Version 3.0.6 (November 2005)
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes, u.a.wurden folgende Fehler behoben:
  • Wenn man bei der grafischen Darstellung einer langen Timeline das Kontext-Menü (rechte Maustaste) für große Programm-Nummern aufruft, wird das Menü nicht an der Position der Maus, sondern am linken Bildschirmrand angezeigt.
  • Fehlerhafte Berechnung der Warte-Zeit für Audio-Synchronisations-Punkte (nur für die Anzeige in der grafischen Darstellung der Timeline).
  • Fehlerhafte Darstellung der Dialoge für die Überblend-Eigenschaften bei Audio-Synchronisations-Punkten.
Version 3.0.5 (November 2005)
  • Wenn bei einer realen Dia-Show der Bildschirmschoner abgeschaltet wird, wird gleichzeitig die Display-Helligkeit reduziert. Näheres findet man hier .
  • In der grafischen Darstellung der Timeline können nun auch die Überblend-Eigenschaften eines Programmschritts editiert werden. Näheres findet man hier .
  • Beim Timeline-Check kann die Standard-Helligkeit für alle Programmschritte und die Überblendzeit (Abblendzeit) für Null-Zeilen übernommen werden. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.0.4 (November 2005)
  • Wenn ein Bildschirmschoner aktiv ist, wird er abgeschaltet, wenn der Projektor aktiv ist und die Fernbedienung gestartet wird. Damit bleibt der Bildschirmschoner während eines Live-Vortrages abgeschaltet. Nach dem Schließen der Fernbedienung wird der Bildschirmschoner wieder aktiviert. Näheres findet man hier .
  • Im Audio-Player können bei *.mp3-Dateien die ID3-Tag-Informationen, sofern vorhanden, angezeigt werden. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.0.3 (Oktober 2005)
  • TwinLightControl wurde um einen Dia-Show-Wizard erweitert, der Anfänger bei der Erzeugung, Fertigstellung und Präsentation von Dia-Shows unterstützt. Näheres findet man hier .
  • Vorbereitung der Unterstützung des "Rolleivision 35 twin digital P", des Vorgängers der MSC-Projektoren. Es fehlt uns noch das Protokoll mit den Steuerbefehlen für den "Rolleivision 35 twin digital P". Wer ein solches Protokoll besitzt, der wird gebeten, sich mit QuiverTree in Verbindung zu setzen. Rollei selbst hat leider keins mehr.
  • Die Konfiguration der seriellen Schnittstelle wurde um das Datum "Zahl der Daten-Bits" (8 Daten-Bits für MSC-Projektoren, 7 Daten-Bits für "Rolleivision 35 twin digital P" Projektoren) erweitert.
  • Die Anzeige des QuiverTree-Logos beim Programmstart ist an-/abschaltbar (Menü Hilfe). Näheres findet man hier .
  • Beim Anlegen einer neuen und beim Öffnen einer vorhandenen Dia-Show kann auf Wunsch die Hilfe-Seite "Fahrplan zur fertigen Dia-Show" angezeigt werden. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.0.2 (Oktober 2005)
  • Verschiedene Detailverbesserungen, u.a. Synchronisation zwischen Dia- und Magazin-Editor beim Scrollen im Dia-Editor. Näheres findet man hier .
  • Verschiedene Bugfixes.
Version 3.0.1 (Oktober 2005)
  • Beim Setzen von Audio-Start-, Audio-Stop- und Audio-Synchronisations-Punkten werden nun auch Sekundenbruchteile berücksichtigt. Damit ist eine noch genauere Synchronisation von Bild und Ton möglich. Näheres findet man hier .
  • Der Import von Bild-Dateien im Dia-Editor wurde verbessert. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 3.0.0 (September 2005)
  • Die Undo- und Redo-Funktionalität wurde komplett überarbeitet. Undo- und Redo-Funktion sind jetzt uneingeschränkt funktionsfähig und im Bedarfsfall zu- oder abschaltbar. Näheres findet man hier .
  • Im Zuge der Überarbeitung wurde TwinLightControl insgesamt hinsichtlich Geschwindigkeit und Sicherheit optimiert.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.7.4 (September 2005)
  • Timeline-Info: bei langen Textzeilen ist nun auch pixelweises (weiches) Scrollen des Lauftextes möglich.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.7.3 (August 2005)
  • Grafische Darstellung der Timeline: Kontext-Menü "Audio-Synchronisations-Punkt entfernen".
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes, u.a. das Setzen von Audio-Synchronisations-Punkten und das Starten von Audio-Dateien betreffend.
Version 2.7.2 (August 2005)
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes: u.a.: Hängenbleiben der Laufschrift im Timeline-Info bei aktivem Projektor.
Version 2.7.1 (August 2005)
  • Verschiedene Bugfixes: u.a.: fehlerhaftes Verhalten beim Start einer Dia-Show mit einer bestimmten Magazin-Nummer, wenn beim ersten Dia des zu startenden Magazins eine Lichtfunktion "Einblenden", "Blinken", "Flashen" oder "Schaukeln" eingetragen ist.
Version 2.7.0 (August 2005)
  • Die Helligkeit kann jetzt für jedes Dia individuell festgelegt werden.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes: u.a.: Fehler bei der Leinwand-Simulation: wenn beim letzten Dia vor einer Null-Zeile eine Licht-Funktion "Einblenden", "Blinken" oder "Flashen" eingetragen ist, dann kommt es am Ende der Dia-Show zum Crash.
Version 2.6.9 (August 2005)
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.6.8 (Juli 2005)
  • Es gibt fünf neue Audio-Funktionen, die nicht auf den ersten (ansteigenden) Ast der Lichtkurve, sondern auf den letzten absteigenden ) Ast der Lichtkurve gestartet werden. So kann z.B. am Ende eines Magazins oder der ganzen Dia-Show das Ausblenden von Bild und Ton synchron gestartet werden. Näheres findet man hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.6.7 (Juli 2005)
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.6.6 (Juli 2005)
  • Die virtuelle Fernbedienung kann auf Wunsch verkleinert werden, so dass die grafische Darstellung der Timeline gänzlich sichtbar wird. Näheres s. hier .
  • Die Demo-Dia-Show "Musik-Ausblendung am Ende" zeigt, wie man die Ausblendung des letzten Dias und die Ausblendung der Musik synchronisieren kann.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.6.5 (Juni 2005)
  • Bugfix: Fehler beim Import von DiaEdit-Dateien.
Version 2.6.4 (Juni 2005)
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.6.3 (Juni 2005)
  • Detailverbesserung: die Vorschau-Funktion auf das nächste Dia im Timeline-Info ist an-/abschaltbar.
Version 2.6.2 (Juni 2005)
  • Verschiedene Detailverbesserungen (u.a.: im Timeline-Info wird jetzt der Kommentar des nächsten Dias als Vorschau angezeigt).
  • Verschiedene Bugfixes (u.a.: Fehler beim Verschieben von Dia-Blöcken, wenn der Zielpunkt innerhalb des Blocks liegt).
Version 2.6.1 (Juni 2005)
  • Mit der neuen Funktion "Eine Gruppe von Dias verschieben" kann eine Gruppe von zusammenhängenden Dias an jeden beliebigen Ort verschoben werden.
  • Das kleine Tool "Leinwand-Rechner" ermittelt die Brennweite des Projektionsobjektivs, die Leinwand-Größe oder den Abstand Projektor - Leinwand. Nützlich für die Planung einer Dia-Show. Näheres s. hier .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.6.0 (Juni 2005)
  • Audio-Dateien und Überblendungen können nun (innerhalb gewisser Grenzen) synchronisiert werden. Näheres erfährt man hier .
  • In der Hilfe wird nochmals ausführlich erläutert, was beim Start und Fortgang einer realen Dias-Show zu beachten ist. Näheres s. hier . Bitte lesen!!!
  • Die Verzögerung der Anzeige der aktuellen Programm-Nummer bei Steuerung der Dia-Show über die virtuelle Fernbedienung ist beseitigt.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.5.2 (Mai 2005)
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes; u.a. das Handling der Dia-Nummern bei Nicht-Koppelmagazinen betreffend (näheres erfährt man hier ); des weiteren wurde das "nervöse Flackern" der Taste "Bild vor" und der Timeline-Info bei aktivem Projektor beseitigt.
Version 2.5.1 (Mai 2005)
  • Die Standalone-Version der "Grafischen Darstellung der Timeline" ist jetzt ein nahezu vollwertiger Ersatz für die virtuelle Fernbedienung (s. "Wie wird die Timeline grafisch dargestellt?" ).
  • Die Demo-Dia-Show "Musik-Vorspann.twc" zeigt, wie man einen professionellen Vor- und Abspann erzeugt. Näheres dazu in "Tips & Tricks" .
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.5.0 (April 2005)
  • Audio-Dateien können jetzt auch über das Kontext-Menü in der grafischen Darstellung der Timeline abgespielt, hinzugefügt oder entfernt und deren Eigenschaften verändert werden. (s. unter "Wie wird die Timeline grafisch dargestellt?" )
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.4.6 (April 2005)
  • Neues Konzept der Archivierung/Dearchivierung von *.twc-Dateien (s. Hilfe).
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.4.5 (April 2005)
  • Bei einem Neu-Start infolge eines Fehlers wird auch die Audio-Datei an der Stelle des tatsächlichen Abbruchs wieder aufgenommen.
  • Verschiedene Bugfixes.
Version 2.4.4 (April 2005)
  • Verschiedene Bugfixes.
Version 2.4.3 (März 2005)
  • Verschiedene Detailverbesserungen (betrifft das Packen, Entpacken, Archivieren und Dearchivieren von Dateien; s. Hilfe).
  • Verschiedene Bugfixes.
Version 2.4.2 (März 2005)
  • Im Dialog "Beschreibung der Dia-Show" werden Datum und Uhrzeit der letzten Änderung der Datei angezeigt.
  • Alle *.twc-Dateien können in einer Archiv-Datei gesichert und später wieder eingespielt (rückgesichert) werden.
  • Neuer Menüpunkt "Alle Backup-Dateien im Programm-Verzeichnis löschen".
  • Verschiedene Bugfixes.
Version 2.4.1 (März 2005)
  • Verschiedene Bugfixes.
Version 2.4.0 (Februar 2005)
  • Drei zusätzliche Felder in der Timeline: Audio-Start- und -Stop-Position, Audio-Track-Länge; damit kann eine Audio-Datei an jeder beliebigen Stelle gestartet bzw. gestoppt werden.
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.3.8 (Februar 2005)
  • Zusätzliches Info-Fenster am unteren Bildschirmrand, welches deutlich sichtbar die wichtigsten Informationen zum momentanen Programmschritt anzeigt.
  • Verschiedene Bugfixes.
Version 2.3.7 (Februar 2005)
  • Im Dialog für das Einfügen von Bildern ist nun Mehrfachauswahl möglich, d.h. es können z.B. ganze eingescannte Magazine auf einmal eingefügt werden; das gleiche trifft auch auf das Entfernen von Bildern zu (näheres s. Hilfe).
  • Beim Start einer Dia-Show mit einer Programm-Nummer > 1 wird die letzte zurückliegende Audio-Funktion gesucht und gestartet (näheres s. Hilfe).
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.3.6 (Januar 2005)
  • Verschiedene Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.3.5 (Januar 2005)
  • Die Kommentare des jeweils ersten und letzten Dias eines Magazins können als Kommentar für das Magazin übernommen werden (s. Hilfe).
  • Die serielle Schnittstelle, an der der Projektor angeschlossen ist, kann manuell und individuell konfiguriert werden.
  • Verschiedene Bugfixes.
Version 2.3.4 (Januar 2005)
  • Bild- und Audio-Dateien können bei Bedarf vom Speichern ausgeschlossen werden.
  • Zahlreiche Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.3.3 (Januar 2005)
  • Komplette Überarbeitung der Leinwand-Simulation und Projektor-Steuerung.
  • Grafische Darstellung der Timeline: Anzeige einer mitlaufenden Zeitmarke.
  • Button Neu-Start in der PC-Fernbedienung (sehr nützlich!).
  • Leertaste als bequeme Alternative zum Steuern einer Dia-Show in der virtuellen Fernbedienung.
  • Überarbeitung der Aktivierung des Projektors und der Abfrage der seriellen Schnittstellen.
  • Zahlreiche Detailverbesserungen.
  • Verschiedene Bugfixes.
Version 2.3.2 (Dezember 2004)
  • Grafische Darstellung der Timeline: Anzeige von Pause-Markern.
  • Behebung eines Bugs.
Version 2.3.1 (Dezember 2004)
  • Grafische Darstellung der Timeline: Anzeige der Bild-Dateien.
  • Behebung einiger Bugs.
Version 2.3.0 (Dezember 2004)
  • Grafische Darstellung der Timeline (Lichtkurven, Audio-Funktionen).
  • Behebung einiger Bugs.
Version 2.2.6 (Dezember 2004)
  • Behebung einiger Bugs.
Version 2.2.5 (Dezember 2004)
  • Zeitliche Optimierung der Leinwand-Simulation.
  • Behebung einiger Bugs.
Version 2.2.4 (November 2004)
  • Optimierung der grafischen Darstellung unter verschiedenen Bildschirm-Auflösungen.
  • Behebung einiger Bugs.
Version 2.2.3 (November 2004)
  • Behebung einiger Bugs.
Version 2.2.2 (November 2004)
  • Behebung einiger Bugs.
Version 2.2.1 (November 2004)
  • Neuer Dialog "Suchen": es kann im Magazin-, Dia- und Timeline-Editor nach Datensätzen gesucht werden, die den gewünschten Such-String im Kommentar-Feld enthalten.
  • Neue Option "Übertragen der Dia-Show mit Ende-Kennung" in den Voreinstellungen.
  • Behebung einiger Bugs.
Version 2.2.0 (November 2004)
  • Das Datei-Handling wurde stark vereinfacht; es gibt jetzt nur noch eine *.twc-Datei, die alle Datenbank-Tabellen, Bild- und Audio-Dateien enthält; *.twc-Dateien, die mit älteren TwinLightControl-Versionen erstellt wurden, werden automatisch konvertiert.
  • Automatisches Scrollen bei Mehrfachauswahl im Magazin-, Dia- und Timeline-Editor.
  • Behebung einiger Bugs.
Version 2.1.1 (Oktober 2004)
  • Verbesserte Installationsroutine mit deutlich kleineren Installationsdateien (schnellerer Download).
  • Verändertes Datei-Format für *.twc-Dateien; alte Dateien werden automatisch ins neue Format konvertiert.
  • Optional kann für das Erscheinungsbild der Bedienelemente von TwinLightControl der Windows XP Stil verwendet werden (s. Menü Hilfe / Windows XP Stil).
  • In der Timeline nicht benutzte Dias können automatisch als "Nicht belegt" markiert werden.
  • Lücken (nicht belegte Dia-Fächer) in Dia-Magazinen können automatisch geschlossen werden.
  • Behebung einiger Bugs.
Version 2.1.0 (September 2004)
  • Neuer Dialog: "Gehe zu ..."; damit kann man zu einem beliebigen Datensatz im Magazin-, Dia- oder Timeline Editor springen.
  • Behebung einiger Bugs.
Version 2.0.3 (Juli 2004)
  • Bugfix: Verschieben von Programmschritten in der Timeline funktioniert nicht.
Version 2.0.2 (Juli 2004)
  • Integrierter Zip-Packer zum Packen und Entpacken von twc-Dateien und Medien-Verzeichnisssen.
  • Behebung einiger Bugs.
Version 2.0.1 (Juli 2004)
  • Behebung einiger Bugs.
Version 2.0.0 (Juni 2004)
  • Das Programm wurde komplett überarbeitet und einigen zusätzlichen nützlichen Features versehen.
  • Bis Version 1.1.4 lagen den Tabellen Paradox-Datenbanken zugrunde, ab Version 2.0.0 sind es speicherorientierte Datenbanken.
  • Das Einlesen von Dateien, die mit früheren Programm-Versionen erstellt wurden, ist problemlos möglich. Man wird darauf hingewiesen, dass ein Backup der alten Datei erstellt wurde.
  • Die Tabellen des Magazin-, Dia- und Timeline-Editors können auf volle Fenstergröße gebracht werden (über Strg+LinksClick in die Kopfleiste oder das Kontext-Menü).
  • In der Timeline können nun Audio-Dateien eingetragen werden, die zeitgenau mit einem bestimmten Dia ein- oder ausgeschaltet werden können. Möglich sind dabei Ein- und Ausschalten (mit oder ohne Pause), Ein- und Ausblenden (mit oder ohne Pause) und Erhöhung oder Reduzierung der Lautstärke.
Version 1.1.4 (November 2003)
  • Änderung der Benutzerschnittstelle; betrifft das Löschen von Magazinen und Programmschritten sowie das Ein- bzw. Anfügen von Dias in die Timeline: ein einzelner Datensatz kann nun gelöscht sowie ein- bzw. angefügt werden, ohne dass er vorher markiert werden muss (s. Hilfe-Datei).
  • *.twc-Dateien werden automatisch registriert; bei einem Doppelklick auf die *.twc-Datei startet TwinLightControl selbständig.
  • Behebung einiger Bugs.
Version 1.1.3 (Oktober 2003)
  • im Dia-Editor können Kommentare von vorhergehenden Dias übernommen werden (s. Tastenkürzel und Maus-Clicks im Dia-Editor ).
  • zur besseren Übersichtlichkeit werden in der Fußzeile der Spalte "Kommentar" des Magazin-, Dia- und Timeline-Editors die aktuelle Magazin-, Dia- bzw. Programm-Nummer angezeigt.
  • Behebung einiger Bugs.
Version 1.1.2 (Oktober 2003)
  • in Null-Zeilen kann nun die Überblendzeit geändert werden; die Überblendzeit einer Null-Zeile ist die Abblendzeit des Dias vor der Null-Zeile.
  • Erweiterung der Berichte um "Timeline-Zusammenfassung".
  • Behebung einiger Bugs.
Version 1.1.1 (Oktober 2003)
  • Exportfunktion: die erstellte Dia-Show kann in eine DiaEdit-Datei exportiert werden; in der Testversion ist die Exportfunktion auf 20 Zeilen beschränkt.
Version 1.1 (Oktober 2003)
  • Komplette Überarbeitung und Vereinfachung der Benutzerschnittstelle; so sind jetzt fast alle Befehle entweder per Menü, Tastenkürzel oder Mausclick erreichbar.
  • Die Tastenkürzel wurden an die Windows-Konventionen angepasst (z.B Strg+A für "Alles markieren", Einfg für "Ein-/Anfügen", Entf für "Löschen").
  • Komplette Überarbeitung der Fernbedienung; die Bedienung ist jetzt einfacher, logischer und intuitiver.
  • Bei nicht aktiviertem Projektor kann eine Leinwand-Simulation der Dia-Show durchgeführt werden.
  • Behebung einiger Bugs (z.B. konnte im Dia-Editor das Dia-Format nur geändert werden, wenn alle Dias in allen Magazinen angezeigt wurden; dies ist auf einen Fehler in einer Borland-Bibliothek zurückzuführen).
Version 1.0.1 (August 2003)
  • die Undo-Funktion ist voll funktionsfähig.
  • Behebung einiger kleinerer Bugs.
Version 1.0 (Juli 2003)
  • Version 1.0 ist die erste freigegebene TwinLightControl-Version.
  • die Vollversion ist voll funktionsfähig.
  • die Testversion unterscheidet sich von der Vollversion lediglich darin, dass nur 20 Programm-Zeilen zum Projektor übertragen werden können.
  • die Undo-Funktion ist momentan noch auf Änderungen im Magazin-Editor beschränkt.
  • die Redo-Funktion arbeitet zur Zeit noch nicht.
  • für das nächste Update ist ein voll funktionsfähiges Undo/Redo bis zurück zum letzten Speichern der Datei geplant.
  • das Hilfe-System wird im Laufe der nächsten Zeit ausgebaut und vervollständigt, momentan sind alle zum Arbeiten mit TwinLightControl notwendigen Dinge erklärt.


Systemvoraussetzungen, Installation, Update und Deinstallation

TwinLightControl ist mit einer Installationsroutine versehen, die alle erforderlichen Dateien kopiert und die Registry aktualisiert. Die Datei "TwinLightControlInstaller.exe" ist selbstentpackend / selbstinstallierend.

Beim ersten Programmstart nach einer Neuinstallation wird die Serien-Nummer abgefragt. Bei der Eingabe der Buchstaben ist wahlweise Groß- oder Kleinschreibung möglich.

Bei der Installation von Updates funktioniert es i.d.R., die neue Version ohne Deinstallation der alten zu installieren. In diesem Falle wird die Serien-Nummer der alten Version übernommen. Sollte das Update nicht ordnungsgemäß arbeiten, dann ist vor einer Neuinstallation eine Deinstallation der alten Version zu empfehlen.

Im Menü "Hilfe" gibt es einen Menüpunkt "Updates suchen, downloaden, installieren ...". Damit können verfügbare Updates gesucht, diese auf Wunsch heruntergeladen und installiert werden. Dabei wird zwischen Updates für die reguläre und die Beta-Version unterschieden. Die reguläre Version ist die zuletzt offiziell freigegebene Version, die Beta-Version beinhaltet Bug-Fixes zur letzten regulären Version sowie Erweiterungen und neue Features, die i.d.R. funktionieren sollten, sich aber noch in der Beta-Phase befinden.

Um nach Auswahl des Menüpunktes "Hilfe/Updates suchen, downloaden, installieren ..." die Update-Funktionalität nutzen zu können, muss der Internet-Explorer zumindest installiert sein (braucht nicht der Standard-Browser sein) und eine aktive Internet-Verbindung bestehen oder mindestens eine DFÜ-Verbindung eingerichtet sein. Wenn noch keine aktive Internet-Verbindung besteht, verwendet man das Button "DFÜ-Verbindung herstellen", nach getaner Arbeit das Button "DFÜ-Verbindung trennen".

Nach Herstellung einer Internet-Verbindung werden alle verfügbaren Downloads in einer Auswahlbox aufgelistet und können auf Wunsch heruntergeladen werden. Die heruntergeladenen Dateien werden im Verzeichnis "Downloads" Ihres TwinLightControl-Installations-Verzeichnisses abgelegt, wobei die Version im Dateinamen vermerkt wird. Das Format ist "TwinLightControlInstaller-X.X.X.X.exe" für die reguläre und "TwinLightControlInstaller-Beta-X.X.X.X.exe" für die Beta-Version, wobei "X.X.X.X" für die Versionsnummer steht. Beenden Sie TwinLightControl nach dem Download des Updates und starten Sie die Installationsdatei. Mit dem Button "Update starten" können Sie auch sofort die Installationsdatei ausführen. Gelegentlich sollten Sie das Verzeichnis "Download" aufräumen und von älteren Installationsdateien befreien.

TwinLightControl ist lauffähig unter folgenden Betriebssystem-Varianten:

  • Windows 95 (mit Einschränkungen)
  • Windows 98 (mit Einschränkungen)
  • Windows NT 3.51, 4.0, 5.0 (mit Einschränkungen)
  • Windows 2000
  • Windows XP
  • Windows Vista
  • Windows 7
  • Windows 8
  • Windows 8.1
  • Windows 10
  • Windows 11

Das einwandfreie Funktionieren von TwinLightControl erfordert, dass das Microsoft NET Framework 2.0 oder höher installiert ist. Dies betrifft insbesondere User, die TwinLightControl auf einem Mac unter VMWare (virtuelle Windows-Maschine) betreiben. Die normale VMWare-Installation ist eine "nackte" Installation ohne NET Framework. Letzteres muss also nachinstalliert werden und kann von den entsprechenden Microsoft-Seiten kostenlos heruntergeladen werden.

Für ein einwandfreies Funktionieren der Projektorsteuerung sollte der Rolleivision Twin mindestens die Firmware-Version 7.0 aufweisen. Bei älteren Versionen kann es zu Problemen kommen, näheres findet man hier.

Wenn man eine Leinwand-Simulation durchführen oder Audio-Dateien in die Dia-Show einbinden will, sollte der Computer eine CPU-Taktfrequenz von mindestens 1 GHz und eine schnelle und ausreichend große Festplatte haben. Andernfalls kann es zu Timing-Problemen kommen, d.h. die Synchronität von Bild und Ton ist nicht gewährleistet.

TwinLightControl wurde entwickelt auf einem Computer mit einer Grafik-Auflösung von 1280 x 1024 Pixeln. Eine solche Auflösung kann mittlerweile quasi als Standard angesehen werden und sollte für eine optimale Darstellung gewählt werden. TwinLightControl ist auch unter anderen Auflösungen lauffähig, allerdings ist dann die Darstellung von Schriften und Grafiken nicht optimal. TwinLightControl wurde unter folgenden Auflösungen getestet:

1024 x 768
1152 x 864
1280 x 720
1280 x 768
1280 x 960
1280 x 1024
1360 x 768
1600 x 900
1600 x 1024
1600 x 1200
1920 x 1080
1920 x 1200
1920 x 1440
2048 x 1536

Unter geringeren Auflösungen als 1024 x 768 ist TwinLightControl zwar lauffähig, die Darstellung ist allerdings sehr mangelhaft. Hinzu kommt, dass man ständig hin- und her scrollen müsste, um an alle Tabellen-Einträge heranzukommen.

TwinLightControl wurde außerdem für kleine und große Schriftarten getestet.

Bei der Deinstallation werden die Inhalte folgender Verzeichnisse nicht gelöscht, da sie persönliche Daten enthalten:

  • Archiv (*.zip-Dateien mit archivierten Dia-Shows)
  • DiaShows (*.twc-Dateien mit den Dia-Shows)
  • Journal (COMPortMonitoring-Dateien)
  • License (SoftKey.dat, License.dat)

Bei einer endgültigen Deinstallation von TwinLightControl müssen diese Dateien manuell gelöscht werden. Installiert man TwinLightControl neu und wählt das gleiche Verzeichnis wie vorher, werden die Dateien einfach übernommen. Bei Installation in eine anderes Verzeichnis können/müssen diese Dateien in die entsprechenden Verzeichnisse des neuen Stammverzeichnisses verschoben werden.


Bekannte Probleme

Nachfolgend sind einige Probleme aufgelistet, die beim Betrieb von TwinLightControl auf Rechnern mit den verschiedensten Hard- und Software-Konfigurationen aufgetreten sind.

  • Auf einigen älteren Computern (133 MHz, 266 MHz unter Windows 98 bzw. Windows 2000) wurde festgestellt, dass sich TwinLightControl aufhängt, wenn versucht wird, den Projektor zu aktivieren. Das Fehlverhalten äußert sich darin, dass bei dem Versuch, den Projektor zu aktivieren oder die Fernbedienung zu starten, TwinLightControl sich nicht zurückmeldet. Es handelt sich um ein Problem mit der Betriebssystem-Funktion WriteFile(), die in der DLL kernel32.dll enthalten ist und für die Kommunikation mit dem seriellen Port verantwortlich ist. Hier kann möglicherweise ein Windows-Update oder ein Update der Treiber für den seriellen Port Abhilfe schaffen. Wir sind dabei, den Fehler zu beheben, haben aber noch keine Lösung gefunden. Falls der Fehler auftreten sollte, bitten wir um kurze Information zur Computer-Hardware und zur Windows-Version.
  • Wenn man versucht, die Projektor-Fernbedienung zu öffnen und damit auf das oder die seriellen Ports zuzugreifen, kann es zu einer Fehlermeldung kommen, dass der Zugriff nicht möglich ist. Ursache ist i.d.R. ein parallel laufendes Programm, welches den Zugriff auf die seriellen Ports verhindert (z.B das Programm DialerControl). Abhilfe: Meist bieten derartige Programme Einstellungen, die einen definierten Zugriff von anderen Programmen aus erlauben. Wenn nicht, dann das problematische Programm beenden.
  • Bei neueren Computern (vor allem Notebooks), die keine serielle Schnittstelle mehr haben und bei denen der Projektor über einen USB-Seriell-Adapter betrieben wird, kann es dazu kommen, dass TwinLightControl sich aufhängt, sobald versucht wird, die PC-Fernbedienung zu aktivieren. Es handelt sich hierbei um ein Inkompatibilitäts-Problem des Adapters und es betrifft nicht alle Arten und Modelle von Adaptern. Einige Informationen hierzu findet man z.B. bei http://www.dia.de in der Abteilung Dia-Projektoren/Optik.
  • Beim Öffnen von *.twc-Dateien, die mit TwinLightControl-Version älter als V 2.1.1 erstellt wurden, treten in seltenen Fällen Probleme auf. Die Datei lässt sich zwar öffnen, bei der weiteren Bearbeitung der Datei kann es aber zu nicht behebbaren Fehlern kommen. TwinLightControl weist auf diesen Umstand hin und empfiehlt, nach dem Öffnen der Datei das Programm zu beenden, neu zu starten und die Datei nochmals zu öffnen. Diesmal sollte alles funktionieren, da TwinLightControl beim Öffnen einer alten Datei diese in der neuen Version abspeichert und die alte Datei mit der Endung *.bak ablegt.
  • Wenn man eine Dia-Show über den PC steuert, kommt es gelegentlich vor, dass der Projektor zwar über die virtuelle Fernbedienung (per PC) gesteuert werden kann, von der realen Fernbedienung aber keinerlei Befehle mehr annimmt. Dieses Verhalten ist völlig ohne Systematik, es kann am Anfang einer Dia-Show, mittendrin, am Ende oder gar nicht auftreten. Es hilft dann nur ein Aus- und Wiedereinschalten des Projektors. Das Problem tritt vor allem dann auf, wenn die Dia-Show über die virtuelle Fernbedienung gestartet wurde, und man später versucht, mit der realen Fernbedienung weiterzumachen. Es kann aber auch sein, dass die Dia-Show über die reale Fernbedienung gestartet wurde, eine ganze Weile normal läuft, und dann plötzlich keine Befehle von der realen Fernbedienung entgegennimmt. Über die virtuelle Fernbedienung kann die Show weiterhin gesteuert werden. Man kann auch die Dia-Show beenden, den Projektor aus- und wieder einschalten und einen Neu-Start (Taste "Neu-Start" in der virtuellen Fernbedienung) machen. Von Rollei wurde uns bestätigt, dass es sich um ein firmwarespezifisches Problem handelt. Für die neueren Projektoren MSC 325P und MSC 535P gibt es ein Firmware-Update auf Version 8.9 (Besitzer älterer Modelle müssen leider mit dem Fehler leben). Dazu muss der EEPROM im Innern des Projektors ausgetauscht werden. Bei Bedarf wende man sich an: DHW Fototechnik, http://www.dhw-fototechnik.de.
  • Bei Projektoren mit älterer Firmware gibt es gelegentlich Probleme bei der Ansteuerung des Projektors. Das äußert sich z.B. darin, dass nach einem Magazinwechsel der Projektor versucht, wieder mit dem alten Magazin zu beginnen. Betroffen davon sind Projektortypen MSC 300P, die vor 1997 (Firmware-Version: ??) gebaut wurden. Außerdem sind bei Firmware-Versionen < 7.1 keine Dia-Shows mit mehr als 255 Dias möglich (alle Geräte, die vor dem Jahre 2001 gebaut wurden). Man sollte ein Update der Firmware durchführen lassen. Je nach Seriennummer des Projektors bedeutet das einen Austausch des EEPROMs oder der ganzen Leiterplatte. Bei Bedarf wendet man sich an: DHW Fototechnik, http://www.dhw-fototechnik.de .


Fehler in TwinLightControl

Kein Programm ist fehlerfrei, es sei denn, es tut nichts.

Wenn bei der Ausführung von TwinLightControl Fehler auftreten, dann bitte eine Fehlermeldung senden an:

 twinlightcontrol@quivertree.de

Die Fehlermeldung sollte folgende Punkte enthalten:

  • Rechner-Konfiguration: Hardware, Betriebssystem, eingestellte Grafik-Auflösung und Schriftart
  • Ist der Fehler reproduzierbar? Bitte den genauen Verlauf angeben, der zum Fehler führte.
  • Wie äußert sich der Fehler?
  • Welcher Text bzw. Dialog wird ggf. mit dem Fehler ausgegeben?
  • Welche *.twc-Datei verursachte den Fehler? Die Datei bitte mitsenden.

Wir werden dann so schnell wie möglich versuchen, den Fehler zu lokalisieren und zu beheben.


Beispiele für Dia-Shows

Im Verzeichnis "DiaShows\Demos" sind einige Beispiele für Dia-Shows, die mit TwinLightControl erstellt wurden, zu finden. Sie demonstrieren verschiedene Features des Programms.


Howtostarttwinlightcontrol

Wie wird TwinLightControl gestartet?

TwinLightControl wird wie jedes andere Programm auch gestartet: durch Eingeben des Namens in einem Kommandofenster oder durch Doppelklick auf das Programmsymbol. Beim Start von TwinLightControl wird ein Startfenster angezeigt, dessen Statuszeile über die einzelnen Phasen des Startvorgangs informiert.

Wenn beim Start von TwinLightControl für ein bis zwei Sekunden die Strg-Taste gedrückt wird, wird die Anzeige dieses Fensters unterdrückt. Der Startvorgang wird dadurch allerdings nicht beschleunigt.


Fahrplan zur fertigen Dia-Show

Folgende Schritte sind notwendig, um eine Dia-Show zu erstellen und zur Präsentation zu bringen:

  • eine neue Dia-Show erzeugen
  • die Voreinstellungen ggf. ändern
  • eine Beschreibung der Dia-Show erstellen
  • die erforderlichen Magazine in den Magazin-Editor einfügen; die Magazine werden automatisch mit Dias gefüllt
  • im Magazin-Editor ggf. Daten ändern
  • wenn gewünscht, im Dia-Editor Bild-Dateien zu den Dias hizufügen
  • im Dia-Editor ggf. Daten ändern
  • im Live-Modus ggf. während der Projektion Dias zur Timeline hinzufügen
  • im Dia-Editor für jedes Magazin die gewünschten Dias selektieren und in die Timeline einfügen
  • im Timeline-Editor ggf. Daten ändern
  • wenn gewünscht, im Timeline-Editor Audio-Dateien für den Programmschritt hinzufügen
  • im Timeline-Editor ggf. die Reihenfolge der Dias ändern
  • den Timeline-Check durchführen; dabei können die Stand- und Überblendzeit ggf. noch geändert werden
  • ggf. die Dia-Show skalieren
  • ggf. Audio-Synchronisations-Punkte hinzufügen
  • den Projektor aktivieren, falls dieser angeschlossen und eingeschaltet ist
  • die Fernbedienung aktivieren
  • die Dia-Show in den Projektorspeicher übertragen
  • die Dia-Show ggf. in den Modul übertragen
  • die Dia-Show starten
  • ggf. einen Bericht zur Dia-Show erstellen


Wie wird eine neue Dia-Show erzeugt?

Man wählt das Menü Datei/Neu oder Strg+N oder das entsprechende ToolButton [image] .

Die evtl. vorher bearbeitete Dia-Show muss geschlossen werden, es kann also immer nur eine Dia-Show bearbeitet werden.

Wie man aus einer DiaEdit-Datei eine TwinLightControl-Datei erzeugt, erfährt man hier.


Wie wird eine Beschreibung der Dia-Show erstellt?

Zu jeder Dia-Show kann eine kurze Beschreibung erstellt werden. Dies geschieht mit Hilfe des Buttons "Beschreibung der Dia-Show" [image] oder mit Hilfe des gleichnamigen Menü-Punktes.

Die Beschreibung enthält Informationen zur Dia-Show, die einzelnen Einträge des Dialogs sind selbsterklärend.


Wie werden die Voreinstellungen geändert?

Man wählt im Hauptfenster von TwinLightControl das Button "Voreinstellungen" [image] .

Voreinstellungen beeinflussen die Art und Weise, wie Magazine, Dias oder Programmschritte zukünftig hinzugefügt werden. Voreinstellungen können jederzeit geändert werden, sie beeinflussen aber nur alle nachfolgenden Operationen.

Voreinstellungen entscheiden z.B. über den Magazin-Typ, das Dia-Format oder die Überblendzeit.

Wie der serielle Port konfiguriert wird, erfährt man hier.

Welche Bedeutung der Schalter "Nur kleine Bild-Nummern verwenden" hat, wird hier erläutert.

Die Option "Übertragen der Dia-Show mit Ende-Kennung" bedarf einer Erläuterung. Beim Laden einer Dia-Show in den Speicher des Projektors wird dieser nicht initialisiert. Wenn man eine lange Dia-Show in den Projektorspeicher lädt und später, ohne dass der Projektor ausgeschaltet wurde, eine kürzere Dia-Show, dann bleibt der Rest der langen Dia-Show im Projektor stehen. Das ist normalerweise kein Problem, wenn die kürzere Dia-Show ordnungsgemäß mit einer Null-Zeile abgeschlossen wurde (was TwinLightControl ja automatisch beim Timeline-Check macht). Lädt man allerdings die Dia-Show aus dem Projektor-Speicher wieder in die Timeline, werden die Reste der langen Dia-Show mit geladen. Dies kann man verhindern, indem man die Option "Übertragen der Dia-Show mit Ende-Kennung" einschaltet. Dabei werden beim Übertragen der Dia-Show in den Projektor am Ende 5 Null-Zeilen geschrieben, an denen TwinLightControl eindeutig erkennt, dass eine Dia-Show zu Ende ist.

Stehen auf einem Computer mehrere Audio-Ausgabe-Geräte zur Verfügung, kann man das gewünschte Audio-Geät aus einer Liste auswählen.

Die globale Helligkeit ist nur bei angeschlossenem Projektor von Bedeutung. Mit diesem Faktor, der zwischen 0 und X liegt (Default: 1), werden alle in der Timeline eingetragenen Helligkeitswerte multipliziert, bevor sie zum Projektor geschickt werden. Der Wert X berechnet sich so, dass das Produkt aus dem größten Helligkeitswert in der Timeline und der globalen Helligkeit den Wert von 110 % (Twin MSC 535P) bzw. 100 % (Twin MSC 325P) nicht übersteigt.

Zwei Beispiele: Ist in der Timeline ein Helligkeitswert von 85 % eingetragen und die globale Helligkeit hat einen Wert von 0,80, dann wird dem Projektor ein Helligkeitswert von 0,80 * 85 % = 68 % übermittelt. Hat die globale Helligkeit den Wert 1,18, wird dem Projektor ein Helligkeitswert von 1,18 * 85 % = 100 % übermittelt.

Sinnvoll anzuwenden ist die globale Helligkeit z.B. dann, wenn man eine Dia-Show den Gegebenheiten verschiedener Räume (Abstand zur Projektionsfläche, Qualität der Leinwand, ...) anpassen möchte, ohne alle Helligkeitswerte in der Timeline zu ändern. Mit einer globalen Helligkeit < 1 kann man alle Helligkeitswerte nach unten, mit einem Wert > 1 entsprechend nach oben korrigieren.

Sinnvoll wäre dann z.B. folgendes Vorgehen: man wählt 100 % als Default-Wert für die Helligkeit in der Timeline. Mit einer globalen Helligkeit von 1,10 beim Twin MSC 535P und 1,00 beim Twin MSC 525P erreicht man die maximale Helligkeit des Projektors, mit einer globalen Helligkeit von 0,85 erhält man 85 % für den Normalfall (Schonung der Projektorlampen).

Die effektive Helligkeit, also der Wert, der tatsächlich zum Projektor übermittelt wird, wird in der Fußzeile der Spalte "Helligkeit" in der Timeline angezeigt. Fehlerhafte Werte infolge eines zu großen Wertes für die globale Helligkeit werden dabei mit fetter roter Schrift gekennzeichnet. Weitere Informationen zu einem konkreten Helligkeitswert kann man durch Doppelklick in eine Zelle in der Spalte "Helligkeit" der Timeline abrufen.

In der virtuellen Fernbedienung wird die globale Helligkeit ebenfalls angezeigt und kann dort auch verändert werden, allerdings nur dann, wenn der Projektor angeschlossen und eingeschaltet ist und sich eine gültige Dia-Show in der Timeline befindet.

Informationen zu den Einstellungen, die die Leinwand-Simulation betreffen. Näheres findet man hier.

Die Option "Hinweis für beendende Audio-Funktionen anzeigen" hat folgende Bedeutung: TwinLightControl überprüft bei der Erzeugung der grafischen Darstellung der Timeline, ob eine beendende Audio-Funktion (Ton aus, Ton ausblenden, ...) evtl. nach vorn verschoben werden kann, weil der Audio-Track schon zu Ende ist. Ggf. kann TwinLightControl das Verschieben dann automatisch durchführen. Die Option "Hinweis für beendende Audio-Funktionen anzeigen" entscheidet darüber, ob dieser Hinweis angezeigt wird oder nicht.

Die Schriftgröße kann in allen Dialogen und Tabellen eingestellt werden, was z.B. bei geringeren Grafikauflösungen die Lesbarkeit verbessert. Die Schriftgröße in der grafischen Darstellung der Timeline kann unabhängig davon eingestellt werden, näheres dazu findet man hier.

Alle Voreinstellungen werden in der Registry abgelegt und stehen somit auch über die Beendigung von TwinLightControl hinaus zur Verfügung.

Mit den Menüpunkten "Datei/Export/Voreinstellungen..." und "Datei/Import/Voreinstellungen..." können die Voreinstellungen (betrifft auch die Voreinstellungen in der virtuellen Fernbedienung) exportiert und importiert und so leicht von einem Computer auf einen anderen übertragen werden (die erzeugte Datei *.def befindet sich im Verzeichnis "Journal" der TwinLightControl-Installation). Auf diese Art und Weise kann man bei Bedarf auch mehrere Profile mit Voreinstellungen vorhalten.


Wie wird der serielle Port konfiguriert?

Im Dialogfeld Voreinstellungen gibt es neben der Auswahlbox für den seriellen Port ein Button "Konfigurieren ...".

Normalerweise ist die Konfiguration des seriellen Ports nicht erforderlich, da die bei der Installation eingestellten Werte bei den meisten Computern funktionieren. Sollte eine Dia-Show am Projektor nicht so ablaufen, wie man dies erwartet, muss man den seriellen Port manuell konfigurieren. Dies erfordert u.U. etwas Zeit, um verschiedene Einstellungen auszutesten.

Welche Einstellungen funktionieren, hängt von der Konfiguration und Geschwindigkeit des Rechners, u.U. vom verwendeten Projektor-Modell und davon ab, ob man z.B. einen USB-Seriell-Adapter verwendet. Nachfolgend werden die einzelnen Einstellungen erläutert und Empfehlungen für sinnvolle Werte gegeben.

Zahl der Daten-Bits

Dieser Wert gibt an, wieviele Daten-Bits gesendet werden. Die MSC-Projektoren benötigen 8 Daten-Bits, der "Rolleivision 35 twin digital P" benötigt 7 Daten-Bits.

Zahl der Stop-Bits

Dieser Wert gibt an, wieviele Stop-Bits nach einer Reihe von Daten-Bits gesendet werden. Rollei empfiehlt für die MSC-Projektoren 1 Stop-Bit, was i.d.R. auch funktioniert und der Default-Wert ist. Lediglich wenn alles andere nicht mehr hilft, sollte man versuchsweise 1,5 oder 2 Stop-Bits einstellen. Der "Rolleivision 35 twin digital P" benötigt 2 Stop-Bits.

ReadIntervalTimeout

Dieser Wert gibt die Zeit (in ms) an, die bei Leseoperationen am seriellen Port zwischen zwei Zeichen vergehen darf. Wird dieser Wert überschritten, wird das Lesen abgebrochen. Ein Wert von 0 bedeutet, dass beliebig viel Zeit vergehen darf. Der Default-Wert ist 0 und sollte ohne zwingenden Grund nicht verändert werden.

ReadTotalTimeoutMultiplier

Dieser Wert gibt die Zeit (in ms) an, die bei Leseoperationen am seriellen Port pro Zeichen eingeplant wird. Sollen n Zeichen gelesen werden, wird diese Zeit n-mal eingeplant. Ist die Zeit für n Zeichen verstrichen, wird die Leseoperation abgebrochen. Der Default-Wert ist 25 ms (Twin MSCxxxP), der i.d.R. funktionieren sollte. Versuchsweise kann man auch kleinere oder größere Werte eingeben.

ReadTotalTimeoutConstant

Dieser Wert gibt die Zeit (in ms) an, die bei Leseoperationen am seriellen Port zu dem soeben ermittelten Wert addiert wird. Die gesamte Zeit, die für das Lesen von n Zeichen zur Verfügung steht, ist also

n * ReadTotalTimeoutMultiplier + ReadTotalTimeoutConstant.

Der Default-Wert ist 25 ms (Twin MSCxxxP), auch hier können kleinere oder größere Werte zum Ziel führen. Als Faustregel kann man sagen, dass ReadTotalTimeoutMultiplier und ReadTotalTimeoutConstant um so größer gewählt werden sollten, je langsamer der Computer bzw. der Projektor sind.

Ist für ReadTotalTimeoutMultiplier und ReadTotalTimeoutConstant jeweils 0 eingetragen, wartet die Leseoperation solange, bis die angegebene Zahl an Zeichen gelesen wurde. Dies kann z.B. dann zum Problem werden, wenn man den seriellen Port danach abfragt, ob der Projektor angeschlossen ist, und dieser nicht angeschlossen oder ausgeschaltet ist. Dann kommt es zu einem Hänger. Man sollte also nicht ohne guten Grund beide Werte auf 0 setzen.

Setzt man zu kleine Werte an, kann es sein, dass der Projektor nicht schnell genug ist, um auf eine Leseoperation zu reagieren, und es kommt zu unvorhersagbaren Resultaten.

Beim "Rolleivision 35 twin digital P" dürfen ReadTotalTimeoutMultiplier und ReadTotalTimeoutConstant nicht gleichzeitig auf 0 gesetzt werden, sonst kommt es zu einem "Hänger".

WriteTotalTimeoutMultiplier

Gibt den Multiplikator (in ms) an, der verwendet wird, um die Gesamtzeit für Schreiboperationen zu berechnen. Für jede Schreiboperation wird dieser Wert mit der Zahl der zu schreibenden Bytes multipliziert.

WriteTotalTimeoutConstant

Gibt die Konstante (in ms) an, die verwendet wird, um die Gesamtzeit für Schreiboperationen zu berechnen. Für jede Schreiboperation wird dieser Wert zum Produkt aus WriteTotalTimeoutMultiplier und der Zahl der zu schreibenden Bytes addiert.

Sind sowohl WriteTotalTimeoutMultiplier als auch WriteTotalTimeoutConstant gleich 0, wird keine Zeitbegrenzung für Schreiboperationen verwendet.

TimeDelay (nur für "Rolleivision 35 digital P")

Dieser Wert gibt die Zeit (in ms) an, die nach dem Senden eines Befehls an den Projektor gewartet werden muss. Der konkrete Wert hängt von der Schnelligkeit des Computers ab. Mögliche Werte sind 10 ... 20, wobei der richtige Wert durch Probieren ermittelt werden muss.

Seriellen Port überwachen

Wenn das Häkchen gesetzt ist, wird der Datenverkehr am seriellen Port überwacht. Dazu öffnet sich ein kleines Fenster, in welchem alle an den Projektor gesendeten Befehle und die zugehörigen Antworten protokolliert werden. ">>" zeigt ausgehende und "<<" eingehende Meldungen an. Zu Beginn wird der eingestellte Projektor-Typ und die Start-Zeit der Überwachung angezeigt. Zu jeder Zeile wird die aktuelle Zeit (in sec), die seit der Start-Zeit vergangen ist, angezeigt.

Weitere Informationen zur Bedeutung der Meldungen: für den Rolleivision Twin MSCxxxP, für den Rolleivision 35 twin digital P.

Mit dem Button "Speichern" wird der Inhalt des Monitor-Fensters in eine Text-Datei geschrieben. Dabei wird im Verzeichnis "Journal" unter Verwendung von Datum und Uhrzeit ein eindeutiger Dateiname im Format "Journal\OMPortMonitoring-YYYY-MM-DD%HH-MM-SS.txt" erzeugt.

Das Optionsfeld "Meldungsverkehr sofort in Datei schreiben" hat folgende Bedeutung:

  • wird das Optionsfeld selektiert, wird eine Datei mit einem eindeutigen Dateinamen (s.o.) erzeugt
  • ab sofort werden alle Meldungen in diese Datei geschrieben
  • wird das Optionsfeld deselektiert, wird die oben erzeugte Datei geschlossen
  • bei erneutem Selektieren des Optionsfeldes wird eine neue Datei erzeugt
  • dieses Vorgehen ist dann von Vorteil, wenn TwinLightControl im Projektorbetrieb abstürzt und das Button "Speichern" nicht mehr funktioniert

Der serielle Port sollte nur überwacht werden, wenn es Probleme bei der Kommunikation mit dem Projektor gibt und man deren Ursache ergründen will. Im Normalfall sollte man die Überwachung abschalten.

Alle bei der Konfiguration des seriellen Ports eingestellten Werte werden in der Registry gespeichert.

Fazit: Die Voreinstellungen, die man mit dem Button "Standardwerte einstellen" jederzeit restaurieren kann, sollten i.d.R. funktionieren, ansonsten ist etwas Probieren angesagt. Optimale Werte anzugeben, ist nicht möglich, da diese auch von der hard- und softwaremäßigen Ausstattung des PC und der verwendeten Firmware-Version des Projektors abhängen. Einmal als tauglich befundene Werte sollte man sich notieren, um nach Änderungen jederzeit wieder zu diesen zurückkehren zu können.

Wichtiger Hinweis zu USB-Seriell-Adaptern

Wenn größere Entfernungen zwischen PC und Projektor zu überbrücken sind (> 10 m), dann ist es nicht empfehlenswert, ein entsprechend langes USB-Kabel zu verwenden. Durch die Leitungsverluste kommt es sehr schnell zu Übertragungsfehlern, die die Kommunikation mit dem Projektor erheblich stören oder sogar unmöglich machen können. Stattdessen sollte man folgende Konfiguration verwenden:

PC - USB-Seriell-Adapter mit max. 2 m langem Kabel - RS232-Kabel der gewünschten Länge - Projektor

Mit dieser Konfiguration sind auch größere Entfernungen problemlos zu überbrücken.

Nützliche Links zu USB-Seriell-Adaptern

www.pci-card.com

Folgende USB-Seriell-Adapter wurden bisher von TwinLightControl-Usern erfolgreich eingesetzt:

  • Prolific USB-To-Serial-Bridge
  • Sitecom USB-To-Serial-Cable CN-104V2 (funktioniert nicht unter Windows 7)
  • Conrad USB-Seriell-Adapter, Best.-Nr. 97 25 43 (funktioniert auch unter Windows 7 64 Bit)

Wer positive Erfahrungen mit weiteren USB-Seriell-Adaptern gemacht hat, bitte eine kurze Mail an twinlightcontrol@quivertree.de senden.


Wie werden Magazine zur Dia-Show hinzugefügt?

Man selektiert den Magazin-Editor (linke obere Tabelle) durch Mausclick oder Strg+1 und führt eine der folgenden Aktionen aus:

Zum Anfügen eines Magazins am Ende der Liste:

  • Menü: "Dia-Show/Magazine/Neues Magazin am Ende anfügen"
  • Tastenkürzel: Strg+Einfg
  • Button:
Zum Einfügen eines Magazins vor der aktuellen Cursorposition (Pfeil am linken Rand der Tabelle):
  • Menü: "Dia-Show/Magazine/Neues Magazin vor Cursorpostion einfügen"
  • Tastenkürzel: Einfg
  • Button:
Zum Anfügen eines leeren Magazins am Ende der Liste:
  • Menü: "Dia-Show/Magazine/Leeres Magazin am Ende anfügen"
  • Tastenkürzel: Strg+Umsch+Einfg
  • Buton:
Zum Einfügen eines leeren Magazins vor der Cursorposition (Pfeil am linken Rand der Tabelle):
  • Menü: "Dia-Show/Magazine/Leeres Magazin vor Cursorpostion einfügen"
  • Tastenkürzel: Umsch+Einfg
  • Button:

Wird ein Magazin zur Dia-Show hinzugefügt, wird es entsprechend seiner Größe mit Dias gefüllt. Man erkennt dies am Inhalt des Dia-Editors (rechte obere Tabelle).

Siehe auch Tastenkürzel und Maus-Clicks im Magazin-Editor.


Wie werden Einträge im Magazin-Editor geändert?

Im Magazin-Editor werden folgende Werte angezeigt:

  • die Magazin-Nummer
  • die Magazin-Nummer im Archiv
  • der Magazin-Typ
  • der Magazin-Kommentar
  • die Zahl der Dias im Magazin
  • die Zahl der belegten Dia-Fächer im Magazin
  • die Zahl der benutzten Dia-Fächer im Magazin (d.h. die Zahl der Dias des Magazins, die sich bereits in der Timeline befinden)
  • die Zahl der Querformate im Magazin
  • die Zahl der Hochformate im Magazin
  • die Zahl der Quadratformate im Magazin
Folgende Einstellungen eines Magazins können geändert werden:
  • die Magazin-Nummer im Archiv (optional)
  • der Magazin-Typ
  • ein Kommentar zum Magazin

Zum Ändern der Werte einer Zelle siehe:
Allgemeine Bemerkungen zum Editieren von Zellen im Magazin-, Dia- und Timeline-Editor.

Die restlichen Werte dienen nur der Information. Wie man nicht benötigte Werte im Magazin-Editor ausblendet, erfährt man hier.


Wie werden Magazine aus der Dia-Show entfernt?

Um ein einzelnes Magazin zu entfernen, drückt man Alt + Entf.

Um mehrere Magazine zu entfernen, markiert man die zu entfernenden Magazine im Magazin-Editor (mit "Strg + Linke Maustaste" oder "Umschalt + Pfeil oben/unten") und drückt das Button [image] oder man drückt Strg + Entf. Ist kein Magazin markiert, wird das aktuelle Magazin entfernt.

Um alle Magazine zu entfernen, drückt man das Button [image] oder man drückt Umsch + Strg + Entf.

Wird ein Magazin entfernt, werden auch alle zu ihm gehörenden Dias entfernt. Dies betrifft auch Dias, die sich bereits in der Timeline (untere Tabelle) befinden. Die Magazin-Nummern der in der Timeline verbleibenden Dias werden ggf. automatisch aktualisiert.

Siehe auch Tastenkürzel im Magazin-Editor.


Wie werden Dias zur Dia-Show hinzugefügt oder aus ihr entfernt?

Im bzw. aus dem Dia-Editor können manuell keine Einträge hinzugefügt bzw. entfernt werden.

Wenn im Magazin-Editor ein Magazin hinzugefügt wird, wird es automatisch mit Dias gefüllt. Die Zahl der Dias, ob die Dia-Fächer belegt sind oder nicht und ob es sich um Dias im Querformat, Hochformat oder quadratischen Format handelt, wird von den Voreinstellungen bestimmt.

Wird aus dem Magazin-Editor ein Magazin entfernt, werden automatisch auch die zugehörigen Dias entfernt.


Wie werden Einträge im Dia-Editor geändert?

Im Dia-Editor werden folgende Werte angezeigt:

  • das Belegt-Feld (ob ein Dia-Fach im Magazin belegt ist oder nicht)
  • das Benutzt-Feld (ob ein Dia bereits in der Timeline verwendet wird)
  • die Magazin-Nummer
  • die Dia-Fach-Nummer
  • das Dia-Format (Quer-, Hoch- oder quadratisches Format)
  • der Dia-Kommentar
  • der Bild-Datei-Name
  • das Bild
Folgende Einstellungen eines Dias können geändert werden:
  • ob das Dia-Fach im Magazin belegt ist oder nicht
  • ob das Dia benutzt wird
  • das Dia-Format (Quer-, Hoch- oder quadratisches Format)
  • ein Kommentar zum Dia
  • eine Bild-Datei zum Dia (Hinzufügen oder Entfernen eines gescannten Dias)

Wenn im Dia-Editor ein Dia als "Nicht belegt" markiert werden soll, und das betreffende Dia befindet sich bereits in der Timeline, wird nachgefragt, ob die Aktion ausgeführt werden soll.

Mit dem Feld "Benutzt" wird angezeigt, ob sich ein Dia bereits in der Timeline befindet (einmal oder mehrmals). Das Feld dient nicht nur der Information, sondern kann auch geändert werden.

Entfernt man das Häkchen bei "Belegt", dann werden nach einer Sicherheitsabfrage alle Programmschritte aus der Timeline entfernt, in denen das Dia mit der betreffenden Magazin- und Dia-Fach-Nummer vorkommt.

Setzt man das Häkchen bei "Belegt", wird das betreffende Dia entsprechend seiner Magazin- und Dia-Fach-Nummer an der "richtigen" Stelle in die Timeline eingefügt (was der "natürlichen" Reihenfolge entspricht). Später kann man das Dia in der Timeline noch verschieben. Dieses Vorgehen stellt eine schnelle Methode dar, Dias zur Timeline hinzuzufügen, ist aber kein vollwertiger Ersatz für die konventionelle Methode.

Wenn im Dia-Editor der Dia-Kommentar geändert wurde, und das Dia befindet sich bereits in der Timeline, dann wird nachgefragt, ob der geänderte Kommentar übernommen werden soll. Die Nachfrage kann man mit dem Menüpunkt '"Dia-Kommentar übernehmen?" anzeigen?' an- oder abschalten. Ist die Nachfrage abgeschaltet, wird der geänderte Kommentar immer in die Timeline übernommen.

Mit der Tastenkombination Alt+K kann der letzte zurückliegende, nicht-leere Kommentar in die aktuelle Zeile übernommen werden. Mit Strg+Alt+K werden zusätzlich alle dazwischenliegenden Zeilen mit diesem Kommentar aufgefüllt.

Mit dem Menüpunkt "Gehe zum zugehörigen Programmschritt" (F11) wird das aktuelle Dia im Timeline-Editor gesucht und, falls vorhanden, zum ersten gefundenen Dia gesprungen.

Zum Ändern der Werte einer Zelle siehe:
Allgemeine Bemerkungen zum Editieren von Zellen im Magazin-, Dia- und Timeline-Editor.

Wie man nicht benötigte Werte im Dia-Editor ausblendet, erfährt man hier.


Wie werden Bild-Dateien zur Dia-Show hinzugefügt, aus ihr entfernt bzw. angezeigt?

Sofern man Scans der in der Dia-Show verwendeten Dias vorliegen hat, kann man diese einem Dia hinzufügen und so eine realistische Leinwand-Simulation erstellen.

Die Scans sollten eine Auflösung von 200 ... 300 dpi haben. Das ist für die Darstellung am Monitor vollkommen ausreichend und die entstehenden Dateien sind in ihrer Größe noch vernünftig. Die Bilder müssen eine Farbtiefe von 24 Bit (True Color) haben (8 Bit pro Kanal). Die Größe der Bilder ist beliebig, ideal ist eine Größe von ca. 240 x 360 Pixeln. Bei wesentlich größeren oder kleineren Bildern entstehen Verluste beim Hoch- bzw. Herunterrechnen der Pixel-Zahl. Das Seitenverhältnis der Bilder sollte etwa dem des Kleinbildformats entsprechen, da sie ansonsten verzerrt dargestellt werden. TwinLightControl entscheidet anhand der Bildabmessungen selbständig, ob es sich um ein Bild im Querformat, Hochformat oder quadratischen Format handelt.

Ein Bild wird zu einem Dia hinzugefügt, indem man mit der rechten Maustaste in die entsprechende Zeile im Dia-Editor klickt und aus dem Kontext-Menü den Punkt "Bild-Datei zum Dia suchen" auswählt. Es erscheint ein Datei-Dialog mit Bild-Vorschau, mit welchem man das gewünschte Bild auswählen kann. Möglich sind Bitmap's (*.bmp) und JPEG's (*.jpg, *.jpeg). Die Original-Bild-Dateien werden dabei nicht angetastet, es wird lediglich eine Kopie des Bildes im Verzeichnis Pictures abgelegt. Aus Gründen der Speicherplatzersparnis werden die Kopien generell im JPEG-Format abgelegt. Das Verzeichnis Pictures wird automatisch beim Anlegen einer *.twc-Datei mit erzeugt.

Es ist möglich, in dem Datei-Dialog mehrere Bild-Dateien auszuwählen und einzufügen. Das ist z.B. dann hilfreich, wenn man ganze Dia-Magazine eingescannt hat und diese Scans einfügen möchte. Das Einfügen der Bilder gehorcht folgenden Regeln:

  • Die Bilder werden ab der momentan aktiven Zeile im Dia-Editor eingefügt.
  • Die Bilder werden in alphabetischer Reihenfolge eingefügt.
  • Es werden nur so viele Bilder eingefügt, bis das aktuelle Magazin bzw. alle Magazine voll sind; überzählige Bilder werden ignoriert.
  • Nicht besetzte Dia-Fächer im Dia-Editor werden ignoriert, d.h. das nächste Bild wird beim nächsten besetzten Dia-Fach eingefügt.
  • Bereits vorhandene Bild-Dateien werden nach einer Sicherheitsabfrage, die positiv beantwortet wurde, durch die neuen Bild-Dateien ersetzt.

Auf analoge Weise kann mittels des Kontext-Menüs "Bild-Datei zum Dia entfernen" eine Bild-Datei wieder entfernt werden. Dabei ist zu beachten, dass lediglich die Kopie des Bildes, nicht das Original entfernt wird. Eine bereits bestehende Bild-Datei kann auch jederzeit durch eine andere ersetzt werden.

Es können auch mehrere Bild-Dateien gleichzeitig entfernt werden. Man selektiert einfach mehrere Zeilen im Dia-Editor, und nach einer positiv beantworteten Sicherheitsabfrage werden die Bild-Dateien entfernt.

Angezeigt werden die Bilder mittels des Kontext-Menüs "Bilder anzeigen" oder mit Hilfe des entsprechenden Tool-Buttons [image] . Für die Anzeige wird ein kleines Fenster geöffnet, in welchem die zur momentanen Zeile des Dia- oder Timeline-Editors gehörige Bild-Datei dargestellt wird. Ist in der betreffenden Zeile keine Bild-Datei eingetragenen, wird ein schwarzes Fenster angezeigt.

Zum Import von Bild-Dateien gibt es folgendes zu sagen:

  • Über den momentanen Stand des Imports wird man in einem kleinen Fenster und in der Status-Zeile informiert. Wenn man viele hundert Bild-Dateien importieren möchte, muss man sich etwas gedulden, da von jeder zu importierenden Bild-Datei eine Kopie angefertigt wird. Stammt die Original-Datei z.B. von einem eingescannten Dia mit hoher Auflösung, muss das Bild erst "heruntergerechnet" werden, was natürlich etwas Zeit in Anspruch nimmt.
  • Die importierten Bilder werden direkt in die Dia-Tabelle integriert. Für diesen Zweck gibt es ein Feld "Bild", in welchem das importierte Bild verkleinert dargestellt wird. Ältere *.twc-Dateien werden automatisch konvertiert. Der Hinweis auf das Speichern der konvertierten Datei sollte unbedingt befolgt werden.
  • Der Import von Bildern ist optimiert. Vor allem beim Import vieler Bilder ist dies vorteilhaft.
  • Der Import von Bildern geschieht über das Kontext-Menü im Dia-Editor. Alternativ kann man in der gewünschten Zeile in die Zelle klicken, in der ein Bild eingefügt werden soll. Es erscheint ein kleines Button, über welches die Datei-Dialogbox aufgerufen wird.
  • Die importierten Bilder werden generell im JPEG-Format abgelegt. In den Voreinstellungen gibt es ein neues Datum "JPEG-Qualität". Man kann hier Werte von 0 bis 100 einstellen. Je kleiner der Wert, desto kleiner die erzeugte JPEG-Datei, desto geringer allerdings auch deren Qualität. Voreingestellt ist ein Wert von 75, der einen guten Kompromiss zwischen Qualität und Kompression darstellt. Die Qualität der importierten Bilder kann visuell sofort beurteilt werden.
  • Im Dialog für die Anzeige der Spalten (Kontext-Menü oder F7) kann die Höhe der Zeilen im Dia-Editor eingestellt werden, was auch die Größe der angezeigten Bilder beeinflusst.


Wie werden Dias im Magazin nach vorn verschoben?

Gelegentlich möchte man aus einem Magazin Dias entfernen und die nachfolgenden Dias auf die freigewordenen Plätze (nach vorn) verschieben. Dabei geht man folgendermaßen vor:

  • zunächst entfernt man die gewünschten Dias aus dem Magazin, indem man die Markierung [image] im Feld "Belegt" des Dia-Editors entfernt; dabei werden verschiedene andere Felder grau hinterlegt
  • wenn das erste der zu verschiebenden Dias gleichzeitig das erste Dia im betreffenden Magazin ist, müssen Dia-Fächer im vorhergehenden Magazin freigemacht werden; man kann auch vor dem betreffenden Magazin ein leeres Magazin einfügen
  • dann drückt man das Button [image] und gibt in dem erscheinenden Dialogfeld die Zahl der Fächer an, um die alle nachfolgenden Dias nach vorn verschoben werden sollen
  • falls keine oder nicht genügend freie Dia-Fächer vorhanden sind, wird eine Fehlermeldung ausgegeben
  • die Magazin- und Dia-Nummern von bereits in der Timeline befindlichen und von der Verschiebung betroffenen Dias werden automatisch aktualisiert
  • bei großen Dia-Shows bzw. vielen zu verschiebenden Dias kann man den Fortgang des Verschiebens links unten in der Status-Zeile verfolgen

Siehe auch Tastenkürzel im Dia-Editor.


Wie werden Dias im Magazin nach hinten verschoben?

Gelegentlich möchte man in ein Magazin Dias einfügen und die nachfolgenden Dias (nach hinten) verschieben. Dabei geht man folgendermaßen vor:

  • zunächst schafft man am Ende des letzten Magazins genügend freie Dia-Fächer (wenn noch nicht vorhanden), indem man die Markierung [image] im Feld "Belegt" des Dia-Editors entfernt; dabei werden verschiedene andere Felder grau hinterlegt
  • man kann auch am Ende ein leeres Magazin anfügen
  • dann drückt man das Button [image] und gibt in dem erscheinenden Dialogfeld die Zahl der Fächer an, um die alle nachfolgenden Dias nach hinten verschoben werden sollen
  • falls keine oder nicht genügend freie Dia-Fächer vorhanden sind, wird ein Dialog ausgegeben, der ggf. das Anhängen der erforderlichen leeren Magazine veranlasst
  • die Magazin- und Dia-Nummern von bereits in der Timeline befindlichen und von der Verschiebung betroffenen Dias werden automatisch aktualisiert
  • bei großen Dia-Shows bzw. vielen zu verschiebenden Dias kann man den Fortgang des Verschiebens links unten in der Status-Zeile verfolgen

Siehe auch Tastenkürzel im Dia-Editor.


Wie wird das Verschiebe-Protokoll verwendet?

Wie wird ein Verschiebe-Protokoll verwendet?

Das Problem

Folgende Situation: die Dia-Show über eine dreiwöchige Reise ist in groben Zügen fertiggestellt. Mit Hilfe des realen/virtuellen Leuchtpults wurden unbrauchbare Dias aussortiert, brauchbare in die Magazine/Timeline einsortiert und in die passende Reihenfolge gebracht. Nun geht es an das "Feintuning". Am Anfang der Dia-Show sollen ein paar Schrift-Dias eingeschoben werden, für jeden Tag der Reise ein weiteres, und hier und da ein Dia mit einer erläuternden Landdkarte. Den Platz für die zusätzlichen Dias hat man natürlich noch nicht vorgehalten, denn erst jetzt nimmt die Show langsam ihre endgültige Gestalt an.

In TwinLightControl ist es natürlich kein Problem, nachträglich Dias einzuschieben, dafür gibt es die Funktionen "Dias nach hinten schieben" und "Dias nach vorn schieben". Wie setzt man aber die virtuellen Verschiebe-Aktionen in reale um? Die sicherste Methode ist, die Verschiebungen, die man in TwinLightControl vorgenommen hat, sofort in die Tat umzusetzen. Dann allerdings verschiebt man die Dias am Ende der Show so oft, dass man bald keine Lust mehr hat. Also schreibt man sich auf, an welcher Stelle man wie viele Dias wohin verschoben hat. Da sich aber mit jedem Verschieben Dia- und ggf. Magazin-Nummer ändern, gibt man spätestens nach der dritten Verschiebe-Aktion entnervt auf. Irgendwie muss das doch einfacher gehen...

Die Lösung

TwinLightControl bietet eine einfache und sichere Lösung an, die bei geringstmöglichem Aufwand zum Ziel führt. Man geht dabei folgendermaßen vor:

  1. Bevor man die Verschiebe-Aktionen startet, wählt man "Dia-Show/Dias/Verschiebe-Protokoll.../...starten". Damit wird ein neues Verschiebe-Protokoll angelegt.
  2. Nun führt man alle gewünschten Verschiebe-Aktionen durch. TwinLightControl merkt sich, wenn der Befehl "Dias nach hinten/vorn Verschieben" aufgerufen wird, und protokolliert alles genauestens.
  3. Nach Abschluss aller Verschiebe-Aktionen wählt man "Dia-Show/Dias/Verschiebe-Protokoll.../...abschließen". Damit wird das Verschiebe-Protokoll geschlossen, alle Verschiebe-Aktionen zusammengefasst und so ausgegeben, dass man das gewünschte Ergebnis mit geringstmöglichem Aufwand erreicht.
  4. Die erzeugte Liste aller Aktionen kann man bei Bedarf abspeichern (und später wieder laden) oder ausdrucken. Verschiebe-Protokolle werden im selben Verzeichnis wie die zugehörige Datei gespeichert.
  5. Am Schluss steht das manuelle Verschieben der Dias in den Magazinen, logischerweise von hinten nach vorn. Diese Arbeit kann TwinLightControl allerdings nicht übernehmen. Hier sind Digitalfotografen eindeutig im Vorteil.
  6. Am Ende sollte man das Verschiebe-Protokoll löschen.

Ein Verschiebe-Protokoll sieht typischerweise folgendermaßen aus:

Folgende Punkte sollten beachtet werden:

  • Die Befehle "Gruppe von Dias verschieben" und "Lücken schließen" werden vom Verschiebe-Protokoll nicht erfasst und machen in diesem Kontext auch keinen Sinn.
  • Während ein Verschiebe-Protokoll aktiv ist, sollte man keine anderen Befehle als "Dias nach hinten verschieben" und "Dias nach vorn verschieben" ausführen. Dafür gibt es auch keinen triftigen Grund.
  • Das Verschiebe-Protokoll unterstützt (noch) kein Undo/Redo. Undo/Redo sollte also unterbleiben, solange ein Verschiebe-Protokoll aktiv ist.


Wie werden nicht benutzte Dias demarkiert und Lücken in Dia-Magazinen geschlossen?

Wenn bestimmte Dias verschiedener Magazine in der Timeline nicht benutzt werden, kann es sinnvoll sein, diese Dias in den betreffenden Magazinen als "Nicht belegt" zu markieren und ggf. aus den (realen) Magazinen zu entfernen. Die Demarkierung der nicht benutzten Dias geschieht mit dem Menüpunkt "Diashow/Dias/Nicht benutzte Dias demarkieren".

Nach dem Entfernen der Dias gibt es Lücken in den Magazinen, die man vielleicht schließen möchte. Leider kann TwinLightControl das Umsortieren der realen Dias nicht für Sie vornehmen. TwinLightControl kann aber die umsortierte Dia-Show problemlos aktualisieren. Dabei geht man folgendermaßen vor:

  • zunächst markiert man die Dia-Fächer, aus denen man die realen Dias entfernt hat, als "Nicht belegt" (entweder manuell oder mit der oben beschriebenen Prozedur)
  • dann drückt man das Button [image] und alle Dias werden so verschoben, dass die Magazine lückenlos gefüllt sind
  • am Ende des Vorgangs wird die Zahl der geschlossenen Lücken angezeigt; ebensoviele leere Fächer sind am Ende des letzten Magazins hinzugekommen
  • die Magazin- und Dia-Nummern von bereits in der Timeline befindlichen und von der Verschiebung betroffenen Dias werden automatisch aktualisiert
  • wenn durch die Verschiebung der Dias am Ende ein oder mehrere leere Magazine entstehen, wird man darauf hingewiesen
Siehe auch Tastaturkürzel im Dia-Editor.


Wie werden Programmschritte zur Timeline hinzugefügt?

Das Hinzufügen von Programmschritten zur Timeline geschieht, indem man Dias aus dem Dia-Editor in die Timeline bringt. Für das Übertragen von Dias aus dem Dia-Editor in die Timeline ist es vorteilhaft, wenn man sowohl den Dia-Editor, als auch den Timeline-Editor im Blick hat. Mit Alt+LinksClick in die Spaltenüberschrift des Dia-Editors oder F6 oder über das entsprechende Menü bringt man das Fenster des Dia-Editors auf volle Breite. Dia- und Timeline-Editor sind nun direkt übereinander angeordnet, und es kann bequem wischen beiden gewechselt werden.

Zuerst wählt man das Magazin, welches die Dias enthält, die man in der Timeline plazieren möchte. Dann markiert man im Dia-Editor die gewünschten Dias. Die Mehrfachselektion von Dias geschieht entweder mit Strg+Linke Maustaste oder mit Strg+Umsch+Linke Maustaste oder mit Umschalt+Pfeil oben/Pfeil unten.

Mit dem Button [image] kann man alle Dias des aktuellen Magazins oder alle Dias aller Magazine selektieren, je nachdem, ob das Optionsfeld "Alle Magazine" selektiert oder deselektiert ist. Mit dem Button [image] kann man alle belegten Dia-Fächer selektieren. Mit dem Button [image] oder einfach durch Maus-Klick in den Dia-Editor hebt man eine Selektion auf.

Nachdem man die gewünschten Dias markiert hat, drückt man das Button [image] oder [image] . Die Dias werden dann in der Timeline plaziert, und zwar am Ende der Tabelle oder vor der aktuellen Cursorposition. Ist kein Dia markiert, wird das aktuelle Dia an- bzw. eingefügt.

Eine andere Möglichkeit, Dias aus dem Dia-Editor in die Timeline zu übertragen, besteht in folgendem: im Dia-Editor geht man zum Feld "Benutzt" des gewünschten Dias. Mit der Leertaste kann ein Häkchen gesetzt werden, mit Return oder Pfeil nach unten bestätigt man die Übernahme des Dias in die Timeline. Das Dia wird an das Ende der Timeline angehängt. Auf diese Art und Weise hat man die Möglichkeit, im Dia-Editor Dia für Dia in der gewünschten Reihenfolge anzusteuern und in die Timeline zu übernehmen.

Will man die meisten Dias eines Magazins zur Timeline hinzufügen, dann ist es am effektivsten, alle Dias im Dia-Editor zu selektieren, sie zur Timeline hinzuzufügen und hinterher die nicht gewünschten Dias aus der Timeline zu entfernen. Sollen nur wenige Dias eines Magazins zur Timeline hinzugefügt werden, markiert man diese und fügt sie in die Timeline ein.

Es bleibt anzumerken, dass in der Timeline manuell keine Nullzeilen (Dia-Nummer 0) hinzugefügt werden können oder müssen, wie man das vielleicht von DiaEdit gewöhnt ist. Die Nullzeilen braucht der Projektor als Trennmarke zwischen zwei Magazinen, sofern keine Rollei-Koppelmagazine verwendet werden. TwinLightControl fügt diese Nullzeilen, dort wo sie benötigt werden, beim Timeline-Check selbständig ein. Man braucht sich darum nicht zu kümmern.

Siehe auch Tastenkürzel und Maus-Clicks im Dia-Editor.


Wie wird das virtuelle Leuchtpult verwendet?

Jeder ernsthafte Diafotograf verwendet ein Leuchtpult, mit dessen Hilfe er seine Dias sichtet, unbrauchbare aussortiert und die brauchbaren in die richtige Reihenfolge bringt. TwinLightControl unterstützt den Diafotografen bei dieser Arbeit, indem es ein virtuelles Leuchtpult zur Verfügung stellt. Wer Scans von seinen Dias verwendet, um die Bilder in den Dia-Editor einzufügen, wird von dieser Möglichkeit besonders profitieren.

Mit dem virtuellen Leuchtpult arbeitet man am besten folgendermaßen:

  1. Der Timeline-Check darf noch nicht ausgeführt worden sein. Gegebenenfalls muss er rückgängig gemacht werden.

  2. Man selektiert im Magazin-Editor das Magazin, dessen Dias man in die Timeline einsortieren möchte. Dabei ist es egal, ob das Magazin bereits Dias in der Timeline hat oder nicht.

  3. Man startet das virtuelle Leuchtpult, wofür es drei Möglichkeiten gibt:
    a) man wählt das entsprechende ToolButton ganz oben (links neben dem Audio-Player),
    b) man wählt im Magazin-Editor den entsprechenden Punkt im Kontext-Menü,
    c) man verwendet bei aktivem Magazin-Editor das Tastenkürzel Strg+U.

  4. Das virtuelle Leuchtpult sieht folgendermaßen aus:

  5. Oben links kann man das Magazin wählen, dessen Dias angezeigt werden sollen.

  6. Rechts daneben kann man die Zahl der Zeilen und Spalten, in denen die Dias angeordnet werden, an die des realen Leuchtpults anpassen. In der Regel ist es so, dass nicht alle Dias eines Magazins auf das Leuchtpult passen. Hat man also ein Magazin mit 50 Dias und ein Leuchtpult, das 25 Dias, angeordnet in 5 Zeilen und 5 Spalten (wie oben), fasst, werden die Dias auf zwei Sets verteilt. Für jedes Set ist ein Karteireiter (s.o.) vorhanden.

  7. Der linke obere Bereich symbolisiert also das eigentliche virtuelle Leuchtpult mit den einzelnen Sets von Dias.

  8. Rechts daneben findet man eine vergrößerte Vorschau des Bildes, über dem die Maus gerade steht. Außerdem wird die Magazin-Nummer, die Dia-Nummer und ein evtl. eingetragener Kommentar angezeigt.
  9. Darunter befindet sich die Timeline, die alle Bilder in der Reihenfolge anzeigt, wie sie bereits in der Timeline liegen. Enthält die Timeline für das Magazin noch keine Dias, ist dieser Bereich leer. Auch in der Timeline wird eine vergrößerte Vorschau des Bildes angezeigt, über dem sich die Maus gerade befindet.

  10. Normalerweise hat man am Anfang eine leere Timeline. Dann geht man folgendermaßen vor: man wählt das Dia-Set (Karteireiter), das man gerade auf das Leuchtpult legen will und zieht dann per Drag & Drop das gewünschte Dia in die Timeline. Am Anfang beginnt man im linken Teil der Timeline, man kann aber jedes neu hinzukommende Dia an jeder beliebigen Stelle einfügen, auch mehrfach.

  11. Die Reihenfolge der Dias in der Timeline kann jederzeit geändert werden. Dazu zieht man einfach das Dia per Drag & Drop an die gewünschte Stelle. Ein kleiner roter Pfeil in der oberen linken bzw. rechten Ecke des Dias zeigt an, zwischen welchen beiden Dias das zu verschiebende Dia eingefügt wird. Der rote Pfeil erscheint übrigens auch, wenn man das Dia vom Leuchtpult in die Timeline zieht.

  12. Möchte man ein Dia aus der Timeline entfernen, zieht man es in den Papierkorb unterhalb der Timeline. Alternativ stellt man den Cursor auf das zu entfernende Dia und drückt die Taste Backspace.

  13. Mit dem Button "Alle hinzufügen" werden alle Dias des aktuellen Magazins zur Timeline hinzugefügt. Dieses Button ist nur aktiv, wenn sich noch keine Dias in der Timeline befinden.

  14. Mit dem Button "Alle entfernen" werden alle Dias aus der Timeline entfernt.

  15. Hat man alle gewünschten Dias in der richtigen Reihenfolge in der Timeline, drückt man das Button "Übernehmen". Dann passiert folgendes: waren bereits Dias in der Timeline, bevor man das virtuelle Leuchtpult gestartet hat, werden alle Dias mit der betreffenden Magazin-Nummer aus der Timeline entfernt und alle Dias, die man in der virtuellen Timeline liegen hat, werden an der richtigen Stelle in der richtigen Reihenfolge eingefügt. Wenn man mit Nicht-Koppelmagazinen arbeitet, ist die Arbeit damit beendet. Bei Koppelmagazinen besteht ja die Möglichkeit, dass aufeinanderfolgende Dias aus verschiedenen Magazinen stammen, also z.B. Dia 49/Magazin 1, Dia 2/Magazin 2, Dia 50/Magazin 1, Dia 1/Magazin 2. Hat man mit dem virtuellen Leuchtpult Magazin 2 bearbeitet, werden die Dias des Magazins 2 in der angegebenen Reihenfolge "en bloc" zwischen Magazin 1 und 3 eingefügt. Man muss also, wenn man erneut solche "Magazinsprünge" haben will, nach dem Verlassen des virtuellen Leuchtpults ggf. noch ein wenig "händisch" korrigieren.

  16. Am Ende der Übernehmen-Aktion wird angezeigt, wie viele Dias aus der Timeline entfernt und wie viele neu hinzugefügt wurden.

  17. Will man seine Änderungen verwerfen, drückt man einfach das gleichnamige Button.

  18. In der Regel wird man also so vorgehen, dass man, Magazin für Magazin, mit einer leeren Timeline beginnt und diese mit Hilfe des virtuellen Leuchtpultes füllt, idealerweise simultan mit dem realen Leuchtpult.

Noch ein paar Hinweise zur Bedienung des virtuellen Leuchtpultes:

  1. Gescrollt werden kann mit den Scrollbalken, dem Mausrad oder der Tastatur (Bild auf, Bild ab, Pfeil links, Pfeil rechts, Pfeil oben, Pfeil unten). Dazu muss die Maus über dem virtuellen Leuchtpult bzw. der Timeline stehen.

  2. Zieht man in der Timeline ein Dia zum linken oder rechten Rand, beginnt die Timeline automatisch zu scrollen, und zwar um so schneller, je näher man dem Rand kommt.

  3. Mit den Tasten "Pos 1" und "Ende" kann man schnell zum Anfang oder Ende des Scrollbereiches springen. Dazu muss die Maus entweder über dem Leuchtpult oder über der Timeline stehen.

  4. Das jeweils aktive Bild im Dia-Set bzw. in der Timeline wird mit einer dünnen roten Linie umrandet. Alle Dias, die sich bereits in der Timeline befinden, werden im Dia-Set (oben links) grün umrandet.

  5. Scrollen im eigentlichen Leuchtpult (oben) und Scrollen in der Timeline (unten) können wahlweise miteinander synchronisiert werden.

  6. Jedes Dia auf dem Leuchtpult (links oben) hat ein Kontext-Menü, mit dessen Hilfe das Dia-Format und der Kommentar zum Dia geändert werden können. Das Dia-Format kann nur geändert werden, wenn bei dem Dia noch kein Bild eingetragen ist, da letzteres das Dia-Format eindeutig festlegt. Noch schneller als mit der rechten Maustaste für das Kontext-Menü geht es über Tastenkürzel: steht die Maus über dem gewünschten Dia, was durch einen dünnen roten Rahmen angezeigt wird, so gelten folgende Tastenkürzel: 1 - Querformat, 2 - Hochformat, 3 - Quadratformat, K - Kommentar.

  7. Der Kommentar-Editor hat zwei spezielle Buttons. Drückt man das Button "Kommentar des vorhergehenden Dias übernehmen", wird der Kommentar des Dias übernommen, das sich im Dia-Editor vor dem aktuellen Dia befindet. Das ist dann praktisch, wenn man mehrere Dias zum gleichen Motiv hintereinander im Dia-Editor hat. Drückt man das Button "Sonderzeichen eingeben" oder die Taste F2, dann öffnet sich eine kleine Tabelle mit Sonderzeichen, die sonst mühsam über bestimmte Tastenkombinationen eingegeben werden müssten. In der Tabelle kann man mit den Pfeiltasten navigieren. Das gewünschte Sonderzeichen wird mit RETURN oder durch Mausklick übernommen und an der Stelle im Kommentar eingefügt, wo der Cursor vor dem Öffnen der Sonderzeichen-Tabelle stand. Momentan sind in der Tabelle vor allem isländische Zeichen enthalten (da ich sie öfter benötige), wer weitere Zeichen wünscht, kann mir gern eine Mail schicken.


Wie werden Einträge im Timeline-Editor geändert?

Im Timeline-Editor können die zu einem Programmschritt gehörenden Werte geändert werden. Es sind dies:

  • die Magazin-Nummer
  • einen Positions-Marker
  • die Dia-Fach-Nummer
  • die Helligkeit eines Dias (max. 110% für MSC 535P, 100% für alle anderen Projektor-Typen); die Helligkeit kann für jeden Programmschritt einzeln verändert werden; der Default-Wert für die Grundhelligkeit des Projektors wird in den Voreinstellungen gesetzt; mit der "globalen Helligkeit" können alle Helligkeitswerte auf einmal beeinflusst werden können; näheres findet man hier
  • eine Mechanische Sonderfunktion
  • eine Licht-Sonderfunktion (Überblendeffekt)
  • ein Cut (Harte Überblendung)
  • die Überblendzeit
  • eine Pause (Manuelle Weiterschaltung)
  • die Standzeit
  • die Effekt-Standzeit (bei Licht-Sonderfunktionen)
  • der Effekt-Zähler (bei Licht-Sonderfunktionen)
  • ein Kommentar
  • eine Audio-Datei (Hinzufügen oder Entfernen)
  • eine Audio-Funktion (Ton ein, Ton aus, Ton ein nach Pause, Ton aus vor Pause, Ton einblenden, Ton ausblenden, Ton einblenden nach Pause, Ton ausblenden vor Pause, Ton lauter, Ton leiser; Ton aus, am Ende, Ton aus vor Pause, am Ende, Ton ausblenden, am Ende, Ton ausblenden vor Pause, am Ende, Ton leiser, am Ende)
  • die Audio-Ein/Ausblendzeit
  • die Audio-Lautstärke
  • die Audio-Start-Position in hh:mm:ss
  • die Audio-Stop-Position in hh:mm:ss
  • die Audio-Track-Länge in hh:mm:ss; dieses Feld dient nur zur Anzeige und ist nicht veränderbar
  • der Maximal-Pegel eines Audio-Tracks in dB; dieses Feld dient nur zur Anzeige und ist nicht veränderbar
  • ein Audio-Synchronisations-Punkt in hh:mm:ss
  • das Audio-Looping
Mit dem Menüpunkt "Gehe zum zugehörigen Dia" (F11) wird das zum aktuellen Programmschritt gehörige Dia im Dia-Editor gesucht und dorthin gesprungen.

Zum Ändern der Werte einer Zelle siehe:
Allgemeine Bemerkungen zum Editieren von Zellen im Magazin-, Dia- und Timeline-Editor.

Es gibt es die Möglichkeit, bestimmte Überblend-Eigenschaften mehrerer Programmschritte auf einmal zu ändern. Dies betrifft folgende Eigenschaften:
  • Helligkeit
  • Cut (harte Überblendung)
  • Überblendzeit
  • Pause
  • Standzeit

Zu diesem Zweck selektiert man diejenigen Programmschritte, deren Überblend-Eigenschaften man ändern will. Im Kontext-Menü der Timeline (rechte Maustaste) gibt es einen Punkt "Überblend-Eigenschaften editieren" (Strg + U). Im daraufhin erscheinenden Dialog wählt man die Eigenschaften aus, deren Werte man ändern will.

Es gibt die Möglichkeit, bei Programmschritten in der Timeline-Tabelle die Magazin- und die Dia-Fach-Nummer händisch zu ändern. Die eingegebenen Werte werden auf Plausibilität geprüft, d.h. es wird untersucht, ob es das Dia mit der entsprechenden Magazin- und Dia-Fach-Nummer gibt und ob das betreffende Dia-Fach belegt ist. Dieses neue Feature ist manchmal für nachträgliche Korrekturen hilfreich, wenn man z.B. das Dia mit der Magazin-Nummer 5 und der Dia-Fach-Nummer 20 in die Timeline gesetzt hat, man aber das Dia mit der Dia-Fach-Nummer 19 meinte.

Es gibt es die Möglichkeit, in der Timeline sog. Positions-Marker zu setzen. Ein bei einem Programmschritt gesetzter Positions-Marker ist nur eine Markierung, mit deren Hilfe bequem in der Timeline navigiert werden kann. Mit Umsch + F9 springt man zum nächsten, mit Umsch + F10 zum vorhergehenden Positions-Marker. Mit Strg + Umsch + F9 toggelt (setzt/entfernt) man einen Positions-Marker, mit Strg + Umsch + F10 entfernt man alle Positions-Marker. Man kann natürlich auch das entsprechende Menü oder Kontext-Menü verwenden. Wer keine Positions-Marker benötigt, kann die Spalte ausblenden.

Die Spalte "Programm-Nummer" wird mehrfach angezeigt, und zwar unter "Nummern", zusätzlich aber noch unter "Überblendung", "Audio-Spur 1" und "Audio-Spur 2". Beim Navigieren und Editieren in der Timeline ist es aufgrund der zahlreichen Spalten manchmal nicht einfach, die Übersicht zu behalten. Die mehrfache Anzeige der Programm-Nummer sowie die gelbe Hinterlegung der Spalte sollen das ganze etwas erleichtern. (Die naheliegendste Lösung, die äußerste linke Spalte beim horizontalen Scrollen zu fixieren, war aus programmtechnischen Gründen leider nicht möglich.)

Wie man nicht benötigte Werte im Timeline-Editor ausblendet, erfährt man hier.


Wie werden Programmschritte aus der Timeline entfernt?

Man markiert in der Timeline die Programmschritte, die man entfernen möchte, mit Hilfe von Strg + Linke Maustaste oder Umschalt + Pfeil Oben/Pfeil unten. Dann drückt man das Button [image] oder man drückt Strg + Entf oder man wählt den Menüpunkt Dia-Show/Timeline/Selektierte Programmschritte löschen. Ist kein Programmschritt markiert, wird der aktuelle Programmschritt gelöscht.

Will man alle Programmschritte der Timeline löschen, kann man dies mit dem Button [image] oder dem Tastenkürzel Umsch + Strg + Entf oder dem Menüpunkt Dia-Show/Timeline/Alle Programmschritte löschen tun.

Siehe auch Tastenkürzel im Timeline-Editor.


Wie werden Audio-Dateien zur Dia-Show hinzugefügt, aus ihr entfernt bzw. abgespielt?

Sofern man Audio-Dateien vorliegen hat, kann man diese einem Programmschritt in der Timeline hinzufügen und so zeitgenau Audio-Ereignisse (Musik, Sprache, Geräusche) steuern.

Der Audio-Player bietet im wesentlichen folgende Möglichkeiten:

  • Es sind alle gängigen Audio-Formate verwendbar (MP1, MP2, MP3, WAV, OGG, AIFF, WMA), wobei MP3 sicher das am häufigsten verwendete Format ist.
  • Die Audio-Tracks können im Audio-Player grafisch dargestellt werden, was die Positionierung von Start-, Stop- und Synchronisations-Punkten deutlich erleichtert. Die grafische Darstellung der Audio-Tracks erfordert allerdings einen einigermaßen leistungsfähigen Computer.
  • Wenn die in der Timeline plazierten Audio-Tracks unterschiedliche Lautstärken (Maximalpegel) aufweisen, können sie normalisiert, d.h. aneinander angeglichen werden.
  • Die Audio-Tracks werden in der Timeline als Audio-Kurven grafisch dargestellt.
  • Die Timeline enthält zwei Audio-Spuren, so dass praktisch beliebige Ein- und Überblendungen möglich sind. Damit kann man z.B. in einen laufenden Audio-Track Geräusche oder Sprache einblenden oder zwischen zwei Audio-Tracks überblenden.
  • Der Audio-Player ist auch "Stand alone" nutzbar, ohne dass eine *.twc-Datei geöffnet ist.
Voraussetzung für die Nutzung des neuen Audio-Players ist natürlich, dass auf dem PC eine Sound-Karte vorhanden ist. Des weiteren ist es erforderlich, dass DirectX ab Version 3 installiert ist, was auf jedem Computer der Fall sein sollte, der softwaremäßig einigermaßen up-to-date ist. Welche Version von DirectX installiert ist, kann man mit Hilfe des Diagnose-Programms "dxdiag" herausfinden. Einfach in der Kommandozeile "dxdiag" eingeben, die gewünschte Versionsnummer befindet sich auf der ersten Registerkarte.

Der Audio-Player unterstützt keine Audio-CD-Dateien (*.cda) mehr, da das Handling solcher Dateien umständlich, langsam und funktional eingeschränkt ist und heutzutage sowieso die meisten Anwender mit *.mp3-Dateien arbeiten.

Eine Audio-Datei wird zu einem Programmschritt hinzugefügt, indem man mit der rechten Maustaste in die entsprechende Zeile im Timeline-Editor klickt und aus dem Kontext-Menü den Punkt "Audio-Datei zum Programmschritt suchen" auswählt. Daraufhin erscheint eine Auswahl-Box für die gewünschte Audio-Spur (1 oder 2) und danach ein Datei-Dialog, mit welchem man die gewünschte Audio-Datei auswählen kann. Folgende Audio-Formate sind möglich: MP1, MP2, MP3, WAV, OGG, AIFF, WMA. Das Gros der Anwender wird sicher MP3-Dateien verwenden, da diese bei guter Qualität relativ klein sind. Die MP3-Dateien sollten aber mit konstanter Bitrate kodiert sein, näheres dazu erfährt man hier.

Die Original-Audio-Dateien werden beim Import nicht angetastet, es wird lediglich eine Kopie der Datei im (versteckten) Verzeichnis Audio abgelegt. Das Verzeichnis Audio wird automatisch beim Anlegen einer *.twc-Datei mit erzeugt. Normalerweise braucht sich der Anwender um diese Dinge nicht zu kümmern, deswegen werden die Verzeichnisse mit Medien-Dateien auch versteckt.

Auf analoge Weise kann mittels des Kontext-Menüs "Audio-Datei zum Programmschritt entfernen" eine Audio-Datei wieder entfernt werden. Dabei ist zu beachten, dass lediglich die Kopie der Datei, nicht das Original entfernt wird. Eine bereits bestehende Audio-Datei kann auch jederzeit durch eine andere ersetzt werden.

Mehrere Audio-Dateien können auch gleichzeitig entfernt werden. Man selektiert einfach mehrere Zeilen im Timeline-Editor, und nach einer positiv beantworteten Sicherheitsabfrage werden die Audio-Dateien entfernt.

Abgespielt werden die Audio-Dateien mittels des Kontext-Menüs "Audio-Datei zum Programmschritt abspielen" oder des entsprechenden Tool-Buttons. Dazu wird ein Fenster mit einem Audio-Player geöffnet, mit welchem die zur momentanen Zeile des Timeline-Editors gehörige Audio-Datei abgespielt werden kann. Die bei einer MP3-Datei eingetragenen ID3-Tag-Informationen können mit Hilfe des entsprechenden Buttons im Audio-Player angezeigt werden.Diese Informationen, sofern vorhanden, stehen nicht nur für MP3-Dateien, sondern für praktisch alle Audio-Datei-Typen zur Verfügung.

Im Stand-Alone-Modus ist der Audio-Player nutzbar, wenn er über das Menü "Tools/Audio-Player" aufgerufen wird. Dazu braucht keine *.twc-Datei geöffnet sein. Der Stand-Alone-Modus ist nützlich:
  • für Testzwecke oder um schnell mal eine Audio-Datei zu suchen
  • um beim Erstellen einer Dia-Show Musik hören zu können; im Stand-Alone-Modus kann der Audio-Player minimiert werden, so dass er beim Arbeiten nicht stört
  • für Pausen-Musik während einer Live-Dia-Show

Das folgende Bild zeigt das beim Aufruf des Audio-Players erscheinende Fenster.

Wir geben eine kurze Erklärung der in diesem Fenster vorhandenen Elemente.

Am unteren Fensterrand findet man rechts neben dem "Hilfe"-Button die Status-Zeile, die einige Kurzinformationen ausgibt. Das Optionsfeld "Audio-Kurven" entscheidet darüber, ob die grafische Darstellung der Audio-Kurven aktiviert ist oder nicht. Normalerweise sollte das Häkchen gesetzt sein, lediglich auf älteren Computern kann es erforderlich sein, das Optionsfeld aus Performancegründen zu demarkieren.

Im Audio-Player-Fenster findet man zwei identische Panels für die beiden Audio-Spuren. Momentan gibt es in der Timeline nur eine Audio-Spur, die zweite kommt in einem der nächsten Releases hinzu. Man kann aber bereits jetzt beide Spuren nutzen, indem man die Audio-Dateien manuell lädt. So kann man zwei Audio-Tracks gleichzeitig abspielen, was nicht sehr sinnvoll ist, aber für das spätere Ein- und Überblenden benötigt wird.

Das erste Button links unterhalb der grafischen Darstellung des Audio-Tracks dient dem manuellen Laden von Audio-Dateien. Mit einem Links-Klick auf das Button öffnet sich eine Datei-Auswahl-Box für die verschiedenen Audio-Formate. Mit einem Rechts-Klick auf das Button öffnet sich ein Kontext-Menü, mit dem man folgendes tun kann:

  • eine beliebige Audio-Datei in den Audio-Player laden
  • die in der aktuellen Timeline-Zeile eingetragene Audio-Datei (erneut) in den Audio-Player laden
  • die im Audio-Player geladene Audio-Datei in die aktuelle Timeline-Zeile übernehmen
  • die im Audio-Player geladene Audio-Datei entladen

Der Stand-Alone-Modus in Kombination mit dem dritten Menü-Punkt ist dann sinnvoll, wenn man zu einem in der Timeline befindlichen Dia ein passendes Musikstück sucht. Dazu öffnet man den Audio-Player und in diesem die gewünschte Audio-Datei, kann sich diese anhören, ggf. auch im Shuffle-Modus (s.u.), und überträgt, wenn man fündig geworden ist, die im Audio-Player geöffnete Datei in die Timeline (dritter Menü-Punkt). Der Vorteil dieser Methode ist, dass man die Audio-Datei erst dann in die Timeline überträgt, wenn man die richtige gefunden hat.

Die nächsten drei Buttons sind die von jedem Audio-Player bekannten Play-, Pause- und Stop-Buttons. Das Pause-Button hat dabei zwei Zustände, beim ersten Drücken wird die Pause eingeleitet, beim zweiten Drücken wird sie beendet. Das Play-Button bietet noch eine Besonderheit: den Shuffle-Modus. Drückt man das Play-Button mit der rechten Maustaste, wird der Audio-Track bei 0%, 10%, 20%, ..., 90% für jeweils 5 sec angespielt.

Die nächsten beiden Buttons dienen dem Setzen und Entfernen von Start- und Stop-Positionen des Audio-Tracks. Start- und Stop-Position dienen dazu, den Audio-Track irgendwo mittendrin zu starten oder zu beenden. Mit der linken Maustaste wird eine Start- bzw. Stop-Position gesetzt, mit der rechten Maustaste wird sie entfernt. Die Buttons sind verfügbar, sobald eine Audio-Datei geladen ist. Bei laufendem Audio-Player können Start- bzw. Stop-Position bequem und punktgenau nach Gehör gesetzt werden. Es ist zu beachten, dass logischerweise die Start-Position kleiner als die Stop-Position sein muss. Eingaben, die diese Regel verletzen, werden ignoriert. Eine gesetzte Start- bzw. Stop-Position ist an einem blauen, senkrechten Strich mit einem nach rechts bzw. links zeigenden Pfeil und einer Zeitangabe zu erkennen. Eine korrekt gesetzte Start- oder Stop-Position wird automatisch in die Timeline übertragen.

Das nächste Button entfernt Audio-Start- und -Stop-Punkt, so dass wieder die volle Audio-Track-Länge zur Verfügung steht.

Das nächste Button dient dem Setzen eines Audio-Synchronisations-Punktes. Dieses Button ist nur aktiv, wenn die grafische Darstellung der Timeline geöffnet ist, aber keine Leinwand-Simulation läuft. Man selektiert in der grafischen Darstellung der Timeline den Programmschritt, auf den man einen Sync-Punkt setzen will, startet den Audio-Player und drückt zum gewünschten Zeitpunkt das Button. Mit der rechten Maustaste kann man einen vorhandenen Sync-Punkt löschen.

Das Optionsfeld "Quickstart" hat folgende Bedeutung:
Wenn man das Button "Play" drückt, dann startet der Audio-Player am Anfang oder, sofern gesetzt, an der Start-Position des Audio-Tracks. Setzt man das Häkchen bei "Quickstart", dann startet der Audio-Player an der momentanen Position, erkennbar am rotbraunen, senkrechten Strich, dem sog. Locator. Das Optionsfeld ist nur verfügbar, wenn keine Leinwand-Simulation läuft und die Option "Looping" nicht gewählt ist. "Quickstart" ist in erster Linie zum bequemen Probieren beim Setzen von Start- und Stop-Positionen gedacht.

In der Timeline gibt es für jede der beiden Audio-Spuren ein Feld "Looping". Damit kann für jede einzelne Audio-Datei separat der Looping-Modus gesetzt werden.

Das Optionsfeld "Looping" hat folgende Bedeutung:
Setzt man das Häkchen bei "Looping", dann startet der Audio-Player, wenn er am Ende oder an der Stop-Position des Audio-Tracks angelangt ist, den Audio-Track am Anfang oder an der Start-Position neu. So kann der Audio-Track in einer Endlosschleife abgespielt werden. Nützlich ist diese Option z.B. in folgendem Fall: Angenommen, ein Audio-Track hat Pausen in der Timeline, die z.B. für den Speaker-Support genutzt werden sollen, und in denen der Audio-Track im Hintergrund leise weiterläuft. Der Audio-Track hat außerdem, was er immer haben muss, ein definiertes Ende auf einem bestimmten Programmschritt. Da Pausen für den Speaker-Support von Vortrag zu Vortrag unterschiedlich sein können und man daher nie weiß, wann diese zu Ende sind, kann es passieren, dass der Audio-Track beendet ist, bevor das eigentlich beabsichtigte Ende erreicht ist. In diesem Falle hat man eine akustische Lücke, die eigentlich mit Musik oder Geräuschen gefüllt sein sollte. Hier setzt der Looping-Modus an: wenn dieser aktiviert und der Audio-Track beendet ist, bevor dessen beabsichtigtes Ende erreicht ist, startet der Audio-Player den Audio-Track mit der aktuellen Lautstärke und Start-Position bzw. am Anfang erneut.

Das rechts davon befindliche Button "ID3-Tags" dient dem Zweck, die ID3-Tags, sofern vorhanden, einer MP3-Datei bzw. jeder anderen Audio-Datei anzuzeigen. ID3-Tags beinhalten Informationen wie Titel, Interpret und Genre des Musikstücks.

Weiterhin folgen die Pegel-Anzeige für die Audio-Pegel des linken und rechten Kanals und der Lautstärke-Regler, mit dem die Lautstärke des Audio-Tracks verändert und angezeigt werden kann. Der Lautstärke-Bereich geht von 0 bis 100. Dabei handelt es sich nicht um die unter "Sounds & Audiogeräte" in den Systemeinstellungen zu findende Gerätelautstärke, sondern um individuelle, nur die Ausgabekanäle des Audio-Players betreffende Lautstärken. Würde also z.B. der Windows Media-Player parallel zu TwinLightControl laufen, bliebe dessen Lautstärke unbeeinflusst.

Der rechts davon befindliche Wippregler erlaubt die Änderung der Lautstärke in großen Schritten. Ein Klick auf den linken Pfeil (Tastenkombination: Strg + F9) halbiert, ein Klick auf den rechten Pfeil (Tastenkombination: Strg + F10) verdoppelt die Lautstärke, was bei Live-Vorträgen für einen temporären Speaker-Support von Nutzen sein kann.

Ganz rechts befindet sich ein Button mit einem Lautsprecher, mit dessen Hilfe man den Ton aus- und wieder einschalten kann.

Das wichtigste Element im Audio-Player ist die Wave-Box, in der die Audio-Kurven grafisch dargestellt werden. Folgende Elemente sind dort zu finden:

  • unten links: der Name der geladenen Audio-Datei; längere Datei-Namen werden verkürzt dargestellt
  • unten Mitte: die Länge (in hh:mm:ss) der Audio-Datei
  • unten rechts: der Maximalpegel (Erklärung s.u.) des Audio-Tracks und die momentan eingestellte Lautstärke
  • der rotbraune, senkrechte Strich ist der sog. Locator, der die momentane Position in der Audio-Datei angibt (in hh:mm:ss bzw. in %)
  • die blauen, senkrechten Striche sind die Start- bzw. End-Position der Audio-Datei (in hh:mm:ss)
  • der bzw. die roten, senkrechten Striche sind Audio-Synchronisations-Punkte (in hh:mm:ss)
  • die dunkelblaue, horizontale Mittellinie trennt die Darstellung der Amplituden für den rechten (oben) bzw. linken (unten) Kanal
In der Wave-Box kann man viele Dinge bequem mit der Maus erledigen. Dies sind:
  • die momentane Position in der Audio-Datei (Locator) verändern; man bewegt die Maus einfach an die gewünschte Stelle und drückt die rechte Maustaste; Drücken und Ziehen der rechten Maustaste verschiebt den Locator in beliebiger Weise
  • mit der linken Maustaste setzt man den Locator an den Anfang der Audio-Datei zurück
  • mit Strg + LinksKlick setzt man die Start-Position in der Audio-Datei, mit Strg + RechtsKlick die End-Position; Drücken und Ziehen der jeweiligen Maustaste verschiebt die Start- bzw. End-Position in beliebiger Weise
  • man kann die Start- bzw. End-Position auch mit der Tastatur setzen: die Taste "8" ("[") bzw. "9" ("]") setzt die Start- bzw. End-Position
  • die Taste "+" setzt einen Audio-Synchronisations-Punkt
  • mit Alt+LinksKlick löscht man die Start-Position, mit Alt + RechtsKlick die Stop-Position
  • mit Umsch + LinksKlick spult man in einem laufenden Audio-Track eine Sekunde zurück, mit Umsch + RechtsKlick eine Sekunde vor; die Tasten F11 bzw. F12 bewirken das gleiche, allerdings mit jeweils einer halben Sekunde; auf diese Weise kann man einen zu setzenden Start-, Stop- oder Sync-Punkt bequem "einkreisen"
  • F8 schaltet den Ton beider Spuren ein bzw. aus
  • F9 bzw. F10 erhöht bzw. erniedrigt die Lautstärke beider Audio-Spuren, wobei gleichzeitiges Drücken der Taste "Strg" die Geschwindigkeit der Änderung erhöht
Nun ein paar Bemerkungen zum Pegel eines Audio-Tracks. Audio-Dateien stammen aus den unterschiedlichsten Quellen und haben i.d.R. unterschiedliche Maximalpegel, d.h. sie klingen, ohne dass der Lautstärke-Regler verändert wird, unterschiedlich laut. Wenn man z.B. mit CDEx oder einem vergleichbaren CD-Ripper aus Audio-CD's MP3-Dateien erzeugt, hat man die Möglichkeit, deren Pegel zu normalisieren, d.h. leise und laute Musikstücke einer CD werden alle auf den gleichen Maximalpegel getrimmt. Das kann erwünscht sein oder auch nicht.

In der Wave-Box hat man die Möglichkeit, die Audio-Tracks zu normalisieren, um eine Angleichung der Maximalpegel vorzunehmen, was im Kontext einer Dia-Show oft sinnvoll ist. Ganz rechts unten in der Wave-Box befinden sich zwei kleine Optionsfelder. Das linke Optionsfeld normalisiert eine Audio-Datei, d.h. sie wird auf Maximalpegel getrimmt. Das rechte Optionsfeld skaliert nur die grafische Darstellung, d.h. wenn eine Audio-Datei unter dem Maximalpegel liegt, wird lediglich die Audio-Kurve der besseren Erkennbarkeit wegen getrimmt, nicht aber die hörbare Kurve. Das linke Optionsfeld hingegen verändert den (hörbaren) Maximalpegel. Der Maximalpegel des Audio-Tracks wird unten links neben der Lautstärke angezeigt, in dB und in Prozent. Maximalpegel bedeutet einen Pegel von 0 dB oder 100%, eine Minderung um 6 dB bedeutet eine Halbierung der Lautstärke, d.h. - 6 dB entsprechen 50%, - 12 dB entsprechen 25% usw.

Man muss sich stets vor Augen halten, dass der Maximalpegel eines Audio-Tracks nichts mit der Stellung des Lautstärke-Reglers zu tun hat. Ein normalisierter Audio-Track klingt lauter als ein nicht normalisierter, ohne dass der Lautstärke-Regler verändert wurde.

Bei einer Dia-Show ist es oft wünschenswert, normalisierte Audio-Tracks zu verwenden, die den gesamten Dynamikbereich ausnutzen. Deshalb sollte man das Häkchen im Optionsfeld "Normalisieren" setzen. Es gilt dann für alle Audio-Tracks. Soll ein bestimmter Audio-Track trotzdem leiser dargeboten werden, hat man immer noch die Möglichkeit, in der Timeline eine Lautstärke < 100% einzutragen.

Die Vorbereitung für die grafische Darstellung der Audio-Kurven geschieht übrigens in einem separaten, vom Haupt-Thread unabhängigen Thread. Wenn eine Audio-Datei im Audio-Player geöffnet wird, steht sie sofort zum Abspielen bereit, parallel wird die grafische Darstellung der Audio-Kurve in einem separaten Thread niedriger Priorität aufbereitet. Das hat folgenden Grund: wenn eine Audio-Datei aus einem laufenden Programm (Leinwand-Simulation, Projektor-Betrieb) heraus geöffnet wird, muss sie sofort zur Verfügung stehen, dami sie ohne Zeitverzögerung zum Abspielen gebracht werden kann. Der Thread zur grafischen Darstellung wird immer dann ausgeführt, wenn das System freie Ressourcen hat. Man kann das überprüfen, indem man eine Audio-Datei öffnet und sofort nach dem Schließen der Datei-Auswahl-Box das Play-Button drückt. Der Audio-Track beginnt sofort zu spielen, während die grafische Darstellung noch eine Weile benötigt.

Wird eine Audio-Datei in die Timeline eingefügt, wird die grafische Darstellung der Audio-Datei erzeugt und die Daten zusammen mit der Audio-Datei in einer (versteckten) Datei abgelegt. Öffnet man später die in der Timeline befindliche Audio-Datei, steht deren grafische Darstellung sofort zur Verfügung und muss nicht erst erzeugt werden. Die Datei mit den Daten für die grafische Darstellung der Audio-Kurve ist klein im Vergleich zur Audio-Datei selbst, fällt also kaum ins Gewicht.

Alle Tastenkürzel für den Audio-Player findet man hier.

Start- und Stop-Position können auch in die entsprechenden Felder der Timeline händisch im Format hh:mm:ss eingetragen werden. In den Feldern der Timeline werden Format-Masken (__:__:__) vorgegeben. Start- und Stop-Position müssen folgende Bedingungen erfüllen:
  • Start-Position <= Track-Länge
  • Stop-Position <= Track-Länge
  • Stop-Position = 0 (bis zum Ende) oder Stop-Position >= Start-Position
Beim Setzen von Audio-Start- und Audio-Stop-Positionen und Audio-Synchronisations-Punkten werden auch Sekundenbruchteile berücksichtigt. Dies ist allerdings nicht durch händische Eingabe der Werte im Timeline-Editor möglich (dort können Zeiten immer nur im Format "00:00:00" eingegeben werden), sondern nur, wenn die Punkte "online" im Audio-Player gesetzt werden. Damit ist eine noch genauere Synchronisation von Bild und Ton möglich. In der grafischen Darstellung der Timeline, in der Fußzeile der Timeline und in der Status-Zeile des Audio-Players werden die entsprechenden Zeiten im Format "00:00:00,000" dargestellt, wobei die letzten drei Ziffern Sekundenbruchteile bedeuten. Man muss sich aber darüber im klaren sein, dass Echtzeitanwendungen in einer Windows-Umgebung ihre Grenzen haben.

Unterhalb der Lichtkurven werden zusätzlich Lautstärke-Kurven gezeichnet. Sie stellen den durch die einzelnen Audio-Funktionen (s.u.) bewirkten Lautstärkeverlauf grafisch dar und verbessern damit die optische Kontrolle der Synchronisation von Bild und Ton.

Zusammen mit den Lautstärke-Kurven werden auch die Audio-Kurven (grafische Darstellung des Audio-Tracks) gezeichnet. Das ist natürlich nur in den Bereichen möglich und sinnvoll, in denen die zugehörigen Licht-Kurven keine Pausen haben. Eine Licht-Pause (für Speaker-Support) zerstört die nachfolgende Synchronisation zwischen Bild und Ton.

Was zu beachten ist, wenn man Start- und/oder Stop-Positionen verwenden will, findet man unter Bemerkungen zu MP3-Dateien.

Wie man Audio-Synchronisations-Punkte zur Synchronisation von Bild und Ton verwendet, findet man unter Wie werden Audio-Synchronisations-Punkte gesetzt?.

Bedeutung der einzelnen Audio-Funktionen:

Folgende Audio-Funktionen werden mit dem ersten (ansteigenden) Ast der zugehörigen Lichtkurve gestartet:

Keine Keine Audio-Funktion
Ton ein Audio-Player starten, angegebene Lautstärke einstellen
Ton aus Audio-Player stoppen
Ton ein nach Pause Audio-Player-Pause beenden, Ton ein, angegebene Lautstärke einstellen
Ton aus vor Pause Ton aus und Audio-Player-Pause
Ton einblenden Audio-Player starten, Ton einblenden bis auf angegebene Lautstärke
Ton ausblenden Ton ausblenden und Audio-Player stoppen
Ton einblenden nach Pause Audio-Player-Pause beenden, Ton einblenden bis auf angegebene Lautstärke
Ton ausblenden vor Pause Ton ausblenden und Audio-Player-Pause
Ton lauter Ton stetig lauter stellen bis zur angegebenen Lautstärke
Ton leiser Ton stetig leiser stellen bis zur angegebenen Lautstärke

Folgende Audio-Funktionen werden mit dem letzten (absteigenden) Ast der zugehörigen Lichtkurve gestartet:

Ton aus, am Ende Audio-Player stoppen
Ton aus vor Pause, am Ende Ton aus und Audio-Player-Pause
Ton ausblenden, am Ende Ton ausblenden und Audio-Player stoppen
Ton ausblenden vor Pause, am Ende Ton ausblenden und Audio-Player-Pause
Ton leiser, am Ende Ton stetig leiser stellen bis zur angegebenen Lautstärke

Die letzten fünf Audio-Funktionen sind immer dann sinnvoll, wenn das Ausblenden des Audio-Tracks synchron mit dem Ausblenden des Dias gestartet werden soll, also i.d.R. beim letzten Dia vor einer Null-Zeile (bei Nicht-Koppelmagazinen) oder beim letzten Dia einer Show. Andernfalls führen auch die "normalen" Audio-Funktionen zum Ziel: die Am-Ende-Audio-Funktion bei Programmschritt n bewirkt i.d.R. das gleiche wie die normale Audio-Funktion bei Programmschritt n+1. S. hierzu auch die Demo-Dia-Show "Audio-Funktion am Ende". In der grafischen Darstellung der Timeline sieht man sofort den Unterschied der neuen fünf Audio-Funktionen zu ihren Pendants.

Beim Timeline-Check wird eine genaue Prüfung aller Audio-Tracks und Audio-Funktionen vorgenommen. Deshalb an dieser Stelle ein paar Hintergrundinformationen.

Es gibt prinzipiell fünf verschiedene Gruppen von Audio-Funktionen:
  • Startende Audio-Funktionen (Ton ein, Ton einblenden): diese und nur diese starten einen Audio-Track und müssen bei einer Audio-Datei eingetragen sein
  • Beendende Audio-Funktionen (Ton aus, Ton aus, Ton ausblenden, Ton ausblenden am Ende): diese beenden einen Audio-Track; jeder Audio-Track muss irgendwo, spätestens vor dem Start eines neuen, mit einer dieser Funktionen beendet werden
  • Pause-einleitende Audio-Funktionen (Ton aus vor Pause, Ton aus vor Pause am Ende, Ton ausblenden vor Pause, Ton ausblenden vor Pause am Ende): diese leiten eine Pause ein, der Audio-Track pausiert an dieser Stelle
  • Pause-beendende Audio-Funktionen (Ton ein nach Pause, Ton einblenden nach Pause): diese beenden eine Audio-Pause; der pausierende Audio-Track wird an dieser Stelle wieder aufgenommen
  • Lautstärke-ändernde Audio-Funktionen (Ton lauter, Ton leiser, Ton leiser am Ende): diese erhöhen oder erniedrigen die Lautstärke
Für die Anordnung dieser Audio-Funktionen gibt es ein paar einfache Regeln, die sich aus der Logik erschließen:
  • Jeder Audio-Track muss mit einer startenden AF begonnen werden
  • Jeder Audio-Track muss mit einer beendenden AF abgeschlossen werden
  • Auf eine startende AF kann nur eine beendende oder pause-einleitende AF folgen
  • Auf eine pause-einleitende AF kann (und muss) nur eine pause-beendende AF folgen
  • Eine lautstärke-ändernde AF kann an jeder Stelle zwischen beginnender und beendender AF außer in einer Audio-Pause selbst stehen

Bei Beachtung dieser einfachen Regeln sollte es kein Problem sein, fehlerfreie Timelines zu erzeugen.

Zulässige Werte für das Feld "Lautstärke" sind 0% ... 100%.
Zulässige Werte für das Feld "Ein-/Ausblendzeit" sind 0 sec ... 100 sec. Bei 0 sec wird allerdings keine Ein-/Ausblendung durchgeführt, der kleinste sinnvolle Wert ist 0,1 sec.

Eine Bemerkung ist zum Verhalten von Audio-Dateien in Null-Zeilen notwendig. Null-Zeilen innerhalb einer Dia-Show treten dann auf, wenn man Nicht-Koppelmagazine verwendet. Beim Magazinwechsel tritt notwendigerweise eine Dunkelpause auf. Wenn während des Magazinwechsels (in einer Null-Zeile) gerade ein Audio-Track läuft, dann wird dieser auch über den Magazinwechsel hinweg weiter abgespielt. Möchte man dieses Verhalten nicht, muss man den Audio-Track beim letzten Dia vor dem Magazinwechsel ausblenden und beim ersten Dia nach dem Magazinwechsel ggf. wieder einblenden. Handelt es sich um einunddenselben Audio-Track, verwendet man sinnvollerweise die Audio-Funktionen "Ausblenden vor Pause" und "Einblenden nach Pause".

Beim Timeline-Check wird eine Warnung ausgegeben, wenn ein Audio-Track nicht beendet wurde, bevor der nächste gestartet wird bzw. das Ende der Timeline erreicht ist. Der Timeline-Check kann zwar trotz dieser Warnung abgeschlossen werden, man sollte die Warnung aber ernst nehmen und den Audio-Track ordnungsgemäß beenden. Ein Audio-Track kann mit einer der folgenden Audio-Funktionen beendet werden: Ton aus, Ton ausblenden, Ton aus am Ende, Ton ausblenden am Ende.

Wie man die punktgenaue Synchronisation von Bild und Ton am Anfang einer Dia-Show sicherstellt, wird in den Tips und Tricks beschrieben.

Es gibt zwei Audio-Spuren, mit deren Hilfe beliebige Ein- und Überblendungen möglich sind. Für die logische Abfolge der einzelnen Audio-Funktionen in den zwei Audio-Spuren ist der Anwender selbst verantwortlich. TwinLightControl überprüft lediglich, ob nicht bei einem Programmschritt zwei Audio-Synchronisations-Punkte eingetragen sind, was natürlich unsinnig wäre.

Die Demo-Datei "Audio-Looping und Audio-Überblendung.twc" demonstriert an einem einfachen Fall die Überblendung zwischen zwei Audio-Spuren und das Looping (Neustart eines Audio-Tracks nach seinem Ende).

Folgendes ist zum Verhalten von Audio-Tracks am Anfang einer Dia-Show anzumerken: Wenn beim ersten Programmschritt einer Dia-Show eine Audio-Datei eingetragen ist, wird diese erst dann gestartet, wenn der Projektor die beiden ersten Dias eingezogen hat und das erste Dia aufblendet. Damit ist eine bessere Synchronisation von Bild und Ton am Anfang einer Dia-Show möglich.


Wie werden Play-Listen für den Audio-Player verwendet?

Für den Audio-Player kann man sog. Play-Listen erstellen. Das sind Listen mit Audio-Tracks, die nacheinander abgespielt werden. Dieses Feature ist dann von Nutzen, wenn man in der Pause zwischen zwei Teilen einer Live-Dia-Show leise Hintergrundmusik zu Gehör bringen oder während der Arbeit an einer Dia-Show Musik hören möchte.

Damit Play-Listen bearbeitet oder abgespielt werden können, darf keine *.twc-Datei geöffnet sein. Man wählt aus dem Menü "Tools" den Audio-Player (Standalone-Modus). Dann klickt man auf das Button "Audio-Datei öffnen" und wählt aus dem Kontext-Menü "Play-Liste bearbeiten ...". Daraufhin öffnet sich folgendes Dialog-Fenster:

Der obere Bereich des Dialogs enthält die eigentliche Play-Liste, d.h. die Liste der Audio-Tracks, die in dieser Reihenfolge zu Gehör gebracht werden.

Das unter der Play-Liste befindliche Optionsfeld "Vollständige Datei-Namen anzeigen" entscheidet darüber, ob die vollen Datei-Namen inkl. Pfad oder, aus Gründen der Übersichtlichkeit, nur die Datei-Namen ohne Pfad angezeigt werden.

Die Häkchen vor den Datei-Namen erlauben es, temporär Audio-Tracks aus der Liste auszublenden. Sie werden dann nicht abgespielt, bleiben aber weiterhin in der Play-Liste.

Mit dem ersten der acht Buttons im unteren Bereich des Dialogs wird eine neue Play-Liste erzeugt.

Mit dem zweiten Button kann man eine vorhandene Play-Liste öffnen. Play-Listen befinden sich standardmäßig im Verzeichnis "PlayLists" des TLC-Installationsverzeichnisses und haben die Datei-Erweiterung ".apl". Der Name der gerade geöffneten Play-Liste wird in der Titelleiste des Dialogs angezeigt. Ein kleiner Stern hinter dem Datei-Namen zeigt an, dass die Datei geändert wurde.

Mit dem dritten Button kann man eine erstellte und geänderte Play-Liste abspeichern.

Mit dem vierten Button kann man eine erstellte und geänderte Play-Liste unter einem anderen Namen abspeichern.

Mit dem fünften Button kann man Audio-Tracks zu einer Play-Liste hinzufügen. Dazu öffnet sich ein Datei-Dialog, mit dessen Hilfe man die gewünschten Audio-Tracks auswählen kann.

Mit dem sechsten Button kann man eine oder mehrere Audio-Tracks aus der Play-Liste entfernen, wobei Mehrfachauswahl möglich ist.

Mit dem siebten und achten Button kann ein Eintrag in der Play-Liste nach oben oder unten verschoben werden.

Hat man eine Play-Liste geöffnet, kann man sie in den Audio-Player laden. Dazu klickt man im Audio-Player auf das Button "Audio-Datei öffnen" und wählt aus dem Kontext-Menü "Play-Liste laden". Dann werden die ersten beiden Dateien der Play-Liste geladen. Mit dem Start-Button beginnt das Abspielen des ersten Audio-Tracks. Beim Abspielen werden die Audio-Tracks nacheinander in die eine bzw. andere Audio-Spur geladen. Der gerade abgespielte Audio-Track wird auch in der Titelzeile des Fensters angezeigt.

Beenden kann man das Abspielen der Play-Liste mit dem Stop-Button. Will man die Play-Liste danach erneut starten, muss sie zunächst wieder geladen werden (s.o.).

Das Laden, Abspielen und Beenden der Play-Liste kann man mit dem neunten bis elften Button auch direkt im Play-Listen-Dialog erledigen.

Während des Abspielens der Play-Liste kann der Audio-Player inkl. Play-Liste bei Bedarf auch minimiert werden.


Wie wird der Audio-Recorder verwendet?

Mit Hilfe des Audio-Recorders kann man eigene Audio-Dateien erzeugen kann. Er ist in erster Linie dafür gedacht, bestimmte Abschnitte in der Dia-Show mit eigens dafür gefertigten Sprachkommentaren zu unterlegen.

Zunächst wählt man die Audio-Quelle aus, i.d.R. wird dies der Mikrofon- oder Line-In-Eingang sein. Mit dem Pegel-Regler kann man die gewünschte Lautstärke einstellen. Tip: Mit Stereomix als Audio-Quelle kann man z.B. Audio-Streams aus dem Internet mitschneiden. Bitte beachten Sie dabei die Bestimmungen des Urheberrechts.

Der Audio-Recorder hat drei Betriebsmodi:

  • Im Modus "Manuelle Aufnahme" werden Start und Stop der Aufnahme manuell gesteuert.
  • Im Modus "Timer-gesteuerte Aufnahme" wird zunächst die gewünschte Dauer der Aufnahme (in sec) eingegeben. Dann wird die Aufnahme manuell gestartet. Nach Ablauf der eingestellten Aufnahmedauer wird die Aufnahme automatisch gestoppt.
  • Im Modus "Programm-gesteuerte Aufnahme" wird der Audio-Recorder durch ein in der Timeline befindliches Programm gesteuert. Mit den drei Buttons "Record", "Pause" und "Stop" wird die Aufnahme gestartet, pausiert und gestoppt. Auch im Modus "Timer-gesteuerte Aufnahme" kann die Aufnahme vor Ablauf der eingestellten Zeit gestoppt werden.

In der rechts neben den drei Buttons befindlichen Fortschrittsanzeige wird bei einer timer-gesteuerten bzw. programm-gesteuerten Aufnahme die bereits verstrichene Zeit angezeigt.

Nach dem Stop der Aufnahme öffnet sich automatisch der Audio-Player, und man kann die soeben gemachte Aufnahme abhören.

Mit dem Button "Speichern" kann man die erzeugte Audio-Datei an einem beliebigem Ort unter einem beliebigen Namen abspeichern. Die Aufnahmen werden als Ogg-Vorbis-Audio-Dateien abgelegt. Ogg-Vorbis-Audio-Dateien sind in puncto Kompression und Qualität MP3-Dateien ebenbürtig, sie sind nur nicht so verbreitet. Der Ogg-Vorbis-Encoder ist freie und lizenzfreie Software.

Die als Ogg-Vorbis-Audio-Dateien abgespeicherten Aufnahmen können danach in der Timeline verwendet werden.

Die beiden Modi "Manuelle Aufnahme" und "Timer-gesteuerte Aufnahme" bedürfen keiner näheren Erläuterung.

Im "Programm-gesteuerten Modus" geht man folgendermaßen vor:

  1. Die twc-Datei öffnen, in die man die Audio-Aufnahme einfügen möchte.
  2. Die grafische Darstellung der Timeline (Standalone-Version) öffnen. Bitte nicht die virtuelle Fernbedienung öffnen, damit funktioniert es nicht.
  3. Die Leinwand-Simulation aktivieren.
  4. Unter den Toolbuttons auf der linken Seite befindet sich eines (rechts unten), welches den Audio-Recorder startet.
  5. Der Audio-Recorder öffnet sich nun rechts neben dem Audio-Player.
  6. Die Audio-Quelle (i.d.R. ein Mikrofon) auswählen und ggf. deren Pegel einstellen.
  7. Die Audio-Spur auswählen, in der die Aufnahme erfolgen soll. Ist eine Audio-Spur bereits vollständig mit Audio-Tracks belegt, wird man darauf hingewiesen.
  8. Die Programm-Nummern auswählen, bei denen die Audio-Aufnahme starten bzw. stoppen soll. Es werden jeweils nur die Programm-Nummern angeboten, bei denen dies möglich ist, d.h. bei denen noch kein aktiver Audio-Track eingetragen ist.
  9. Die Audio-Funktionen und ggf. Überblendzeiten zu den entsprechenden Start- und Stop-Programm-Nummern auswählen.
  10. Mit dem Optionsfeld "Audio-Spur ... stummschalten" kann man die jeweils andere Audio-Spur während der Aufnahme stummschalten.
  11. Das Button "Vorschau" drücken. In der betreffenden Audio-Spur wird der Bereich der Audio-Aufnahme zwischen Start- und Stop-Programm-Nummer hellblau dargestellt.
  12. Das Button "Aufnahme" drücken. Die Leinwand-Simulation startet einen Programmschritt vor der Aufnahme und endet einen Programmschritt nach der Aufnahme.
  13. Die Aufnahme (Button "Speichern") an einem beliebigen Ort speichern.
  14. Die Aufnahme in die Timeline einfügen.
  15. Alle Schritte können jederzeit abgebrochen werden, mit dem Button "Verwerfen" kehrt man zu den Grundeinstellungen zurück.

Die wahrscheinlich effektivste und flexibelste Methode ist folgende:

  1. Man überlegt sich, welche Bilder man mit Text unterlegen will.
  2. Man überlegt sich den Text und spricht ihn probeweise, um die dafür notwendige Zeit zu ermitteln.
  3. Im manuellen oder timer-gesteuerten (Zeitvorgabe) Modus macht man die Aufnahme.
  4. Man fügt die Aufnahme in die Timeline ein.
  5. Man passt die Standzeit der Dias an die Dauer der Aufnahme an.


Wie wird die Reihenfolge von Programmschritten in der Timeline geändert?

Oft kommt es vor, dass man die Reihenfolge der Dias (Programmschritte) in der Timeline ändern möchte.

Man markiert einfach den oder die Programmschritte mittels Strg+Linke Maustaste oder Strg+Umsch+Linke Maustaste oder Umschalt+Pfeil oben/Pfeil unten und drückt dann eine der beiden Pfeil-Buttons [image] über der Timeline. Die obere Pfeiltaste verschiebt den oder die markierten Programmschritte nach oben, die untere Pfeiltaste nach unten.

Selektiert man mehrere Programmschritte, ist zu beachten, dass nur zusammenhängende Blöcke von Programmschritten verschoben werden können.

Siehe auch Tastenkürzel im Timeline-Editor.


Wie wird ein Timeline-Check durchgeführt?

Um eine fertige Dia-Show zum Projektor übertragen zu können, muss zuerst die Timeline auf Fehler bzw. Plausibilität geprüft werden. Bei diesem Check werden außerdem die für den Projektor notwendigen Null-Zeilen eingefügt.

Der Timeline-Check wird mit dem Button [image] oder mit Strg + T durchgeführt.

Sind Fehler vorhanden, werden entsprechende Fehlermeldungen ausgegeben. Diese müssen korrigiert werden.

Ist die Timeline OK, wird ebenfalls eine entsprechende Meldung ausgegeben, und das Button [image] wird zum Button

Ist der Timeline-Check nämlich vollzogen, kann an der Dia-Show nichts mehr geändert werden. Sollen nachträglich Änderungen durchgeführt werden, sind zuerst die Null-Zeilen wieder zu entfernen. Einzige Ausnahmen sind die Überblendzeit und das Feld "Cut" bei Null-Zeilen, sie können auch nach dem Timeline-Check noch geändert werden. Die Überblendzeit einer Null-Zeile ist die Abblendzeit des vorhergehenden Dias.

Bei einem Timeline-Check wird u.a. folgendes überprüft:

  • Gibt es leere Magazine (alle Dia-Fächer unbelegt)?
  • Gibt es Magazine, die nichts zur Timeline (Dia-Show) beitragen?
  • Gibt es gemischte Magazin-Typen?
  • Sind die Magazin-Nummern gültig?
  • Ist die maximale Programmschritt-Zahl überschritten?
  • Befindet sich einunddasselbe Dia mehrmals direkt hintereinander in der Timeline?
  • Ist beim ersten Dia eines Magazins eine Sonderfunktion eingetragen?
  • Gibt es zu große Dia-Abstände (Absturzgefahr bei Koppelmagazinen)?
  • Sind alle eingetragenen Audio-Dateien vorhanden?
  • Sind die eingetragenen Audio-Funktionen sinnvoll?
  • Ist die logische/zeitliche Abfolge der Audio-Funktionen sinnvoll?
  • Sind die Audio-Start- und -Stop-Zeiten zulässig?
  • Wird jede Audio-Datei irgendwo gezielt beendet?
Außerdem wird in einem Dialog abgefragt, ob Dia-Kommentare als Magazin-Kommentare übernommen und Standardwerte für Helligkeit, Überblend- und Stand-Zeiten verwendet werden sollen.

Wählt man die Option Dia-Kommentare als Magazin-Kommentare übernehmen, wird der Kommentar des jeweils ersten und letzten belegten Dia-Fachs eines Magazins in der Form <Erster Kommentar> ... <Letzter Kommentar> als Kommentar für das Magazin übernommen. So sieht man auf einen Blick, welche Dias ein Magazin enthält. Sind der erste und/oder letzte Dia-Kommentar (noch) leer, werden Platzhalter eingefügt. Das Übernehmen der Kommentare ist übrigens auch unabhängig vom Timeline-Check im Menü bzw. Kontext-Menü für den Magazin-Editor verfügbar.

Es gibt Standardwerte für
  • Helligkeit des Dias
  • Überblendzeit bei normaler Überblendung (gilt auch für die Abblendzeit bei Null-Zeilen)
  • Überblendzeit bei Dia-Format-Wechsel (möglichst kurze Zeiten, um das unschöne "Lichtkreuz" zu vermeiden)
  • Standzeit bei normaler Überblendung, d.h. bei Dias, bei denen keine Licht-Sonderfunktion eingetragen ist

Man sollte die Optionen in dem Dialog mit Bedacht verwenden, da sie auf die gesamte Timeline angewendet werden und evtl. mühsam gemachte Einstellungen überschreibt. Im Zweifelsfall sollte man alle Optionen abwählen. Hat man doch einmal eine Option unbedachterweise an- oder abgewählt, dann hilft ein "Undo" auf alle Fälle weiter.

Bei einem Formatwechsel kann neben einer kurzen Überblendzeit auch die Licht-Sonderfunktion "Ab-/Aufblenden" automatisch eingefügt werden. Welches Handling bei einem Formatwechsel gewählt wird, legt man in den Voreinstellungen fest.

Bei einem Formatwechsel gelten folgende Regeln:

  • Beim ersten Dia nach einer Null-Zeile (bei Nicht-Koppelmagazinen) wird weder eine kurze Überblendzeit noch die Sonderfunktion "Ab-/Aufblenden" eingetragen
  • Die kurze Überblendzeit für den Formatwechsel wird nur dann eingetragen, wenn nicht bereits ein Cut oder eine kürzere Überblendzeit eingetragen ist

Für die Abblendzeit von Null-Zeilen gilt: wählt man die Option "Bei Null-Zeilen (Abblendzeit)", wird in Null-Zeilen die Überblendzeit für normale Überblendung eingetragen. Wählt man diese Option ab, wird für die Null-Zeile die Überblendzeit des vorhergehenden Programmschritts übernommen.

Die Einstellungen einer Null-Zeile (Cut, Überblendzeit) gehen beim Entfernen der Null-Zeilen nicht verloren. Man kann also einen Timeline-Check mehrmals ausführen und zurücknehmen, ohne dass man die in den Null-Zeilen vorgenommenen Änderungen wiederholen muss.

Fehler im Zusammenhang mit Audio-Dateien werden als solche behandelt. Vor einem erneuten Timeline-Check müssen die Fehler korrigiert werden (z.B. die fehlende Beendigung einer Audio-Datei).

Der Timeline-Check nimmt eine Unterscheidung zwischen Warnungen und Fehlern vor. Fehler müssen zuerst beseitigt werden, bevor der Timeline-Check absolviert werden kann. Fehler bestehen z.B. in leeren Magazinen oder Magazinen, die nichts zur Timeline beitragen. Warnungen stehen i.d.R. in Zusammenhang mit Audio-Tracks (ein paar Hintergrundinformationen findet man hier). Warnungen lassen die Absolvierung des Timeline-Checks zu, sollten aber auf alle Fälle beseitigt werden. Man kann dies direkt in der Timeline oder in der grafischen Darstellung der Timeline tun. Es ist aber zu beachten, dass die grafische Darstellung der Timeline fehlerhaft sein kann, solange es noch Warnungen gibt. Wenn die Timeline noch Warnungen hat, kann man z.B. in der grafischen Darstellungen keine Audio-Sync-Punkte setzen. Hat man alle Warnungen beseitigt, sollte man die grafische Darstellung der Timeline noch einmal schließen und erneut öffnen.

Fehler und Warnungen beim Timeline-Check werden in einem Dialog mit unterschiedlichen Farben (Fehler: gelb, Warnungen: hellblau) angezeigt. In dem Dialog finden sich Zeilen, die mit einem "#" beginnen und den genauen Fehlertext enthalten. Klickt man eine solche Zeile mit der Maus an, wird sie selektiert, und je nach Fehlerursache wird die richtige Zeile im Magazin- oder Timeline-Editor selektiert. Ggf. wird der Fehlerdialog dabei verschoben, so dass man den gewünschten Editor sieht. Bei geöffnetem Fehler-Dialog kann man dann den Fehler korrigieren (vorher Null-Zeilen entfernen) und den Timeline-Check wiederholen.

Den fehlenden Abschluss einer Audio-Datei kann man beim Timeline-Check automatisch hinzufügen lassen. TwinLightControl fordert den Anwender dazu auf. Der Abschluss der Audio-Datei wird auf den letzten Programmschritt der Dia-Show (bei Nicht-Koppelmagazinen auf den letzten Programmschritt des Magazins mit der Audio-Datei) bzw. auf den letzten Programmschritt vor der nächsten Audio-Datei gelegt und kann bei Bedarf später noch verschoben werden.

Obwohl TwinLightControl über eine Undo-/Redo-Funktion verfügt, sollte man so oft wie möglich den aktuellen Stand sichern (Button "Speichern" oder den entsprechenden Menü-Eintrag). Ist einem trotz aller Sorgfalt ein Fehler unterlaufen, kann man den letzten Stand restaurieren (Button "Wieder öffnen" oder der entsprechende Menü-Eintrag).


Wie wird die Timeline grafisch dargestellt?

Mit Hilfe des Buttons [image] oder des entsprechenden Menü-Punktes kann die Timeline grafisch dargestellt werden. Wenn die PC-Fernbedienung geöffnet wird, wird auch das Fenster für die grafische Darstellung der Timeline mit geöffnet. Das Fenster für die grafische Darstellung der Timeline kann in der Höhe verändert werden und hat einen horizontalen und einen vertikalen Scrollbalken.

Die grafische Darstellung der Timeline ist nur nach erfolgreich absolviertem Timeline-Check möglich. Die Erzeugung der grafischen Darstellung der Timeline kann, je nach Rechnergeschwindigkeit und Länge der Dia-Show, einige Sekunden in Anspruch nehmen. Am Sanduhr-Mauszeiger kann man erkennen, dass der Rechner noch beschäftigt ist. Die grafische Darstellung der Timeline wird beim Start der Fernbedienung auch dann (unsichtbar) erzeugt, wenn man die grafische Darstellung abgewählt hat. Sie enthält nämlich wesentliche Informationen für die Leinwand-Simulation.

Es werden die Lichtkurven der zu zeigenden Dias in den beiden Kanälen dargestellt. Überblendungen sind abwechselnd rot und grün, Einblenden, Blinken und Flashen blau gekennzeichnet. Pausen (manuelle Weiterschaltung) sind durch gestrichelte Linien erkennbar. Jede Überblendung wird durch ihre Programm-Nummer PN, Magazin-Nummer MN und Bild-Nummer (absolute Dia-Nummer) BN gekennzeichnet.

Unterschiedliche Helligkeiten einzelner Dias werden nicht dargestellt, die Scheitel der Lichtkurven haben eine einheitliche Höhe. Wie schon an anderer Stelle erwähnt, sollten unterschiedliche Helligkeiten einzelner Dias nur in Ausnahmefällen verwendet werden.

Die jeweils aktive Überblendkurve wird farbig hervorgehoben. Mit dem Kontext-Menü (rechte Maustaste) kann man wählen, ob die aktive Überblendkurve durch ein Rechteck oder das zugehörige Polygon dargestellt wird.

Sofern bei einer Lichtkurve eine Pause (manuelle Weiterschaltung) eingetragen ist, wird dies durch ein kleines farbiges Dreieck unter der Lichtkurve gekennzeichnet.

Unter den Lichtkurven werden die zugehörigen Bild-Dateien, sofern vorhanden, verkleinert angezeigt. Gibt es zu dem Programmschritt keine Bild-Datei, wird als Platzhalter ein schraffiertes Rechteck angezeigt.

Im unteren Teil des Fensters werden die Audio-Funktionen, sofern vorhanden, dargestellt. Der Name der Audio-Datei und die Audio-Start-Position werden angegeben. Bei der grafischen Darstellung werden folgende Symbole verwendet:

Ton ein
Ton aus
Ton ein nach Pause
Ton aus vor Pause
Ton einblenden
Ton ausblenden
Ton einblenden nach Pause
Ton ausblenden vor Pause
Ton lauter (Lautstärke erhöhen)
Ton leiser (Lautstärke erniedrigen)

Audio-Tracks werden, sofern möglich, in ihrer wahren zeitlichen Länge dargestellt. Außerdem werden nun auch Audio-Synchronisations-Pausen in ihrer wahren zeitlichen Länge dargestellt.

Solange der Audio-Player in Aktion ist, wird dies durch farbige Hinterlegung der Leiste der Audio-Funktionen gekennzeichnet. Dabei werden folgende Farben zur Kennzeichnung unterschiedlicher Zustände verwendet:

Abschnitt | Bedeutung
 | Dieser Abschnitt des Audio-Tracks enthält Pausen in der Timeline; da man die Länge dieser Pausen für den Speaker-Support nicht wissen kann, ist dieser Abschnitt des Audio-Tracks nicht in seiner wahren zeitlichen Länge darstellbar.
 | Dieser Abschnitt des Audio-Tracks enthält keine Pausen in der Timeline und wird in seiner wahren zeitlichen Länge dargestellt. Die Vorschau bei Audio-Aufnahmen wird ebenfalls hellblau hinterlegt.
 | Dieser Abschnitt des Audio-Tracks ist ungültig, da die gesamte Länge des Audio-Tracks nicht ausreicht, diesen Abschnitt zu bedienen. Man setzt einfach die den Audio-Player beendende Funktion zeitlich weiter zurück, bis das rote Band verschwindet. Das geht direkt in der grafischen Darstellung der Timeline mit "Rechte Maustaste/Audio-Eigenschaften. Das rote Band hat keine Auswirkungen auf den Ablauf des Audio-Players (der ja sowieso vorher beendet wird), es soll bei der Erstellung einer Dia-Show lediglich signalisieren, dass man etwas plant, was so nicht geht.
 | Der Audio-Player (nicht die Timeline!) befindet sich im Zustand "Pause".

Audio-Kurven veranschaulichen den Lautstärkeverlauf eines Audio-Tracks grafisch.

In der Status-Zeile am oberen Rand des Fensters werden die aktuelle Programm-Nummer, Magazin-Nummer, Dia-Nummer, Licht-Sonderfunktion und der Dia-Kommentar sowie die aktuelle Koordinate der Zeitachse angezeigt. Pausen und Nullzeilen schlagen mit je 5 sec zu Buche.

Im Fenster kann man mit den Tasten PfeilLinks, PfeilRechts, BildAuf, BildAb, Pos 1 und Ende navigieren. Die Dia-Show kann mit Strg-BildAuf gestartet werden. Bei einem Mausklick in das Fenster wird die angeklickte Lichtkurve zur aktuellen Lichtkurve. Wenn eine "einbettende" Lichtkurve eine "eingebettete" Lichtkurve umfasst (beim Einblenden, Blinken, Flashen und Schaukeln), wird bei einem Mausklick zwischen "einbettender" und "eingebetteter" Lichtkurve getoggelt. Klingt komplizierter als es ist, einfach ausprobieren...

Die oben beschriebene Navigation funktioniert nur, wenn gerade kein Programm läuft (Simulation oder Echtzeit). Wenn ein Programm läuft, sind die gleichen Tastenkombinationen wie in der PC-Fernbedienung verwendbar.

Wenn die PC-Fernbedienung nicht geöffnet ist, ist die ToolBar zur Navigation verfügbar. Sie enthält folgende ToolButtons (von oben nach unten):

Aktuelle Lichtkurve durch Rechteck kennzeichnen

Leinwand-Simulation aktivieren / deaktivieren
Leinwand-Simulation: Bild zurück
Leinwand-Simulation: Pause
Audio-Player aktivieren / deaktivieren

Aktuelle Lichtkurve durch Polygon kennzeichnen

Legende für grafische Darstellung der Timeline
Leinwand-Simulation: Bild vor
Leinwand-Simulation: Ende
Audio-Recorder aktivieren / deaktivieren

Wenn der Projektor ausgeschaltet ist und eine Leinwand-Simulation gestartet wird, läuft im Fenster für die grafische Darstellung der Timeline eine senkrechte Linie mit, die sog. Zeitmarke oder der Locator. Diese Zeitmarke repräsentiert die aktuelle Zeit der laufenden Leinwand-Simulation.

Läuft die Dia-Show am realen Projektor ab, wird im Fenster für die grafische Darstellung der Timeline nur der jeweils aktuelle Programmschritt selektiert, ohne dass die Zeitmarke mitläuft, da die Synchronisation zwischen Projektor und Zeitmarke nicht möglich resp. sinnvoll ist.

Es ist möglich, in der grafischen Darstellung der Timeline mit Hilfe des Kontext-Menüs (rechte Maustaste) Audio-Dateien abzuspielen, hinzuzufügen, zu entfernen oder deren Eigenschaften zu ändern. Dafür öffnet sich folgender Dialog:

Das ist aber nur möglich, wenn die virtuelle Projektor-Fernbedienung nicht aktiv ist, d.h. wenn die grafische Darstellung der Timeline über den entsprechenden Menü-Befehl oder das entsprechende Button aufgerufen wurde. Klicken Sie einfach mit der zuerst mit der linken, dann mit der rechten Maustaste in die Überblendkurve, deren Audio-Datei oder -Eigenschaften Sie ändern möchten. Die angeklickte Überblendkurve wird aktiviert und das Kontext-Menü öffnet sich. Audio-Dateien können nur entfernt werden, wenn zu diesem Programmschritt bereits eine Audio-Datei eingetragen ist. Das Ändern der Audio-Eigenschaften und das Abspielen einer Audio-Datei beziehen sich auf den momentanen oder letzten zurückliegenden Programmschritt, bei dem eine Audio-Datei eingetragen ist.

Ein kompletter Audio-Thread von der startenden bis zur beendenden Audio-Funktion kann in die andere Audio-Spur verschoben werden. Diese darf natürlich im betreffenden Bereich nicht schon belegt sein.

Die grafische Darstellung der Timeline ist ein nahezu vollwertiger Ersatz für die virtuelle Fernbedienung. Audio-Dateien können hier eingefügt, entfernt, abgespielt und deren Eigenschaften verändert werden. Die fertige Dia-Show kann inkl. der Audio-Dateien simuliert werden (Leinwand-Simulation). Für die Erstellung einer Dia-Show und deren schnelles Testen ist die grafische Darstellung der Timeline bestens geeignet. Sie bietet für die Leinwand-Simulation fast alle Funktionen, die die virtuelle Fernbedienung auch bietet. Die virtuelle Fernbedienung ist damit in erster Linie für die Präsentation der Dia-Show am Projektor prädestiniert.

Wenn man die grafische Darstellung der Timeline aufgerufen hat und feststellt, dass bei einem oder mehreren Programmschritten Änderungen der Überblendeigenschaften notwendig sind, war das bisherige Vorgehen folgendes: die grafische Darstellung der Timeline verlassen, den Timeline-Check rückgängig machen, die gewünschten Änderungen vornehmen, den Timeline-Check wiederholen, die grafische Darstellung der Timeline aufrufen. Ein ziemlich aufwendiges Procedere.

Es ist auch möglich, die Überblendeigenschaften des momentanen Programmschritts direkt in der grafischen Darstellung der Timeline zu ändern. Dazu navigiert man mit den Pfeiltasten zum gewünschten Programmschritt oder man klickt mit der linken Maustaste in den gewünschten Programmschritt (bei einer eingebetteten Lichtfunktion ggf. mehrmals). Dann ruft man mit der rechten Maustaste das Kontext-Menü "Überblend-Eigenschaften des Programmschritts" auf. Der erscheinende Dialog mit einer grafischen Illustration der einzelnen Werte unterstützt bei den vorzunehmenden Änderungen. Nach einer Änderung der entsprechenden Werte wird die grafische Darstellung der Timeline neu berechnet, was bei langen Timelines ein wenig dauern kann. Deshalb ist diese Art der Änderung der Überblend-Eigenschaften nur für das "Fein-Tuning" einer Dia-Show geeignet. Alle wesentlichen Grundeinstellungen sollte man vor dem eigentlichen Timeline-Check vornehmen.

Die Farben zur grafischen Darstellung der Timeline können frei gewählt und so den persönlichen Vorlieben angepasst werden. Man kann dabei auch eigene Farben definieren. Folgende Farben sind frei wählbar:

  • die Hintergrundfarbe
  • die Farbe der ersten Lichtkurve einer einbettenden Lichtfunktion
  • die Farbe der zweiten Lichtkurve einer einbettenden Lichtfunktion
  • die Farbe der Lichtkurve einer eingebetteten Lichtfunktion (Einblenden, Blinken, Flashen, Schaukeln)

Die Befehle zum Einstellen der Farben findet man im Kontextmenü der Timeline-Darstellung (rechte Maustaste). Mit dem Befehl "Standardfarben" kann man die voreingestellten Farben wiederherstellen.

Positions-Marker: In der grafischen Darstellung der Timeline sind Positions-Marker daran erkennbar, dass die Beschriftung eines Programmschrittes (PN: XXX, MN: XXX, BN: XXX) unterstrichen dargestellt wird.

In der grafischen Darstellung der Timeline werden für jede Audio-Datei deren Länge sowie die Start- und Stop-Position angezeigt. Außerdem kann die Schriftgröße frei gewählt werden. Dazu verwendet man das Kontextmenü der Timeline-Darstellung (rechte Maustaste).

Im Dialog für die Audio-Eigenschaften eines Programmschritts (Kontext-Menü, rechte Maustaste) kann die momentane Audio-Funktion zu einem anderen Programmschritt verschoben werden. Man gibt einfach die Nummer des gewünschten Programmschritts ein und drückt das OK-Button. Die Audio-Funktion kann aber nur bis einen Platz hinter die letzte bzw. einen Platz vor die nächste Audio-Funktion verschoben werden. Außerdem darf das Ziel keine Null-Zeile sein.

  • die Audio-Kurven werden in der Timeline grafisch dargestellt; der besseren Erkennbarkeit sind die Audio-Kurven in der Timeline-Darstellung immer skaliert; die grafische Darstellung der Audio-Kurven ist natürlich nur in den Bereichen sinnvoll und möglich, in denen keine Licht-Pausen vorhanden sind, da Pausen eine Synchronisation zwischen Bild und Ton zunichte machen; in den Bereichen mit Licht-Pausen werden keine Audio-Kurven, sondern farbige Bänder dargestellt
  • der senkrechte rote Strich (im obigen Bild bei bei 20 sec) hat folgende Bedeutung: wenn im Audio-Player "Looping" aktiviert ist, wird ein Audio-Track nach seinem Ende neu gestartet; der rote Strich trennt zwei "Loopings" voneinander; wenn kein "Looping" eingeschaltet ist, wird nach dem Ende des Audio-Tracks zur Warnung ein rotes Band dargestellt
  • Lichtkurven- und Audio-Player-Locator sind nun besser synchronisiert; bisher war es so, dass bei einer Leinwand-Simulation der Locator für die Licht-Kurve dem Locator des Audio-Players mit der Zeit hinterherlief; nun werden beide regelmäßig synchronisiert und zeigen i.d.R. die gleiche Zeit an; man erkennt dies daran, dass der Timeline-Locator von Zeit zu Zeit kleine Sprünge macht, um den Locator des Audio-Players "einzuholen"
Wie man die punktgenaue Synchronisation von Bild und Ton am Anfang einer Dia-Show sicherstellt, wird in den Tips und Tricks beschrieben.
  • die zweite Audio-Spur wird unterhalb der ersten Audio-Spur dargestellt
  • das Kontext-Menü (rechte Maustaste) wurde in drei bzw. vier Bereiche aufgeteilt, die verschiedene Aufgaben erfüllen:
  • wenn man mit der rechten Maustaste knapp unterhalb des oberen Randes des Fenster der grafischen Darstellung der Timeline klickt, wird das Kontext-Menü für die "Allgemeinen Einstellungen" (Farben, Schriftarten) aufgerufen
  • wenn man weiter unten im Bereich der Licht-Kurven klickt, wird das Kontext-Menü für die Überblend-Eigenschaften aufgerufen
  • wenn man noch weiter unten in den Bereich einer der beiden Audio-Spuren klickt, wird das Kontext-Menü für die Audio-Eigenschaften der jeweiligen Audio-Spur aufgerufen

  • ist noch keine Audio-Spur vorhanden, klickt man in den Bereich knapp oberhalb des unteren Fenster-Randes; dann kann man z.B. eine Audio-Datei hinzufügen
  • ist nur eine Audio-Spur vorhanden, klickt man wiederum knapp oberhalb des unteren Fenster-Randes, um eine Audio-Datei zur zweiten Audio-Spur hinzuzufügen
  • die einzelnen Kontext-Menüs haben eine Art Titel-Zeile, so dass man immer weiß, welches Kontext-Menü gerade aktiv ist
  • Wichtiger Hinweis: nicht vergessen, vor dem Aufruf des Kontext-Menüs den gewünschten Programmschritt zu aktivieren (Klick mit der linken Maustaste in die zugehörige Licht-Kurve)

Die Demo-Datei "Audio-Looping und Audio-Überblendung.twc" demonstriert an einem einfachen Fall die Überblendung zwischen zwei Audio-Spuren und das Looping (Neustart eines Audio-Tracks nach seinem Ende).


Wie werden Audio-Synchronisations-Punkte gesetzt?

Dieser Abschnitt beschreibt, was Audio-Synchronisations-Punkte sind und wie sie gesetzt und benutzt werden.

Was sind Audio-Synchronisations-Punkte (kurz: Sync-Punkte)

Beim Start einer Audio-Datei sind die Audio-Datei und der Programmschritt, bei dem sie gestartet wurde, synchronisiert Gelegentlich möchte man später eine Audio-Datei und einen bestimmten Programmschritt erneut synchronisieren, d.h. bei einer bestimmten Position im Audio-Track zu einem bestimmten Dia überblenden oder ein bestimmtes Dia auf- oder einblenden. Für diesen Zweck wurden Sync-Punkte geschaffen. Sync-Punkte sind nichts anderes als bestimmte Zeiten (Positionen) in einer Audio-Datei, zu denen ein Bildwechsel in der Leinwand-Simulation oder im Projektor angestoßen (getriggert) wird. In Audio-Synchronisations-Punkten wird also immer der Bildwechsel durch die Position des Audio-Players angestoßen und nicht umgekehrt.

Bedingungen, denen Sync-Punkte unterliegen

Sync-Punkte unterliegen folgenden Bedingungen bzw. Einschränkungen:

  • Möchte man Sync-Punkte verwenden, muss man CBR-codierte Audio-Dateien verwenden, da ansonsten eine Synchronisierung nicht möglich ist. Näheres s. hier.
  • Ein Sync-Punkt bezieht sich immer auf die letzte zurückliegende Audio-Datei. Der Versuch, einen Sync-Punkt ohne zugehörige Audio-Datei zu setzen, wird abgewiesen.
  • Beim ersten Programmschritt kann kein Sync-Punkt gesetzt werden, da eine dort eingetragene Audio-Datei sowieso mit dem ersten Programmschritt synchronisiert ist.
  • Bei dem Programmschritt, bei dem eine Audio-Datei eingetragen ist, kann kein Sync-Punkt gesetzt werden, da die dort eingetragene Audio-Datei sowieso mit dem Programmschritt synchronisiert ist.
  • Die bei einem Sync-Punkt eingetragene Zeit gilt immer relativ zum Anfang der Audio-Datei, nicht zu deren evtl eingetragener Start-Position.
  • Verwendet man Nicht-Koppelmagazine, so kann auf den ersten Programmschritt nach einer Null-Zeile kein Sync-Punkt gelegt werden. Das ist leicht einzusehen, da bei Nicht-Koppelmagazinen der Start eines neuen Magazins manuell erfolgen muss.
  • Zwischen dem Sync-Punkt und dem Start der zugehörigen Audio-Datei können (rückwärtig) weitere Sync-Punkte liegen. Was nicht dazwischenliegen darf, sind Pausen (manuelle Weiterschaltung) und Licht-Sonderfunktionen "Aus-/Einblenden mit Pause". Auch das ist verständlich, da Pausen nicht vorhersehbare Zeiten beinhalten, die eine Synchronisation unmöglich machen.
  • Der Sync-Punkt darf nicht vor der Start-Position, hinter der Stop-Position oder hinter der Länge eines Audio-Tracks liegen.
  • Mehrere Sync-Punkte hintereinander müssen Zeiten in aufsteigender Reihenfolge beinhalten.
Wie werden Sync-Punkte realisiert?

Sync-Punkte werden folgendermaßen realisiert: Sollen ein Sync-Punkt und Programmschritt n miteinander synchronisiert werden, trägt TwinLightControl bei Programmschritt n-1 eine Standzeit 0 ein. Es wird keine Pause eingetragen, das unterscheidet sog. Sync-Pausen von normalen Pausen. Programmschritt n-1 wartet also solange, bis die Audio-Datei die im Sync-Punkt eingetragene Zeit erreicht hat und startet dann automatisch Programmschritt n.

Sync-Punkte müssen so gesetzt werden, dass eine Synchronisation auch möglich ist. Dafür ist der Anwender verantwortlich. Es ist also ein wenig Rechnen und Probieren angesagt, um die Überblend- und Standzeiten zwischen Start einer Audio-Datei und nachfolgendem Snchronisations-Punkt zu ermitteln. Garantiert ist dann aber, dass die Synchronisierung funktioniert.

Beispiel: Eine Audio-Datei wird bei Programmschritt 10 gestartet, bei Programmschritt 20 soll auf einen bestimmten Takt eines Musikstückes hin ein bestimmtes Dia aufgeblendet werden. Zwischen den beiden Programmschritten dürfen keine Pausen liegen. Die (timer-gesteuert ablaufende) Projektion der Dias zwischen Programmschritt 10 und 19, bei dem eine Sync-Pause eingetragen ist, dauert 45 sec. Beim Sync-Punkt ist eine Zeit von 33 sec (ein bestimmter Takt der Musik) eingetragen. In einem solchen Falle funktioniert die Synchronisierung nicht, da der gewünschte Musiktakt schon lange vorbei ist, wenn das gewünschte Dia erreicht wird. Die Projektion wird dann einfach fortgesetzt, aber die Synchronisierung ist natürlich dahin. Um eine Synchronisierung zu ermöglichen, müsste man also die Überblend- und Standzeiten der Dias reduzieren. Programmschritt 19, welcher auf die Audio-Datei wartet, müsste also spätestens nach 28 sec erreicht werden, damit auch das zu Programmschritt 19 gehörende Dia eine Chance hat, hinreichend lang projiziert zu werden, bevor die Synchronisation greift. Man muss auch die Dia-Wechselzeiten (4,0 ... 5,5 sec) beachten. Wenn der Projektor viel hin- und herfahren muss (z.B. Diafolge 1, 50, 2, 49, 3, 48, ...), was man sowieso nach Möglichkeit vermeiden sollte, kann die Dia-Wechselzeit durchaus auf 6,0 ... 7,5 sec steigen. Man sollte also beim Setzen von Audio-Sync-Punkten eine ausreichend große Wartezeit für den Projektor einplanen. Hier ist also, wie schon gesagt, ein wenig Probieren angesagt.

Wie werden Sync-Punkte gesetzt?

Sync-Punkte können händisch in der Timeline gesetzt werden. Besser ist es allerdings, dies in der grafischen Darstellung der Timeline zu tun. Das hat im wesentlichen zwei Gründe. Zum ersten hat man eine bessere audiovisuelle Kontrolle, da man die Lichtkurven sieht und den Sync-Punkt nach Gehör setzen kann. Zum zweiten beeinflussen Null-Zeilen die Bedingungen für das Setzen von Sync-Punkte (s.o.), und dies setzt einen bereits vollzogenen Timeline-Check voraus. Dies ist aber der Fall, wenn man die grafische Darstellung der Timeline geöffnet hat.

Zum Setzen von Sync-Punkten in der Timeline-Darstellung geht man folgendermaßen vor:
  • Man führt den Timeline-Check durch und öffnet dann die grafische Darstellung der Timeline (Button [image] ). Es funktioniert nur in der Stand-Alone-Version der grafischen Darstellung der Timeline (die virtuelle Fernbedienung ist nicht geöffnet). Die Timeline darf keine Warnungen mehr haben, andernfalls kann man keine Sync-Punkte setzen. Außerdem darf keine Leinwand-Simulation laufen.
  • Man klickt in der grafischen Darstellung der Timeline den Programmschritt an, für den man eine Synchronisation durchführen möchte.
  • Mit der rechten Maustaste öffnet man den Audio-Player (Audio-Datei zum Programmschritt abspielen), es wird die letzte zurückliegende Audio-Datei geladen.
  • Mit der Play-Taste startet man die Audio-Datei und setzt dann nach Gehör den Sync-Punkt, indem man das Button "Synchr.-Punkt" drückt. Der Audio-Player wird kurz angehalten, der Sync-Punkt in die Timeline eingetragen und der Audio-Player danach fortgesetzt. So kann man bei Bedarf mehrere Sync-Punkte nacheinander setzen (für verschiedene Programmschritte natürlich).
  • Wenn die o.g. Bedingungen für das Setzen der Sync-Punkte eingehalten wurden, erscheint in der grafischen Darstellung der Timeline, unmittelbar über der Leiste mit den Audio-Funktionen, ein Symbol [image] , [image] , [image] in der Farbe der zugehörigen Lichtkurve. Rechts neben dem Symbol steht die bei dem Sync-Punkt eingetragene Zeit, in Klammern die Zeitdifferenz zwischen der Zeit für den Ablauf der Audio-Datei und der Zeit für den Ablauf der Überblendungen. M.a.W. ist das die Zeit, die das Dia vor dem Sync-Punkt auf den Audio-Player warten muss. Wenn diese Zeit größer als die erforderliche Dia-Wechsel-Zeit (je nach Projektormodell 4,0 ... 6,0 sec bzw. 5,5 ... 7,5 sec) ist, ist alles in Ordnung. Dann kann der Projektor auf den Audio-Player warten, bis der richtige Synchronisationszeitpunkt erreicht wird. Ist die Zeit kleiner als die erforderliche Dia-Wechsel-Zeit (mit der Kennzeichnung "Fehler!!!" versehen), ist der Audio-Player bereits am Synchronisationszeitpunkt für das zu synchronisierende Dia "vorbei", und eine Synchronisation ist nicht mehr möglich. Dann ist die Sync-Pause unwirksam, es geht einfach ohne Pause weiter. In einem solchen Falle muss man die Überblend-/Standzeiten der Dias vor dem Sync-Punkt solange verkürzen, bis eine gültige Zeitdifferenz herauskommt.
  • Wenn der Synchronisationszeitpunkt für den Sync-Punkt bereits verstrichen ist, bevor der Projektor dort ankommt, dann geht es, wie oben schon erwähnt, einfach ohne Pause weiter. Es kann aber trotzdem dazu führen, dass der Projektor später "aus dem Takt" kommt, vor allem dann, wenn mehrere Sync-Punkte hintereinander gesetzt werden. Der Projektor erhält nämlich an jedem Sync-Punkt einen Vorwärts-Befehl, denn er im Moment noch gar nicht verarbeiten kann. Das Verhalten des Projektors kann dann unvorhersehbar werden. Man sollte also immer darauf achten, dass alle Sync-Punkte fehlerfrei gesetzt sind.
  • Bei dem dem Sync-Punkt vorangehenden Programmschritt (der Programmschritt, der auf die Audio-Datei "wartet") wird eine Sync-Pause eingetragen. Das Symbol sieht aus wie eine auf dem Kopf stehende normale Pause ( [image] , [image] , [image] ).
  • Wenn man einen oder mehrere Sync-Punkte eingetragen hat, sollte man den Timeline-Check wiederholen. Dann werden nämlich die Sync-Punkte nochmals auf ihre Korrektheit hin überprüft.

Die Demo-Dia-Show "Musikvorspann mit Audio-Sync-Punkt.twc" zeigt, wie man einen Sync-Punkt benutzen kann, um einen Vorspann zu erzeugen. Das erste Dia ist wieder ein Schwarz-Dia, das erste richtige Dia wird nach der im Sync-Punkt angegebenen Zeit eingeblendet. Die Audio-Datei wurde wieder entfernt, um die TwinLightControl-Installationsdatei nicht zu groß werden zu lassen.

Wie werden Sync-Punkte entfernt?

Es gibt zwei Möglichkeiten, Sync-Punkte zu entfernen.

Sync-Punkte können händisch in der Timeline entfernt werden. Dazu gibt man im Feld für den Sync-Punkt für alle Ziffern in der erscheinenden Maske jeweils eine 0 an (insgesamt sechs Nullen). Nach der Eingabe jeder Ziffer wird der Cursor in der Maske weiterbewegt. Nach dem Drücken der RETURN-Taste wird der Inhalt des Feldes gelöscht und damit der Sync-Punkt entfernt.

Sync-Punkte können auch in der grafischen Darstellung der Timeline entfernt werden. Man klickt mit der rechten Maustaste in den Programmschritt, bei dem der Sync-Punkt entfernt werden soll und wählt im Kontext-Menü "Audio-Synchronisations-Punkt entfernen".

Beim Setzen des jetzt entfernten Sync-Punktes wurde die Standzeit des vorhergehenden Dias auf 0 gesetzt (s.o.). Diese Standzeit wird beim Entfernen des Sync-Punktes auf einen sinnvollen Wert gesetzt, kann aber ggf. noch geändert werden. Dies muss händisch erledigt werden.

Wie man die punktgenaue Synchronisation von Bild und Ton am Anfang einer Dia-Show sicherstellt, wird in den Tips und Tricks beschrieben.


Wie wird zu einem bestimmten Datensatz gesprungen?

Mit Hilfe des Tool-Buttons [image] kann man zu einem bestimmten Datensatz springen. Dafür gibt es verschiedene Möglichkeiten:

  • Magazin-Editor: Magazin- oder Archiv-Nummer angeben
  • Dia-Editor: Magazin- und Dia-Fach-Nummer angeben
  • Timeline-Editor: Programm-Nummer oder Magazin- und Dia-Fach-Nummer oder Dia-Nummer absolut angeben


Wie wird nach bestimmten Datensätzen gesucht?

Mit Hilfe des Tool-Buttons [image] kann man nach Datensätzen suchen, die einen bestimmten Text im Kommentar-Feld des Magazin-, Dia- oder Timeline-Editors enthalten. Dabei kann zwischen Groß- und Kleinschreibung unterschieden werden. Auf Wunsch können auch alle Datensätze angezeigt werden.

Für die gefundenen Datensätze werden angezeigt:

  • die Magazin-Nummer
  • die Magazin-Nummer Archiv
  • die Dia-Fach-Nummer
  • die Nummer des Programmschritts
  • der Kommentar

Das Button "Gehe zum aktuellen Datensatz" bewirkt einen Sprung zum aktuellen Datensatz. Dabei kann der Such-Dialog wahlweise geöffnet bleiben oder geschlossen werden.


Wie wird eine Dia-Show skaliert?

Wenn man die Gesamt-Dauer einer Dia-Show verkürzt oder verlängert, indem man die Überblend- und Stand-Zeiten entsprechend verändert, nennt man das Skalierung.

In TwinLightControl ist dies möglich, indem man das Button [image] drückt oder den entsprechenden Menü-Eintrag wählt. Es ist zu beachten, dass der Timeline-Check erfolgreich durchgeführt worden sein muss, bevor man die Show skalieren kann.

Bei der Skalierung erscheint ein Dialog, welcher die momentane Dauer der Show anzeigt und die gewünschte Dauer als Eingabe erwartet. Voreinstellungsgemäß wird hier die momentane Dauer der Show eingetragen. Außerdem erwartet TwinLightControl Angaben darüber, welche der Überblend- und Stand-Zeiten skaliert werden sollen. Es ist zu beachten, dass Programmschritte, bei denen "Cut" oder "Pause" selektiert ist, nicht skaliert werden.

Ist die gewünschte Dauer der Dia-Show zu kurz oder zu lang, werden die Überblend- bzw. Stand-Zeiten auf ihre zulässigen Werte beschränkt, die Skalierung durchgeführt und eine Fehlermeldung ausgegeben.


Wie wird ein Bericht zur Dia-Show erzeugt?

Man kann zu jeder Dia-Show einen Bericht erzeugen, der nach Bedarf auch ausgedruckt werden kann. Der Bericht kann wahlweise folgende Punkte beinhalten:

  • Die Beschreibung der Dia-Show
  • Eine Zusammenstellung aller Magazine
  • Eine Zusammenstellung aller Dias
  • Eine detaillierte Zusammenstellung aller Programmschritte in der Timeline
  • Eine Zusammenstellung aller Magazin- und Dia-Nummern in der Timeline
  • Eine Zusammenstellung der Start-Dias aller Magazine; dies ist hilfreich, wenn man die Dia-Show aus dem Modul heraus präsentiert und einen Neu-Start durchführen muss
  • Eine kurze Zusammenfassung der Dia-Show (Zahl der Magazine, Dias, Programmschritte usw.)

Den Bericht erzeugt man mit Hilfe des Menüs Dia-Show/Bericht zur Dia-Show oder mit dem Tastenkürzel Strg + R oder mit dem Button Bericht [image] .


Wie wird die Dia-Reihenfolge grafisch dargestellt?

Projiziert man alle Dias eines Magazins in ihrer "natürlichen" Reihenfolge (eins nach dem anderen), beträgt die Differenz der Dia-Nummern zweier aufeinanderfolgender Programmschritte stets 1. Normiert man dies auf den Wert 0 und stellt die Abweichung von der "natürlichen" Dia-Reihenfolge als Funktion der Programm-Nummer dar, erhält man für ein solches Magazin mit "natürlicher" Dia-Reihenfolge eine Null-Linie.

Je größer die Abweichungen von der Null-Linie sind, desto mehr ist der Projektor beim Ablauf der Dia-Show mit Hin- und Herfahren des Magazins beschäftigt. Große Abweichungen von der Null-Linie sollte man vermeiden und die Dias lieber umsortieren.

Mit dem Button "Dia-Reihenfolge" [image] kann man die Dia-Reihenfolge grafisch darstellen. Man kann in die Darstellung hineinzoomen, indem man mit der linken Maustaste von links oben nach rechts unten ein Rechteck aufzieht. Dabei werden zur besseren Orientierung die Programmschritt-Nummern angezeigt. Mit der rechten Maustaste kann man den Bildinhalt verschieben. Den Grundzustand stellt man wieder her, indem man mit der linken Maustaste von rechts unten nach links oben ein Rechteck aufzieht.


Wie wird der Projektor aktiviert?

Nachdem man eine Dia-Show fertiggestellt hat, kann man sie zum Projektor übertragen. Dazu muss dieser zunächst aktiviert werden.

Man aktiviert den Projektor mit dem Menü "Projektorsteuerung/Projektor aktivieren" oder dem entsprechenden Tool-Button [image] .

Der Projektor wird an einer der seriellen Schnittstellen COM1 ... COM16 gesucht. COM-Ports mit hohen Nummern treten vorwiegend bei neueren Desktop-Computern oder Notebooks auf, die keine serielle Schnittstelle mehr haben und wo diese über einen USB-Seriell-Adapter bereitgestellt wird.

Wurde der Projektor an einer der seriellen Schnittstellen gefunden, wird diese in den Voreinstellungen vermerkt. Bei der nächsten Aktivierung des Projektors werden nicht wieder alle Schnittstellen abgesucht. Es wird überprüft, ob die vorher gefundene Schnittstelle noch gültig ist, und nur wenn dies nicht der Fall ist, werden die anderen Schnittstellen abgesucht.

U.U. kann es notwendig sein, den seriellen Port noch manuell zu konfigurieren. Wie man dies macht, findet man hier.

Wurde der Projektor erfolgreich aktiviert, erkennt man dies an dem gedrückten Tool-Button. Man kann den Projektor auch wieder deaktivieren, indem man das Tool-Button erneut drückt. Dies kann z.B. sinnvoll sein, wenn man nach dem Test einer Dia-Show am Projektor wieder eine Leinwand-Simulation durchführen will.

Ist der Projektor nicht an den PC angeschlossen oder nicht eingeschaltet oder ist die Verbindung anderweitig gestört, wird eine Fehlermeldung ausgegeben. Manchmal hilft auch einfach Aus- und Wiedereinschalten des Projektors.

Bei einem Start der virtuellen Fernbedienung wird eine Leinwand-Simulation durchgeführt, falls der Projektor nicht aktiviert ist. Andernfalls wird die Dia-Show zum realen Projektor übertragen und auf diesem gestartet.


Wie wird die Firmware-Version abgefragt?

Jeder Projektor trägt eine bestimmte Firmware-Version (aktuell: V 8.9). Diese kann man mit dem Menü "Projektorsteuerung/Firmware-Version" oder dem zugehörigen Tool-Button [image] abfragen. Der Menüpunkt ist nur erreichbar, wenn zuvor der Projektor erfolgreich aktiviert wurde.


Wie wird die virtuelle Fernbedienung benutzt und eine Dia-Show übertragen und gestartet?

Die Fernbedienung des Projektors erfüllt im wesentlichen zwei Aufgaben:

  • die auf der realen Fernbedienung vorhandenen Funktionen nachzubilden
  • eine Dia-Show vom PC aus fernzusteuern

Welche der Möglichkeiten genutzt werden kann, hängt davon ab, ob sich in der Timeline eine (geprüfte) Dia-Show befindet und/oder der Projektor aktiviert ist.

Folgende Möglichkeiten sind denkbar:

Modus | Bedeutung
Manueller Modus | Der Projektor ist aktiviert, es ist keine Datei geöffnet: mit Hilfe der virtuellen Fernbedienung kann man den Projektor steuern wie mit der realen Fernbedienung
Live-Modus | der Projektor ist aktiviert, es befindet sich keine oder keine geprüfte Dia-Show in der Timeline: im sog. Live-Modus kann man Dias während eines Magazindurchlaufs "On the fly" in die Timeline übernehmen
Simulations-Modus | der Projektor ist nicht aktiviert, es befindet sich eine (geprüfte) Dia-Show in der Timeline: mit Hilfe der virtuellen Fernbedienung kann eine Simulation der Dia-Show gesteuert werden; auf Wunsch kann dies eine Leinwand-Simulation sein
Programm-Modus | der Projektor ist aktiviert, es befindet sich eine geprüfte Dia-Show in der Timeline: mit Hilfe der virtuellen Fernbedienung kann die Dia-Show vom Projektor aus gesteuert werden wie mit der realen Fernbedienung

Der momentan aktive Modus wird in der Titelzeile des Fensters der virtuellen Fernbedienung angezeigt.

Der erste Punkt erklärt sich von selbst und bedarf keiner näheren Erläuterung. Die Bedeutung der Tasten auf der Fernbedienung des Projektors kann man in der Bedienungsanleitung zum Projektor nachlesen.

Wie geht man vor, wenn man eine Dia-Show vom PC aus simulieren oder steuern will?

Zunächst muss die in der Timeline befindliche Dia-Show den Timeline-Check erfolgreich absolviert haben. Die Fernbedienung wird aktiviert, indem man das Menü Projektorsteuerung/Fernbedienung/Dia-Show auswählt oder das entsprechende Tool-Button [image] drückt.

Wenn der Projektor vorher noch nicht aktiviert wurde, ist die Fernbedienung trotzdem verwendbar, allerdings werden alle Funktionen nur simuliert. Dies ist eine gute Methode, eine Dia-Show zu testen, ohne dass jedesmal der Projektor eingeschaltet werden muss.

Als nächstes muss man die Dia-Show von der Timeline zum Projektor übertragen. Dies geschieht mit dem betreffenden Button [image] im linken oberen Teil des Dialogs. Sobald die Dia-Show zum Projektor übertragen und die grafische Darstellung der Timeline erzeugt wurde, was je nach Größe der Dia-Show und PC-Konfiguration einige Minuten in Anspruch nehmen kann (Sanduhr!), werden die Buttons für die Fernsteuerung aktiviert.

Mit dem Button Vorwärts (grüne Taste) auf der Fernbedienung oder der Taste "Bild auf" kann die Dia-Show gestartet werden. Man hat dabei die Wahl, bei einer bestimmten Programm-Nummer, einer bestimmten Magazin-Nummer (erstes Dia in diesem Magazin), einer bestimmten Magazin- und Dia-Nummer oder einer bestimmten Dia-Nummer (absolut) oder zu starten. Sinnvolle Werte werden voreingestellt, unzulässige Werte werden abgewiesen. Versucht man bei einer Programm-Nummer zu starten, bei der eine Licht-Sonderfunktion "Einblenden", "Blinken", "Flashen" oder "Schaukeln" eingetragen ist, macht TwinLightControl folgendes: da der Start bei einem solchen Dia (eingebettete Lichtfunktion) nicht sinnvoll ist (in welches Dia sollte man auch einblenden?), sucht TwinLightControl das Dia (einbettende Lichtfunktion), in welches eingeblendet wird und startet das Programm dort. Bei Verwendung von Koppelmagazinen kann dieses Start-Dia durchaus auch im vorhergehenden Magazin liegen. Der Projektor würde zwar bei einer solchen "eingebetteten Lichtfunktion starten, aber er führt sie nicht korrekt aus.

Der Start mit einer Dia- oder Magazin-Nummer ist dann sinnvoll, wenn die Dia-Show aus irgendeinem Grund unterbrochen wurde (z.B. durch ein verklemmtes Dia). Man kann eine Dia-Show zu jedem beliebigen Zeitpunkt neu starten, man muss nur daran denken, das richtige Magazin anzusetzen. Auf eine Besonderheit bei der Behandlung des zweiten Magazins bei Verwendung von Koppelmagazinen wird man von TwinLightControl hingewiesen.

Für den Start der Dia-Show und das Weiterschalten kann sowohl die PC-Fernbedienung als auch die reale Fernbedienung des Projektors verwendet werden. Soll die Dia-Show aber nicht am Anfang, sondern an einer beliebigen Stelle gestartet werden, geht man folgendermaßen vor:

  • Möglichkeit 1: man gibt im Feld für die Start-Programm-, Start-Dia- oder Start-Magazin-Nummer den gewünschten Wert ein und startet die Dia-Show mit der PC-Fernbedienung; unzulässige Start-Werte werden abgewiesen
  • Möglichkeit 2: man gibt am Bedienfeld des Projektors die gewünschte Start-Bild-Nummer (in der Timeline von TwinLightControl die Zahl, die im Feld 'Dia-Nummer' steht) und startet die Dia-Show mit der realen Fernbedienung; handelt es sich um einen ungültigen Start-Wert, wird im Display des Projektor-Bedienfeldes eine '0' angezeigt und der Projektor tut nichts (s.u.); warum man am Projektor die Dia-Nummer und nicht die Programm-Nummer eingeben muss (was viel sinnvoller wäre), bleibt ein Geheimnis von Rollei; es gibt leider auch keine Möglichkeit, dem Projektor per Software einen Start-Wert mitzuteilen und dann mit der realen Fernbedienung zu starten

Wichtiger Hinweis!
Präsentiert man die Dia-Show mittels PC, ist dringend zu empfehlen, die Dia-Show immer mit der virtuellen Fernbedienung zu starten, auch wenn man mit Programm-Nummer 1 startet. Danach kann die Projektor-Fernbedienung verwendet werden. Aus uns nicht bekannten Gründen reagiert der Projektor manchmal nicht auf die Projektor-Fernbedienung.

Vor einer Live-Dia-Show hat sich folgendes Vorgehen bewährt: man lädt die Dia-Show in den Projektor und startet sie versuchsweise. Wenn die Projektor-Fernbedienung schon in diesem Stadium nicht reagiert, sollte man den Projektor ausschalten (!) und die Show nochmals laden. Dann hat man gute Chancen, dass bis zum Ende der Show alles normal läuft. Sollte der Projektor trotzdem irgendwann nicht mehr auf seine Ferbedienung reagieren, hat man zwei Möglichkeiten: entweder man bedient den Projektor über die PC-Fernbedienung, oder man nutzt die Funktionalität des Neu-Start-Buttons (s.u.).

Eine Eigenheit des Projektors soll an dieser Stelle erwähnt werden. Steuert man die Dia-Show nicht mit dem PC, sondern lässt sie automatisch über das im Modul gespeicherte Programm ablaufen, muss man im Falle eines Fehlers (z.B. ein verklemmtes Dia) die Show neu starten. Man kann dies an jeder beliebigen Stelle tun, muss aber die richtige Dia-Nummer eingeben. Gibt man eine Dia-Nummer ein, die in der Show gar nicht vorhanden ist, dann macht der Projektor nichts. Das ist kein Fehler, man muss es nur wissen, um es nicht für einen solchen zu halten und erfolglos danach zu suchen. Man sollte für die Fälle, wo man die Dia-Show aus dem Modul heraus vorführt, stets einen Ausdruck der gesamten Show oder zumindest der Start-Dias eines jeden Magazins mit sich führen. Einen Ausdruck der Dia-Show in Papierform kann man mit Hilfe eines Berichts erzeugen.

Das Button "Neustart" [image] ist eine u.U. sehr hifreiche Angelegenheit. Während eine Dia-Show läuft, wird der jeweils zuletzt erfolgreich absolvierte Programmschritt und die Position des Audio-Players mitprotokolliert und in der Registry gesichert. Muss die Dia-Show aufgrund eines Fehlers neu gestartet werden, so drückt man einfach das Button "Neu-Start". Dann wird automatisch an der zuletzt gesicherten Position gestartet. Auch die zuletzte gespielte Audio-Datei wird an der Stelle wieder aufgenommen, an der sie abgebrochen wurde. Das gilt auch, wenn TwinLightControl sich "aufgehängt" haben sollte und selbst neu gestartet werden muss.

Mit der Vorwärts-Taste (grüne Taste) oder der Taste "Bild auf" geht man zum nächsten Programmschritt, mit der Rückwärts-Taste (rote Taste) oder der Taste "Bild ab" zum vorhergehenden (rückwärts ist jeweils nur ein Schritt möglich). Ist beim momentanen Programmschritt eine "Pause" eingetragen, dann blinkt die Vorwärts-Taste, um den Anwender darauf hinzuweisen, dass er diese drücken muss, um die Dia-Show fortzusetzen.

Verwendet man keine Koppelmagazine, muss am Ende eines jeden Magazins die Vorwärts-Taste gedrückt werden. Jedes Magazins muss also für sich gestartet werden, es wird aber automatisch die jeweils richtige Programm-Nummer im entsprechenden Feld eingetragen. Dies gilt aber nur, wenn man die PC-Fernbedienung verwendet. Will man die reale Fernbedienung benutzen, muss man vorher am Anfang jedes Magazins am Projektor-Bedienfeld den richtigen Start-Wert eingeben (s.o.).

Mit dem Stop/Go-Button oder der Taste "Pause" kann die Dia-Show unterbrochen und weitergeführt werden.

Mit dem Ende-Button oder der Taste "Ende" wird eine Dia-Show beendet.

Die Optionen sind in einen scrollbaren Bereich eingebettet.

Mit dem Optionsfeld "Bei Magazinwechsel anzeigen: Dialog" kann man festlegen, ob ein animiertes Dialogfenster angezeigt wird, das zu gegebener Zeit an die Notwendigkeit des Abkoppelns des alten bzw. des Ankoppelns des neuen Magazins (bei Verwendung von Koppelmagazinen) oder an den Wechsel des Magazins (bei Verwendung von Nicht-Koppelmagazinen) erinnert. Außerdem wird in der Timeline-Info am unteren Bildschirmrand ein entsprechender Hinweis eingeblendet. Das Ankoppeln des neuen Magazins sollte spätestens beim 45.Dia des aktuellen Magazins erfolgen, das Abkoppeln des alten Magazins kann ab dem 6.Dia, sollte aber spätestens beim 12.Dia des aktuellen Magazins erfolgen. Das animierte Dialogfenster kann manuell geschlossen werden, schließt aber nach einer gewissen Zeit selbstständig.

Das Optionsfeld "Bei Magazinwechsel anzeigen: Hinweis" entscheidet darüber, ob bei fälligem Magazinwechsel ein Hinweisdialog angezeigt werden soll, der manuell bestätigt werden muss. Wenn man die Dia-Show komplett über die virtuelle Fernbedienung steuert, kann man diese Option anwählen. Verwendet man die reale Fernbedienung des Projektors, ist es besser, die Option abzuwählen, da man den aufscheinenden Dialog immer bestätigen und während der Dia-Show ggf. zum Computer laufen muss (was andererseits bei einem Magazinwechsel sowieso erforderlich ist).

Mit dem Optionsfeld Leinwand-Simulation anzeigen entscheidet man, ob man eine Leinwand-Simulation anzeigen will oder nicht. Alle Zwischenbilder der Leinwand-Simulation werden bei der Überblendung im Hintergrund berechnet und dann angezeigt. Dies erfordert einiges an Rechenleistung, so dass ältere Rechnern hiermit u.U. überfordert sind. Ist die Leinwand-Simulation zu langsam, was man an der in der Status-Zeile der grafischen Timeline-Darstellung mitlaufenden Zeit erkennt, sollte man die Leinwand-Simulation abschalten. Generell ist das Timing einer Überblendung von der Leistungsfähigkeit des Rechners abhängig.

Generell ist zu bemerken, dass man einen einigermaßen leistungsfähigen Rechner benötigt, wenn man die Dia-Show am PC simulieren oder am Projektor vom PC aus steuern will. Allgemeinverbindliche Angaben lassen sich nicht machen, da die Leistungsfähigkeit eines Rechners von vielen Faktoren abhängt (CPU, Mainboard, Speicherausbau, ...). Man sollte es einfach ausprobieren. Funktioniert es nicht, hat man nur die Möglichkeit, die Dia-Show in den Modul zu übertragen und automatisch ablaufen zu lassen.

Ist das Optionsfeld Dias bei der Leinwand-Simulation mit Text versehen gewählt, erhält jedes Dia eine kleine Textmarke zur Kennzeichnung.

Im Feld Zahl der Zwischenbilder beim Überblenden gibt man die Zahl der Zwischenbilder pro Sekunde an, die beim Überblenden verwendet werden sollen. Eine größere Zahl erzeugt einen weicheren Übergang, erfordert aber mehr Rechenleistung. Zulässig sind Werte zwischen 10 und 50, 25 ist ein guter Kompromiss. Je nach Zahl der Zwischenbilder wird die grafische Darstellung der Timeline mehr oder weniger gestreckt.

Das Optionsfeld Grafische Darstellung der Timeline anzeigen entscheidet darüber, ob während einer laufenden Dia-Show die grafische Darstellung der Timeline angezeigt wird oder nicht. Näheres hierzu unter Grafische Darstellung der Timeline anzeigen.

Das Optionsfeld Timeline-Info anzeigen hat drei mögliche Zustände: "Ohne Häkchen", "Mit Häkchen, grau hinterlegt", "Mit Häkchen, weiß hinterlegt". Im Zustand "Mit Häkchen, grau hinterlegt" werden am unteren Bildschirmrand die wichtigsten Informationen zum momentanen Programmschritt einer gerade laufenden Dia-Show angezeigt. Im einzelnen sind dies: die Programm-Nummer, die Magazin-Nummer, die Dia-Fach-Nummer und der Dia-Kommentar. Im Zustand "Mit Häkchen, weiß hinterlegt" werden diese Informationen zusätzlich für den nachfolgenden Programmschritt angezeigt. Die Schriftgröße kann individuell so eingestellt werden, dass man sie auch aus größerer Entfernung deutlich lesen kann, was für Live-Vorträge von Nutzen sein kann. Wenn bei Rollei-Koppelmagazinen ein Magazin-Wechsel ansteht, wird dies im Timeline-Info angezeigt, zusätzlich wird der gesamte Text in roter Schrift dargestellt. Ist der nächste Programmschritt durch manuelles Weiterschalten ("Pause") erreichbar, blinkt das Timeline-Info. Mit dem Optionsfeld "Fließend" kann man ein pixelweises (weiches) oder ein buchstabenweiches Scrollen der Lauftexte bei längeren Textzeilen einstellen. Weiches Scrollen erfordert allerdings einen leistungsfähigen Rechner, da die Anzeige des Lauftextes oft aktualisiert werden muss. Hier kommt es auf einen Versuch an. Wenn der Lauftext stark ruckelt, sollte man die Option ausschalten, vor allem dann, wenn der Projektor eingeschaltet ist.

Ist das Optionsfeld Hauptformular verbergen selektiert, wird das Hauptformular von TwinLightControl beim Anzeigen der Fernbedienung als Symbol dargestellt, was u.U. die Übersichtlichkeit erhöht.

Mit Hilfe des Optionsfeldes Blinken entscheidet man darüber, ob das Blinken bei einer Pause (manuelle Weiterschaltung) in der Fernbedienung bzw. im Timeline-Info angezeigt wird oder nicht.

Wenn eine Live-Dia-Show über den PC gesteuert wird, möchte man den Fortgang der Show nach Möglichkeit ständig im Auge behalten. Dann ist es lästig, wenn ein Bildschirmschoner nach der eingestellten Zeit aktiviert wird. Deshalb kann man in der virtuellen Fernbedienung mit Hilfe des Optionsfeldes "Bildschirmschoner abschalten" entscheiden, ob der Bildschirmschoner für die Zeit der Dia-Show, d.h. solange die virtuelle Fernbedienung geöffnet ist, abgeschaltet werden soll. Das Ganze funktioniert nur bei aktiviertem Projektor. Gleichzeitig mit dem Abschalten des Bildschirmschoners wird die Grundhelligkeit des Displays (i.d.R. wird es sich um das LCD-Display eines Notebooks handeln) reduziert, um einerseits das Display zu schonen und andererseits eine die Dia-Show u.U. störende Resthelligkeit auszuschalten. Leider wird dieses Feature nicht von allen Grafikkarten unterstützt. Wenn dem so ist, wird man darauf hingewiesen, die Helligkeit des Displays manuell zu reduzieren.

Mit dem Optionsfeld "Audio-Track erst nach Dia-Einzug starten" kann eine der beiden folgenden Möglichkeiten gewählt werden: 1. (Neu) Wenn beim ersten Programmschritt einer Dia-Show eine Audio-Datei eingetragen ist, wird diese erst dann gestartet, wenn der Projektor die beiden ersten Dias eingezogen hat und das erste Dia aufblendet. Damit ist eine bessere Synchronisation von Bild und Ton am Anfang einer Dia-Show möglich. 2. (Wie bisher) Der Audio-Track wird sofort gestartet, während der Projektor noch mit dem Einziehen der beiden ersten Dias beschäftigt ist .

Die Option "Taste 'end' deaktivieren" hat folgende Bedeutung: Normalerweise kann eine laufende (reale) Dia-Show entweder mit der Taste "end" auf der realen Projektor-Fernbedienung oder mit der entsprechenden Taste auf der virtuellen Fernbedienung resp. der Taste "Ende" auf der Computertastatur beendet werden. Bei bestimmten Projektor-Computer-Konfigurationen kommt es gelegentlich zu einem unerwarteten Ende der Dia-Show. Es handelt sich dabei offenbar um ein noch nicht befriedigend gelöstes Timing-Problem: der Projektor meldet gelegentlich die Programm-Nummer 0, die das Ende einer Dia-Show signalisiert. Sollte dieses Problem auftreten, ist es ratsam, das Häkchen bei "Taste 'end' deaktivieren" zu setzen. Dann dürfte das Problem nicht mehr auftreten, allerdings kann nun die Dia-Show nicht mehr mit der realen Projektor-Fernbedienung beendet werden, sondern nur noch per Computer. (Genaugenommen beendet der Projektor zwar die Dia-Show, TLC bekommt davon aber nichts mit und läuft weiter.) Die vorzeitige Beendigung einer Dia-Show ist aber ein eher seltener Fall, so dass sich diese Einschränkung sicher verschmerzen lässt.

Die Option "Allgemeine Dialoge anzeigen" entscheidet darüber, ob Dialoge wie "Keine Verbindung zum Projektor, Dia-Show wird nur simuliert", "Greifernase am Projektor umstellen" und "Ende der Dia-Show" angezeigt werden oder nicht.

Die Option "Position der Dialoge merken" hat folgende Bedeutung: wenn eine Dia-Show gestartet wird, wird der Dialog der virtuellen Fernbedienung auf die eigentliche Fernbedienung verkleinert, und die Dialoge des Audio-Players, der Leinwand-Simulation, der grafischen Darstellung der Timeline usw. werden automatisch so angeordnet, dass man alle wichtigen Informationen im Blick hat. Wenn man die Dialoge nach eigenem Belieben anordnen möchte, dann aktiviert man die Option "Position der Dialoge merken", startet die Dia-Show mit der grünen Vorwärts-Taste und ordnet die Dialoge so an, wie man es möchte. TwinLightControl merkt sich diese Anordnung und stellt sie beim nächsten Start einer Dia-Show wieder her. Dies gilt auch nach dem Beenden und dem Neustart des Programms..

Im Menü "Tools" gibt es einen Menü-Punkt "Display-Helligkeit setzen". Sollte TwinLightControl während einer Live-Dia-Show abstürzen, kann man die ggf. reduzierte Bildschirm-Helligkeit wieder auf den Normalwert zurücksetzen. Mit dem Schieberegler kann man jede Helligkeit von 0 bis 255 einstellen, der Normalwert ist 128. Mit dem Button "Normale Helligkeit setzen" wird ein Helligkeitswert von 128 eingestellt. Mit dem Button "Gespeicherte Helligkeit restaurieren" wird die Helligkeit eingestellt, die TwinLightControl beim letzten ordnungsgemäßen Beenden in die Registry geschrieben hat.

Anmerkung: Genaugenommen wird nicht die Helligkeit, sondern die Gamma-Kurve des Monitors verändert. Einem Helligkeitswert von 128 entspricht ein Gamma-Wert von 1. Der aus einer nichtlinearen Gamma-Kurve berechnete Helligkeitswert ist deshalb nicht eindeutig.

Bei einem Start von TwinLightControl wird der Gamma-Wert der Grafikkarte resp. des Monitors nicht verändert. Nach Beendigung der Live-Dia-Show wird der alte Gamma-Wert wiederhergestellt. Das ist wichtig, wenn ein kalibrierter Monitor verwendet wird.

Wenn zum Kalibrieren des Monitors z.B. der ColorSpyder von DataColor verwendet wird, dann läuft im Hintergrund das sog. ColorSpyder Utility. Dieses kleine Programm überwacht in einstellbaren Zeitabständen, ob durch andere Programme Änderungen an den Grafikkarteneinstellungen vorgenommen wurden, die vom aktuellen Monitorprofil abweichen. Ist das der Fall, dann lädt ColorSpyder Utility immer wieder das aktuelle Monitorprofil und hebt damit die von TwinLightControl bewirkte Abdunklung des Monitors bei einer Live-Präsentation auf. Vor einer solchen sollte man also das ColorSpyder Utility oder analoge Programme anderer Hersteller temporär ausschalten.

Im oberen rechten Teil der Fernbedienung hat man die Möglichkeit, die Dia-Show zum Modul zu übertragen und dort dauerhaft zu speichern. Kommentare werden allerdings im Modul nicht abgelegt.

Der umgekehrte Weg ist auch möglich: man kann eine Dia-Show aus dem Modul in den Projektor-Speicher und von dort in die Timeline übertragen. Dabei muss ein bestimmter Magazin-Typ ausgewählt werden, da ja TwinLightControl nicht wissen kann, welche Magazin-Typen der im Modul befindlichen Dia-Show zugrunde lagen. So hat man aber die Möglichkeit, alte Dia-Shows, die nur noch im Modul vorhanden sind, in die Timeline zu holen und nachzubearbeiten.

Besteht keine Verbindung zum Projektor, d.h. ist der Projektor nicht angeschlossen oder eingeschaltet, kann das Optionsfeld "Leinwand-Simulation anzeigen" markiert und eine Leinwand-Simulation durchgeführt werden. Näheres siehe unter Leinwand-Simulation.

Wenn in der Timeline Audio-Dateien eingetragen sind, wird gemeinsam mit der Fernbedienung eine Bedienung für den Audio-Player geöffnet. Angezeigt werden der Name der gerade geladenen Audio-Datei, die Position innerhalb des Sound-Tracks (0 ... 100) und die Lautstärke (0 ... 100). Position und Lautstärke können während des Abspielens auch händisch geändert werden. Der Ton kann wahlweise ein- oder ausgeschaltet werden.

Wird die Dia-Show nicht mit Programm-Nummer 1, sondern mit einer höheren Programm-Nummer (z.B. Neu-Start) gestartet, sucht TwinLightControl die letzte gültige Audio-Datei und startet diese, es sei denn der Ton wurde vorher durch eine entsprechende Audio-Funktion ausgeschaltet/ausgeblendet. Die Audio-Datei wird dabei an einer Position gestartet, die anhand der Timeline so berechnet wurde, als sei die Dia-Show bis zur Start-Programm-Nummer normal abgelaufen. Bei einem Neu-Start wird die Audio-Datei an der Abbruchstelle wieder aufgenommen.

Verwendet man keine Audio-Dateien, kann die fertige Dia-Show in den Modul des Projektors übertragen und unabhängig vom PC präsentiert werden. Steuert man die Dia-Show über den PC, hat man die Möglichkeit, sowohl die simulierte PC-Fernbedienung, als auch die reale Projektor-Fernbedienung zu verwenden. Der Start der Dia-Show sollte aber am PC erfolgen. Das hat folgenden Grund: will man die Show z.B. nicht mit dem ersten Dia starten, sondern mit einer bestimmten Programm-, Magazin- oder Dia-Nummer, gibt man diese Nummer an der simulierten Fernbedienung ein drückt die Vorwärts-Taste. Die Show wird dann an der richtigen Position gestartet inkl. evtl. eingetragener Audio-Dateien. Beim Start über die Projektor-Fernbedienung müsste man die gewünschte Programm-Nummer an der Tastatur des Projektors eingeben, welcher möglicherweise an einem weiter entfernten Ort steht. Ist die Dia-Show einmal per PC-Fernbedienung gestartet, können alle folgenden manuellen Weiterschaltungen mit der Projektor-Fernbedienung getätigt werden, sofern die Dia-Show nicht sowieso automatisch abläuft (keine Pause-Markierungen).

Bei der Verwendung von Audio-Dateien muss die Steuerung logischerweise per PC erfolgen.

Wenn man eine Dia-Show über den PC steuert, kommt es gelegentlich vor, dass der Projektor zwar über die simulierte Fernbedienung (per PC) gesteuert werden kann, von der realen Fernbedienung aber keinerlei Befehle mehr annimmt. Es handelt sich offenbar um ein firmwarespezifisches Problem. Es hilft dann nur ein Aus- und Wiedereinschalten des Projektors.

Bei neueren Computern (vor allem Notebooks), die keine serielle Schnittstelle mehr haben und bei denen der Projektor über einen USB-Seriell-Adapter betrieben wird, kann es dazu kommen, dass TwinLightControl sich aufhängt, sobald versucht wird, die PC-Fernbedienung zu aktivieren. Es handelt sich hierbei um ein Inkompatibilitäts-Problem des Adapters und es betrifft nicht alle Arten und Modelle von Adaptern. Einige Informationen hierzu findet man z.B. bei http://www.dia.de in der Abteilung Dia-Projektoren/Optik.

Das Fenster der virtuellen Fernbedienung kann verkleinert werden, so dass die grafische Darstellung der Timeline gänzlich sichtbar wird, was für die Überwachung einer laufenden Dia-Show auf Monitoren mit geringerer Auflösung nützlich sein kann. Das Umschalten funktioniert nur, wenn die grafische Darstellung der Timeline eingeschaltet und der Audio-Player sichtbar ist, weil nur in diesem Falle der Platz auf dem Monitor zu klein wird. Erreicht wird dies, indem alle Bedienelemente außer der eigentlichen Fernbedienung ausgeblendet und alle sichtbaren Fenster neu angeordnet werden. Mit der Taste F4 kann man zwischen normaler und reduzierter Darstellung der Fernbedienung hin- und herschalten. Beim Start einer Dia-Show und nach jeder Null-Zeile wird automatisch auf die reduzierte Darstellung der Fernbedienung umgeschaltet. Am Ende einer Dia-Show oder wenn der Projektor in einer Null-Zeile steht, wird automatisch wieder auf die normale Darstellung umgeschaltet. Wer die reduzierte Darstellung der Fernbedienung nicht braucht oder mag, kann jederzeit, auch während einer laufenden Dia-Show, mit der Taste F4 die Darstellung umschalten.

Im Simulations- und Programm-Modus wird in der virtuellen Fernbedienung die seit dem Start der Dia-Show verstrichene Zeit angezeigt. Dies ist vor allem für Live-Dia-Shows nützlich, wenn man den aktuellen zeitlichen Stand der Dia-Show im Auge behalten möchte. Sollte die Dia-Show aus irgendeinem Grund unterbrochen worden sein, und man nimmt sie mit dem Restart-Button wieder auf, beginnt die Uhr beim letzten Stand vor der Unterbrechung weiterzulaufen, gezählt wird also nur die reine Show-Zeit.

Mit den Menüpunkten "Datei/Export/Voreinstellungen..." und "Datei/Import/Voreinstellungen..." können die Voreinstellungen in der virtuellen Fernbedienung (betrifft auch die normalen Voreinstellungen) exportiert und importiert und so leicht von einem Computer auf einen anderen übertragen werden (die erzeugte Datei *.def befindet sich im Verzeichnis "Journal" der TwinLightControl-Installation). Auf diese Art und Weise kann man bei Bedarf auch mehrere Profile mit Voreinstellungen vorhalten.

Siehe auch Tastenkürzel und Maus-Clicks in der virtuellen Fernbedienung.


Wie wird eine Leinwand-Simulation durchgeführt?

Bei einer Leinwand-Simulation wird der Ablauf der Dia-Show mit Überblendungen, Einblendungen usw. simuliert und in dem Fenster rechts neben der Fernbedienung angezeigt. Voraussetzung dafür, dass vor allem das Timing der Leinwand-Simulation richtig funktioniert, ist ein hinreichend schneller Rechner, er sollte einen CPU-Takt von mindestens 600 bis 700 MHz und ausreichend Hauptspeicher haben. Andernfalls läuft die Simulation nur sehr schleppend ab. Der Grund dafür ist, dass für die Überblendungen etwa 15 ... 50 Zwischenbilder pro Sekunde berechnet werden müssen, und das ist relativ zeitaufwendig.

Es gibt drei Möglichkeiten, auf die bei der Leinwand-Simulation vervwendeten Bilder Einfluss zu nehmen:

  • man kann eigene Bitmap's oder JPEG's (z.B. eingescannte Dias) verwenden
  • man kann Platzhalter verwenden
  • man kann einfache, einfarbige Bitmap's verwenden
Will man eigene Bilder verwenden, benötigt man für jedes Dia eine Bitmap- oder JPEG-Datei. Möglich sind die Dateiformate *.bmp, *.jpg und *.jpeg. Das erfordert das Einscannen aller Dias, wenn sie nicht bereits in elektronischer Form vorliegen (z.B. Kodak-Picture-CD). Kopien der Bild-Dateien werden nach dem Einfügen im Verzeichnis Pictures abgelegt. Näheres hierzu s. Einfügen, Entfernen und Anzeigen von Bild-Dateien.

Sind keine eigenen Bilder vorhanden, wählt TwinLightControl automatisch die zweite Möglichkeit: es werden Platzhalter verwendet.

Man kann im Verzeichnis "PlaceHolder" verschiedene Bitmaps ablegen, die als Platzhalter für nicht vorhandene eigene Bitmaps dienen. Hier gibt es eine Namenskonvention: die Bitmaps müssen die Namen Slide_XXX_qf.bmp, Slide_XXX_hf.bmp bzw. Slide_XXX_mf.bmp haben, wobei es sich um Bitmaps im Querformat, Hochformat bzw. quadratischen Format handelt. X steht für die Ziffern 0 ... 9, es sind führende Nullen erforderlich. TwinLightControl verwendet die im Verzeichnis "PlaceHolder" vorhandenen Bitmaps in zyklischer Reihenfolge, d.h. je mehr Bitmaps vorliegen, desto länger ist die Periode, mit der die Bilder getauscht werden. Möchte man z.B. erreichen, dass sich die Bilder erst nach 20 Überblendungen wiederholen, dann muss man je 20 Bitmaps Slide_XXX_qf.bmp, Slide_XXX_hf.bmp und Slide_XXX_mf.bmp in das Verzeichnis "PlaceHolder" kopieren.

Wenn die Zahl der Platzhalter-Bilder begrenzt ist, dann kann es vorkommen, dass bei einer Überblendung zwei gleiche Bilder ineinander überblendet werden (Beispiel: 5 Platzhalter-Bilder, Überblendung von Dia-Fach-Nr. 3 auf Dia-Fach-Nr. 8). Das hängt damit zusammen, dass die Bilder zyklisch durchgetauscht werden, wir sehen das aber nicht als Fehler an. In einem solchen Falle sollte man entweder die Zahl der Platzhalter-Bilder erhöhen oder eingescannte Bilder verwenden.

Findet TwinLightControl auch in "PlaceHolder" keine Bitmaps, verwendet es die dritte Möglichkeit: einfache, einfarbige Bitmaps, die es selbst erzeugt. Man kann dann wirklich nur das Prinzip der Überblendeffekte erkennen.

Für die Bilder selbst gelten folgende Konventionen:
  • die Bilder sollten (ungefähr) ein Format von 360 x 240 Pixeln, 240 x 360 Pixeln bzw. 240 x 240 Pixeln haben, je nachdem, ob es sich um Querformat, Hochformat bzw. quadratisches Format handelt. Wenn eine Seite eines Bildes um mehr als 10% länger ist als die andere, wird automatisch Quer- bzw. Hochformat angesetzt, andernfalls quadratisches Format. Kleinere oder größere Bitmaps als oben angegeben werden in ihrer Größe zwar angepasst, was aber zu Formatverzerrungen und Qualitätsverlusten durch Stauchen oder Strecken führen kann
  • die Bilder müssen unbedingt mit einer Farbtiefe von 24 Bit (True Color) abgelegt werden, andernfalls kommt es zu unvorhersagbaren Darstellungsfehlern
  • für die Erzeugung der Ein-/Überblendungen wird sog. Alpha-Blending verwendet
  • bei der Leinwand-Simulation können auch größere Bilder verwendet werden

Für Ein-/Überblendungen wird OpenGL genutzt werden, was von allen modernen Grafikkarten unterstützt wird.

Beim sog. Alpha-Blending wird die Tatsache ausgenutzt, dass Bitmaps einen Alpha-Kanal zur Steuerung der Bild-Transparenz haben können. Alpha-Blending kann Überblendungen schneller berechnen, ist aber nicht auf allen Systemen verfügbar, da es hard- und softwaremäßig unterstützt werden muss. Alpha-Blending ist eine Technik, die mit Windows 2000 eingeführt wurde. Auf allen neueren Rechnern sollte Alpha-Blending also funktionieren. Für Alpha-Blending ist die DLL msimg32.dll zuständig, die sich i.d.R. im Systemverzeichnis ("Windows\ystem32") befindet. Bei der Installation von TLC wird diese DLL, falls nicht vorhanden, mit installiert. Es gibt auch eine Version dieser DLL, die für Win 95 / Win 98 / Win NT geeignet ist, diese muss allerdings manuell installiert werden.

Alpha-Blending mit OpenGL wird auf den meisten Grafikkarten die Methode der Wahl sein. OpenGL ist eine weit verbreitete Grafikbibliothek ähnlich DirectX. Alle einigermaßen modernen Grafikkarten unterstützen OpenGL. OpenGL ist seit Windows 98 Bestandteil des Betriebssystems, sollte eine ältere Grafikkarte kein OpenGL unterstützen, wird es softwaremäßig emuliert.

Alpha-Blending wird in den Voreinstellungen unter "Leinwand-Simulation" aktiviert/deaktiviert. Sollte es nicht funktionieren und man unerklärliche Fehlermeldungen (z.B. "Der engegebene Ressourcentyp wurde in der Image-Datei nicht gefunden." oder "Systemressourcen erschöpft") erhalten, dann kann man nach wie vor die bisher verwendete Methode der Erzeugung der Überblendungen verwenden, indem man Alpha-Blending deaktiviert.

In der Regel werden mit OpenGL die besten Ergebnisse bei Ein-/Überblendungen erzielt, vor allem, wenn man große Bilder wählt. Man sollte einfach ausprobieren, welche Methode auf dem eigenen Rechner die beste Performance hat.

Größere Bilder bei der Leinwand-Simulation werden ebenfalls in den Voreinstellungen ausgewählt. Aus Performance-Gründen ist dies nur bei aktiviertem Alpha-Blending (GDI und OpenGL) und in der Standalone-Version der grafischen Darstellung der Timeline (also nicht mit virtueller Fernbedienung) möglich. Bei Verwendung größerer Bilder werden Audio-Player und grafische Darstellung der Timeline verkleinert bzw. verschoben.

Die standardmäßig verwendeten Bilder haben eine Größe von 360 x 240 Pixeln (Querformat) und sind in die twc-Datei integriert. Um bei Verwendung größerer Bilder die twc-Dateien nicht unnötig aufzublähen, geht TwinLightControl folgendermaßen vor: wenn die Original-Dateien, aus denen die Bilder ursprünglich importiert wurden, noch an ihrem ursprünglichen Ort vorhanden sind, werden die Bilder für die Überblendung daraus erzeugt, da diese Dateien i.d.R. aus Dia-Scans stammen und eine hohe Auflösung aufweisen. Sind die Original-Dateien nicht mehr vorhanden, verwendet TLC die integrierten Bild-Dateien (Auflösung 360 x 240 Pixel) und rechnet diese auf die höhere Auflösung hoch. Das führt insbesondere bei jpg-Dateien oft zu unschönen Ergebnissen mit mosaikartigen Bildern.

Für die Auflösung der Original-Bild-Dateien sollte folgende Faustregel gelten: die lange Seite des Bildes sollte etwa so viele Pixel aufweisen wie der Bildschirm des Computersystems in Pixeln hoch ist. Beispiel: Bildschirmauflösung: 1200 x 800 Pixel, Auflösung der Bilder: ca. 800 x 533 Pixel (Querformat) oder 533 x 800 Pixel (Hochformat) oder 533 x 533 Pixel (quadratisches Format). Haben die Bilder eine geringere Auflösung werden sie hochgerechnet (schlechtere Bildqualität, s.o.), haben sie eine höhere Auflösung, werden sie heruntergerechnet, was zwar der Bildqualität keinen wesentlichen Abbruch tut, aber längere Ladezeiten bedeutet. Die Leinwand-Simulation wird dadurch etwas ruckeliger. Dies macht sich dadurch bemerkbar, dass am Beginn einer Über- oder Einblendung, wenn ein neues Bild geladen werden muss, der Timeline-Locator für eine gewisse Zeit hängenbleibt. In diesem Fall sollte man also die Auflösung der Original-Bild-Dateien reduzieren (s.o.).

In den Voreinstellungen zur Leinwand-Simulation gibt es noch eine dritte Option: "Original-Bild-Dateien verwenden". Wenn man diese Option deaktiviert, werden, auch wenn die Original-Bild-Dateien noch vorhanden sind, hochgerechnete Bilder (s.o.) verwendet. Nützlich ist diese Option zum Testen, wenn man längere Bild-Lade-Zeiten vermeiden, trotzdem aber einen großen Bildeindruck haben möchte.

Die Leinwand-Simulation kann auch auf einem angeschlossenen und aktiven Sekundär-Monitor im Vollbild-Modus angezeigt werden. Das ist allerdings nicht im OpenGL-Modus, sondern nur im GDI-Modus möglich.


Wie wird eine DiaEdit-Datei importiert?

Bereits vorhandene, mit dem Rollei-eigenen Programm DiaEdit erstellte Dia-Shows können in TwinLightControl problemlos importiert werden. Man braucht an den erzeugten *.twc-Dateien meist nicht eine einzige Zeile ändern, es sei denn, man möchte weitere Informationen hinzufügen.

Man wählt das Menü Datei/Importieren/DiaEdit-Datei und öffnet mit Hilfe des Datei-Dialogs die gewünschte *.dpd-Datei. Da TwinLightControl nicht wissen kann, welcher Magazin-Typ der mit DiaEdit erzeugten Dia-Show zugrundelag, wird der Magazin-Typ in einem Dialog abgefragt. TwinLightControl bietet den aufgrund der Dia-Nummern wahrscheinlichsten Magazin-Typ als Vorauswahl an. Nachdem man den Typ ausgewählt hat, erzeugt TwinLightControl aus der *.dpd-Datei eine *.twc-Datei. Diese sollte man nach dem Erzeugen auch sofort abspeichern.

War die DiaEdit-Datei fehlerhaft (z.B. keine Nullzeile nach jedem Magazin), muss der Timeline-Check noch einmal händisch durchgeführt werden. Darauf weist TwinLightControl aber hin. Die erzeugte *.twc-Datei kann nun noch nach Belieben verändert und abgespeichert werden.

Will man an der erzeugten *.twc-Datei Änderungen vornehmen, also z.B. Bild- oder Audio-Dateien hinzufügen, darf man nicht vergessen, vorher die Null-Zeilen zu entfernen, d.h. den Timeline-Check rückgängig zu machen.

Der generierten *.twc-Datei wird eine Information hizugefügt, welche DiaEdit-Datei (mit Zeitstempel) ihr zugrundelag.

Die aus DiaEdit-Dateien importierten *.twc-Dateien sind bei gleichem Informationsgehalt i.d.R. kleiner als die DiaEdit-Dateien.

Es können auch Dateien importiert werden, die mit der DOS-Version von DiaEdit erstellt wurden. Diese Dateien enthalten z.B. Informationen über das Dia-Format, was bei der Windows-Version von DiaEdit leider nicht mehr der Fall ist.

Man sollte nach dem Import die erzeugte Dia-Show auf alle Fälle noch einmal auf ihre Richtigkeit überprüfen. Oft sind in der zugrundeliegenden DiaEdit-Datei (logische) Fehler enthalten, da DiaEdit keinerlei Plausibilitätsprüfung durchführt. Ein häufiger Fehler ist z.B. das Vergessen von Nullzeilen als Trennung zwischen verschiedenen Magazinen.

Ein Beispiel:

In einer DiaEdit-Datei kommen folgende Bildnummern vor: ..., 247, 248, 249, 250, 251, 252, 253, ... Diese Folge von Bildnummern lässt sich u.a. folgendermaßen interpretieren:
a) es handelt sich um den Übergang vom fünften zum sechsten Koppelmagazin,
b) es handelt sich um den Übergang vom fünften zum sechsten 50-er-Normalmagazin, wobei die Nullzeile vergessen wurde,
c) es handelt sich um den Inhalt des dritten 100-er-Magazins.

Es gibt also meist mehrere Möglichkeiten, eine Abfolge von Bildnummern zu interpretieren. Deshalb ist es wichtig,

  • nach Möglichkeit nur logisch fehlerfreie DiaEdit-Dateien zu importieren,
  • beim Import den richtigen Magazin-Typ anzugeben,
  • das Ergebnis zu kontrollieren (Zahl und Typ der Magazine, Zahl der Programmschritte) und ggf. nachzubearbeiten.

Man sollte es vermeiden, DiaEdit-Dateien zu importieren, die verschiedene Magazin-Typen beinhalten. In einem solchen Fall hat TLC kaum eine Chance, ein vernünftiges Ergebnis zu liefern.


Wie wird in eine DiaEdit-Datei exportiert?

Wer auf das Rollei-eigene Programm DiaEdit nicht verzichten kann, der hat die Möglichkeit, seine mit TwinLightControl erstellte Dia-Show in eine DiaEdit-Datei zu exportieren.

Man wählt das Menü Datei/Exportieren/DiaEdit-Datei und mit Hilfe des Datei-Dialogs die *.dpd-Datei, in die exportiert werden soll. Der Export in eine DiaEdit-Datei ist bei der Testversion auf 20 Programm-Zeilen beschränkt.


Wie wird der Dia-Show-Wizard benutzt?

Der Dia-Show-Wizard soll Anfänger bei der Erzeugung, Fertigstellung und Präsentation von Dia-Shows unterstützen. Er ist verfügbar über das Menü "Dia-Show/Dia-Show-Wizard" oder das Tool-Button [image] .

Mit Hilfe des Wizards kann man

  • eine neue Dia-Show erstellen (manuell oder im Live-Modus)
  • eine bestehende Dia-Show fertigstellen (Timeline-Check, Skalierung)
  • eine fertige Dia-Show präsentieren, indem man sie an die grafische Darstellung der Timeline oder an die Fernbedienung übergibt; wenn der Projektor aktiviert ist, kann sie auch am Projektor präsentiert werden

Der Wizard ist im Prinzip selbsterklärend. Man wählt lediglich die gewünschten Optionen aus und drückt das Button "Weiter" bzw. "Fertigstellen". Mit dem Button "Zurück" kann man einen Schritt rückwärts gehen. In jedem Registerblatt gibt es ausführliche Erklärungen zu dem, was gerade gemacht werden soll. Einfach ausprobieren!


Was ist der Live-Modus und wie wird er verwendet?

Im Projektor-Betrieb gibt es den sog. Live-Modus. Er ist eine elegante Möglichkeit, Dias aus einem Magazin-Durchlauf direkt in die Timeline zu übernehmen. Man benutzt den Projektor gewissermaßen als komfortables Leuchtpult und übernimmt geeignete bzw. verwirft ungeeignete Dias eines oder mehrerer Magazine. Die Projektion eines Dias bietet die beste Möglichkeit, dessen Qualität zu beurteilen, besser als auf dem Leuchtpult. Auf dem Leuchtpult hingegen lassen sich mehrere Dias auf einen Blick besser miteinander vergleichen. So haben beide Methoden, Dias für eine Show auszuwählen, ihre Vorzüge.

Der Live-Modus ist besonders dann geeignet, wenn man seine Dias in Magazinen archiviert und für eine oder verschiedene Dia-Shows die Dias nicht extra umsortieren möchte.

Im Live-Modus kann der Projektor mit der realen oder virtuellen Fernbedienung oder über Tastenkombinationen gesteuert werden. Das Einfügen oder Entfernen von Dias in der Timeline oder im Dia-Editor (s.u.) funktioniert aber nicht mit der realen Fernbedienung. Deshalb bietet es sich an, die virtuelle Fernbedienung entweder mit der Maus oder über Tastenkombinationen zu steuern.

Es gibt prinzipiell zwei Herangehensweisen, den Live-Modus einzusetzen. Entweder startet man mit einer leeren Timeline und fügt die gewünschten Dias hinzu, oder man beginnt mit einer gefüllten Timeline und entfernt alle nicht gewünschten Dias. Nachfolgend werden beide Methoden beschrieben.

Start mit einer leeren Timeline

Beim Start mit einer leeren Timeline geht man folgendermaßen vor:

  • Man öffnet zunächst eine neue Datei.
  • Man fügt im Magazin-Editor so viele Magazine hinzu, wie die gesamte, noch nicht bearbeitete Dia-Show Magazine enthält.
  • Man aktiviert den Projektor.
  • Man startet die virtuelle Fernbedienung.
  • Man kann nun den Projektor mit der realen oder virtuellen Fernbedienung steuern. Die Tastenkombinationen der virtuellen Fernbedienung findet man hier.
  • Man startet die Projektion mit der grünen Vor-Taste (oder mit der Leertaste), mit der roten Rück-Taste kann man beliebig oft zurückfahren. Wenn man in den Edit-Feldern "Start-Magazin-Nummer" und "Start-Dia-Nummer" gültige Zahlen eingibt, startet die Projektion mit diesem Magazin und Dia und nicht am Anfang.
  • Bei einem Dia, welches man in die Timeline übernehmen möchte, klickt man mit der linken Maustaste (ohne oder mit Strg-Taste) das Button "Memo" auf der virtuellen Fernbedienung (oder die Taste "Einfg" / "Strg+Einfg"). In diesem Fall hilft es nicht, die Memo-Taste auf der realen Fernbedienung zu drücken, die bewirkt nämlich nur das, was in der Beschreibung zum Projektor zu lesen ist.
  • Will man ein Dia nicht am Ende der Timeline anfügen, sondern irgendwo mittendrin einfügen, klickt man mit der Maus auf den Programmschritt in der Timeline, vor dem man das Dia einfügen möchte. Die aktuelle Zeile ist an dem kleinen schwarzen Pfeil (Dreieck) am linken Rand des Timeline-Editors erkennbar.
  • Man kann aber auch die Dias immer ans Ende der Timeline anhängen und die Reihenfolge später noch ändern.
  • Danach wird die Nummer des gerade angesetzten Magazins erfragt, da der Projektor sich nicht im Programm-Modus befindet und demzufolge nicht "wissen" kann, welches Magazin sich gerade im Projektor befindet. Als Voreinstellung in dem erscheinenden Edit-Feld steht die zuletzt eingegebene Magazin-Nummer, man braucht also meist einfach nur RETURN zu drücken. Lediglich nach einem Magazin-Wechsel muss ggf. eine neue Nummer eingegeben werden.
  • An dieser Stelle kann man auch gleich das Dia-Format und einen Dia-Kommentar eingeben. Man kann die Eigenschaften des momentan projizierten Dias auch nachträglich noch ändern, indem man gleichzeitig die Umsch-Taste und die Memo-Taste auf der virtuellen Fenbedienung drückt (Tastenkombination: "Strg+E").
  • Das gewünschte Dia wird nun am gewünschten Ort der Timeline eingefügt bzw. angehängt.
  • Wenn man fertig ist, drückt man das End-Button auf der (realen oder virtuellen) Fernbedienung und schließt die virtuelle Fernbedienung.
  • Die nun in der Timeline befindliche Dia-Show kann noch beliebig verändert und anschließend gespeichert werden.
Start mit einer gefüllten Timeline

Beim Start mit einer gefüllten Timeline geht man folgendermaßen vor:
  • Man öffnet zunächst eine neue Datei.
  • Man fügt im Magazin-Editor so viele Magazine hinzu, wie die gesamte, noch nicht bearbeitete Dia-Show Magazine enthält.
  • Man selektiert alle Dias in alle Magazinen und fügt sie in die Timeline ein.
  • Man aktiviert den Projektor.
  • Man startet die virtuelle Fernbedienung.
  • Man kann nun den Projektor mit der realen oder virtuellen Fernbedienung steuern. Die Tastenkombinationen der virtuellen Fernbedienung findet man hier.
  • Man startet die Projektion mit der grünen Vor-Taste (oder mit der Leertaste), mit der roten Rück-Taste kann man beliebig oft zurückfahren. Wenn man in den Edit-Feldern "Magazin-Nummer" und "Dia-Nummer" gültige Zahlen eingibt, startet die Projektion mit diesem Magazin und Dia und nicht am Anfang.
  • Bei einem Dia, welches man aus der Timeline entfernen möchte, klickt man mit der rechten Maustaste das Button "Memo" auf der virtuellen Fernbedienung (oder die Taste "Entf").
  • Danach wird die Nummer des gerade angesetzten Magazins erfragt, da der Projektor sich nicht im Programm-Modus befindet und demzufolge nicht "wissen" kann, welches Magazin sich gerade im Projektor befindet. Als Voreinstellung in dem erscheinenden Edit-Feld steht die zuletzt eingegebene Magazin-Nummer, man braucht also meist einfach nur RETURN zu drücken. Lediglich nach einem Magazin-Wechsel muss eine neue Nummer eingegeben werden.
  • Das gewünschte Dia wird nun aus der Timeline entfernt.
  • Wenn man fertig ist, drückt man das End-Button auf der (realen oder virtuellen) Fernbedienung und schließt die virtuelle Fernbedienung.
  • Die nun in der Timeline befindliche Dia-Show kann noch beliebig verändert und anschließend gespeichert werden.

Beide Methoden können natürlich beliebig kombiniert werden. Es hängt von der Art der zu bearbeitenden Dia-Show und den persönlichen Vorlieben ab, wie man vorgeht.

Befindet sich das gerade projizierte Dia bereits in der Timeline, wird der zugehörige Programmschritt zur besseren Erkennbarkeit rot eingefärbt. Man beachte: man kann unabhängig von der roten Markierung einen Programmschritt durch Klicken mit der Maus zum aktuellen Programmschritt machen, vor dem z.B. ein Dia eingefügt werden soll (s.o.).

Man kann das gerade projizierte Dia auch im Dia-Editor als "Nicht belegt" markieren, wenn man feststellt, dass das Dia dauerhaft entfernt werden sollte. Das Dia wird, wenn vorhanden, aus der Timeline entfernt und dann im Dia-Editor als "Nicht belegt" markiert. Später kann man die Lücken mit den als "Nicht belegt" markierten Dias schließen.

Man kann beim gerade aktiven Programmschritt in der Timeline das Dia-Format setzen: dazu verwendet man die Tastenkombination Strg+Alt+Q für das Querformat und Strg+Alt+H für das Hochformat. Das Dia-Format wird im Dia- und Timeline-Editor übernommen. (Diese beiden Tastenkombinationen werden beibehalten, sind aber durch die Tastenkombination "Strg+E" (s.o.) überholt.)

Die Undo- und Redo-Funktion sind im Live-Modus aktiv, so dass jede Änderung ggf. rückgängig gemacht oder wiederholt werden kann.

Auch der Wizard bietet die Möglichkeit, nach dem Einfügen einer entsprechenden Zahl von Magazinen den Live-Modus zu starten und eine Dia-Show "On the fly" zu erstellen.

Man kann auch eine unfertige Dia-Show, die mit Hilfe des Live-Modus erstellt wurde, später wieder öffnen und im Live-Modus weiterbearbeiten. Dazu ist es hilfreich, mit dem Dia zu starten (s.o.), mit dem man die Show beim letzten Mal beendet hat. Voraussetzung ist es, dass der Timeline-Check noch nicht vollzogen wurde (wenn doch, dann einfach die Null-Zeilen wieder entfernen).

Wenn der Live-Modus aktiv ist, wird dies in der Titelzeile des Fensters der virtuellen Fernbedienung angezeigt.


Wie wird das Erscheinungsbild einer Tabelle den persönlichen Bedürfnissen angepasst?

In den Tabellen für Magazin, Dia und Timeline sind zahlreiche Felder vorhanden, die entweder geändert werden können oder nur der Information dienen. Die Timeline-Tabelle ist die mit den meisten Feldern, und um an alle Informationen heranzukommen, muss man gelegentlich scrollen.

Für manchen Anwender sind aber einige Felder ohne Belang, da er diese nicht benötigt. Es ist daher möglich, im Magazin-, Dia- und Timeline-Editor jede einzelne Spalte separat anzuzeigen bzw. zu verstecken. So kann man ggf. einzelne Spalten, die man nicht immer benötigt, ausblenden, um mehr Platz für andere zu schaffen. Dazu hält man die Umschalt-Taste gedrückt und klickt mit der linken Maustaste in die Titelzeile der betreffenden Spalte (z.B. Magazin-Typ). Alternativ kann man im gerade aktiven Editor die Taste F7 drücken.

In dem erscheinenden Dialog kann man die Spalten wählen, die man anzeigen bzw. verstecken möchte. Die Breite der Spalten kann man verändern, indem man mit der Maus in der Titelzeile die Grenze zwischen zwei Spalten verschiebt. Mit dem Button "Spalten-Breite an Inhalt anpassen" wird die Spalten-Breite aller sichtbaren Spalten automatisch so angepasst, dass der Inhalt der Kopfzeile und der einzelnen Zellen vollständig sichtbar und so eine optimale Darstellung gewährleistet ist.

Alle gewählten Einstellungen werden in der Registry abgelegt und bleiben über die Beendigung von TwinLightControl hinaus erhalten.


Tips und Tricks

Nachfolgend sind in loser und ungeordneter Folge einige Tips und Tricks im Umgang mit TwinLightControl und den RolleiVision Twin Projektoren aufgelistet.

  • Eine bequeme Möglichkeit, Dias aus dem Dia-Editor in die Timeline zu übertragen, besteht in folgendem: im Dia-Editor geht man zum Feld "Benutzt" des gewünschten Dias. Mit der Leertaste kann ein Häkchen gesetzt werden, mit Return oder Pfeil nach unten bestätigt man die Übernahme des Dias in die Timeline. Das Dia wird an das Ende der Timeline angehängt. Auf diese Art und Weise hat man die Möglichkeit, im Dia-Editor Dia für Dia in der gewünschten Reihenfolge anzusteuern und in die Timeline zu übernehmen.
  • Zu den meisten Befehlen und Funktionen gibt es Tastenkürzel für ein schnelleres Arbeiten; sie sind über die Buttons "Strg-?" bzw. Strg+F1 bzw. Umsch+F1 für die Dia-Show allgemein, den Magazin-Editor, den Dia-Editor, den Timeline-Editor, den Audio-Player, die grafische Darstellung der Timeline und die virtuelle Fernbedienung abrufbar.
  • Lässt man die Maus kurz über einem aktiven Steuerelement ruhen, wird ein Kurzhinweis angezeigt, was das Element macht.
  • Wenn TwinLightControl einmal abgestürzt ist, kann man Datei-Reste mit Hilfe des Menüpunktes Datei/Restaurieren wieder zusammenfügen.
  • Sollte die Kommunikation mit dem Projektor nicht ordnungsgemäß funktionieren, kann man unter Voreinstellungen die serielle Schnittstelle manuell konfigurieren.
  • Wurde eine laufende Dia-Show aus irgendeinem Grund abgebrochen (z.B. ein verklemmtes Dia), kann man die Show mit Hilfe des Buttons Neu-Start in der virtuellen Fernbedienung genau an der Abbruchstelle neu starten.
  • Folgende Schritte sind notwendig, um eine fertige Dia-Show zu präsentieren: 1. Timeline-Check durchführen, 2. Projektor aktivieren, 3. Fernbedienung aktivieren, 4. Dia-Show in den Projektor-Speicher übertragen, 5. Dia-Show ggf. in den Modul schreiben, 6. Dia-Show mit Hilfe der virtuellen oder realen Fernbedienung starten
  • Innerhalb von Kommentarfeldern (Magazin-, Dia- und Timeline-Editor) sollte man keine TAB's verwenden, weil dies unschöne Darstellungen am Bildschirm und beim Ausdruck ergibt. Vor allem in der Laufschrift unterhalb der grafischen Darstellung der Timeline führt dies zu verwirrenden Ergebnissen.
  • Im Dia-Editor kann man den Kommentar eines vorhergehenden Dias mit Alt+K bzw. Strg+Alt+K übernehmen
  • Die wichtigsten Informationen zum momentanen Programmschritt einer laufenden Dia-Show findet man in der Status-Zeile der grafischen Darstellung der Timeline am oberen Fensterrand
  • Mit Hilfe des Suchen-Dialogs kann man leicht nach Magazinen, Dias oder Programmschritten suchen, die eine bestimmten Text im Kommentarfeld enthalten
  • Die zehn zuletzt geöffneten oder gespeicherten Dateien findet man am unteren Ende des Menüs "Datei"
  • Sollte TwinLightControl einmal abgestürzt sein, kann es vorkommen, dass eine *.twc-Datei als nicht mehr vorhanden oder nicht lesbar gemeldet wird. Mit dem Menüpunkt "Datei/Restaurieren..." kann man die fehlerhafte Datei i.d.R. wiederherstellen.
  • Eine Dia-Show kann bequem mit der Leertaste gestartet, pausiert und fortgesetzt werden.
  • Mit "Datei/Medien-Dateien ausschließen" kann man Bild- und Audio-Dateien vom Speichern ausschließen, damit die *.twc-Datei kleiner wird (z.B. für einen Versand per E-Mail). Man darf allerdings nicht vergessen, für die Endfassung der Dia-Show die Bild- und Audio-Dateien wieder aufzunehmen. Hat man die Option "Medien-Dateien ausschließen" gewählt, wird man beim Öffnen einer Datei aus Sicherheitsgründen darauf hingewiesen.
  • Wer seiner Dia-Show einen professionellen Touch verleihen und in der Dunkelpause vor dem Aufblenden des ersten Dias Musik einspielen möchte, geht folgendermaßen vor: 1. Einfache Möglichkeit: man trägt beim ersten Dia die gewünschte Audio-Datei ein und setzt die Überblendzeit auf den maximal möglichen Wert (25 sec). Dann wird das erste Dia sehr langsam aufgeblendet, und in dieser Zeit die Musik eingespielt. 2. Etwas aufwendigere, aber flexiblere Möglichkeit: man fügt als allererstes Dia in die Dia-Show ein schwarzes Dia ein. Schwarze Dias bekommt man gratis mit jedem Filmanfang und -ende aus dem Entwicklungslabor. Bitte kein schwarzes Papier verwenden, es könnte sich zu stark erhitzen. Um die Spielzeit der bei diesem ersten Dia eingetragenen Audio-Datei genau kontrollieren zu können, setzt man die Überblendzeit des ersten Dias auf 0,1 sec (Cut) und die Standzeit auf den gewünschten Wert. Nach dieser Zeit wird dann das zweite (eigentlich das erste richtige Dia) eingeblendet. Man kann in eine bereits vorhandene Dia-Show leicht ein Dia am Anfang einfügen, indem man im Dia-Editor alle Dias ab dem ersten Dia nach hinten verschiebt. (Das manuelle Umsortieren der Dias kann TwinLightControl leider nicht übernehmen.) Zur Verdeutlichung des geschilderten Procederes ist im Ordner "DiaShows\Demos" die Datei "Musik-Vorspann.twc" zu finden. Dort wird auch gezeigt, wie man einen professionellen Abspann erzeugt. Um die Installations-Datei für TwinLightControl nicht zu groß werden zu lassen, ist die Audio-Datei beim ersten Programmschritt mit einer niedrigen Bitrate codiert worden. Platzhalter für das Schwarz-Dia, verschiedene Titel-Dias und das Ende-Dia findet man im Verzeichnis "PlaceHolder".
  • Es ist es noch einfacher, einen solchen Vorspann zu erzeugen. Man geht folgendermaßen vor: Als erstes Dia fügt man ein Schwarz-Dia in die Dia-Show ein. Mit dem ersten Dia wird auch der Audio-Track gestartet. Das zweite Dia ist das erste "richtige" Dia der Dia-Show. Auf dieses zweite Dia setzt man einen Audio-Synchronisations-Punkt, um dieses Dia bei einem bestimmten Takt des Audio-Tracks aufzublenden. Vor dem Setzen des Sync-Punktes müssen für den gewünschten Bereich alle Licht-Pausen entfernt werden. Details zum Setzen von Audio-Synchronisations-Punkten findet man hier. Demo-Dia-Show: "Musik-Vorspann mit Audio-Sync-Punkt.twc".
  • Startet man eine Dia-Show mit einem Audio-Track, was i.d.R. der Fall sein wird, sollte man generell am Anfang ein Schwarz-Dia einfügen. Das hat folgenden Grund: am Beginn einer Dia-Show muss der Projektor zwei Dias einziehen, bevor er mit der Projektion beginnen kann. Das benötigt eine längere Zeit als der Einzug nur eines Dias. Dadurch kommt es zu Verschiebungen bei der Synchronisation von Bild und Ton. Wenn man möchte, dass das erste Bild punktgenau mit dem Start des Audio-Tracks aufgeblendet wird, sollte man als erstes Dia ein Schwarz-Dia einfügen, dieses z.B 5 sec stehenlassen und den Beginn des Audio-Tracks auf das zweite Dia legen. Leider lässt sich das ganze programmtechnisch nicht anders lösen, da der Projektor die neue Bild-Nummer meldet, wenn er mit dem Einziehen des Dias beginnt, und nicht, was vernünftig wäre, wenn er mit dem Aufblenden beginnt. Dieser kleine Trick sichert die Synchronisation von Bild und Ton am Anfang einer Dia-Show, ist aber natürlich nur bei Koppelmagazinen sinnvoll, da man ja sicher nicht bei jedem neuen Magazin, das auch mit einem Audio-Track startet, ein Schwarz-Dia einfügen möchte. Wie man einen professionellen Vorspann erzeugt, wurde weiter oben beschrieben.
  • In der virtuellen Fernbedienung kann man die Option wählen, ob der Audio-Player erst nach Einzug der beiden ersten Dias gestartet werden soll. Näheres findet man hier.
  • Wer sich auch schon mal über die stolzen Preise für die originalen Rollei-Koppelmagazine (und anderes Zubehör) geärgert hat, dem sei hier eine unkonventionelle Methode empfohlen, Rollei-Koppelmagazine zu sparen. Man legt sich einige dieser Koppelmagazine zu (10 sollten für die meisten Zwecke ausreichen) und füllt die Dias vor einer Show in die Koppelmagazine um. Mit einem verkehrtherum angesetzten "Zwischenmagazin" geht das nach einiger Übung sehr schnell. Für 10 Magazine ist das Ganze in ca. 5 min erledigt. So kann man die zugegebenermaßen gute Verarbeitungsqualität der Rollei-Magazine für die Projektion nutzen, für die Aufbewahrung kann man weiterhin billige Magazine benutzen. Letztere haben nämlich u.a. den Nachteil, dass man sie erst von diversen, vom Produktionsprozess herrührenden Rückständen befreien muss, damit sie anstandslos durch den Twin gehen. Außerdem sind mit ihnen natürlich keine längeren Dia-Shows ohne Unterbrechung möglich.
  • Verwendet man Koppelmagazine und ist das letzte Magazin nur zu einem geringen Teil gefüllt, fährt der Projektor am Ende der Dia-Show soweit zurück, dass das zuletzt angekoppelte Magazin herunterfällt. Die Demo-Dia-Show "Blind-Dia am Ende einer Show.twc" demonstriert, wie man das verhindern kann. Man fügt einfach beim letzten Magazin ein Blind-Dia (Schwarz-Dia) mit folgenden Einstellungen an: Dia-Fach-Nummer: ca. 40, Überblendzeit nach Belieben, keine Pause, Standzeit möglichst kurz (0,1 sec), Lichtsonderfunktion: Ab-/Aufblenden mit Pause, Kommentar: Blind-Dia; vorderes Magazin abnehmen, danach Vor-Taste drücken. Dann wartet der Projektor vor dem letzten Dia (Blind-Dia), und man kann das vordere Magazin in aller Ruhe abnehmen. Die Vor-Taste beendet dann die Dia-Show.
  • Die Demo-Dia-Show "Musik-Ausblendung am Ende" zeigt, wie man die Ausblendung des letzten Dias und die Ausblendung der Musik synchronisieren kann. Man fügt als letztes Dia ein Schwarz-Dia ein, bei welchem man die Audio-Funktion "Ton ausblenden" mit identischer Bild- und Ton-Überblendzeit einträgt. Dann beginnt und endet die Ausblendung der Musik zeitgleich mit der Ausblendung des letzten Dias (der Überblendung auf das Schwarz-Dia).
  • Wenn der Projektor einmal nicht mehr auf die reale Fernbedienung reagiert, was gelegentlich vorkommt (der Grund dafür ist nach einer Information von Rollei ein Firmware-Problem), dann hilft für den Moment nur Aus- und Wiedereinschalten. Will man das Problem dauerhaft beseitigen, sollte man den EEPROM im Innern des Projektors austauschen (lassen). Dies ist allerdings nur für die neueren Projektoren MSC 325P und MSC 535P möglich.
  • Vor einer Live-Dia-Show hat sich folgendes Vorgehen bewährt: man lädt die Dia-Show in den Projektor und startet sie versuchsweise. Wenn die Projektor-Fernbedienung schon in diesem Stadium nicht reagiert, sollte man den Projektor ausschalten (!) und die Show nochmals laden. Dann hat man gute Chancen, dass bis zum Ende der Show alles normal läuft. Sollte der Projektor trotzdem irgendwann nicht mehr auf seine Ferbedienung reagieren, hat man zwei Möglichkeiten: entweder man bedient den Projektor über die PC-Fernbedienung, oder man nutzt die Funktionalität des Neu-Start-Buttons.
  • Das Feld "Bei Magazinwechsel Hinweis anzeigen" in der virtuellen Fernbedienung sollte man auf jeden Fall mit einem Häkchen versehen. Dann wird man im Falle eines fälligen Magazinwechsels (z.B bei einem Neustart) darauf hingewiesen, welches Magazin man anzusetzen oder anzukoppeln hat und welches spezielles Procedere beim zweiten Magazin nötig ist (bei Koppelmagazinen).
  • Wenn man im Menü "Datei" die Option "Medien-Dateien ausschließen" anwählt, werden die Bild- und Audio-Dateien nicht zusammen mit der eigentlichen *.twc-Datei gesichert. Es werden lediglich Links auf die Medien-Dateien gesichert. Das erzeugt kleinere *.twc-Dateien. Wenn man später die Option wieder abwählt, restauriert TwinLightControl die Medien-Dateien aus den Links, sofern die originalen Bild- und Audio-Dateien nicht gelöscht oder verschoben wurden.
  • Die Anzeige des QuiverTree-Logos beim Start von TwinLightControl kann über das Menü "Hilfe/QuiverTree-Logo beim Start anzeigen" an- oder abgeschaltet werden.
  • Beim Anlegen einer neuen und beim Öffnen einer vorhandenen Dia-Show wird die Hilfe-Seite "Fahrplan zur fertigen Dia-Show" angezeigt. Wer mit TwinLightControl hinreichend vertraut ist und diese Hilfestellung nicht mehr benötigt, kann das Anzeigen der Hilfe-Seite über das Menü "Hilfe/'Fahrplan zur fertigen Dia-Show' anzeigen" abschalten.
  • Vergessen Sie nicht, in regelmäßigen Abständen die Archiv-Dateien aller Ihrer Dia-Shows auf CD oder DVD auszulagern. Ein Festplatten-Crash kommt selten, aber immer dann, wenn man es am wenigsten vermutet (Murphy: Wenn etwas schiefgehen kann, dann geht es auch schief).
  • Undo/Redo ist zwar eine hilfreiche Sache, es hat aber auch seinen Preis. Alle seit dem letzten Sichern durchgeführten Änderungen müssen in den Speicher geschrieben und dort gehalten werden. Dadurch wird TwinLightControl beim Editieren langsamer. Wer Zwischenstände regelmäßig sichert und Undo/Redo nicht benötigt, kann es abschalten ("Bearbeiten/Undo/Redo verwenden") und TwinLightControl dadurch deutlich schneller machen.
  • Wenn zum Kalibrieren des Monitors z.B. der ColorSpyder von DataColor verwendet wird, dann läuft im Hintergrund das sog. ColorSpyder Utility. Dieses kleine Programm überwacht in einstellbaren Zeitabständen, ob durch andere Programme Änderungen an den Grafikkarteneinstellungen vorgenommen wurden, die vom aktuellen Monitorprofil abweichen. Ist das der Fall, dann lädt ColorSpyder Utility immer wieder das aktuelle Monitorprofil und hebt damit die von TwinLightControl bewirkte Abdunklung des Monitors bei einer Live-Präsentation auf. Vor einer solchen sollte man also das ColorSpyder Utility oder analoge Programme anderer Hersteller temporär ausschalten.

  • Wenn größere Entfernungen zwischen PC und Projektor zu überbrücken sind (> 10 m), dann ist es nicht empfehlenswert, ein entsprechend langes USB-Kabel zu verwenden. Durch die Leitungsverluste kommt es sehr schnell zu Übertragungsfehlern, die die Kommunikation mit dem Projektor erheblich stören oder sogar unmöglich machen können. Stattdessen sollte man folgende Konfiguration verwenden:
    PC - USB-Seriell-Adapter mit max. 2 m langem Kabel - RS232-Kabel der gewünschten Länge - Projektor
    Mit dieser Konfiguration sind auch größere Entfernungen problemlos zu überbrücken.


Der wahlfreie Zugriff auf Dias und die Realisierung in TwinLightControl

Vorweg sei bemerkt, dass die nachfolgenden Ausführungen nur den technischen Hintergrund des wahlfreien Zugriffs auf Dias beleuchten sollen. Steuert man den Projektor mittels TwinLightControl, braucht man sich um die Zusammenhänge bei der Berechnung der Bild-Nummern nicht zu kümmern, dies erledigt TwinLightControl automatisch.

Unter dem wahlfreien Zugriff auf Dias versteht man die Möglichkeit, im manuellen oder automatischen Betrieb des Projektors jederzeit auf jedes beliebige Dia zugreifen zu können.

Projektor-Betriebsart "Manuell"

In der Projektor-Betriebsart "Manuell" ist die Sache unkompliziert und schnell erklärt.

Jedes Magazin, egal ob Rollei-Koppelmagazin oder ein anderer Magazin-Typ, wird separat behandelt. Es gibt Dia-Fach-Nummern 1 ... n, je nach Magazingröße. Dia-Fach-Nummern und Bild-Nummern (so die Bezeichnung von Rollei) sind identisch. Möchte man also das Dia im Dia-Fach Nr. 75 eines CS-100-Magazins anfahren, dann gibt man über den Ziffernblock der Projektor-Tastatur den Wert "75" ein und drückt die grüne Vorwärtstaste. Die Dias 75 und 76 werden eingezogen und die Projektion wird gestartet.

Es sollten keine Bild-Nummern eingegeben werden, die größer sind, als die Magazin-Größe, das Verhalten des Projektors hängt in diesem Falle vom Magazin-Typ ab und ist nicht vorhersagbar.

Projektor-Betriebsart "Auto"

In der Projektor-Betriebsart "Auto", d.h. wenn man ein im Arbeitsspeicher des Projektors befindliches Programm ablaufen lassen will, ist die Sache komplizierter und hängt davon ab, welchen Magazin-Typ man verwendet.

Rollei-Koppelmagazine

Rollei-Koppelmagazine werden vom Projektor wie ein einziges großes Magazins mit maximal 999 Dias behandelt. Das erste Magazin hat die Dia-Fach-Nummern 1 ... 50, das zweite Magazin die Dia-Fach-Nummern 51 ... 100, das dritte Magazin 101 ... 150 usw.

In der Bedienungsanleitung zum Projektor wird auf S.37, 50, 51 beschrieben, dass die Start-Dias der einzelnen Magazine folgende sind: 1, 101, 151, 201, 251, ..., 951. Zwischen 51 und 100 gibt es also eine Lücke. Wahrscheinlich hängt dies mit der Möglichkeit zusammen, 100-er CS-Magazine verwenden zu können. Interessanterweise darf man diese Lücke bei Koppelmagazinen nicht lassen, worauf in der Bedienungsanleitung nicht hingewiesen wird. (Überhaupt ist die Bedienungsanleitung u.E. ziemlich unübersichtlich strukturiert, und an vielen Stellen muss man zwischen den Zeilen lesen können, will man einen Sachverhalt ergründen.)

Möchte man eine Dia-Show nicht mit dem ersten Magazin starten, muss man das entsprechende Magazin in den Projektor einführen und an der Projektor-Tastatur die Bild-Nummer (!) eingeben, z.B. gibt man die Bild-Nummer 234 ein, um das Dia-Fach 34 des fünften Magazins anzufahren. Nach dem Drücken der grünen Vorwärtstaste startet die Dia-Show mit Bild Nr. 234. Dabei ist darauf zu achten, dass es die Bild-Nummer 234 im Programm auch gibt, andernfalls tut nämlich der Projektor nichts.

Eine Ausnahme bildet das zweite Magazin. Möchte man die Dia-Show z.B. mit Bild-Nummer 75 starten, reicht es nicht, das zweite Magazin anzusetzen und die Bild-Nummer 75 einzugeben. Das Procedere ist etwas komplizierter. Man muss Magazin 1 ansetzen, dieses mit den Fokus-Tasten soweit vorfahren, dass man das zweite Magazin ankoppeln kann, dann die Bild-Nummer 75 eingeben und die grüne Vorwärts-Taste drücken.

Es bleibt wohl ein ewiges Geheimnis von Rollei, warum man an der Projektor-Tastatur die Bild-Nummern, und nicht die Programm-Nummern eingeben muss. Die Programm-Nummern sind nämlich eindeutig, ganz im Gegensatz zu den Bild-Nummern. Eine Bild-Nummer kann innerhalb eines Programms mehrfach vorkommen. Steuert man den Projektor über den PC, kann man glücklicherweise gezielt eine Programm-Nummer anfahren, was von TwinLightControl genutzt wird.

Nicht-Koppelmagazine

Möchte man eine Dia-Show programmieren, die aus mehreren Nicht-Koppelmagazinen besteht, muss (!) das jeweils erste Dia eines Magazins im Programm enthalten sein, d.h. das Programm muss am Anfang bzw. nach einer Null-Zeile die Dia-Nummern 1, 101, 151, 201, ..., 951 enthalten. Dies stellt u.E. eine erhebliche Einschränkung dar. Weiterhin ist es auch nicht immer möglich, eine bestimmte Bild-Nummer über die Zifferntasten des Projektors anzufahren. Arbeitet man z.B. mit CS-100-Magazinen und möchte Bild-Nummer 195 (das Dia-Fach 95 im zweiten Magazin) anfahren, erlebt man eine Überraschung. Der Projektor fährt nicht bis Dia-Fach 95, sondern nur bis Fach 45 vor (das gleiche tut er übrigens, wenn man Bild-Nummer 145 eingibt). Es ist nicht klar, ob es sich dabei um einen Fehler in der Firmware handelt, oder ob das beabsichtigt ist (aus welchen Gründen auch immer).

Wenn man die Regel, dass das jeweils erste Dia eines Magazins in der Show enthalten sein muss, nicht beachtet, kann es vorkommen, dass der Projektor beim Magazinwechsel nicht das nächste, sondern ein bestimmtes Bild aus einem der vorherigen Magazine anfährt. Diese Regel stellt u.E. eine erhebliche Einschränkung der Möglichkeit dar, verschiedene Dia-Shows aus einunddemselben Magazin erstellen zu können.

Aus den genannten Gründen wird in TwinLightControl folgendes Konzept verfolgt:

Es werden keine Bild-Nummern verwendet, die höher sind, als es der Magazingröße entspricht. Das heißt, dass jedes Magazin praktisch eine eigene Dia-Show beinhaltet. Ein Beispiel soll dies verdeutlichen, wobei angenommen wird, dass CS-100-Magazine verwendet werden:

Programm-Nr. | Dia-Fach-Nr. | Bild-Nr.
1 | 1 | 1
2 | 2 | 2
3 | 3 | 3
... | ... | ...
36 | 97 | 97
37 | 0 | Null-Zeile! (wird automatisch ezeugt)
38 | 1 | 1
39 | 3 | 3
40 | 6 | 6
... | ... | ...
86 | 0 | Null-Zeile! (wird automatisch ezeugt)

Dia-Fach-Nummer und Bild-Nummer sind also identisch. Das hat den Nachteil, dass, wenn man das Programm aus dem Modul heraus präsentiert, man z.B. nicht mit Programm-Nummer 38 starten kann, da man Bild-Nummer 1 eingeben müsste und diese nicht eindeutig ist. Wenn man aber die Dia-Show mittels TwinLightControl präsentiert, was man sowieso machen sollte, will man z.B. Audio-Dateien verwenden, gibt es (fast) keinerlei Einschränkungen. Dann kann man jede beliebige Programm-Nummer eingeben, bei der gestartet werden soll. Auch der Wechsel von einem Magazin auf das nächste funktioniert jetzt problemlos. Ein Problem bleibt bei der Verwendung von Nicht-Koppelmagazinen bestehen: bei einem Magazinwechsel muss (!) man das neue Magazin mit der PC-Fernbedienung starten, da die Projektor-Fernbedienung keine Programm-Nummern übertragen kann. Steht das Programm in einer Null-Zeile zwischen zwei Magazinen und man drückt einfach die Vor-Taste auf der Projektor-Fernbedienung, startet das Programm wieder mit dem ersten Magazin. Also: Start eines neuen Magazins immer mit der PC-Fernbedienung, danach kann man die Projektor-Fernbedienung verwenden. Dies stellt u.E. keine erhebliche Einschränkung dar, da man zum Magazinwechsel sowieso zum Projektor resp. PC gehen muss. Aufgrund des Konzepts von Rollei lässt es sich leider nicht anders machen. Die Alternative wäre (bei der von Rollei vorgeschlagenen Numerierung), dass das jeweils erste Dia eines Magazins in der Dia-Show enthalten sein muss (!). U.E. ist es das kleinere Übel, den ersten Programmschritt eines neuen Magazins mit der PC-Fernbedienung zu starten.

Präsentiert man die Dia-Show mittels PC, ist dringend zu empfehlen, die Dia-Show immer mit der PC-Fernbedienung zu starten, auch wenn man mit Programm-Nummer 1 startet. Danach kann die Projektor-Fernbedienung verwendet werden. Aus uns nicht bekannten Gründen reagiert der Projektor manchmal nicht auf die Projektor-Fernbedienung.

Vor einer Live-Dia-Show hat sich folgendes Vorgehen bewährt: man lädt die Dia-Show in den Projektor und startet sie versuchsweise. Wenn die Projektor-Fernbedienung schon in diesem Stadium nicht reagiert, sollte man den Projektor ausschalten (!) und die Show nochmals laden. Dann hat man gute Chancen, dass bis zum Ende der Show alles normal läuft. Sollte der Projektor trotzdem irgendwann nicht mehr auf seine Ferbedienung reagieren, hat man zwei Möglichkeiten: entweder man bedient den Projektor über die PC-Fernbedienung, oder man nutzt die Funktionalität des Neu-Start-Buttons.

Bei Verwendung von Nicht-Koppelmagazinen ist noch folgendes zu beachten: steht das Programm in einer Null-Zeile (Magazinwechsel) ist es nicht möglich, das Programm mit Druck auf die Ende-Taste der realen Fernbedienung zu beenden. Will man das Programm beenden, muss man dies mit der PC-Fernbedienung tun.

Viele Vorteile bietet die Benutzung einer separaten Fernbedienung. Näheres s. hier.

Für die Nutzer von Rollei-Koppelmagazinen ändert sich nichts, es bleibt alles beim alten. Koppelmagazine sind hier wieder einmal eindeutig im Vorteil, ein weiteres Argument für deren Verwendung.

Der Anwender kann über einen Schalter in den Voreinstellungen entscheiden, ob er die neue Numerierung für die Dias (Default) oder die alte Numerierung verwenden will.

Das etwas verwirrende Konzept des wahlfreien Dia-Zugriffs hätte irgendwann von Rollei einmal einer Überarbeitung unterzogen werden sollen (selbst Microsoft hat es geschafft, sich von DOS weitgehend zu lösen). Nachdem Rollei aber seine Entwicklungsabteilung für Dia-Projektoren geschlossen hat, ist dies nicht mehr zu erwarten. Schade eigentlich.

Wie am Anfang bereits erwähnt, braucht sich der Anwender um diese Dinge keine Gedanken zu machen. Er transferiert lediglich die durch Magazin- und Dia-Fach-Nummer eindeutig gekennzeichneten Dias in die Timeline, den Rest macht TwinLightControl. Die erzeugten Bild-Nummern (absolute Dia-Nummern) können sowieso nicht händisch geändert werden.

Zum Schluss noch einmal in tabellarischer Übersicht die Start-Dia-Nummern der einzelnen Magazin-Typen:

Magazin-Typ | Start-Dia-Nummern
36-er, 40-er, 50-er-Magazine | 1, 101, 151, 201, 251, 301, 351, 401, 451, 501, 551, 601, 651, 701, 751, 801, 851, 901, 951
60-er, 80-er, 100-er-Magazine | 1, 101, 201, 301, 401, 501, 601, 701, 801, 901
50-er-Rollei-Koppelmagazine | 1, 51, 101, 151, 201, 251, 301, 351, 401, 451, 501, 551, 601, 651, 701, 751, 801, 851, 901, 951
100-er-CS-Koppelmagazine (Eigenbau) | 1, 101, 201, 301, 401, 501, 601, 701, 801, 901


Begriffserklärungen

Cut (Timeline-Editor)
Ein Cut ist ein schneller Übergang (0,1 sec) von einem Dia zum nächsten. Er wird vor allem eingesetzt, um das unerwünschte Lichtkreuz beim Wechsel zwischen Quer- und Hochformat zu vermeiden.

Pause (Timeline-Editor)
Eine Pause (Standzeit 0) bedeutet, dass der Wechsel auf das nächste Dia mit der Vorwärts-Taste der Fernbedienung angestoßen werden muss.

Helligkeit (Timeline-Editor)
Das ist die Helligkeit eines Dias in % der maximalen Helligkeit (mögliche Werte in Abhängigkeit vom Projektor-Modell: 0% ... 110% für den MSC 535P, 0% ... 100% für alle anderen Modelle). Der Default-Wert für die Grundhelligkeit des Projektors wird in den Voreinstellungen festgelegt. In der Timeline kann die Helligkeit jedes Dias individuell festgelegt werden. Man sollte davon aber nur in Ausnahmefällen Gebrauch machen. Unter- oder überbelichtete Dias weisen zugelaufene Schatten oder ausgefressene Lichter aus und können und sollten damit nicht "korrigiert", sondern ausgesondert werden.

Eine Besonderheit gibt es bei der Einstellung unterschiedlicher Helligkeiten zu beachten. Angenommen, man möchte für die ersten Dias der Show folgende Helligkeiten einstellen:

1. 0% (für ein Schwarz-Dia am Anfang der Show)
2. 85% (normale Helligkeit, lampenschonend)
3. 60% (reduzierte Helligkeit für ein überbelichtetes Dia; sollte die Ausnahme sein)
4. 85% (normale Helligkeit, lampenschonend)
5. 110% (erhöhte Helligkeit für ein unterbelichtetes Dia; sollte die Ausnahme sein)

Obwohl der Steuerbefehl für die Helligkeit des ersten Dias korrekt zum Projektor übertragen wird, wird dieser vom Projektor aus uns unbekannten Gründen ignoriert. Abhilfe schafft ein kleiner Trick: man fügt am Anfang ein zweites Schwarz-Dia ein, so dass der Anfang der Show folgendermaßen aussieht:

1. 0% (für ein zusätzliches Schwarz-Dia am Anfang der Show)
2. 0% (für ein Schwarz-Dia am Anfang der Show)
3. 85% (normale Helligkeit, lampenschonend)
4. 60% (reduzierte Helligkeit für ein überbelichtetes Dia; sollte die Ausnahme sein)
5. 85% (normale Helligkeit, lampenschonend)
6. 110% (erhöhte Helligkeit für ein unterbelichtetes Dia; sollte die Ausnahme sein)


Die Verzeichnisstruktur von TwinLightControl

Bei der Installation von TwinLightControl werden im Installationsverzeichnis verschiedene Verzeichnisse erzeugt. Im einzelnen sind dies:

Verzeichnis | Inhalt
Bitmaps

Bitmap-Dateien, die von TwinLightControl benötigt werden;
in diesem Verzeichnis darf nichts verändert werden

DiaShows

Dia-Show-Dateien (*.twc);
alle Dia-Show-Dateien sollten hier abgelegt werden;
es können beliebig viele Unterverzeichnisse erzeugt werden

Archiv

Archiv-Dateien;
Archiv-Dateien sind *.zip-Dateien, die in gepackter Form
mehrere *.twc-Dateien inkl. der Verzeichnisstruktur enthalten

Help

Hilfe-Dateien, die von TwinLightControl benötigt werden;
in diesem Verzeichnis darf nichts verändert werden

Journal

Temporäre Dateien;
in diesem Verzeichnis darf nichts verändert werden

License

Lizenz-Dateien
in diesem Verzeichnis darf nichts verändert werden

PlaceHolder

Picture-Dateien, die als Platzhalter für die in der Leinwand-Simulation
benötigten Bilder dienen; näheres hierzu siehe unter Leinwand-Simulation

PlayLists | Play-Listen für den Audio-Player
AudioRecorder | Vom Audio-Recorder erzeugte *.ogg-Dateien

Für den Anwender sind also nur die Verzeichnisse DiaShows, Archiv und PlaceHolder von Interesse. Alle anderen Verzeichnisse dürfen nicht verändert werden.


Das Datei-Handling von TwinLightControl

Bei der Arbeit mit TwinLightControl sind einige Besonderheiten des Datei-Handlings zu beachten.

TwinLightControl-Dateien haben die Endung *.twc. Eine twc-Datei besteht genaugenommen aus vier Dateien:

  • einer Text-Datei mit einer allgemeinen Beschreibung der Dia-Show (Endung *.txt)
  • und drei Datenbank-Dateien, je einer für den Magazin-, Dia- und Timeline-Editor (Endung: ab Version 2.0: *.tbl, vorher: *.db)
Wenn eine twc-Datei geöffnet wird, werden die vier Dateien aus der twc-Datei generiert, wenn die twc-Datei wieder geschlossen wird, werden die vier Dateien wieder in einer twc-Datei vereinigt.

Neben der *.twc-Datei wird ein Verzeichnis mit dem gleichen Namen, aber ohne die Endung .twc erzeugt. In diesem Verzeichnis werden zwei weitere Verzeichnisse angelegt, das Verzeichnis Pictures und das Verzeichnis Audio. Dort werden Bild- bzw. Audio-Dateien abgelegt. Weitere Informationen dazu findet man unter Einfügen und Entfernen von Bild-Dateien und unter Einfügen und Entfernen von Audio-Dateien.

Um den Inhalt des Verzeichnisses DiaShows nicht zu unübersichtlich werden zu lassen, können die zu jeder *.twc-Datei gehörenden Medien-Verzeichnisse ausgeblendet (versteckt) werden. Dies geschieht mit Hilfe des Menü-Punktes "Datei/Medien-Verzeichnisse verstecken". Die Medien-Verzeichnisse werden automatisch mit gesichert, darum braucht man sich nicht zu kümmern.

Mit dem Menüpunkt "Backup-Dateien löschen" können Backup-Dateien (*.bak) in jedem beliebigen Verzeichnis, inklusive der Backup-Dateien in allen Unterverzeichnissen, gelöscht werden (normalerweise sollten sich Backup-Dateien nur im Verzeichnis "DiaShows" befinden). Das Verzeichnis, welches nach Backup-Dateien durchsucht werden soll, kann frei gewählt werden, voreingestellt ist das Programm-Verzeichnis (das Verzeichnis, in dem TwinLightControl installiert wurde). Vor dem Löschen kann man die (alphabetisch sortierte) Liste der zu löschenden Dateien noch editieren. Die Dateien werden noch nicht endgültig gelöscht, sondern nur in den Papierkorb verschoben, so dass sie ggf. wieder restauriert werden können.

*.twc-Dateien sollten nach Möglichkeit nicht auf Disketten gesichert werden. Zum einen werden, wie bereits erwähnt, beim Öffnen einer *.twc-Datei temporäre Dateien erzeugt, und das Anlegen solcher Dateien auf Diskette dauert deutlich länger als auf der wesentlich schnelleren Festplatte. Zum anderen reicht die Speicherkapazität einer Diskette nicht aus, vor allem dann, wenn Audio- und Bild-Dateien eingebunden werden. Lässt sich eine auf einer Diskette gespeicherte *.twc-Datei auch problemlos öffnen, kann es später trotzdem nicht mehr möglich sein, sie zu sichern, da die Datei bei der Bearbeitung zu groß geworden ist bzw. Audio- und Bild-Dateien hinzugekommen sind.

Eine auf einer CD-ROM gespeicherte *.twc-Datei kann nicht direkt auf CD-ROM geöffnet werden, da die bereits erwähnten temporären Dateien nicht angelegt und die geänderte Datei später nicht zurückgeschrieben werden kann. Deshalb wird bei dem Versuch, eine *.twc-Datei auf CD-ROM zu öffnen, gefragt, ob die Datei auf die Festplatte kopiert und dann geöffnet werden soll. Die fertige Datei kann man später ggf. packen (s.u.) und mit einem Brenn-Programm wieder auf CD-ROM zurücksichern.

Wenn man die *.twc-Dateien nicht auf der Festplatte ablegen will, sind Memory-Sticks (USB-Sticks) ideal zum Speichern. Sie sind i.d.R. groß und schnell genug, um die gesamte *.twc-Datei inkl. der Medien-Dateien aufzunehmen.

Mit "Datei/Packen ..." kann man eine oder mehrere *.twc-Dateien (inklusive aller Medien-Dateien) in eine Zip-Datei packen. Man wählt einfach eine oder mehrere *.twc-Dateien aus und erhält im Ergebnis die entsprechenden Zip-Dateien.

Das Entpacken einer oder mehrerer Zip-Dateien geschieht mit "Datei/Entpacken ...". Ausgewählt werden eine oder mehrere Zip-Dateien, im Ergebnis erhält man die entsprechenden *.twc-Dateien (inklusive aller Medien-Dateien).

Mit "*.twc-Dateien archivieren" kann man *.twc-Dateien innerhalb eines frei wählbaren Verzeichnisses in eine Zip-Datei packen. Normalerweise sollte man alle *.twc-Dateien innerhalb des Verzeichnisses "DiaShows" finden. Die Liste der zu packenden Dateien kann vor dem eigentlichen Packvorgang noch editiert werden. Dateien im Verzeichnis "DiaShows\emos\ werden standardmäßig nicht selektiert, man kann dies aber selbstverständlich manuell nachholen. Für die Zip-Datei wird ein eindeutiger Name der Form DiaShows(yyyy-mm-dd%hh-mm-ss).zip unter Einbeziehung des Datums und der Uhrzeit erzeugt.

Mit "Archiv-Datei wieder einspielen" kann man die eine Archiv-Datei entpacken und die darin enthaltenen *.twc-Dateien wieder an ihrem ursprünglichen Speicherort einspielen.

Das Archivieren und Dearchivieren von *.twc-Dateien ist nur innerhalb des Verzeichnisses "DiaShows" möglich. Das soll den Anwender dazu ermutigen, die *.twc-Dateien nicht irgendwo verstreut auf der Festplatte (wo man sie im Ernstfall nicht wiederfindet), sondern nur im Verzeichnis "DiaShows" abzulegen. Die Archiv-Dateien gehorchen jetzt der Namenskonvention DiaShows-Archiv(yyyy-mm-dd%hh-mm-ss).zip und werden einheitlich im neu eingeführten Verzeichnis "Archive" abgelegt. Man kann die *.zip-Dateien in diesem Verzeichnis in ein anderes Verzeichnis verschieben oder auf CD auslagern, von wo man sie im Bedarfsfall wieder einspielen kann. Man kann (muss aber nicht) die Archiv-Datei vor dem Entpacken wieder in das Verzeichnis "Archive" zurückkopieren. Noch ein Hinweis: Archiv-Dateien, die vor V2.4.6 erstellt wurden (Namenskonvention DiaShows(yyyy-mm-dd%hh-mm-ss).zip) können ebenso problemlos dearchiviert werden, wenn sie nicht von ihrem ursprünglichen Speicherort verschoben oder umbenannt wurden wurden. Wurden sie irgenwo andershin kopiert, können die Dateien nicht mehr in das ursprüngliche Verzeichnis dearchiviert werden, in einem solchen Falle sollte man die Dearchivierung manuell (z.B. mit "WinZip") vornehmen. Das ist u.a. einer der Gründe, warum die neue Art der Archivierung/Dearchivierung eingeführt wurde.

Sollte es infolge eines Fehlers zum Absturz oder zu einer abnormalen Beendigung von TwinLightControl kommen, hat man die Möglichkeit, die Einzel-Dateien wieder zusammenfügen, indem man den Menü-Eintrag "Datei/Restaurieren" wählt und im Datei-Dialog eine der vier Dateien selektiert. Die vier zusammengehörigen Einzel-Dateien werden dann wieder zu einer *.twc-Datei vereinigt.

Der Dateityp *.twc ist registriert, so dass bei einem Doppelklick auf eine *.twc-Datei TwinLightControl automatisch startet und die Datei geöffnet wird.

Das Datei-Handling gestaltet sich für den Anwender einfach und transparent. Beim Schließen einer *.twc-Datei werden alle notwendigen Dateien, also die Datenbank-Tabellen, die Bild- und die Audio-Dateien in eine einzige *.twc-Datei gepackt, beim Öffnen einer *.twc-Datei werden die oben erwähnten Dateien in die entsprechenden Verzeichnisse entpackt. Von all dem merkt der Anwender normalerweise nichts, er hat es immer nur mit einer *.twc-Datei zu tun, die er beliebig kopieren, umbenennen, löschen, verschieben usw. kann. Hat man also eine Dia-Show "MeineDiaShow.twc" mit diversen Bild- und Audio-Dateien erzeugt, sind alle notwendigen Dateien in dieser einen *.twc-Datei enthalten, die man z.B. auf eine CD-ROM brennen kann. Ohne diverse Bild- und Audio-Dateien passt das Ganze auch auf eine Diskette.

Es gibt die Möglichkeit, Bild- und Audio-Dateien beim Öffnen oder Speichern auszuschließen. Dies geschieht mit Hilfe des Menüpunktes "Datei/Medien-Dateien ausschließen". Die Verweise in der Timeline auf die Bild- und Audio-Dateien bleiben dabei erhalten, es werden lediglich die Dateien in den Verzeichnissen Pictures und Audio nicht mit ent- bzw. gepackt. Das macht die *.twc-Dateien kleiner und das Öffnen und Schließen derselben schneller. Sind die Original-Bild- und -Audio-Dateien auf dem Rechner vorhanden, können sie jederzeit restauriert werden, was automatisch geschieht. Man darf natürlich nicht vergessen, die Bild- und Audio-Dateien mit abzuspeichern, wenn man die *.twc-Datei zum Vorführen der Dia-Show verwenden will.

*.twc-Dateien, die mit einer älteren TwinLightControl-Version erstellt wurden, werden beim Öffnen automatiisch konvertiert.

Wenn, was natürlich passieren kann, TwinLightControl einmal abstürzt, sollte man wissen, wie man seine Daten retten kann. Dies geschieht mit Hilfe des bereits erwähnten Menüpunktes "Datei/Restaurieren ...".
Welche Möglichkeiten gibt es? Man sollte die folgenden Punkte in dieser Reihenfolge abarbeiten:
  • in dem erscheinenden Datei-Dialog wählt man Dateien mit der Endung *.txt, *.mg.tbl, *.sl.tbl oder *.tl.tbl; die Datenbank-Tabellen werden mit allen vorhandenen Bild- und Audio-Dateien wieder zu einer *.twc-Datei vereint; dabei sollte man folgendes wissen: wenn eine neue Dia-Show erzeugt wird, werden beim ersten Speichern die Dateien mit der Endung *.txt, *.mg.tbl, *.sl.tbl oder *.tl.tbl erzeugt; bei jedem Speichern werden diese Dateien aktualisiert; erst wenn die Datei (Dia-Show) geschlossen wird, wird aus diesen vier Dateien eine *.twc-Datei erzeugt; mit "Datei/Restaurieren ..." kann aber zu jedem Zeitpunkt eine *.twc-Datei mit dem Stand der letzten Speicherung erzeugt werden
  • in dem erscheinenden Datei-Dialog wählt man Dateien mit der Endung *.twc.bak; wenn man den Menüpunkt "Datei/Backup-Datei erzeugen" aktiviert hat (was dringend zu empfehlen ist), wird vor dem Öffnen einer *.twc-Datei eine Backup-Datei *.twc.bak erzeugt, die man restaurieren kann; damit sind natürlich alle Änderungen seit dem letzten Öffnen der *.twc-Datei verloren
  • in dem erscheinenden Datei-Dialog wählt man Dateien mit der Endung *.twc.zip; nach dem Öffnen einer *.twc-Datei wird eine Zip-Datei *.twc.zip erzeugt, die man restaurieren kann; damit sind natürlich alle Änderungen seit dem letzten Öffnen der *.twc-Datei verloren

Mi einem dieser Punkte sollte man Erfolg haben.

Abschließend ist noch eine Bemerkung notwendig: wenn man eine *.twc-Datei geöffnet hat, werden in dem Verzeichnis, in dem sich die Datei befindet, verschiedene weitere Dateien und Verzeichnisse erzeugt. Diese sollte man auf keinen Fall in irgendeiner Weise manipulieren, ansonsten sägt man sich den Ast ab, auf dem man sitzt.

Gelegentlich hat man den Fall vorliegen, dass man eine Dia-Show in zwei Teilen erstellt hat und diese beiden Teile nun zu einer einzigen Dia-Show zusammenfügen möchte. Dazu wählt man den Menüpunkt "Datei/Dia-Show zusammenfügen". Es erscheinen nacheinander zwei Datei-Dialoge, in denen man die beiden zusammzufügenden Dia-Shows in der gewünschten Reihenfolge auswählt. Der Rest geschieht automatisch. Am Ende ist nur noch der der Timeline-Check für die erzeugte Dia-Show zu vollziehen und das Ganze abzuspeichern.

Beim Öffnen bzw. Erzeugen einer *.twc-Datei wird automatisch der Dialog zur Eingabe der Dia-Show-Beschreibung geöffnet. Wer das nicht wünscht, kann es unter "Datei/Dia-Show-Beschreibung anzeigen" abschalten.

Wichtige Hinweise für Benutzer von Windows Vista und Windows 7!

Unter Windows Vista und Windows 7 gibt es neue Richtlinien für das Dateisystem. Abhängig davon,ob man als Administrator oder als normaler Benutzer angemeldet ist, hat man unterschiedliche Dateizugriffsrechte. Ein normaler Benutzer darf z.B.in das Programmverzeichnis (normalerweise "C:\Programme") keine Daten schreiben. Versucht er dies dennoch, kommt die sog. Dateivirtualisierung ins Spiel. Die Daten werden dann z.B. nicht ins Verzeichnis C:\Programme\QuiverTree\TwinLightControl\" geschrieben, sondern in ein Verzeichnis "...\User\AppData\Local\VirtualStore\Program Files (x86)\QuiverTree\TwinLightControl\". Dort kann TwinLightControl die Daten natürlich nicht finden, und es kommt zu unerklärlichen Reaktionen des Programms.

Deshalb werden ab Windows Vista die für das Funktionieren von TwinLightControl erforderlichen Dateien in unterschiedlichen Verzeichnissen abgelegt. Bis einschl. Windows XP waren alle Dateien im Programmverzeichnis (normalerweise C:\Programme\QuiverTree\TwinLightControl") zu finden. Ab Windows Vista werden die Verzeichnisse folgendermaßen abgelegt:

Archiv | {userdocs}\Archiv
AudioRecorder | {userdocs}\AudioRecorder
Bitmaps | {userappdata}\Bitmaps
DiaShows | {userdocs}\DiaShows
Download | {userappdata}\Download
Help | {app}\Help
Journal | {userappdata}\Journal
License | {userappdata}\License
PlaceHolder | {userdocs}\PlaceHolder
PlayLists | {userdocs}\PlayLists

Hinter den symbolischen Verzeichnisnamen verbirgt sich folgendes (kann je nach System variieren):

{app} | Installationsverzeichnis, z.B. C:\Programme (x86)\QuiverTree\TwinLightControl
{userdocs} | Eigene Dateien des aktiven Benutzers, z.B. C:\...\User-xxx\Eigene Dateien\QuiverTree\TwinLightControl
{userappdata} | Anwendungsdaten des aktiven Benutzers, z.B. C:\...\User-xxx\Anwendungsdaten\QuiverTree\TwinLightControl

Alle anderen Dateien befinden sich wie bisher im Programmverzeichnis (Installationsverzeichnis).

Für den normalen TwinLightControl-Benutzer sind nur die Verzeichnisse Archiv, AudioRecorder, DiaShows, PlaceHolder und PlayLists interessant. Dort befinden sich die eigentlichen DiaShow-Dateien, archivierte DiaShow-Dateien, mit dem AudioRecorder aufgenommene Tracks, Platzhalter für Bilder und Play-Listen für den AudioPlayer.

Die Anpassung an Window Vista / Windows 7 wurde mit Version 5.0.1 vorgenommen. Um sie so einfach wie möglich zu gestalten, werden bei der Installation auf dem Computer bereits vorhandene Daten in die richtigen Verzeichnisse verschoben. Aus Sicherheitsgründen wird dringend empfohlen, vor der Installation ein Backup des Verzeichnisses DiaShows vorzunehmen, um Datenverluste zu vermeiden. Außerdem sollte nach der Installation der gesamte Computer noch einmal nach TwinLightControl-Daten durchsucht und überprüft werden, ob sie sich am richtigen Platz befinden (s.o.). Man beachte dabei, dass das Verzeichnis {userappdata} normalerweise nicht sichtbar ist, man muss es also ggf. im Explorer erst sichtbar machen.


Die Undo- und Redo-Funktionen von TwinLightControl

Jedes gute Programm sollte eine Undo-/Redo-Funktion anbieten, damit Änderungen jederzeit rückgängig gemacht oder widerrufen werden können.

Bitte lesen Sie diesen Abschnitt genau durch, damit Sie das Wesen der Undo-/Redo-Funktionalität verstehen.

Sämtliche an einer *.twc-Datei vom Anwender vorgenommenen Änderungen werden in einer speicherbasierten Liste, der Undo-Liste, notiert. In dieser Liste kann man bei Bedarf beliebig vorwärts oder rückwärts blättern. Da die Liste im Speicher gehalten wird, sind die Undo-/Redo-Operationen schneller. Die Zahl der Undo-Redo-Schritte ist beliebig groß und letztendlich nur vom Speicherausbau des Rechners abhängig.

Folgende Besonderheiten sind bei der Verwendung von Undo/Redo zu beachten:

  • Trotz Undo/Redo sollte man seine Arbeit in regelmäßigen Abständen sichern. Bei einem Absturz des Programms oder Rechners sind alle vorgenommenen Änderungen weg.
  • Der Anwender kann entscheiden, ob er Undo/Redo verwendet, was dringend zu empfehlen ist. Vom Ausschalten der Undo-Redo-Funktionalität (Menüpunkt "Bearbeiten->Undo/Redo verwenden") sollte nur dann Gebrauch gemacht werden, wenn TwinLightControl auf einem langsamen oder mit wenig Speicher ausgestatteten Rechner läuft.
  • Undo/Redo kann nur ein- oder ausgeschaltet werden, wenn keine Datei geöffnet ist.
  • Wenn an einer *.twc-Datei irgendeine Änderung vorgenommen wird, wird die Undo-Liste um einen Eintrag erweitert, und "Undo" ist verfügbar.
  • Sobald man in der Undo-Liste zurückblättert, ist auch "Redo" verfügbar.
  • In den Kurzhinweisen zu den Toolbuttons "Undo" bzw. "Redo" sowie im Text der entsprechenden Menüpunkte wird die momentane Zahl der vorgenommenen Änderungen und die Stelle, wo man sich gerade in der Undo-Liste befindet (Undo-Ebene), angezeigt.
  • Blättert man in der Undo-Liste zurück und führt dann eine neue Änderung durch, werden alle Änderungen hinter der, wo man sich in der Undo-Liste gerade befindet, verworfen. Das ist wichtig zu wissen, um die Undo-Redo-Funktionalität zu verstehen. Würde man nämlich die weiter hinten in der Undo-Liste stehenden Änderungen nicht verwerfen, müsste man eine baumartige Listenstruktur aufbauen, was nicht nur fehleranfällig, sondern nach kurzer Zeit vom Anwender nicht mehr zu durchschauen wäre.
  • Beim Speichern einer Datei wird der Stand gesichert, der dem Eintrag in der Undo-Liste entspricht, bei dem man sich gerade befindet. Das entspricht dem, was man am Bildschirm gerade sieht. Hat man "nur so aus Spaß" in der Undo-Liste mal zurückgeblättert und speichert dann, werden alle später gemachten Änderungen verworfen (s.o.). Befindet man sich auf der Undo-Ebene 0 (alle Änderungen wurden rückgängig gemacht) und schließt die Datei, gehen ohne Nachfrage alle Änderungen verloren. Dieser Tatsachen sollte man sich bei der Verwendung von Undo/Redo bewusst sein.
  • Beim Speichern einer Datei werden alle Einträge in der Undo-Liste verworfen, man beginnt also praktisch wieder mit einem "leeren Blatt".
  • Wenn man sich sicher ist, dass man die momentan in der Undo-Liste gespeicherten Änderungen nicht mehr braucht, kann man die Einträge in der Undo-Liste gezielt verwerfen (Menüpunkt "Bearbeiten->Undo-Liste verwerfen"). Dabei wird der von der Undo-Liste belegte Speicher freigegeben. Veranlassung zu diesem Schritt sollte eigentlich nur dann bestehen, wenn die Undo-Liste so groß geworden ist, dass der Rechner beginnt, den Speicherinhalt temporär auf die Platte auszulagern (Swap-File). Soweit sollte man es aber sowieso nicht kommen lassen, indem man in regelmäßigen Abständen seine Arbeit sichert und so die Undo-Liste immer wieder leert.
  • Der für Undo/Redo verwendete Speicher wird in den Kurzhinweisen zu den entsprechenden Tool-Buttons und in der Statuszeile am unteren Bildschirmrand angezeigt. Wenn der verwendete Speicher zu groß wird, gibt TwinLightControl eine Warnung aus, die dazu veranlassen sollte, die *.twc-Datei zu sichern und damit wieder Speicher freizugeben.

Dem aufmerksamen Anwender wird sicher aufgefallen sein, dass viele Editier-Operationen bei eingeschaltetem Undo/Redo etwas langsamer sind. Warum das so ist, soll an einem Beispiel erläutert werden.

Angenommen, man möchte aus dem Dia-Editor ein Dia herausnehmen, indem man im Feld "Belegt" das Häkchen entfernt. Dann muss zunächst der aktuelle Dia-Datensatz in die Undo-Liste geschrieben werden. Gleiches gilt für den aktuellen Magazin-Datensatz, da sich das Datum "Anzahl der belegten Dia-Fächer" ändert, welches Bestandteil des Magazin-Editors ist. Dann muss geprüft werden, ob sich das Dia, welches gerade entfernt wurde, bereits in der Timeline befand, möglicherweise mehrfach. Wenn dem so ist, müssen das oder die Dias aus der Timeline entfernt und die Timeline vor und nach der Änderung in die Undo-Liste geschrieben werden. Das alles benötigt Zeit (vor allem die Suchoperationen), und zwar um so mehr, je mehr Dias sich bereits im Dia- und Timeline-Editor befinden.

Die im Dia-Editor eingetragenen Bild-Dateien sind integraler Bestandteil der Dia-Tabelle. Das hat den Vorteil, dass man keine separaten Bild-Dateien handeln muss, es hat aber den Nachteil, dass bei manchen Undo-Operationen immer die gesamte Dia-Tabelle inkl. aller Bilder gesichert werden muss. Bei einigen hundert Bildern braucht das Zeit und viel Speicher. Wenn man also viele Bilder integriert hat, sollte man entweder die JPEG-Qualität der Bilder verringern (Voreinstellungen->JPEG-Qualität der Bilder, Standardwert: 75, noch brauchbarer Wert: 25), oder man sollte Undo/Redo abschalten (Menü Bearbeiten->Undo/Redo verwenden; ist nur aktiv, wenn keine Datei geöffnet ist).

Man sollte also (nicht nur aus diesem Grund) die Dia-Show im voraus einigermaßen gut planen. So sollte man zuerst soviel Magazine in die Show einbauen, wie man voraussichtlich benötigt, und die entsprechenden Änderungen vornehmen (Magazin-Typ, ...). Danach sollten alle notwendigen Änderungen im Dia-Editor vorgenommen werden (Belegt, Dia-Format, Kommentar, Bild-Dateien). Erst am Schluss sollte man die gewünschten Dias in die Timeline einfügen und die betreffenden Felder dort ändern. Man muss sich natürlich nicht an diese Reihenfolge halten und kann jede Operation zu jedem beliebigen Zeitpunkt durchführen, muss dann aber in Kauf nehmen, dass die Editier-Operationen etwas langsamer sind.

Wer sich sicher ist, dass er Undo/Redo nicht benötigt, sollte es abschalten, viele Editier-Operationen sind dann schneller. Selbstverständlich bleibt die Einstellung "Undo/Redo verwenden", wie auch alle anderen Einstellungen, über die Beendigung von TwinLightControl hinaus erhalten, da alle Einstellungen bei der Beendigung von TwinLightControl in die Registry geschrieben und beim Start wieder gelesen werden.


Allgemeine Bemerkungen zum Editieren von Zellen im Magazin-, Dia- und Timeline-Editor

Die Zellen im Magazin-, Dia- oder Timeline-Editor sind je nach Kontext editierbar oder nicht. Nicht editierbare Zellen können entweder nicht in den Edit-Modus versetzt werden (z.B. Magazin-Nummer, Dia-Nummer, Programm-Nummer, ...) oder die Zellen sind grau hinterlegt, nämlich dort, wo der zur Zelle gehörende Wert keine Sinn macht (z.B. der Zähler bei normaler Überblendung).

In den Edit-Modus einer Zelle gelangt man, indem man die Zelle selektiert und

  • die Taste F2 drückt oder
  • die Eingabetaste (RETURN) drückt oder
  • mehrmals mit der linken Maustaste in die Zelle klickt oder
  • einfach beginnt, mit der Tastatur zu schreiben
Der Edit-Modus als solcher ist an der Form des Cursors eindeutig zu erkennen.

Die Werte einer Zelle können geändert werden, indem man
  • einfach einen Wert eingibt; bei Gleitkomma-Werten ist zu beachten, dass das Komma und nicht der Dezimalpunkt verwendet wird; unzulässige Werte werden mit einer Fehlermeldung quittiert
  • mit Hilfe des Buttons [image] einen Eintrag aus einer Liste von Strings auswählt; Shortcuts: Aufklappen der Liste mit RETURN, Auswahl mit Pfeiltasten und erneut RETURN
  • mit Hilfe des Buttons [image] einen Wahr- oder Falsch-Wert auswählt; die Leer-Taste und die Eingabe-Taste toggelt zwischen beiden Werten
  • mit Hilfe des Buttons [image] (Ellipse) einen Dialog aufruft, der die Festlegung eines sinnvollen Wertes erlaubt (Dialog zur Festlegung der Überblend- und Standzeiten); Tastenkürzel: Strg+RETURN, nachdem der integrierte Editor aktiviert wurde; bei niedrigen Bildschirmauflösungen hat das in dem Dialog enthaltene Bild Scrollbalken; ein Doppelklick auf das Bild zeigt es in voller Größe
Geänderte Werte einer Zelle werden übernommen, indem man
  • die Eingabetaste drückt oder
  • zu einem anderen Datensatz wechselt oder
  • der Tabelle den Eingabe-Fokus entzieht (durch Wechsel zu einem anderen Steuerelement)
Geänderte Werte einer Zelle werden verworfen, indem man
  • die Taste ESC drückt
Bei der Mehrfachauswahl von Zeilen im Magazin-, Dia- und Timeline-Editor ist es mitunter lästig, mit der Maus zum vertikalen Scrollbalken wechseln zu müssen, um weitere Einträge sichtbar zu machen. Deshalb kann auf Wunsch "Automatisches Scrollen" eingeschaltet werden (Menüpunkt Bearbeiten/Automatisches Scrollen). Das automatische Scrollen funktioniert folgendermaßen:

Selektiert man im Editor den ersten bzw. letzten sichtbaren Eintrag, dann wird automatisch, sofern möglich, um drei Zeilen nach oben bzw. unten gescrollt. Hält man die Strg-Taste gedrückt, hat bereits Einträge selektiert und bewegt die Maus etwas oberhalb bzw. unterhalb der ersten bzw. letzten sichtbaren Zeile, so wird, sofern möglich, kontinuierlich nach oben bzw. unten gescrollt.

Ist das Optionsfeld "Synchronisieren: Magazin mit Dia" gewählt, wird beim Scrollen im Dia-Editor bei einem Wechsel zu einem anderen Magazin im Magazin-Editor mitgescrollt. Das gilt natürlich nur dann, wenn im Dia-Editor das Optionsfeld "Alle Magagzine" gewählt ist.

Ist das Optionsfeld "Synchronisieren: Timeline mit Magazin" gewählt, wird beim Scrollen im Magazin-Editor das erste Dia aus dem betreffenden Magazin im Timeline-Editor gesucht und - sofern vorhanden - dorthin gescrollt. Diese Option verlangsamt allerdings das Scrollen im Magazin-Editor erheblich, vor allem, wenn die Timeline viele Dias enthält, und sollte nur dann gewählt werden, wenn man sie wirklich benötigt.

Es ist möglich, im Magazin-, Dia- und Timeline-Editor jede einzelne Spalte separat anzuzeigen bzw. zu verstecken. So kann man ggf. einzelne Spalten, die man nicht immer benötigt, ausblenden, um mehr Platz für andere zu schaffen. Dazu hält man die Umschalt-Taste gedrückt und klickt mit der linken Maustaste in die Titelzeile der betreffenden Spalte (z.B. Magazin-Typ). Alternativ kann man im gerade aktiven Editor die Taste F7 drücken. In dem erscheinenden Dialog kann man die Spalten wählen, die man anzeigen bzw. verstecken möchte. Die Breite der Spalten kann man verändern, indem man mit der Maus in der Titelzeile die Grenze zwischen zwei Spalten verschiebt. Mit dem Button "Spalten-Breite an Inhalt anpassen" wird die Spalten-Breite aller sichtbaren Spalten automatisch so angepasst, dass der Inhalt der Kopfzeile und der einzelnen Zellen vollständig sichtbar ist.

Im Dia- und Timeline-Editor (Felder Dia-Format, Licht-Sonderfunktion und Audio-Funktion) kann man sich kleine Piktogramme anzeigen lassen. Dieses Feature kann im entsprechenden Dialog zur Anzeige des Editors (F7) an- bzw. abgeschaltet werden.

In den Dialogen für die Spaltenbreite des Magazin-, Dia- oder Timeline-Editors (Kontext-Menü oder F7) kann auch die Höhe der Zeilen eingestellt werden. Die Zeilenhöhe wird dabei als Vielfaches der normalen Zeilenhöhe angegeben. Es sind Werte von 1 bis 10 möglich. Im Dia-Editor ist eine größere Zeilenhöhe u.U. sinnvoll, um die Bilder besser sehen zu können. In allen drei Editoren erzwingt eine größere Zeilenhöhe den Umbruch langer Kommentarzeilen, so dass diese auf einen Blick sichtbar sind.

Magazin-, Dia- und Timeline-Editor werden automatisch fokussiert, sobald die Maus in den entsprechenden Editor bewegt wird. Damit entfällt das Klicken in den Editor, um ihn zu aktivieren. Diese Option ist an-/abschaltbar (Menü: "Bearbeiten/Automatisches Fokussieren"). Die automatische Fokussierung wird in folgenden Fällen abgeschaltet:
  • die grafische Darstellung der Timeline ist geöffnet
  • die virtuelle Fernbedienung ist geöffnet und der Live-Modus ist nicht aktiv

An geeigneter Stelle werden Ballon-Tips verwendet, die wahlweise ein- oder ausgeschaltet werden können (Menü Bearbeiten/Ballon-Tips verwenden).


Tastenkürzel und Maus-Klicks für die Dia-Show

Folgende Tastenkürzel und Maus-Klicks sind für die Dia-Show verfügbar:

Datei

Strg + N | Neue Datei
Strg + O | Datei öffnen
Strg + W | Datei wieder öffnen (zuletzt gespeicherte Version)
Strg + S | Datei speichern
Umsch + Strg + S | Datei speichern unter
Alt + F3 | Datei schließen
Alt + F4 | Programm beenden

Bearbeiten

Strg + Z | Rückgängig (Undo)
Strg + Y | Widerrufen (Redo)
Strg + X | Ausschneiden
Strg + C | Kopieren
Strg + V | Einfügen
Strg + F

Suchen
(im Magazin-, Dia- oder Timeline-Editor nach Datensätzen suchen,
die den gewünschten Such-String im Kommentar-Feld enthalten)

Strg + H | Ersetzen
Strg + G

Gehe zu ...

  • Magazin-Editor: Magazin-Nummer oder Archiv-Nummer
  • Dia-Editor: Magazin-Nummer und Dia-Fach-Nummer
  • Timeline-Editor: Programm-Nummer oder Magazin-
    und Dia-Fach-Nummer oder absolute Dia-Nummer

Dia-Show

Alt + B | Beschreibung der Dia-Show
Alt + V | Voreinstellungen
Alt + I | Dia-Show-Info
Alt + R | Bericht zur Dia-Show
Alt + L | Bilder (wenn vorhanden) zum Dia anzeigen
Alt + W | Dia-Show-Wizard aufrufen

Allgemeines

Buttons, Menüs und Kontext-Menüs eines Editors werden erst dann aktiviert, wenn der Editor den Eingabefokus besitzt.
Ein Editor erhält den Eingabefokus folgendermaßen:

Strg + 1 oder Links-Klick in einen freien Bereich der Magazin-GroupBox | Eingabefokus in den Magazin-Editor
Strg + 2 oder Links-Klick in einen freien Bereich der Dia-GroupBox | Eingabefokus in den Dia-Editor
Strg + 3 oder Links-Klick in einen freien Bereich der Timeline-GroupBox | Eingabefokus in den Timeline-Editor

Hilfe

F1 | Hilfe
F12 | Bedienelemente im Windows XP Stil (dieser Modus ist langsam und auf älteren Computern nicht zu empfehlen)


Tastenkürzel und Maus-Klicks im Magazin-Editor

Folgende Tastenkürzel sind im Magazin-Editor verfügbar:

Allgemeines

Strg + 1 oder Links-Klick in einen freien Bereich der Magazin-GroupBox | Eingabefokus in den Magazin-Editor
Umsch + Links-Klick in die Spaltenüberschrift des Magazin-Editors | Dialog für Spalten ein- / ausblenden aufrufen
F7 | dito
Strg + Links-Klick in die Spaltenüberschrift des Magazin-Editors | Magazin-Editor vergrößern / verkleinern (der Mauszeiger verändert seine Form)
F5 | dito
Alt + Links-Klick in die Spaltenüberschrift des Magazin-Editors | Magazin-Editor-Breite vergrößern / verkleinern (der Mauszeiger verändert seine Form)
F6 | dito
Strg + + | Alle Spalten anzeigen (expandieren)
Strg + - | Alle Spalten verstecken (kontrahieren)

Magazine einfügen

Einfg | Neues Magazin vor der aktuellen Cursorposition einfügen
Strg + Einfg | Neues Magazin ans Ende anfügen
Umsch + Einfg | Leeres Magazin vor der aktuellen Cursorposition einfügen
Umsch + Strg + Einfg | Leeres Magazin ans Ende anfügen

Magazine entfernen

Alt + Entf | Aktuelles Magazin löschen
Strg + Entf | Alle selektierten Magazine oder aktuelles Magazin löschen
Umsch + Entf | Alle Magazine löschen

Magazine selektieren

Umsch + Pfeil-Auf / Pfeil-Ab | Einzelne Magazine selektieren
Strg + A | Alle Magazine selektieren
Strg + D, ESC | Alle Selektionen aufheben

Sonstiges

Strg + M | Wechsel der Magazin-Typen zwischen 50-er Normal-Magazinen und Rollei-Koppelmagazinen
Strg + K | Den Kommentar des jeweils ersten und letzten Dias eines Magazins als Kommentar für das Magazin übernehmen

Navigation

TAB
  • Ins nächste Feld des aktuellen Datensatzes wechseln
  • Ist das Ende des Datensatzes erreicht, wird zum nächsten gewechselt
  • Am Ende des letzten Datensatzes wird abgefragt, ob ein neues Magazin
    angehängt werden soll
  • Mit der TAB-Taste sind nur die Felder erreichbar,
    deren Werte verändert werden können
Umsch + TAB
  • Ins vorhergehende Feld des aktuellen Datensatzes wechseln
  • Ist der Anfang des Datensatzes erreicht, wird zum vorhergehenden gewechselt
  • Mit der TAB-Taste sind nur die Felder erreichbar,
    deren Werte verändert werden können
Pfeil-Links | Innerhalb des aktuellen Datensatz ins vorhergehende Feld wechseln
Pfeil-Rechts | Innerhalb des aktuellen Datensatz ins nachfolgende Feld wechseln
Pfeil-Auf | Zum vorhergehenden Datensatz wechseln
Pfeil-Ab | Zum nachfolgenden Datensatz wechseln
Bild-Auf | Mehrere Datensätze nach oben springen
Bild-Ab | Mehrere Datensätze nach unten springen
Strg + Bild-Auf | Zum ersten sichtbaren Datensatz in der Tabelle springen
Strg + Bild-Ab | Zum letzten sichtbaren Datensatz in der Tabelle springen
Pos1 | Innerhalb des aktuellen Datensatz zum ersten Feld springen
Ende | Innerhalb des aktuellen Datensatz zum letzten Feld springen
Strg + Pos1 | Zum ersten Datensatz springen
Strg + Ende | Zum letzten Datensatz springen
Mausrad | 3 Zeilen aufwärts/abwärts Scrollen
Strg + Mausrad | 10 Zeilen aufwärts/abwärts Scrollen

Editieren

RETURN
  • Editor aktivieren / deaktivieren
  • Wenn man in einem Feld zu schreiben beginnt, wird der Editor automatisch aktiviert
  • In einem Listenfeld wird mit RETURN der momentane Eintrag übernommen
F2 Editor aktivieren
Leertaste
  • Editor aktivieren
  • bei Listenfeldern: Liste aufklappen
  • bei Optionsfeldern: Wert toggeln (umschalten)

Alle Befehle sind auch über das Kontext-Menü (rechte Maustaste) erreichbar.


Tastenkürzel und Maus-Klicks im Dia-Editor

Folgende Tastenkürzel und Maus-Klicks sind im Dia-Editor verfügbar:

Allgemeines

Strg + 2 oder Links-Klick in einen freien Bereich der Dia-GroupBox | Eingabefokus in den Dia-Editor
Umsch + Links-Klick in die Spaltenüberschrift des Dia-Editors | Dialog für Spalten ein- / ausblenden aufrufen
F7 | dito
Strg + Links-Klick in die Spaltenüberschrift des Dia-Editors | Dia-Editor vergrößern/verkleinern (der Mauszeiger verändert seine Form)
F5 | dito
Alt + Links-Klick in die Spaltenüberschrift des Dia-Editors | Dia-Editor-Breite vergrößern/verkleinern (vorteilhaft beim Ein-/Anfügen von Dias in die Timeline; der Mauszeiger verändert seine Form)
F6 | dito

Dias in die Timeline einfügen

Einfg | Markierte Dias oder aktuelles Dia vor der aktuellen Cursorposition in die Timeline einfügen
Strg + Einfg | Markierte Dias oder aktuelles Dia ans Ende der Timeline anfügen

Dias verschieben

Umsch + Bild-Auf | Alle Dias ab der momentanen Position nach vorn verschieben (zu kleineren Dia-Fach-Nummern)
Umsch + Bild-Ab | Alle Dias ab der momentanen Position nach hinten verschieben (zu größeren Dia-Fach-Nummern)
Strg + G | Ein einzelnes Dia oder eine Gruppe von zusammenhängenden Dias verschieben
Strg + M | In der Timeline nicht benutzte Dias als "Nicht belegt" markieren
Strg + L | Lücken (nicht belegte Dia-Fächer) in Magazinen schließen

Dias selektieren

Umsch + Pfeil-Auf / Pfeil-Ab | Einzelne Dias selektieren
Strg + A | Alle Dias selektieren
Strg + B | Belegte Dia-Fächer selektieren
Strg + D, ESC | Alle Selektionen aufheben

Bilder anzeigen/einfügen / entfernen

Alt + L | Bilder zum Dia anzeigen
Strg + I | Eine Bild-Datei zum Dia suchen und einfügen
Strg + E | Die Bild-Datei zum Dia entfernen

Sonstiges

Alt + A | "Alle Magazine" an-/abwählen (toggeln); es werden alle Dias im aktuellen Magazin oder alle Dias in allen Magazinen angezeigt
Alt + K | Den Kommentar vom vorhergehenden Dia übernehmen; der Cursor muss in der Kommentar-Spalte stehen
Strg + Alt + K | Bis zur aktuellen Position alle Kommentare vom letzten Dia mit Kommentar übernehmen; der Cursor muss in der Kommentar-Spalte stehen
Strg + C und Strg + V (Standard-Tastenkürzel) | Kopieren und Einfügen in einer Zelle; dazu muss die Zelle im Editier-Modus sein

Navigation

TAB
  • Ins nächste Feld des aktuellen Datensatzes wechseln
  • Ist das Ende des Datensatzes erreicht, wird zum
    nächsten gewechselt
  • Mit der TAB-Taste sind nur die Felder erreichbar,
    deren Werte verändert werden können
Umsch + TAB
  • Ins vorhergehende Feld des aktuellen Datensatzes wechseln
  • Ist der Anfang des Datensatzes erreicht, wird zum
    vorhergehenden gewechselt
  • Mit der TAB-Taste sind nur die Felder erreichbar,
    deren Werte verändert werden können
Pfeil-Links | Innerhalb des aktuellen Datensatz ins vorhergehende Feld wechseln
Pfeil-Rechts | Innerhalb des aktuellen Datensatz ins nachfolgende Feld wechseln
Pfeil-Auf | Zum vorhergehenden Datensatz wechseln
Pfeil-Ab | Zum nachfolgenden Datensatz wechseln
Bild-Auf | Mehrere Datensätze nach oben springen
Bild-Ab | Mehrere Datensätze nach unten springen
Strg + Bild-Auf | Zum ersten sichtbaren Datensatz in der Tabelle springen
Strg + Bild-Ab | Zum letzten sichtbaren Datensatz in der Tabelle springen
Pos1 | Innerhalb des aktuellen Datensatz zum ersten Feld springen
Ende | Innerhalb des aktuellen Datensatz zum letzten Feld springen
Strg + Pos1 | Zum ersten Datensatz springen
Strg + Ende | Zum letzten Datensatz springen
F11
  • Gehe zum (ersten) zugehörigen Programmschritt
    (sofern vorhanden) im Timeline-Editor
  • Mit F11 kann man bequem zwischen Dia- und
    Timeline-Editor     toggeln
Mausrad | 3 Zeilen aufwärts/abwärts Scrollen
Strg + Mausrad | 10 Zeilen aufwärts/abwärts Scrollen

Editieren

RETURN
  • Editor aktivieren/deaktivieren
  • Wenn man in einem Feld zu schreiben beginnt,
    wird der Editor automatisch aktiviert
  • In einem Listenfeld wird mit RETURN der
    momentane Eintrag übernommen
F2 Editor aktivieren
Leertaste
  • Editor aktivieren
  • Bei Listenfeldern: Liste aufklappen
  • Bei Optionsfeldern: Wert toggeln (umschalten)

Alle Befehle sind auch über das Kontext-Menü (rechte Maustaste) erreichbar.


Tastenkürzel und Maus-Klicks im Timeline-Editor

Folgende Tastenkürzel und Maus-Klicks sind im Timeline-Editor verfügbar:

Allgemeines

Strg + 3 oder Links-Klick in einen freien Bereich der Timeline-GroupBox | Eingabefokus in den Timeline-Editor
Umsch + Links-Klick in die Spaltenüberschrift des Timeline-Editors | Dialog für Spalten ein- / ausblenden aufrufen
F7 | dito
Strg + Links-Klick in die Spaltenüberschrift des Timeline-Editors | Timeline-Editor vergrößern/verkleinern (der Mauszeiger verändert seine Form)
F5 | dito
Strg + + | Alle Spalten anzeigen (expandieren)
Strg + - | Alle Spalten verstecken (kontrahieren)

Programmschritte entfernen

Alt + Entf | Aktuellen Programmschritt löschen
Strg + Entf | Alle selektierten Programmschritte oder aktuellen Programmschritt löschen
Umsch + Entf | Alle Programmschritte löschen

Programmschritte verschieben

Umsch + Bild-Auf | Programmschritte in der Timeline nach vorn verschieben (zu kleineren Programm-Nummern)
Umsch + Bild-Ab | Programmschritte in der Timeline nach hinten verschieben (zu größeren Programm-Nummern)

Programmschritte selektieren

Umsch + Pfeil-Auf / Pfeil-Ab | Einzelne Programmschritte selektieren
Strg + A | Alle Programmschritte selektieren
Strg + D, ESC | Alle Selektionen aufheben

Sonstiges

Strg + U | Überblend-Eigenschaften der selektierten Programmschritte editieren
Strg + T | Timeline-Check
Alt + L | Bilder zum Dia anzeigen
Strg + P | Audio-Datei zum Programmschritt abspielen
Strg + I | Audio-Datei zum Programmschritt einfügen
Strg + E | Audio-Datei zum Programmschritt entfernen

Navigation

TAB
  • Ins nächste Feld des aktuellen Datensatzes wechseln
  • Ist das Ende des Datensatzes erreicht, wird zum nächsten gewechselt
  • Mit der TAB-Taste sind nur die Felder erreichbar, deren Werte verändert werden können
Umsch + TAB
  • Ins vorhergehende Feld des aktuellen Datensatzes wechseln
  • Ist der Anfang des Datensatzes erreicht, wird zum vorhergehenden gewechselt
  • Mit der TAB-Taste sind nur die Felder erreichbar, deren Werte verändert werden können
Pfeil-Links | Innerhalb des aktuellen Datensatz ins vorhergehende Feld wechseln
Pfeil-Rechts | Innerhalb des aktuellen Datensatz ins nachfolgende Feld wechseln
Pfeil-Auf | Zum vorhergehenden Datensatz wechseln
Pfeil-Ab | Zum nachfolgenden Datensatz wechseln
Bild-Auf | Mehrere Datensätze nach oben springen
Bild-Ab | Mehrere Datensätze nach unten springen
Strg + BildAuf | Zum ersten sichtbaren Datensatz in der Tabelle springen
Strg + BildAb | Zum letzten sichtbaren Datensatz in der Tabelle springen
Pos1 | Innerhalb des aktuellen Datensatz zum ersten Feld springen
Ende | Innerhalb des aktuellen Datensatz zum letzten Feld springen
Strg + Pos1 | Zum ersten Datensatz springen
Strg + Ende | Zum letzten Datensatz springen
F11 Gehe zum zugehörigen Dia im Dia-Editor;
mit F11 kann man bequem zwischen Dia- und Timeline-Editor toggeln
Umsch + F9 | Zum vorhergehenden Positions-Marker springen
Umsch + F10 | Zum nachfolgenden Positions-Marker springen
Strg + Umsch + F9 | Einen Positions-Marker toggeln (setzen/entfernen)
Strg + Umsch + F10 | Alle Positions-Marker entfernen
Mausrad | 3 Zeilen aufwärts/abwärts Scrollen
Strg + Mausrad | 10 Zeilen aufwärts/abwärts Scrollen

Editieren

RETURN | Editor aktivieren/deaktivieren; wenn man in einem Feld zu schreiben beginnt, wird der Editor automatisch aktiviert; in einem Listenfeld wird mit RETURN der momentane Eintrag übernommen
F2 | Editor aktivieren
Leertaste | Editor aktivieren; bei Listenfeldern: Liste aufklappen; bei Optionsfeldern: Wert toggeln (umschalten)
Strg+RETURN | bei aktiviertem Editor: Dialog zur Festlegung von Überblend- und Standzeiten aufrufen


Tastenkürzel und Maus-Klicks in der virtuellen Fernbedienung

Folgende Tastenkürzel und Maus-Klicks sind in der virtuellen Fernbedienung verfügbar (die Tastenkürzel des Audio-Players werden übernommen):

Strg + Bild-Auf oder Leertaste | Dia-Show starten
Bild-Auf oder Leertaste | Bild weiter
Bild-Ab | Bild zurück
Ende | Dia-Show beenden
Pause oder Leertaste | Dia-Show stoppen / fortführen (entspr. der Stop- / Go-Taste)
F8 | Ton ein / aus
F9 | Lautstärke erniedrigen (in 5-er-Schritten)
F10 | Lautstärke erhöhen (in 5-er-Schritten)
Strg + F9 | Lautstärke halbieren
Strg + F10 | Lautstärke verdoppeln
F11 | Audio-Track zurückspulen (in 5-er-Schritten)
F12 | Audio-Track vorspulen (in 5-er-Schritten)
Strg + F8 | Autofokus ein
Strg + F11 | Fokus zurück
Strg + F12 | Fokus vor
# | Memo
Links-Klick auf "Memo" oder Einfg | Im Live-Modus: momentan projiziertes Dia vor dem aktuellen Programmschritt in die Timeline einfügen
Strg + Links-Klick auf "Memo" oder Strg + Einfg | Im Live-Modus: momentan projiziertes Dia an das Ende der Timeline anfügen
Rechts-Klick auf "Memo" oder Entf | Im Live-Modus: momentan projiziertes Dia aus der Timeline entfernen
Strg + Rechts-Klick auf "Memo" oder Strg+Entf | Im Live-Modus: momentan projiziertes Dia im Dia-Editor als "Nicht Belegt" markieren
Shift + Links-Klick auf "Memo" oder Strg + E | Im Live-Modus: Eigenschaften des momentan projizierten Dias ändern
Strg + Alt + Q | Im Live-Modus: beim gerade aktiven Programmschritt das Querformat einstellen; ist durch Strg+E überholt
Strg + Alt + H | m Live-Modus: beim gerade aktiven Programmschritt das Hochformat einstellen; ist durch Strg+E überholt
F4 | Umschalten zwischen normaler und reduzierter Darstellung der virtuellen Fernbedienung

Man beachte: die Leertaste ist eine im jeweiligen Kontext mehrfach belegte Taste.


Tastenkürzel und Maus-Klicks im Audio-Player

Folgende Tastenkürzel und Maus-Klicks sind im Audio-Player verfügbar:

Wave-Box (Anzeigebereich für die Audio-Kurve)

Links-Klick | Locator an den Anfang des Audio-Tracks
Rechts-Klick | Locator an die aktuelle Stelle des Audio-Tracks (Ziehen mit der Maus möglich)
Strg + Links-Klick | Start-Position setzen (Ziehen mit der Maus möglich)
Strg + Rechts-Klick | Stop-Position setzen (Ziehen mit der Maus möglich)
Alt + Links-Klick | Start-Position entfernen
Alt + Rechts-Klick | Stop-Position entfernen
Umsch + Links-Klick | Audio-Track zurückspulen (um eine Sekunde)
Umsch + Rechts-Klick | Audio-Track vorspulen (um eine Sekunde)

Buttons (unterhalb der Wave-Box)

Links-Klick | Setzen eines Start-, Stop- oder Sync-Punktes
Rechts-Klick | Löschen eines Start-, Stop- oder Sync-Punktes

Tastenkürzel

Leertaste | Start / Pause des Audio-Tracks (nur, wenn keine Leinwand-Simulation oder reale Dia-Show läuft)
Ende | Stop des Audio-Tracks (nur, wenn keine Leinwand-Simulation oder reale Dia-Show läuft)
F8 | Ton ein / aus
F9 | Lautstärke erniedrigen (in 5-er-Schritten)
Strg + F9 | Lautstärke halbieren
F10 | Lautstärke erhöhen (in 5-er-Schritten)
Strg + F10 | Lautstärke verdoppeln
F11 | Audio-Track zurückspulen (um eine halbe Sekunde)
F12 | Audio-Track vorspulen (um eine halbe Sekunde)
8 bzw. [ | Start-Position setzen
9 bzw. ] | Stop-Position setzen
+ | Sync-Punkt setzen


Tastenkürzel und Maus-Klicks in der grafischen Darstellung der Timeline

Folgende Tastenkürzel und Maus-Klicks sind in der grafischen Darstellung der Timeline verfügbar:

Wenn keine Leinwand-Simulation läuft:

Pfeil-Links, Mausrad-Ab | In der Timeline (einen Programmschritt) nach links scrollen
Pfeil-Rechts, Mausrad-Auf | In der Timeline (einen Programmschritt) nach rechts scrollen
Bild-Ab, Strg + Mausrad-Ab | In der Timeline (fünf Programmschritte) nach links scrollen
Bild-Auf, Strg + Mausrad-Auf | In der Timeline (fünf Programmschritte) nach rechts scrollen
Pos1 | In der Timeline zum ersten Programmschritt springen
Ende | In der Timeline zum letzten Programmschritt springen
F8 | Ton ein/aus
F9 | Lautstärke erniedrigen (in 5-er-Schritten)
F10 | Lautstärke erhöhen (in 5-er-Schritten)
Strg + F9 | Lautstärke halbieren
Strg + F10 | Lautstärke verdoppeln
F11 | Audio-Track zurückspulen (in 5-er-Schritten)
F12 | Audio-Track vorspulen (in 5-er-Schritten)
Umsch + F9 | Zum vorhergehenden Positions-Marker springen
Umsch + F10 | Zum nachfolgenden Positions-Marker springen
Strg + Umsch + F9 | Einen Positions-Marker toggeln (setzen/entfernen)
Strg + Umsch + F10 | Alle Positions-Marker entfernen
Strg + Ü | Überblend-Eigenschaften eines Programm-Schritts editieren
Strg + I | Audio-Datei zum Programm-Schritt suchen
Strg + E | Audio-Datei zum Programm-Schritt entfernen
Strg + H | Audio-Eigenschaften eines Programm-Schritts editieren
Strg + F9 | Audio-Synchronisations-Punkt entfernen

Wenn eine Leinwand-Simulation läuft:

Bild-Ab | Vorhergehender Programmschritt
Bild-Auf | Nächster Programmschritt
Ende | Leinwand-Simulation beenden
Pause | Leinwand-Simulation pausieren/fortführen
Leertaste | Nächster Programmschritt bzw. Leinwand-Simulation pausieren/fortführen
F8 | Ton ein/aus
F9 | Lautstärke erniedrigen (in 5-er-Schritten)
F10 | Lautstärke erhöhen (in 5-er-Schritten)
Strg + F9 | Lautstärke halbieren
Strg + F10 | Lautstärke verdoppeln
F11 | Audio-Track zurückspulen (in 5-er-Schritten)
F12 | Audio-Track vorspulen (in 5-er-Schritten)


Verwendung des "eDio Wireless USB Remote Controller IR501"

Hier wird eine Möglichkeit beschrieben, die Fernbedienung des Projektors durch eine separate Fernbedienung zu ersetzen, die den Computer steuert und somit eine Fernsteuerung von "TwinLightControl" möglich macht. Damit wird das gelegentlich auftretende Problem, dass die Projektor-Fernbedienung nicht reagiert, umgangen.

Von "Conrad Electronic" gibt es eine Infrarot-Fernbedienung für PC's, die einer TV-Fernbedienung ähnelt und einen IR-Empfänger mit USB-Anschluss hat. Es handelt sich um den "Wireless USB Multi Remote Controller IR501" von "eDio". Er schlägt mit derzeit € 19,95 zu Buche, eine Investition, die sich u.E. lohnt.

Vorteil Der Vorteil dieser Fernbedienung ist, dass man nicht nur Standard-Programme wie "WinDVD", "WinRip" oder "WinAmp" fernsteuern, sondern auch Hotkeys für andere Programme wie z.B "TwinLightControl" definieren kann.

Bei der Verwendung gibt es, wie so oft, einige Klippen zu umschiffen. Aus unerfindlichen Gründen, so haben wir nach langem Experimentieren herausgefunden, hat die mitgelieferte Software "Remote Master" Probleme mit Dateinamen, die länger als 11 Zeichen (vor dem Punkt) sind. Das Programm kann zwar mit Hilfe der Fernbedienung gestartet werden, nimmt danach aber keinerlei Befehle von der Fernbedienung entgegen.

Wir haben den Fehler an "eDio" gemeldet, in der Hoffnung, dass er irgendwann ausgemerzt wird. Für all jene, die Gefallen an der separaten Fernbedienung gefunden haben, wird das Problem vorerst folgendermaßen gelöst:

Im Installationsverzeichnis von "TwinLightControl" gibt es eine exakte Kopie von "TwinLightControl.exe" namens "TLC.exe". Diesen Dateinamen "versteht" der IR Remote Controller. Wichtig: Wenn man die separate Fernbedienung benutzen will, darf man "TwinLightControl" nicht per Mausklick auf das entsprechende Icon starten, sondern man muss "TLC" durch Drücken der entsprechenden Taste "Speech" der IR-Fernbedienung starten. Beim "Remote Master" muss als Dateiname "TLC.exe" eingetragen sein.

Wer die separate Fernbedienung nicht benutzt, kann die Datei "TLC.exe" löschen, um ein wenig Speicherplatz auf der Festplatte zu sparen.

Die Vorteile einer separaten Fernbedienung liegen auf der Hand:

  • Das Problem des gelegentlichen "Hängens" der Projektor-Fernbedienung ist beseitigt.
  • Unabhängig davon, welchen Magazin-Typ man verwendet, kann man nach einem Magazinwechsel immer die IR-Fernbedienung benutzen (zur Einschränkung bei der Verwendung von Nicht-Koppelmagazinen und Projektor-Fernbedienung s. hier).
  • Es werden alle Funktionen der Projektor-Fernbedienung nachgebildet.
  • Darüberhinaus kann der Audio-Player ferngesteuert werden. Tastenkürzel für den Audio-Player findet man hier.
  • Des weiteren wird die Möglichkeit eröffnet, den Projektor direkt anzusteuern, ohne dass das Programm in den Projektorspeicher geladen wird. Auf diese Weise könnte man beliebige Lichtkurven zeichnen (z.B. das bereits im Forum "Dissolve!" diskutierte gemeinsame Auf- oder Abblenden von Dias u.v.a.m.). Die Direktansteuerung des Projektors erfordert allerdings ein komplettes Redesign von "TwinLightControl". Ob sich der dafür notwendige Aufwand lohnt, wird durch die zukünftige Akzeptanz des Programms entschieden.
  • Der Infrarot-Empfänger hat eine Klemmvorrichtung und drei integrierte, abschaltbare LEDs. Am aufgeklappten Deckel eines Notebooks befestigt, hat man auf diese Weise sogar noch eine Tastaturbeleuchtung, was manchmal ganz praktisch ist.
Aus unserer Sicht einziger Nachteil der separaten Fernbedienung: sie hat keinen Laserpointer. Entweder benutzt man den der Projektor-Fernbedienung oder einen separaten. Kleine und handliche Laserpointer gibt es schon für wenige Euro.

Für diejenigen Nutzer, die aufgrund der Vorteile die eDio-Fernbedienung nutzen wollen, hier ein paar Tips.
  • Die Installation der mitgelieferten Software "Remote Master" ist problemlos. Auf der Website http://www.edio21.com gibt es aktualisierte Versionen.
  • Die Fernbedienung hat eine Reichweite von ca. 7 m, was u.E. ausreichend ist, da man bei einer Live-Diashow i.d.R. sowieso in der Nähe des Projektors resp. Computers steht.
  • Im Verzeichnis "Journal" des "TwinLightControl"-Installationsverzeichnisses befinden sich drei ini-Dateien (RMCtrl.ini, UserDef.ini, UserDefInf.ini), die in das Installationsverzeichnis der Fernbedienung (i.d.R. "C:\rogramme\emote Master\) kopiert werden sollten. Diese drei Dateien enthalten alle Einstellungen und Hotkeys, die für die Fernsteuerung von "TwinLightControl" notwendig sind. Selbstverständlich kann man auch eine eigene Tastenbelegung definieren.
Hier die voreingestellte Tastenbelegung:


Verwendung von Notebook-Presentern zur Fernsteuerung

Seit einigen Jahren gibt es sog. Notebook-Presenter. Diese Geräte vereinen meist eine PowerPoint-Steuerung, einen Laser-Pointer, eine Maus und eine Multimedia-Fernsteurung in einem. Viele Modelle besitzen einen sog. Multimedia-Modus, mit dessen Hilfe der Windos Media Player oder andere vergleichbare Programme gesteuert werden können. Ob ein spezielles Modell einen Multimedia-Modus besitzt, kann der Betriebsanleitung entnommen werden.

Stellvertretend für andere Modelle seien die Funktionen des Multimedia-Modus am Digital Data Equip "4 in 1" Notebook-Presenter gezeigt:

Folgende Funktionen sind verfügbar:

  • Ton ein/aus (Mute)
  • Ton leiser
  • Ton lauter
  • Stop
  • Play/Pause
  • Nächster Track
  • Vorhergehender Track

TwinLightControl fängt die vom Presenter gesendeten Befehle ab und setzt sie in folgende Befehle um:

  • Ton ein/aus (Mute)
  • Ton leiser
  • Ton lauter
  • Stop (Beenden einer laufenden Dia-Show)
  • Play / Pause
  • Fokus vor
  • Fokus zurück

Alle Befehle sind sowohl im Simulations- als auch im Echtzeit-Betrieb (mit Projektor) verfügbar, die beiden letzten nur im Echtzeit-Betrieb.

Damit bietet sich eine weitere Möglichkeit, die Fernbedienung des Projektors durch eine separate Fernbedienung zu ersetzen und das gelegentlich auftretende Problem, dass die Projektor-Fernbedienung nicht reagiert, zu umgehen. Darüber hinaus weisen die meisten Presenter, da sie nicht mit Infrarot, sondern mit Mikrowellen arbeiten, eine größere Reichweite und Richtungsunabhängigkeit auf.


Farbige Markierungen in den Editoren

In den Editoren für die Dias und die Timeline werden bestimmte Einstellungen zur besseren Kenntlichkeit farbig markiert. Im einzelnen sind dies:

Magazin-Editor

Anzahl der Querformat-Dias im Magazin
Anzahl der Hochformat-Dias im Magazin
Anzahl der Quadratformat-Dias im Magazin

Dia-Editor

 | Aktuelle Magazin-Nummer (nur dann, wenn "Alle Magazine" angekreuzt ist)
 | "Benutzt"-Feld des Dias, wenn sich das Dia auch in der Timeline befindet; so sieht man auf einen Blick, welche Dias eines Magazins auch in der Timeline sind
Dia-Format | So kann z.B. ein häufiger Wechsel zwischen den verschiedenen Dia-Formaten leicht erkannt und ggf. eliminiert werden
 | Querformat-Dias
 | Hochformat-Dias
 | Quadratformat-Dias

Timeline-Editor

Start-Dia (das jeweils erste Dia in einem Magazin)
Unzulässiger Sprung in der Magazin-Nummer
(z.B. von 3 auf 5)
Querformat-Dias
Hochformat-Dias
Quadratformat-Dias
Überblendzeit bei Formatwechsel
Pause (manuelle Weiterschaltung)
Audio-Synchronisations-Pause (Timer-Feld)
(s. Audio-Synchronisations-Punkte )
Zu kleine Dia-Standzeiten
(< 4,0 sec bei 150-W-Projektoren bzw. < 5,5 sec bei 250-W-Projektoren);
bei manchen Überblendeffekten (z.B. bei der Einblendung mehrerer Dias
in ein anderes Dia) ist dies aber sinnvoll
Mechanische oder Licht-Sonderfunktionen
Momentan nicht aktive (editierbare) Felder
Aktuelle Programmzeile, wenn gerade eine Leinwand-Simulation läuft


Magazin-Typen

Die Rolleivision Twin Projektoren kommen mit folgenden Magazin-Typen zurecht:

  • 36-er Einheitsmagazin
  • 50-er Einheitsmagazin
  • Rollei-Koppelmagazin CM 55/50
  • 60-er LKM-Magazin
  • 80-er LKM-Magazin
  • 40-er CS-Magazin
  • 100-er CS-Magazin
  • 100-er CS-Koppelmagazin (Eigenbau)

Die Rollei-Koppelmagazine können, wie der Name schon sagt, aneinandergekoppelt werden. Damit ist es möglich, Dia-Shows ohne die sonst notwendige Unterbrechung nach jedem Magazin zu erstellen.

Die Rollei-Koppelmagazine sind von der Qualität her ausgezeichnet und für die Projektion ohne Einschränkung zu empfehlen. Ihr Preis schreckt aber wahrscheinlich die meisten davor zurück, komplette Dia-Shows in den Koppelmagazinen nicht nur zu präsentieren, sondern auch zu archivieren.

Billige Magazine sind für die Projektion mit dem Rolleivision Twin nicht zu empfehlen, da sie wegen der komplizierten Mechanik des Projektors schnell mal zum "Hakeln" neigen. Man kann die Problematik zwar etwas entschärfen, indem man vor der Benutzung die herstellungsbedingten Kunststoffgrate mit einem Messer entfernt, aber oft haben diese Billigmagazine Toleranzen, die der Projektor nicht mehr verträgt. Deshalb an dieser Stelle ein Tip für all diejenigen, die Einheitsmagazine verwenden:

Die Archivierung der Dias erfolgt in billigen Einheitsmagazinen, die Projektion in Rollei-Koppelmagazinen. Von letzteren legt man sich gerade so viele zu, wie für die größte denkbare Dia-Show notwendig sind. Vor der Präsentation füllt man die Dias aus den Billigmagazinen in die Koppelmagazine um. Das hört sich komplizierter und zeitaufwendiger an, als es ist. Zunächst füllt man die Dias aus dem Billigmagazin in ein (beliebiges) anderes Magazin um, indem man die beiden Magazine spiegelbildlich aneinandersetzt und auf den Kopf stellt. Jetzt sind die Dias in dem "Zwischenmagazin" natürlich in der falschen Reihenfolge und kopfstehend angeordnet. Im zweiten Schritt wiederholt man das Procedere nochmals, wobei man nun als Zielmagazin ein Koppelmagazin verwenden muss. Bei einiger Übung kann man auf diese Art und Weise selbst größere Dia-Shows in zehn Minuten umsortieren.

Es gibt einen neuen Magazin-Typ: 100-er CS-Koppelmagazine. Damit wird dem Umstand Rechnung getragen, dass einige User koppelbare CS-100-Magazine der Marke Eigenbau verwenden. Damit sind offenbar auch mit CS-Magazinen Endlos-Dia-Shows ohne Dunkelpause möglich. In TwinLightControl werden diese Magazine ähnlich wie die Rollei-Koppelmagazine behandelt, nur eben mit 100 Dias pro Magazin.

Es muss an dieser Stelle darauf hingewiesen werden, dass bei der Herstellung der Magazine sehr sorgfältig gearbeitet werden muss und dass die Benutzung solcher Magazine auf eigene Gefahr geschieht. Wir übernehmen keinerlei Verantwortung für Schäden am Projektor, die aus der Verwendung von Nicht-Standard-Magazinen resultieren.

Die Verwendung von verschiedenen Magazin-Typen innerhalb einer Dia-Show ist zwar prinzipiell möglich, sollte aber nach Möglichkeit vermieden werden. Der Projektor könnte bei den unterschiedlichen Magazingrößen leicht aus dem Tritt kommen, außerdem müsste man u.U. innerhalb einer Dia-Show die Nase des Diagreifers mehrmals umstellen.


Überblend-Effekte

Ein bei einem Dia in der Timeline eingetragener Überblend-Effekt bezieht sich immer auf das momentane und das vorhergehende Dia. Im einzelnen sind dies:

Normale Überblendung
Zwei Dias werden normal ineinander übergeblendet. Das erste Dia einer Show oder eines Magazins wird eingeblendet, das letzte Dia wird ausgeblendet.

Einblenden (in vorhergehendes Dia)
Ist bei einem Dia in der Timeline unter Licht-Sonderfunktion "Einblenden" eingetragen, so wird dieses Dia in das vorhergehende eingeblendet.
Das Feld Standzeit bestimmt die Standzeit des Dias, in das eingeblendet wird, nach der Einblendung. Wenn mehrere Dias in ein Dia eingeblendet werden sollen, bestimmt das Feld Standzeit die Pause zwischen den einzelnen Einblendungen; sie sollte möglichst kurz gewählt werden (z.B. 1 sec, auf jeden Fall kleiner als 3,5 sec bzw. 5 sec, aber nicht 0 sec), um eine möglichst schnelle Abfolge der Einblendungen zu erzielen. Letztendlich wird die Abfolge der Einblendungen wesentlich von der Diawechselzeit des Projektors bestimmt. Wählt man für den Standzeit den Wert 0 sec, wird die nächste Einblendung erst bei Druck auf die Vorwärtstaste gestartet.
Wird im Timeline-Editor die Licht-Sonderfunktion "Einblenden" für mehrere Dias gewählt, können mehrere Dias in ein Dia (das letzte vor der Gruppe einzublendender Dias) eingeblendet werden. Für die Standzeit wird automatisch der Wert 1 sec eingetragen. Da dieser Wert kleiner ist, als die minimale Dia-Wechsel-Zeit, wird er rot markiert. Diese Warnung kann man aber getrost ignorieren.

Einfrieren (mit vorhergehendem Dia)
Ist bei einem Dia in der Timeline unter Licht-Sonderfunktion "Einfrieren" eingetragen, so wird die Überblendung zwischen dem vorhergehenden und diesem Dia in der Mitte der Überblendung eingefroren. Auf diese Art und Weise kann ein drittes Bild erzeugt werden.
Die beim Überblendeffekt eingetragene Standzeit bestimmt die Standzeit des dritten Bildes, die normale Standzeit bestimmt die Standzeit des zweiten Dias nach dem Einfrieren.
Bei der Überblendzeit ist zu beachten, dass die eingetragene Zeit die Summe aus den beiden Überblendzeiten zu Beginn und Ende des Einfrierens ist.

Blinken (in vorhergehendes Dia)
Unter Blinken versteht man das ein- oder mehrfache Ein- und Ausblenden eines Dias in ein bereits projiziertes Dia. Die Überblendzeit des einzublinkenden Dias bestimmt die Auf- und Abblenddauer des Blinkvorgangs, sie sollte möglichst kurz gehalten werden (z.B. 0,5 sec). Der unter Zähler eingetragene Wert bestimmt die Zahl der Blinkvorgänge. Die Standzeit des einzublinkenden Dias ist die Standzeit nach dem Blinken.

Flashen (in vorhergehendes Dia)
Flashen ist das gleiche wie Blinken mit dem Unterschied, dass die Einblendungen schneller erfolgen, d.h. die Pausen zwischen den Einblendungen sind kürzer.

Schaukeln (mit vorhergehendem Dia)
Schaukeln ist die wechselweise Überblendung zwischen zwei Dias. Es wird von Dia 1 auf Dia 2 und anschließend von Dia 2 auf Dia 1 übergeblendet. Der ganze Vorgang wiederholt sich ein- bis neunmal. Der Schaukelvorgang endet normalerweise bei Dia 1, mit einem Trick kann man erreichen, dass er bei Dia 2 endet.

Aus- / Einblenden (vorhergehendes / momentanes Dia)
Aus- / Einblenden wird verwendet, wenn man eine Überblendung zwischen zwei Dias vermeiden will, z.B. beim Wechsel zwischen Quer- und Hochformat oder am Ende einer thematischen Dia-Sequenz. Dia 1 wird vollständig ausgeblendet, bevor Dia 2 eingeblendet wird. Aus- und Einblendung gehen nahtlos ineinander über.

Aus- / Einblenden mit Pause (vorhergehendes / momentanes Dia)
Aus- / Einblenden mit Pause ähnelt dem soeben beschriebenen Überblendeffekt mit dem Unterschied, dass zwischen Aus- und Einblenden eine Pause liegt, die mit der Vor-Taste beendet werden muss.

Man kann zu allen Überblendeffekten den zugehörigen Dialog aufrufen, der die geschilderten Verhältnisse grafisch veranschaulicht. Wie das geht, erfährt man hier.

Zu beachten ist, dass beim ersten Dia der Dia-Show und bei Nicht-Koppelmagazinen bei jedem ersten Dia eines Magazins keine Licht-Sonderfunktion eingetragen werden kann. Hier kann nur eine "Normale Überblendung" stehen.


Bemerkungen zu MP3-Dateien

Audio-Dateien sollten nach Möglichkeit als MP3-Dateien eingebunden werden. Was ist aber MP3 und welche Einstellungen wählt man am besten?

MP3 ist das gebräuchlichste Kompressionsformat für qualitativ hochwertige Audio-Dateien und hat im wesentlichen über das Internet Verbreitung gefunden. MP3-Dateien haben i.d.R. die Endung "*.mp3". Eine reiche Informationsquelle zu den technischen Aspekten von MP3 ist http://www.mp3-tech.org .

Im folgenden erläutern wir nur kurz die Fakten, die für die Verwendung von MP3-Dateien unter TwinLightControl wichtig sind.

Grundsätzlich gibt es zwei verschiedenene Formate von MP3-Dateien: solche mit konstanter und solche mit variabler Bit-Rate.

Bei MP3-Dateien mit konstanter Bit-Rate (CBR) wird aus dem Datenstrom pro Sekunde immer die gleiche Anzahl an Bits gelesen, z.B.128 kbps (KiloBit pro Sekunde). Bei MP3-Dateien mit variabler Bitrate (VBR) variiert die aus dem Datenstrom gelesene Zahl an Bits mit dem momentan vorliegenden Informationsgehalt des Musikstücks. Bei ruhigen Passagen mit wenigen Instrumenten ist die Bit-Rate z.B. kleiner als bei Passagen mit vielen Instrumenten unterschiedlicher Klangfarben.

VBR hat den Vorteil, dass die Qualität eines Musikstücks differenziert angepasst werden kann und die MP3-Dateien so insgesamt bei gleichem Informationsgehalt kleiner werden.

Ein entscheidender Nachteil von VBR ist aber, dass es keinen linearen Zusammenhang zwischen Bitposition in der Datei und Zeitposition mehr gibt, wie das bei CBR der Fall ist. Bei CBR kann man z.B. die zeitliche Länge eines Musikstücks einfach dadurch ermitteln, dass man die Bit-Rate mit der Anzahl der Daten-Bits in der MP3-Datei multipliziert. Das ist bei VBR nicht mehr möglich, da die Bit-Rate ständig variiert. Noch schwieriger wird es mit der exakten Positionierung innerhalb eines Musikstücks mit VBR.

Will man in TwinLightControl die Möglichkeit des Startens oder Stoppens eines Musikstücks an einer Position innerhalb des Stücks nutzen, sollte man keine MP3-Dateien mit VBR-Kodierung verwenden, sondern nur CBR-kodierte Dateien. Dann ist die Positionierung innerhalb eines Musikstücks punktgenau möglich. Von dieser Möglichkeit sollte man aber nur in Ausnahmefällen Gebrauch machen, da man die nicht benutzten Teile des Audio-Tracks als unnötigen Ballast mitschleppt. Besser ist es, den Audio-Track vorher mit einem geeigneten Audio-Editor zu schneiden (z.B. Audacity, http://www.audacity.de ).

Mit einem geeigneten Programm kann man *.wav-Dateien oder *.cda-Dateien (Audio-CD) in MP3-Dateien konvertieren. Es gibt eine Reihe guter Konverter, wir haben z.B. gute Erfahrungen mit "CDEx" gemacht. Man kann es unter http://cdexos.sourceforge.net herunterladen. Man kann z.B. auch VBR-kodierte MP3-Dateien in CBR-kodierte umwandeln, besser ist es allerdings, dies am Original zu tun.


Leinwand-Rechner

Das kleine Tool ist nützlich für die Planung einer Dia-Show in unterschiedlichen Räumen. Folgende Größen sind bei der Projektion von Dias über eine Gleichung verknüpft:

  • Brennweite des Projektionsobjektivs
  • Abstand Projektor - Leinwand
  • Breite bzw. Höhe eines Dias (in unserem Falle wird eine 35-mm-Maske angenommen)
  • Breite bzw. Höhe des projizierten Bildes (Leinwand-Größe)

Bis auf die dritte Größe sind alle anderen Größen veränderlich. Jeweils zwei der drei veränderlichen Größen sind Eingabegrößen, die dritte berechnet sich eindeutig aus den beiden anderen.

So kann man z.B. berechnen, in welcher Entfernung der Projektor vor der Leinwand stehen muss, damit man mit einem 90-mm-Objektiv ein 3x3m² großes Bild erzeugt.

Der Leinwand-Rechner befindet sich im Menü "Tools" und ist selbsterkärend.


Wichtige Bedienhinweise für den Projektor (MSCxxxP)

Greiferarm aus-/einfahren
Greiferarm ausfahren: Stop-/Go-Taste + grüne Vor-Taste.
Greiferarm einfahren: grüne Vor-Taste.

Dia-Show beenden
Taste "end".

Dia-Fach anfahren
Vordere bzw. hintere Focus.-Taste drücken bzw. gedrückt halten.

Wiedergabe einer im Modul gespeicherten Dia-Show
Taste "mode": "auto" wählen (LED blinkt),
Taste "modul": Programm wird geladen.

Standby-Betrieb
Durch folgendes Vorgehen werden die beiden ersten Dias vor dem Beginn der Show eingezogen:
Stop-/Go-Taste + grüne Vor-Taste.
Der Projektor wartet nun auf den nächsten Transport-Befehl. Während der Wartezeit blinkt die Timer-LED.
Funktioniert offenbar nicht im PC-Betrieb.

Pause-Betrieb
Funktioniert nur im manuellen Betrieb (Timer nicht aktiv).
Stop-/Go-Taste + grüne Vor-Taste: aktuelles Bild wird abgeblendet, Pausenlicht leuchtet auf.


Wesentliche Unterschiede zwischen "Rolleivision Twin MSCxxxP" und "Rolleivision 35 twin digital P"

Folgende Unterschiede zwischen den beiden grundlegenden Projektortypen sind zu beachten:

 | Rolleivision Twin MSCxxxP | Rolleivision twin digital P
Überblendzeiten | 0.1 ... 25.0 (0.1-er Schritte) | 0.5 ... 25.0 (0.5-er Schritte)
Timer-Zeiten | 0.0 ... 600.0 (0.1-er Schritte) | 0.0 ... 99.9 (0.1-er Schritte)
Programmzeilen | 1 ... 999 | 1 ... 300
Dia-Fach-Nummern | 1 ... 999 | 1 ... 250
Grundhelligkeit | 0 ... 100% bzw. 110% | 80, 90, 100%
Licht- Sonderfunktionen |  |
Normale Überblendung | vorhanden | vorhanden
Einblenden | 1 ... 9 sec | 2, 4 oder 8 sec
Einfrieren | 1 ... 9 sec | 2, 4 oder 8 sec
Blinken | 1 ... 9 x | nicht vorhanden
Flashen | 1 ... 9 x | 1 ... 4 x
Schaukeln | 1 ... 9 x | 1 ... 4 x
Aus-/Einblenden | vorhanden | vorhanden
Aus-/Einblenden mit Pause | vorhanden | nicht vorhanden
Mechanische Sonderfunktionen |  |
Autoreverse | vorhanden | vorhanden
alle anderen | vorhanden | nicht vorhanden

TwinLightControl berücksichtigt die Unterschiede zwischen den Projektortypen und weist unzulässige Werte zurück.


Befehlssatz zur Steuerung des Twin MSC 300
(Information von Rollei)

1. Schnittstellen-Parameter

Der Projektor verfügt über eine serielle Schnittstelle gemäß RS232, die auf eine 9-polige Sub-Min-D-Buchse mit folgender Belegung geführt ist:

Anschluss Funktion

2 serieller Ausgang
3 serieller Eingang
5 Signalmasse

Die Schnittstelle benutzt folgende Parameter:

- 9600 Baud
- 1 Startbit
- 8 Datenbits
- 1 Stoppbit
- kein Paritätsbit

Grundsätzlich wird jedes zum Projektor übertragene Zeichen von diesem zurückgesendet (Echo-Betrieb). Der Eingang des Echos muss abgewartet werden, bevor dem Projektor ein weiteres Zeichen gesendet wird.

Befehle an den Projektor bestehen aus einer Folge von Zeichen, die im ASCII-Code vorliegen. Das Steuerzeichen 0D(hex) schließt eine Befehlszeichenfolge ab.

Numerische Parameter sind 3-stellig und mit führenden Nullen zu übertragen.Beim TI-Befehl (s.u.) hat eine 4-stellige Angabe der Standzeit zu erfolgen.

Daten, die vom Projektor gesendet werden, liegen ebenfalls im ASCII-Code vor und sind mit den Steuerzeichen 0D(hex) 0A(hex) abgeschlossen.

Eine Ausnahme bildet der Befehl 'ß', der kein Echo liefert und als Antwort eine Statusinformation sendet (1 Zeichen), der keine weiteren Zeichen folgen.

2. Befehle ohne Parameterübergabe

2.1 Allgemeine Einstellungen

Befehl | Funktion
PE | Einschalten des PC-Modus: Die Projektortastatur ist gesperrt und alle beschriebenen RS232-Befehle sind aktiviert. In der Projektoranzeige erscheint PC.
PA | Abschalten des PC-Modus: Der Projektor ist über seine Tastatur bedienbar. Von der Schnittstelle wird lediglich der PE-Befehl (s.o) akzeptiert.
RS | RESET-Funktion: Führt die END-Funktion aus (s.u) und schaltet den PC-Modus aus.

2.2 Tastatur-Befehle

Befehle aus dieser Gruppe entsprechen in ihrer Funktion Tastenbetätigungen am Projektor.

Befehl | Funktion
BV | Bild vorwärts: Funktion wie VORWÄRTS-Taste
BR | Bild rückwärts: Funktion RÜCKWÄRTS-Taste
FV | Focus vor: Funktion wie FOCUS VOR-Taste
FR | Focus zurück: Funktion wie FOCUS RÜCK-Taste
AE | Autofocus einschalten
AA | Autofocus abschalten
ST | Stop: Anhalten des Projektionsablaufes. Entspricht dem Druck auf die STOP/GO-Taste, wenn gerade eine Projektion läuft.
WE | Weiter: Start oder Wiederanlauf des Projektionsablaufes. Entspricht dem Druck auf die STOP/GO-Taste, wenn zuvor die Projektion angehalten wurde.
MOM | Einstellen der Betriebsart "MANUELL"
MOT | Einstellen der Betriebsart "TEST"
MO | Memo-Funktion: Das jeweils in Projektion befindliche Bild wird in den Memo-Speicher übernommen und kann am Ende der Show noch einmal gezeigt werden.
ML | Modul lesen: Der Inhalt des Moduls wird in den Arbeitsspeicher des Projektors zu übertragen.
MS | Modul schreiben: Der Inhalt des Arbeitsspeichers wird in das Modul übertragen.
EN | END-Funktion: Funktion wie END-Taste

3. Befehle zum Datenaustausch zwischen PC und Projektor
3.1 Beschreiben des Programmspeichers im Projektor

Befehl | Funktion
SZ:XXX | Selektiere Zelle: Nachfolgende Schreibbefehle gelten für die Zelle (Programmnummer) XXX.
BN:XXX | Bildnummer definieren: Bildnummer XXX im Programmspeicher in die selektierte Zelle eintragen
DI:XXX | Dissolve-Zeit (Überblendzeit) definieren: Dissolve-Zeit XXX im Programmspeicher in die selektierte Zelle eintragen. Die Angabe erfolgt in 1/10 Sekunden.
TI:XXXX | Timer-Zeit (Standzeit) definieren: Timer-Zeit XXXX im Programmspeicher in die selektierte Zelle eintragen. Die Angabe erfolgt in 1/10 Sekunden.
SF:XXX | Sonderfunktion definieren: Sonderfunktions-Code XXX im Programmspeicher in die selektierte Zelle eintragen.

3.2 Lesen des Programmspeichers im Projektor

Befehl | Funktion
LZ:XXX | Lies Zelle: Es wird der Inhalt der Zelle mit der Adresse XXX gesendet. Der Projektor sendet: '"ZZZ BBB DDD TTTT SSS" 0D 0A (hex) Dabei bedeutet: ZZZ Programmnummer BBB Bildnummer DDD Dissolve-Zeit in 1/10 Sek. TTTT Timer-Zeit in 1/10 Sek. SSS Sonderfunktions-Code

3.3 Starten einer Diaschau

Befehl | Funktion
GB:XXX | Programmstart bei Bildnummer XXX. Betriebsart 'TEST' (s. MOT-Befehl): Eine Schau startet an der ersten Zelle, welche die Bildnummer XXX enthält. Die Prüfung der Bildnummern beginnt mit Zelle 1, die Suche erfolgt aufsteigend. Betriebsart 'MANUELL' (s. MOM-Befehl): Das Bild mit der Nummer XXX wird solange projiziert, bis weitere Befehle übertragen werden.
GZ:XXX | Programmstart bei Zelle Nummer XXX: Die Bilder aus den Zellen XXX und XXX+1 werden eingeräumt und die Schau startet.

3.4 Überwachen einer laufenden Diaschau

Befehl | Funktion
AZ | Aktuelle Zelle abfragen: Der Projektor sendet die aktuelle Programmnummer PPP.
AB | Aktuelle Bildnummer abfragen: Der Projektor sendet die Nummer BBB des gerade in Projektion befindlichen Bildes.

3.5 Allgemeine Einstellungen

Befehl | Funktion
SL:XXX | Einstellen der maximalen Helligkeit: Der Code XXX legt für alle Bilder einer folgenden Schau die Projektionshelligkeit fest. XXX kann die Werte 001..255 annehmen, die Helligkeit ist dem Wert proportional.
SU:XAÜ | Auswahl einer Überblendtabelle: Der Code XAÜ wählt eine der möglichen Überblendtabellen aus, die bei Auf-, Ab- und Überblendungen verwendet werden. A und Ü können die Werte 1, 2, 3 und 4 annehmen. Voreingestellt sind die Werte 2 für die Auf- und Abblendungen (A) und 3 für Überblendungen (Ü).

4. Befehle zur direkten Steuerung des Projektors

4.1 Kondensoren mit Bildern laden

Befehl | Funktion
B1:XXX | Das Bild aus dem Magazinfach mit der Nummer XXX wird in das linke Kondensorsystem geladen.
B2:XXX | Das Bild aus dem Magazinfach mit der Nummer XXX wird in das rechte Kondensorsystem geladen.
B1:000 | Das Bild im linken Kondensorsystem wird entladen.
B2:000 | Das Bild im rechten Kondensorsystem wird entladen.

4.2 Auf-, Ab- oder Überblendfunktionen ausführen

Befehl | Funktion
LD1:XXX | Der Code XXX stellt die aktuelle Helligkeit des Bildes im linken optischen System ein. XXX kann die Werte 001..255 annehmen, die Helligkeit ist dem Wert proportional.
LD2:XXX | Der Code XXX stellt die aktuelle Helligkeit des Bildes im rechten optischen System ein. XXX kann die Werte 001..255 annehmen, die Helligkeit ist dem Wert proportional.
SD:XXX | Der Code XXX definiert die Dissolvezeit für die nächste Lampenansteuerung (Auf-, Ab- bzw. Überblendung). Die Zeit wird in 1/10 Sekunden festgelegt.
LM:XXX | Der Code XXX legt die nächste Lichtfunktion fest und startet sie: 200 linkes optisches System aufblenden 201 rechtes optisches System aufblenden 202 linkes optisches System abblenden 203 rechtes optisches System abblenden 204 überblenden vom linken auf das rechte optische System 205 überblenden vom rechten auf das linke optische System 206 beide optische Systeme aufblenden 207 beide optische Systeme abblenden

5. Statusabfrage

Statusinformationen werden vom Projektor als Antwort auf den Statusbefehl gesendet. Unter Umständen bezieht sich der Status auf den vorletzten Befehl (z.B. verändert ein LZ-Befehl den Status nicht, da dabei lediglich eine Information abgefragt wird).

Vorgehen bei der Statusbeobachtung
in zeitlicher Reihenfolge
  • wenn Status 'v', warten bis Status ungleich 'v'
  • wenn Status 'j', Befehl wiederholen, sonst
  • wenn Status 'B', warten bis Status ungleich 'B'
  • wenn Status 'R' ist der Befehl abgeschlossen
Statusbefehl | ß (ASCII-Code 225)
Mögliche Statuscodes
'v' | Befehl wurde akzeptiert
'B' | busy, der Projektor führt gerade einen Befehl aus
'R' | ready
'g' | Befehl nicht ausführbar, da z.B. Projektor nicht im PC-Modus.
'i' | Unbekannten Befehl empfangen.
'e' Fehler bei der Ausführung des Befehls aufgetreten,
z. B. mechanischer Fehler, Dia verklemmt o.ä.
'p' Der im Befehl übergebene Parameter liegt ausserhalb des
zugelassenen Wertebereiches.
'j' Befehl lässt sich nicht ausführen, z. B. weil ein anderer Befehl
noch bearbeitet wird.
'X' | Kein Modul eingesetzt.
'Y' | Modulkapazität zum Speichern aller Schaueinträge zu klein.
'Z' | Zugriff auf Modul war fehlerfrei.

6. Binärbefehle

Die Binärbefehle gestatten es, direkt auf einen Datenbereich im Projektor zuzugreifen. Das allgemeine Format dieser Befehle lautet:

1. Befehlscode | 1 Byte
2. Anfangsadresse | 2 Byte (MSB zuerst)
3. Blocklänge | 2 Byte (MSB zuerst)
4. Daten | Anzahl gemäß Blocklänge und eventuell eingefügter Tokenbytes

Im Befehlscode wird festgelegt, welcher Datenbereichstyp gelesen oder beschrieben wird:

Code | Funktionsbeschreibung |
000h | Schreiben von Daten in den Xdata-Bereich |
 | Format |
 | 1.byte | 0
 | 2.byte | Anfangsadresse high
 | 3.byte | Anfangsadresse low
 | 4.byte | Länge high
 | 5.byte | Länge low
 | 6.Daten |
001h | Lesen von Daten aus dem Xdata-Bereich |
 | Format |
 | 1.byte | 01h
 | 2.byte | Anfangsadresse high
 | 3.byte | Anfangsadresse low
 | 4.byte | Länge high
 | 5.byte | Länge low
 | empfangen: |
 | 6.Daten aus dem Xdata-Bereich |
002h | Lesen von Daten aus dem Code-Bereich |
 | Format |
 | 1.byte | 02h
 | 2.byte | Anfangsadresse high
 | 3.byte | Anfangsadresse low
 | 4.byte | Länge high
 | 5.byte | Länge low
 | empfangen: |
 | 6.Daten aus dem Code-Bereich |
003h | reserviert |
004h | Abbruch der Datenübertragung bei Befehlen 000h bis 002h, bei Befehlen 001h und 002h ist der Abbruch als Echo auf das vom PC empfangene Datenbyte zu senden. |
005h | reserviert |
006h | reserviert |
007h | reserviert |
008h | reserviert |
009h | reserviert |
00ah | reserviert |
00bh | reserviert |
00ch | reserviert |
00dh | reserviert |
00eh | reserviert |
00fh | reserviert |

Bei der Datenübertragung in den Befehlen 00, 01 und 02 muss der Zahlen-Bereich 00h bis 0fh gesondert behandelt werden, da diese Codes für die Befehle reserviert sind (s.o.). Zur Übertragung dieser Zahlen als Rohdaten wird eine Folge von zwei Bytes verwendet. Das erste Byte ist das Markierungsbyte 010h token marker), das zweite Byte ist das eigentliche Datenbyte, welches mit einem Offset von 080h versehen wurde.

Der Bereich 00h ... 10h kommt damit folgendermaßen zur Übertragung:

000h | 010h, 080h
001h | 010h, 081h
002h | 010h, 082h
003h | 010h, 083h
004h | 010h, 084h
usw. bis |
00fh | 010h, 08fh
010h | 010h, 090h

6.1 Informationen im Code-Bereich

Im Code-Bereich des Master-Prozessors befindet sich ab Code-Adresse 00a0h ein Verzeichnis von Speicheradressen, welches folgende Struktur besitzt:

Offset |
0 | Länge dieser Tabelle
2 | Adresse des Programmspeichers XData
4 | Länge des Programmspeichers
6 | Adresse des Komprimierungsspeichers XData
8 | Länge des Komprimierungsspeichers
10 | Adresse X1 von Überblendtabelle 1 XData
12 | Länge der Tabelle
14 | Adresse X2 von Überblendtabelle 2 XData
16 | Länge der Tabelle
18 | Adresse X3 von Überblendtabelle 3 XData
20 | Länge der Tabelle
22 | Adresse X4 von Überblendtabelle 4 XData
24 | Länge der Tabelle
26 | reserviert
28 | reserviert
30 | reserviert
32 | reserviert
34 | reserviert
36 | reserviert
38 | reserviert
40 | reserviert
42 | Adresse des Versionsstrings Code
44 | Länge des Versionsstrings
46 | 0 Ende

Alle Längen- und Adressangaben umfassen 2 Byte in der Reihenfolge MSB LSB.

Aufbau der Tabellen für Auf-/Abblendungen und Überblendungen:

Jede Tabelle besteht aus zwei Datensätzen (je Kanal 256 byte), die Lichtwerte in aufsteigender Reihenfolge enthalten. Auf- bzw. Abblendungen werden intern durch Abarbeitung der Datensätze mit auf- bzw. absteigender Adresszählung realisiert. Die Tabelle mit der Adresse X3 wird für standardmäßig Auf-/Ab- blendungen benutzt, die Tabelle mit der Adresse X4 für Überblendungen. In Verbindung mit dem SU:XAÜ-Befehl und durch gezieltes Beschreiben der RAM-Bereiche ab Adresse X1 ... X4 können die Tabelle bezüglich der Lichtwerte und der Verwendung für Auf-/Abblendungen bzw. Überblendungen beliebig variiert bzw. kombiniert werden.

7. Verwendete Begriffe

Programmspeicher | Speicherbereich des Projektors, in dem die Daten für eine Diaschau (Bildnummern, Überblendzeiten, Standzeiten und Sonderfunktionen (s.u)) abgelegt sind. Der Programmspeicher ist in 999 Zellen (s.u) aufgeteilt, jede Zelle trägt die Information für einen Programmschritt.
Zelle | Bereich aus dem Programmspeicher (s.o) des Projektors, der die Information für einen Programmschritt aufnimmt. Die Zellen sind von 1 bis 999 durchnumeriert, die Zellennummer entspricht einer Adresse, unter der die Daten einer Zelle erreichbar sind. Achtung: Zellennummer und die in einer Zelle eingetragene Bildnummer (s.u) können gleich sein, müssen es aber nicht!
Bild | Gerahmtes Dia.
Bildnummer | Lage eines Dias im Magazin bzw. in der Magazinfolge. Entspricht der Nummer des Magazinfaches.


Steuerung des Rolleivision 35 twin digital P (Auszug aus dem Programmierhandbuch)

1. Übertragungsformat

Serielles Übertragungsformat mit Hardware-Handshake, 1200 Baud, even parity, 2 Stoppbits, 7 Datenbits.

2. Allgemeines

Die Befehle an den Projektor über die serielle Schnittstelle erlauben einen tiefen und zum Teil direkten Eingriff in die Ablaufsteuerung des Gerätes. Folgende Grundregeln sollten unter allen Umständen beachtet werden, da die serielle Schnittstelle vom Projektor in Zeitabständen von 10 ms abgearbeitet wird:

  • Einzelne Zeichen eines Befehls dürfen nur im Abstand > 10 ms an den Projektor gesendet werden.
  • Ein neuer Befehl darf erst nach der Quittierung des vorher übertragenen Befehls gesendet werden.
XXX steht für eine dreistellige Dezimalzahl, führende Nullen müssen mitgesendet werden.

Das Ende eines Befehls wird mit einem Carriage-RETURN (0DH) markiert. Der Projektor wertet nur Großbuchstaben aus. Jeden erkannten Befehl quittiert der Projektor mit dem ASCII-Zeichen "*" (2AH). Tritt ein Fehler auf, sendet der Projektor ein "!" (21H). Leerzeichen werden nicht mitgesendet. "CR" steht für Carriage-Return (0DH).

Folgende Betriebsarten sind zu wählen:
  • Tastatur-Mode: Der Projektor kann von seiner Tastatur bedient werden (wie Grundzustand nach Einschalten). Zusätzlich werden einige Befehle über die serielle Schnittstelle angenommen.
  • Direkt-Mode: Der Projektor kann über die serielle Schnittstelle wie von der Tastatur bedient werden. Z.B. "BV" und "CR" entspricht dem Drücken der Vorwärtstaste. Die Projektortastatur ist abgeschaltet.
  • Memory-Mode: Der Arbeitsspeicher des Projektors kann über die serielle Schnittstelle manipuliert werden. Die Projektortastatur ist abgeschaltet.

Direkt-Mode und Memory-Mode sind anzuwählen im Tastatur-Mode über die Befehle "DM" und "MM". Mit "RS" (Reset) ist jederzeit eine Rückkehr in den Tastatur-Mode möglich.

3. Befehle, die immer wirksam sind

RS Reset; schaltet den Projektor in den Tastatur-Mode.
Entspricht dem Drücken der Taste "End".

FV Fokus-Motor ein Schritt vorwärts.

FR Fokus-Motor ein Schritt rückwärts.

AE Autofokus einschalten.

AA Autofokus ausschalten.

ST Stop-/Go-Funktion.

MO Memo.

AB Aktuelle Bild-Nummer.
Der Projektor sendet die Dia-Nummer des Dias,
das gerade projiziert bzw. bearbeitet wird.

AZ Aktuelle Zeile.
Der Projektor sendet die Programm-Nummer,
deren Inhalt gerade projiziert bzw. bearbeitet wird.

SL:XXX Stelle Licht.
XXX = 000: Schaltet die Projektionslampe aus.
XXX = 001: Stellt den Dimmer auf ca. 80% Lampenhelligkeit.
XXX = 002: Stellt den Dimmer auf ca. 90% Lampenhelligkeit.
XXX = 003: Stellt den Dimmer auf ca. 100% Lampenhelligkeit.
XXX = 004: Schaltet die Anzeige auf niedrige Intensität.
XXX = 005: Schaltet die Anzeige auf höhere Intensität.

4. Befehle, die nur im Tastatur-Mode erlaubt sind

DM Direkt-Mode: Schaltet den Projektor in den Direkt-Mode.
Keine Bedienung mehr über die Projektortastatur.

MM Memory-Mode: Schaltet den Projektor in den Memory-Mode.
Keine Bedienung mehr über die Projektortastatur.

5. Befehle, die nur im Direkt-Mode wirksam sind

BV Bildtransport vorwärts.

BR Bildtransport rückwärts.

SD:XXX Setze Dissolve-Zeit auf den Wert XXX
(1/190 sec, 3-stellige Dezimalzahl,
z.B. muss 0,5 sec als 005 gesendet werden).

6. Befehle, die nur im Memory-Mode wirksam sind

SZ:XXX Selektiere Zelle.
Die folgenden Werte für die Dissolve-, Timerzeit
und Sonderfunktionen werden in die Zelle
(Programmnummer) XXX eingetragen.

BN:XXX Bildnummer.
Die Bildnummer XXX wird in die vorher selektierte Zelle
(Programmnummer) eingetragen.

DI:XXX Dissolve.
Die Dissolvezeit XXX wird in die vorher selektierte Zelle
(Programmnummer) eingetragen.
Der Projektor rundet immer auf 0,5 sec auf.

TI:XXX Timer.
Die Timerzeit (Diastandzeit) XXX wird in die vorher
selektierte Zelle (Programmnummer) eingetragen.

SF:XXX Sonderfunktion.
Der Sonderfunktionscode wird in die vorher selektierte Zelle
(Programmnummer) eingetragen.

LZ:XXX Lese Zelle.
Projektor gibt den Inhalt der Zelle (Programmnummer) XXX
in folgendem Format aus: "BBB DDD TTT HHH"
(Bildnummer, Dissolvezeit, Timerzeit, Sonderfunktion).

GO:XXX Gehe nach XXX.
Programmstart bei Zelle (Programmnummer) XXX.

ML Modul lesen.
Der Inhalt des Moduls wird in den Arbeitsspeicher geladen.

MS Modul schreiben.
Der Inhalt des Arbeitsspeichers wird ins Modul abgespeichert.


Firmware-Update V 8.5 für MSC 535P (Information von Rollei)

Der Projektor MSC 535 P ist um eine Attraktion reicher.

Die neueste Softwareversion 8.5 bietet die freie Auswahl zwischen 3 verschiedenen Auf-/Ab- und 3 Überblendtabellen, die frei kombinierbar sind, so dass sich 9 verschiedene Kombinationen einstellen lassen.

Die Aktivierung erfolgt über den Enter-Modus2 und kann auch als Grundeinstellung
gespeichert werden.

Die werksseitig voreingestellte Kurvenkombination ist ebenfalls leicht reaktivierbar.

Technische Beschreibung:

Enter-Modus2 einstellen: Mit mode-Taste auf record
Taste Enter drücken

Eingabe der dreistelligen Zahl: Kurven einstellen:

  • 800: alte Auf-/Abblendkurve und alte Überblendkurve kombinieren
  • 801: neue Auf-/Abblendkurve(1) und alte Überblendkurve kombinieren
  • 802: neue Auf-/Abblendkurve(2) und alte Überblendkurve kombinieren
  • 810: alte Auf-/Abblendkurve und neue Überblendkurve(1) kombinieren
  • 811: neue Auf-/Abblendkurve(1) und neue Überblendkurve(1) kombinieren
  • 812: neue Auf-/Abblendkurve(2) und neue Überblendkurve(1) kombinieren
  • 820: alte Auf-/Abblendkurve und neue Überblendkurve(2) kombinieren
  • 821: neue Auf-/Abblendkurve(1) und neue Überblendkurve(2) kombinieren
  • 822: neue Auf-/Abblendkurve(2) und neue Überblendkurve(2) kombinieren

Eingabe mit der Enter-Taste bestätigen.

Speichern der ausgewählten Kurvenpaare über das Abschalten des Gerätes hinaus und automatische Aktivierung nach dem erneuten Einschalten:

Wiederum Enter-Modus2 wählen und 888 eingeben. Mit Enter bestätigen.

Reaktivierung der Kurven wie beim Auslieferungszustand:
Wiederum Enter-Modus2 wählen und 899 eingeben. Mit Enter bestätigen.

Während des Betriebes mit der Steuersoftware mobjects können jetzt die manuellen Focustasten am Projektor bedient werden.

Ein Update wird bei allen Projektoren, die noch in der Garantiezeit sind, ausschließlich im Hause Rollei durchgeführt. Anfragen bitte im Rollei-Service, H.Scholz, 0531/6800330.

Mai 2003

Anm.:
Eine Nachfrage bei Rollei ergab, dass die neuen Auf-/Ab-/Überblendkurven leider nur manuell, nicht per Software (COM-Port) einstellbar sind.
QuiverTree


Firmware-Probleme bei älteren Projektoren

Nach Informationen von Franke & Heidecke (inzwischen insolvent) wurden bzw. werden bei den Rolleivision-Twin-MSC-Projektoren folgende Firmware-Versionen eingesetzt:

Projektor-Typ | Baujahr | Firmware-Version
Erste Geräte | bis Ende 1998 | 2.7 ... 5.8
MSC 330P | bis Ende 2003 | 5.8 ... 6.2
MSC 325P MSC 535P | bis etwa 2004 | 8.3
MSC 325P MSC 535P | ab etwa 2004 | 8.9

Bei älteren Projektoren (MSC 300P) mit entsprechend alter Firmware kann es zu Problemen bei der Ansteuerung der Projektoren kommen. Dies betrifft unseres Wissens insbesondere Projektoren, die vor 1997 gebaut wurden. Dia-Shows mit mehr als 255 Dias sind erst mit Geräten ab Baujahr 2001 möglich. Die aktuelle Firmware-Version ist 8.9.

Die Probleme äußern sich z.B. folgendermaßen:

  • Endlos-Dia-Shows mit Koppelmagazinen und mehr als 255 Dias werden nicht richtig erkannt und abgearbeitet
  • Bei Dia-Shows mit CS-Magazinen funktioniert der Magazin-Wechsel nicht ordnungsgemäß; der Projektor beginnt wieder mit dem alten Magazin

Die beschriebenen Probleme sind nicht TLC-typisch, sie betreffen auch andere Steuerprogramme wie "m.objects" oder "Wings". Hier ein paar Links für den an Einzelheiten Interessierten:

http://www.mobjects.com/forum/viewtopic.php?t=235&highlight=msc+300p
http://www.mobjects.com/forum/viewtopic.php?t=124&highlight=msc+300p
http://www.mobjects.com/forum/viewtopic.php?t=111&highlight=msc+300p

TwinLightControl weist beim Aktivieren des Projektors auf mögliche Probleme hin. In einem solchen Fall sollte man an ein Update der Firmware denken. In Abhängigkeit vom Baujahr (Seriennummer) des Projektors reicht es, den entsprechenden EEPROM auszutauschen, bei älteren Modellen muss ggf. die gesamte Leiterplatte ausgetauscht werden.

Leider sind uns keine genauen Angaben zu den einzelnen Firmware-Versionen bekannt. Folgende Fakten gelten allerdings als sicher:

  • Steuerungsprobleme können auftreten bei MSC 300P, die vor 1997 produziert wurden
  • Dia-Shows mit mehr als 255 Dias sind erst mit Geräten ab Baujahr 2001 möglich
  • Die höchstmögliche Firmware-Version beim MSC 300P nur durch Austausch des EEPROMS ist 5.8; höhere Firmware-Versionen sind nur bei Austausch der Platine möglich

Die dritte Ziffer in der Seriennummer des Projektors macht eine Aussage über die Möglichkeit eines Upgrades der Firmware-Version:

  • 2: kein Upgrade möglich (nur bei Geräten vor 1996)
  • 3 oder 4: Upgrade möglich, aber mit Kosten verbunden (Austausch der Platine und des EEPROMs erforderlich); Einschicken des Projektors notwendig
  • 5: Upgrade kostenlos (Austausch des EEPROMs erforderlich); Einschicken des Projektors nicht notwendig, Austausch des EEPROMs kann selbst vorgenommen werden

Verbindliche Aussagen zu diesen Fragen kann aber nur der Hersteller Rollei bzw. dessen Rechtsnachfolger Franke & Heidecke bzw. DHW Fototechnik GmbH treffen. Bei Fragen bzgl. eines Firmware-Updates wendet man sich deshalb am besten direkt an DHW Fototechnik GmbH, die Mitarbeiter sind diesbezüglich sehr hilfsbereit:

Telefon: | +49 (0) 531 6800 - 0
Website: | http://www.dhw-fototechnik.de
E-Mail: | mailto:info@dhw-fototechnik.de


Literatur

  • Handbücher zu den Rolleivision Twin Projektoren
  • Befehlssatz zur Steuerung des Twin MSC 300 (Information von Rollei)
  • Steuerung des Rolleivision 35 twin digital P
  • Firmware-Update V 8.5 für MSC 535P (Information von Rollei)
  • Josef Scheibel, Rollei vision twin MSC 300 P, MSC 300, Laterna Magica, München 1994, 1997


Tastenkürzel und Maus-Klicks im Audio-Recorder

Folgende Tastenkürzel und Maus-Klicks sind im Audio-Recorder verfügbar:

Tastenkürzel

Leertaste | Starten / Pausieren / Fortsetzen der Audio-Aufnahme
Ende | Stoppen der Audio-Aufnahme


Wie wird eine Gruppe von Dias im Magazin verschoben?

Diese Funktion hat Ähnlichkeit mit dem Verschieben von Dias im Magazin nach vorn oder hinten. Der Unterschied ist, dass mit dieser Funktion eine Gruppe von Dias an einen beliebigen Ort verschoben werden kann. Eine Gruppe von Dias kann dabei natürlich auch aus nur einem Dia bestehen. Voraussetzung ist, dass die Dias alle lückenlos hintereinander liegen.

Beim Verschieben geht man folgendermaßen vor:

Nehmen wir an, wir wollen die Dias in den Dia-Fächern 11 bis 15 des Magazins 1 in die Dia-Fächer 21 bis 25 des Magazins 2 verschieben (umstecken, physikalisch umsortieren). Wir markieren (selektieren) die Dias 11 bis 15 in Magazin 1 (Strg+LinkeMaustaste). Die Dia-Fächer, zu denen die Dias verschoben werden sollen, müssen natürlich leer (nicht besetzt) sein. Nach dem Selektieren drückt man das Button [image] oder ruft den entsprechenden Menü-Befehl auf. Im aufscheinenden Dialog gibt man das Ziel der Verschiebeoperation (Magazin-Nummer, Dia-Fach-Nummer) an, wobei sich diese Angabe auf das erste Dia der Gruppe bezieht. Nach dem Drücken von OK werden die Dias, sofern Magazin- und Dia-Fach-Nummer gültig und die Fächer frei sind, verschoben. Am Ende wird die Zahl der verschobenen Dias gemeldet.

Das Verschieben von Dias ist auch über Magazingrenzen hinweg möglich. Die Magazin- und Dia-Nummern von Dias, die sich bereits in der Timeline befinden, werden automatisch korrigiert.


Popupnullrows

Null-Zeilen sind Programmschritte in der Timeline, bei denen die Dia-Nummer gleich 0 ist.
Der Projektor braucht diese Nullzeilen, um das Ende eines Magazins oder einer Dia-Show zu erkennen.
Null-Zeilen sind im Timeline-Editor hellblau hinterlegt.